none
Offline Address Book Error (0x8004010F) - The operation failed. An object cannot be found

    Question


  • Hi All,

    It seems that this problem is notorious among the Exchange Server user ever since 2003 until 2007 SP1 that I'm now using.

    I got this Error Thousand of times already every time I do "Send and Receive"

    Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'

    I also tried:
    http://support.microsoft.com/kb/939765
    http://support.microsoft.com/kb/905813


    and googling around but there seems no solution to this problem ?

    any idea please ?

    here's the result of Test-Outlookwebservices


    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address atedja@(company).com.au.

    Id      : 1007
    Type    : Information
    Message : Testing server (servername).(companyname).com.au with the published name https://(servername).(companyname).com.au/EWS/Exchange.asmx & .

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://(servername).(companyname).com.au/Autodiscover/Autodiscover.xml.

      <?xml version="1.0" encoding="utf-8" ?>
    - <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    - <Response>
    - <Error Time="16:15:08.5937500" Id="1433479874">
      <ErrorCode>600</ErrorCode>
      <Message>Invalid Request</Message>
      <DebugData />
      </Error>
      </Response>
      </Autodiscover>


    Id      : 1013
    Type    : Error
    Message : When contacting https://(servername).(companyname).com.au/Autodiscover/Autodiscover.xml received the error The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF

    Id      : 1006
    Type    : Error
    Message : The Autodiscover service could not be contacted.
    Wednesday, May 07, 2008 7:50 AM

All replies

  • Hi,

     

    I understand that the error code 0x8004010F was received when downloading OAB ever since 2003 until 2007 SP1. When trying to run test-outlookwebservices, it indicated that the Autodiscover service could not be contacted.

     

    Actually, many factors could cause this issue. Before going on, I would like to explain that the following information. The Autodiscover service is the dependency of the OAB since here are two methods by which the OAB is distributed to client computers: Web-based distribution and Public folder distribution, to determine which OAB download method to use, Microsoft Office Outlook 2007 uses information that is provided by the Autodiscover service.

     

    Generally, the Autodiscover service failed to be contacted may has two possible causes. One is the DNS, the other is corrupted Autodiscover.

     

    Based on the current situation, I suggest we first add a host (A) record in DNS for Autodiscover.domain.com and point to the Exchange 2007 server that has the Client Access server role. For example, if the user's primary SMTP address is user@contoso.com, the host (A) record you need to add is: autodiscover.contoso.com A <IPaddress>.

     

    After that, please check this issue. If the issue persists, please remove and recreate the Autodiscover virtual directory to check this issue. Please implement this operation in Exchange Management Shell.

     

    The command for Remove the Autodiscover: Remove-AutodiscoverVirtualDirectory -Identity <VirtualDirectoryIdParameter> [-DomainController <Fqdn>]

     

    The reference you can view http://technet.microsoft.com/en-us/library/bb124113(EXCHG.80).aspx

     

    The command for re-create the Autodiscover: New-AutodiscoverVirtualDirectory -Websitename <websitename> -BasicAuthenticationEmbarrassedtrue -WindowsAuthenticationEmbarrassedtrue

     

    The reference you can view http://technet.microsoft.com/en-us/library/bb123983(EXCHG.80).aspx

     

    Please note: Please pay attention to the relevant properties of the Autodiscover before deleting it in order to keep have the same configuration for the new Autodiscover that you create.

     

    Thanks

     

    Allen

     

    Thursday, May 08, 2008 11:33 AM


  • Hi Allen,

    Thanks for your thorough posting, I'll give it a try then.

    today I did assign https to all of the Internal URI of OAB and the Autodiscover.

    I even had created A record in DNS "Autodiscover" so that when itype https://autodiscover.domain.com/autodiscover/autodiscover.xml shall be working.

    but still the problem exist Sad
    tomorrow I'll follow your suggestion.

    Anyhow, my current exchange server still using self signed certificate issued by exchangeserver for exchangeserver itself, i didn't put autodiscover.domain, maybe i shall put that thing also in my COMODO SSL certificate

    1. imail.domain.com
    2. autodiscover.domain.com
    3. servername.domain.com


    Thursday, May 08, 2008 12:43 PM
  • OK, please take your time to perform the suggestions.

     

    Additionlly, I would like to make up one point about the remove and re-create command for Autodiscover.

     

    The exact command is:

     

    Remove-autodiscovervirtualdirectory -identity "Client server role name\Autodiscover (Default Web Site)"

     

    New-autodiscovervirtualdirecotry -websitename "Default Web Site" -basicauthentication $true -windowsauthentication $true

     

    Please note: Please pay more attention to the word which I write with majuscule.

     

    Thanks

     

    Allen

    Friday, May 09, 2008 3:13 AM
  •  

     

    Hi Allen,

     

    this is the result of thie script below:

     

    Script:

    Get-AutodiscoverVirtualDirectory -Identity "<ExchangeServer>\Autodiscover (Default Web Site)" | fl

     

    Result:

     

    Name                          : Autodiscover (Default Web Site)
    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    BasicAuthentication           : False
    DigestAuthentication          : False
    WindowsAuthentication         : True
    MetabasePath                  : IIS://"<exchangeserver>"."<domain>".com.au/W3SVC/1/ROOT/Autodiscover
    Path                          : C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover
    Server                        : "<exchangeserver>"
    InternalUrl                   :
    https://"<exchangeserver>"."<domain>".com.au/autodiscover/autodiscover.xml
    ExternalUrl                   :
    AdminDisplayName              :
    ExchangeVersion               : 0.1 (8.0.535.0)
    DistinguishedName             : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN="<exchangeserver>",CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN="<domain>" Software,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC="<domain>",DC=com,DC=au
    Identity                      : "<exchangeserver>"\Autodiscover (Default Web Site)
    Guid                          : a9e0138b-90f4-4627-b12a-0993f0c6dba5
    ObjectCategory                : "<domain>".com.au/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                   : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                   : 8/05/2008 5:37:37 PM
    WhenCreated                   : 27/02/2008 9:41:46 PM
    OriginatingServer             : "<GCServer>"."<domain>".com.au
    IsValid                       : True

     

    would these new cmdlets recrrete that Autodiscover virtual directory ?

     

    Remove-autodiscovervirtualdirectory -identity "<exchangeserver>\Autodiscover (Default Web Site)"

     

    New-autodiscovervirtualdirectory -websitename "Default Web Site" -basicauthentication $true -windowsauthentication $true

     

    Monday, May 12, 2008 4:50 AM
  • Yes, what you wrote was correct, please implement it based on the command that you posted.

    Monday, May 12, 2008 8:10 AM


  • still the same anyway Sad

    The Error is still there .... eventhough I already execute those two lines of CMDlets

    and selecting Yes to all in deleting VARIANTs.
    Wednesday, May 14, 2008 8:30 AM
  •  

    Friday, May 16, 2008 10:19 AM
  • Hi

     

    Please Add the following into the web.config file under Autodiscover directory to troubleshoot the issue

     

    <system.net>

    <settings>

    <httpWebRequest useUnsafeHeaderParsing="true"/>

    </settings>

    </system.net>

    </configuration>

     

    For your reference:

    http://msdn.microsoft.com/en-us/library/system.net.configuration.httpwebrequestelement.useunsafeheaderparsing(VS.80).aspx

     

    After that, please restart the IIS service and attempt to run the command again.

     

    Thanks

     

    Allen

    Friday, May 16, 2008 10:21 AM
  • Hi Allen,

     

    thanks for your patience and support so far, I'll give it a try.

     

    So I shall add those lines on the XML file and then execute those two the cmdlets before to delete and re-create autodiscover vistual directory in IIS ?

     

    I've successfully install my SSL certificate on exhange server from COMODO but still, the error still there :-(

     

    Allen, I still haven't tried Update Rollup 2, have you ?

    my POP3.exe and IMAP4.exe still failing as well but so far email flow is working anyway.

     

    Monday, May 19, 2008 8:10 AM
  •  Allen Song wrote:

    Hi

     

    Please Add the following into the web.config file under Autodiscover directory to troubleshoot the issue

     

     

    For your reference:

    http://msdn.microsoft.com/en-us/library/system.net.configuration.httpwebrequestelement.useunsafeheaderparsing(VS.80).aspx

     

    After that, please restart the IIS service and attempt to run the command again.

     

    Thanks

     

    Allen

     

     

    Allen,

     

    I've added those line at the very end of the web.config file:

    Code Snippet

    .

    .

    .

    .

     <system.diagnostics>
      <trace autoflush="true"/>
     </system.diagnostics>
     <system.net>
      <settings>
       <httpWebRequest useUnsafeHeaderParsing="true"/>
      </settings>
     </system.net>
    </configuration>

     

     

     

    it goes like that.

     

    and here's the content of my Autodiscover.xml file:

      <?xml version="1.0" encoding="utf-8" ?>
    - <Autodiscover>
      </< SPAN>Autodiscover>
     
    and here's the result of  Test-OutlookWebServices -ClientAccessServer "exchangeserver" |fl
     
    Code Snippet
    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address
    admin@domain.com.au.
    Id      : 1007
    Type    : Information
    Message : Testing server exchangeserver.domain.com.au with the published name
    https://exchangeserver.domain.com.au/EWS/Exchange.asmx &.
    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is
    https://exchangeserver.domain.com.au/autodiscover/autodiscover.xml.
    Id      : 1013
    Type    : Error
    Message : When contacting
    https://exchangeserver.domain.com.au/autodiscover/autodiscover.xml received the error The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF
    Id      : 1006
    Type    : Error
    Message : The Autodiscover service could not be contacted.

     

     

    Monday, May 19, 2008 8:29 AM
  •  

    Added new thread regarding this dreaded Error Message here: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3388640&SiteID=17&mode=1
    Tuesday, June 24, 2008 2:38 AM
  • Is there anyone who ever surviced this Autodiscover error here ?

     

    please shed some lgiht here in order to make the necessarry changes in AD database regarding Autodiscover.

     

    it's also affecting my Free/Busy status in Calendar  for OOF message too.

     

     

     

    thanks.

    Tuesday, July 15, 2008 8:08 AM
  • hi everyone, first time to post, got the same problem but on my side its only happening on my outlook 2007. Seems working with other computers inside my network. I just disabled the downloading of offline address book. I'll try fixing outlook and I'll get back here as soon as it works.

    Wednesday, February 18, 2009 7:42 AM
  • I'm having the same problem but only with Outlook 2007 on workgroup clients. Any updates on a possible solution?
    Monday, February 23, 2009 3:18 PM
  • To All,

    yes you're not alone here.

    the problem seems to be caused by broken update of .NET framework last year. but this year, Microsoft has released another updates though around ~ 210 MB for .NET Fx 3.5 and also Update rollup 6.

    I also found out that from http://support.microsoft.com/default.aspx/kb/958934 that the broken update also make these features:
    1. Offline Address Book.
    2. Out of Office Message.
    3. Free/Busy status in shared calendar.

    unusable.

    /* Support Engineer */
    • Proposed as answer by jadaka Thursday, August 16, 2012 8:07 PM
    Thursday, March 12, 2009 2:03 AM
  • Hi,

    So, is your problem fixed after applying the Update for NET framework and Update Rollup 6?
    Saturday, March 14, 2009 1:09 PM
  • sadly not yet as I was failed in installing the patch RU6 now RU7 has been out already.
    /* Support Engineer */
    Tuesday, March 24, 2009 12:56 PM
  • Hi,

    Thanks for the reply. Could you confirm after applying the Update Rollup 7 whether your problem is fixed or not?
    Saturday, March 28, 2009 9:38 AM
  • Hi There,

    I'm not applying RU7 yet as it seems to cause more problem than it solves.

    see the error thread in: http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/thread/57afad3c-a7fd-431d-bb2e-438c04b6e647

    please let me know your experience :-)

    /* Support Engineer */
    • Proposed as answer by tessjc Sunday, December 05, 2010 9:45 PM
    Sunday, April 19, 2009 10:07 AM
  • me neither. i have not even applied Update rollup 6 yet (having no problem with UR5).

    Regards
    Sunday, April 19, 2009 10:20 AM
  • Using EX2010 over here.
    And i used to have the same (Object not found) when sending receiving.
    Or when o tried to DJ the OAB.

    The solution Allen song provided worked for me.

    I created a New A record
    "domain.net/autodiscover"
    Restarted DNS service

    I deleted the default offline adress book
    Created a new one "Oab"

    Used outlook to DJ the OAB and success !!

    Thank you allen !
    Friday, December 04, 2009 6:43 PM
  • Hello Edwin

    I ran across your solution to a problem I am having with my Exchange 2010.  I recently migrated, suing the SBS 2011 migration tool, from SBS 2003 to SBS 2011.

    I am using a self-signed certicate called office.domain name.  Everything seems to work well.  Just the objest error 0X8004010F.

    Can you help with with specifics on how to accomplish your solution, specifically:

    create new A Record...where and how?

    Delete OAB and create new one....where and how?

    Used Outlook to DJ the OAB....What is DJ and how specifically is this accomplished

    Sunday, February 27, 2011 2:59 PM
  • I mistakenly used a CNAME entry instead of an A record and was getting this error:  Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'  

    Removing the CNAME and adding the A record did the trick.

     

    -Jester

    Wednesday, May 04, 2011 10:15 PM
  • Hi,

    I am also facing the same issue Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found. Inexchange server 2010, Its a fresh installation of Ex 2010 sp2 ;


    Thanks Vinesh Rathi
    Sunday, February 05, 2012 2:22 PM
  • Hello

    I too was baffled by the issue and I had to use a Microsoft support ticket to solve it.  It took 1.5 days to resolve but below is the series of events and solution.  I have attached the final email sent; it has good documentation and links to articles.  It contains more than you need but all is good information from our friends at Microsoft.....or at least one of their paid for support contractors.

    It was my pleasure to serve you during your issue Unable to create an outlook profile for a specific user on Exchange Server "cltsvr02" and getting error message, "The name could not be resolved. The name could not be matched to a name in the address list." I am providing you with a summary of the key points of the case for your records. If you ever have any questions please feel free to call me. My contact information is below.

         Unable to create an outlook profile for a specific user on Exchange Server

         "XXXXX" and getting error message, "The name could not be resolved. The

         name could not be matched to a name in the address list."

    1.    We found when the user trying to configure Outlook client it gave following error message.

    “The name could not be matched to a name in the address list”

    2.    But we are able to login to OWA with the same user.

    3.    Ran EXBPA and found nothing relevant to the issue.

    4.    Took LDP Dump for the working and non-working user.

    5.    Found Show in Address Book attribute is not set and visible for Non-working user.

    6.    Configured the same as working user.

    7.    Tried to configure outlook again, still no go.

    8.    Created a Test mailbox profile and logged into the same machine where the non-working profile was configured. It worked fine.

    9.    Downloaded SP2 and ran command Update /domainprep successfully.

    10.  Still no go.

    11.  Went to ADUC and compare the properties of working user with non-working user.

    12.  Found Email address tab is missing for the non-working user.

    13.  So Remove the exchange attributes for the non-working user.

    14.  Ran Clean up agent on mailboxes.

    15.  It displayed non-working user mailbox in disconnected state.

    16.  Connected the mailbox to same user.

    17.   Email address tab is visible for the non-working user.

    18.  Configured the outlook profile successfully.

    19.  Issue got resolved.

    For more information regarding the issues please refer to the KB Articles:

    Removing Exchange attributes and deleting a mailbox:

    http://blogs.technet.com/b/exchange/archive/2006/10/13/3395089.aspx

    How to use the remove exchange attributes options:

    http://support.microsoft.com/kb/823170

    How to recover a deleted mailbox in exchange:

    http://support.microsoft.com/kb/274343

    Working with Active Directory Users and Computers:

    http://technet.microsoft.com/en-us/library/aa997340(EXCHG.65).aspx

    How to take system state backup:

    http://technet.microsoft.com/en-us/library/aa997709(EXCHG.80).aspx

    As part of Knowledge sharing I just want to update you regarding a few important Exchange related concepts and troubleshooting tools which help you to isolate and fix the exchange issues in future.

    Knowledge base articles

    What to Do When an Exchange Store Won't Mount

    http://technet.microsoft.com/en-us/library/aa996027(EXCHG.65).aspx

    Backing up and restoring data:

    http://technet.microsoft.com/en-us/library/cc738632(WS.10).aspx

    Exchange Server Database Utility Guide

    http://technet.microsoft.com/en-us/library/aa996953(EXCHG.65).aspx

    Microsoft Exchange Best Practices Analyzer Tool:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=22485

    Compliment article

    Exchange Posters and Visio Stencils from Microsoft Exchange Team

    http://social.technet.microsoft.com/wiki/contents/articles/749.aspx

    Exchange 2007 – How Do I Do Videos:

    http://technet.microsoft.com/en-us/exchange/dd314386

    Sunday, February 05, 2012 3:05 PM