none
Exchange 2010 CAS and NLB RRS feed

  • Question

  • Hello Everyone,

    I'm having an issue getting NLB to work correctly with an Exchange 2010 CAS array.  My configuration is set up as follows:

    2 Mailbox servers, one physical and one virtual (Vsphere4)
    2 HT/CAS servers, one physical and one virtual (Vsphere 4), set up with NLB and port rules for ports 80 and 443 only

    My issue is this: If I bring down the virtual CAS, OWA stops working until it comes back up.  If I bring down the physical CAS, everything still works.  I've deleted and recreated the NLB cluster repeatedly, adding servers in differnt order, all to the same result. I double checked the NLB config looks to be fine.

    I have an identical set up at another site(except that the CAS server are not hosting the HT role and both servers are virtual).  When I noticed the issue I checked this site and found it was doing the same thing.  However, I was able to fix it by changed the host priorities from 1 and 2 to 2 and 3.  Changing this at the site described above doesn't resolve the issue.

    Has anyone else encountered this?  Are there any ideas for other things I can try?  Any help would be appreciated.

    Thanks!
    -Nate

    Thursday, April 1, 2010 2:45 PM

Answers

  • OK, we got it figured out.  In order for this to work correct, you have to use multicast-mode for NLB.  For some reason it just won't behave correctly in unicast.  Once we configured the cluster, we had to add a static ARP entry into the switch for the NLB MAC, and everything worked like a charm!
    • Marked as answer by cvtnate Tuesday, April 13, 2010 3:32 PM
    Tuesday, April 13, 2010 3:32 PM

All replies