none
Outlook 2010 / Exchange 2010 color coded shared calendar categories

    Question

  • I'm having a problem with a shared calendar. Now we are using Exchange 2010 SP1 Multi-Tenant but I don't think it is related to that version yet.

    What happened is the client had Exchange 2003 with public folders. In the public folders was a Shared Calendar that everyone connected to. What they did is created custom categories with custom colors so they could see who was who. Like John was Blue, Don was Red, Jamie was Purple, etc.

    So after migrating them to the hosted exchange (using ExMerge and MailboxImportRequest) the colors are not there (they were using Outlook 2007). I thought with Outlook 2007+ the categories/colors were included in the PST.

     

    So anyways... since the Exchagne 2010 SP1 Multi Tenant has no public folders, I created a single user and added the calendars to it. I then told it to share out the calendar (keep in mind I had to do this from OWA since Outlook kept giving me errors when trying to share it out.. possibly autodiscover problem?). So it sent the email to every user, they clicked on Open Shared Calendar in the email and have access to it.

     

    But they cannot create new categories / colors. All the buttons are grayed out for them. How do I make this work?

    Tuesday, March 08, 2011 1:06 AM

Answers

  • Hi,

     

    When you are using Outlook 2007 or later, Exchange server  2007 or later, Exchange server will remove categories automatically as default.

     You could run this command to verify it.

    Get-transportConfig |FL*categories

    If you see the result: ”categories: True”, it means now the Exchange server will automatically remove categories.

     

    Run this command to allow transport categories.

    Set-transportConfig-ClearCategories: $False

     

    If you are using Outlook 2003, you don’t need to do any configuration at client end, else you need to edit registry.

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\outlook\preferences]
    "AcceptCategories"=dword:00000001
    "SendPersonalCategories"=dword:00000001


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 2:36 AM
    Wednesday, March 09, 2011 1:31 AM
  • What I ended up having to do is click the "Update Categories" in the data file properties and this seemed to work. Then to make eveyrone else see the same thing I had to change the view on the shared mailbox to apply to everyone
    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 2:36 AM
    Wednesday, March 09, 2011 4:43 PM

All replies

  • Hi,

     

    When you are using Outlook 2007 or later, Exchange server  2007 or later, Exchange server will remove categories automatically as default.

     You could run this command to verify it.

    Get-transportConfig |FL*categories

    If you see the result: ”categories: True”, it means now the Exchange server will automatically remove categories.

     

    Run this command to allow transport categories.

    Set-transportConfig-ClearCategories: $False

     

    If you are using Outlook 2003, you don’t need to do any configuration at client end, else you need to edit registry.

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\outlook\preferences]
    "AcceptCategories"=dword:00000001
    "SendPersonalCategories"=dword:00000001


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 2:36 AM
    Wednesday, March 09, 2011 1:31 AM
  • Ok so I need to set that as false and have exchange re-import the PST files?
    Wednesday, March 09, 2011 3:22 PM
  • What I ended up having to do is click the "Update Categories" in the data file properties and this seemed to work. Then to make eveyrone else see the same thing I had to change the view on the shared mailbox to apply to everyone
    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 2:36 AM
    Wednesday, March 09, 2011 4:43 PM
  • Hi,

    As I known, you don’t need do other configuration after applied the top configuration.

    Re-import the PST file always used to display the hidden attributions.

    You could create a new calendar and share to others after you applied the top configuration.

    And i think it is better use group policy to modify registry.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, March 10, 2011 1:43 AM
  • Well what it actually ended up being was you have to go to the data file properties and click "Import Color Categories...". I am still having a problem with a user that uses Office 2011 for Mac. The colors do not seem to show on that. Do you happen to know if this is supposed to work? I do see some things talking about problems about categories under investigation on Microsoft Mac site but don't really see anything that says "This doesn't work"
    Sunday, March 13, 2011 11:40 PM
  • Thanks Jerome,

     It's worked for me. Thanks for sharing .

    LP

    Sunday, April 03, 2011 10:35 AM
  • Where is this option, i cannot find it or where to look for the data file properties. Please can you help?

     

    Thanks

    Thursday, October 27, 2011 2:56 PM
  • Right click on the top level folder of your Outlook Folder.  It is usually your email name. It's at the top-level of your Outlook folder list.  You'll see Data Properties there.
    Friday, January 06, 2012 10:53 PM
  • Ok, I've found the Data Properties but cannot find the "Import Color Categories"

    Please help, thanks :)

    Thursday, January 12, 2012 1:58 PM