locked
Delete Button Disabled in Outlook 2010 with Exchange 2013 RRS feed

  • Question

  • I recently switched from a 3rd party mail software to Microsoft Exchange.  I have had some users ask me why the Delete button is disabled.  I didn't enable any special policy to cause this, and the Delete key on the keyboard will delete messages.  The disabled Delete button I am referring to is in the Home ribbon and the right-click menu for selected e-mail(s).  Is this standard behavior for Exchange, and can it be changed?
    Tuesday, November 27, 2012 3:55 PM

Answers

  • This issue has been resolved with the help of Microsoft support.  It was somehow caused by or related to importing from IMAP PSTs.  The solution was to use mfcmapi to change the PR_CONTAINER_CLASS on the Inbox.

    This was set to IPF.IMAP and should have been set to IPF.Note.

    Basic detailed steps (for my record as much as anyone's) are as follows:

    Launch mfcmapi
    Session -> Logon
    Select appropriate profile
    Double-click appropriate data store (PST/OST)
    Expand Root
    Expand Top
    Select Inbox
    Double-click PR_CONTAINER_CLASS to edit

    • Marked as answer by PRDIT Friday, January 4, 2013 8:20 PM
    Friday, January 4, 2013 8:20 PM

All replies

  •   The disabled Delete button I am referring to is in the Home ribbon and the right-click menu for selected e-mail(s). 

    Hi PRDIT,

    It should work.

    What's the issue when you select the Delete button?

    Do all users have the issue or just some ones?

    If one user works, could you please log on to the working client for one problematic user to narrow down the issue?


    Frank Wang
    TechNet Community Support

    Thursday, November 29, 2012 2:31 AM
  • I can't select the Delete button.  It is greyed out in both places.  All users have this issue, but can use the delete key on the keyboard to delete messages.  We are running Office 2010 everywhere with Win7 and WinXP clients.  The button was not disabled on the POP3 and IMAP account PSTs even after the Exchange 2013 accounts were added.  The button is only disabled when in special folders (Inbox, Deleted Items, etc).  It works normally outside of those folders.  It is almost as if the button is greyed out to prevent the user from deleting the selected folder even though the user has subsequently selected an e-mail message within the folder.
    Thursday, November 29, 2012 12:13 PM

  • The top example clearly shows the delete buttons disabled while dealing with the Inbox, and the bottom example clearly shows the delete buttons enabled while dealing with another folder.  Note the dates of the e-mails are irrelevant and the behavior is consistent across multiple accounts, Windows versions, and Outlook versions.  Specifically, I have seen this on WinXP with Outlook 2003 and Win7 with Outlook 2010.
    • Edited by PRDIT Wednesday, January 2, 2013 5:50 PM Copied comment out of picture to post for easier readability.
    Wednesday, January 2, 2013 5:48 PM
  • Hi ,

    As far from exchange prospect there is no such settings. I would suggest take a test machine. Install outlook 2007 and see if same problem reoccur over there. If no that mean there is some patches or updates creating this problem on outlook 2010. Additionally you can try running scanpst & scanost tools. to repair for any kind of corruption on profiles.


    DV MCTS,Exchange 2010

    Thursday, January 3, 2013 2:40 AM
  • >> It is almost as if the button is greyed out to prevent the user from deleting the selected folder even though the user has subsequently selected an e-mail message within the folder.

    Are they actually selecting the message or doing the hover-over select but not display trick?

    What are the two commands under the Delete command? I don't have them with my Outlook 2010/Exchange 2013 setup.

    Did you test it in Safe mode?

    How is Outlook 2003 connecting to Exchange 2013?



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, January 3, 2013 1:40 PM
  • Are they actually selecting the message or doing the hover-over select but not display trick?

    It doesn't matter, the delete button stays disabled either way.  As indicated in the screenshots (I think you could see that better if you save a copy or quote it, because I think the forum has the full-size image), the e-mails were definitely selected, and the behavior was only witnessed on the inbox (in other folders, the delete option in the right-click menu is enabled and functional even when the e-mail is hover-over selected).

    What are the two commands under the Delete command? I don't have them with my Outlook 2010/Exchange 2013 setup.  

    They are related to an Adobe Acrobat plugin (Convert to Adobe PDF & Append to Adobe PDF)

    Did you test it in Safe mode?

    No, are you suggesting I try safe mode with networking in Windows, or safe mode in Outlook?  In the case of the latter, could you tell me how?

    How is Outlook 2003 connecting to Exchange 2013?

    It used the default auto-configuration stuff.  I believe OWA is the only way any Outlook can connect to Exchange 2013.
    Thursday, January 3, 2013 2:16 PM
  • It so happens that I have an XP VM with Outlook 2007.  That having been said, as previously mentioned, before testing, I (thought I) could confirm the same consistent behavior in the following configurations:

    WinXP + Outlook 2003

    Win7 + Outlook 2010

    Each of these systems was using a different user account, and I have tried folderview repairs in EMC to no avail.

    Strangely, WinXP + Outlook 2007 does not appear to exhibit the behavior.  In this test case, the profile and OST were just created, but switching to folderview or moving the reading pane to the bottom did not affect the behavior.

    Given that information, I proceeded to re-verify, and I hadn't checked winXP + Outlook 2003 because the computer in question had been upgraded to Outlook 2010.  However, I verified the issue does still exist there.  Next, I proceeded to check another computer that I thought would be WinXP + Outlook 2003, but it had also been upgraded to Outlook 2010.  This computer did not have the issue, and this leads me to a new theory about the cause (but no closer to resolution).  For the record, of the three computers (two exhibiting the issue, one not), only one has the Adobe plugin mentioned in my last post in response to Diane Poremsky, so the issue doesn't appear to be related to that.

    That said, my theory follows:  This is somehow related to IMAP in Outlook 2010.  The computers that exhibit the issue were all previously running IMAP in Outlook 2010, and the IMAP PST filse were imported using the MailboxImportRequest feature.  I suspect this is related because of other issues that happen for these accounts.  For instance, all new e-mail was only visible in OWA and not Outlook on all folders on these accounts, and I have had to have the users reset filters in the view settings for each folder individually.  I don't remember exactly which filter was somehow imported, but it definitely had to do with IMAP.  This may be another red herring, but the behavior is consistent with it.  I should also note that this behavior did NOT exist when they were connected via IMAP to the old (non MS) server.  I should also note that the filter behavior is somehow stored on the server (and therefore I imagine the delete button behavior could be as well), because creating a new Windows Profile  (and as such, a new Outlook profile and OST file) on a new computer did not make the IMAP filters go away.

    Thursday, January 3, 2013 2:47 PM
  • Use Outlook Safe mode. We want to see if an add-in or support file is at fault. Delete should work in all folders (unless its a shared folder and you don't have permissions to delete). It works as expected here on Outlook 2013, 2010, and 2007 against Exchange 2013.

    To open Outlook in Safe mode: Close Outlook then hold Ctrl as you click on the Outlook icon. You'll get a message asking if you want to start in Safe mode. Click Ok.



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, January 3, 2013 6:19 PM
  • To test your theory that imap is behind it, are all messages affected or only imported ones? If it's due to the import, new messages would not be affected.

    I'm assuming by filter you mean View - and the IMAP specific views were moved with the mail. I know of experience that those views don't work well in non-IMAP accounts.

    Since a new profile apparently fixed it, try deleting the ost from an profile and letting outlook rebuild it. Does that fix it too?



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, January 3, 2013 6:26 PM
  • Use Outlook Safe mode. We want to see if an add-in or support file is at fault. Delete should work in all folders (unless its a shared folder and you don't have permissions to delete). It works as expected here on Outlook 2013, 2010, and 2007 against Exchange 2013.

    To open Outlook in Safe mode: Close Outlook then hold Ctrl as you click on the Outlook icon. You'll get a message asking if you want to start in Safe mode. Click Ok.

    The buttons are still disabled for all e-mail in the inboxes when using safe mode.  Note that delete works (using the key on the keyboard, both Del and Shift+Del work as expected), it is just that the buttons are grayed out and as such, cannot be used.  The issue is definitely related to specific user accounts more than specific Windows/Outlook versions.


    • Edited by PRDIT Thursday, January 3, 2013 6:34 PM IMAP convo addressed separately, so removed here
    Thursday, January 3, 2013 6:30 PM
  • To test your theory that imap is behind it, are all messages affected or only imported ones? If it's due to the import, new messages would not be affected.

    I'm assuming by filter you mean View - and the IMAP specific views were moved with the mail. I know of experience that those views don't work well in non-IMAP accounts.

    Since a new profile apparently fixed it, try deleting the ost from an profile and letting outlook rebuild it. Does that fix it too?

    All messages are affected.  The issue is definitely related to the Inbox folder and not individual message properties.

    You may be referring to the same thing as me, specifically, there was a filter to delete in View -> View Settings -> Filter (button) -> Advanced (tab).

    Creating a new profile did NOT fix it, only accounts that have e-mail copied/imported from IMAP PST files are affected, but they are affected on brand new computers as well (but not in OWA).

    Thursday, January 3, 2013 6:33 PM
  • This issue has been resolved with the help of Microsoft support.  It was somehow caused by or related to importing from IMAP PSTs.  The solution was to use mfcmapi to change the PR_CONTAINER_CLASS on the Inbox.

    This was set to IPF.IMAP and should have been set to IPF.Note.

    Basic detailed steps (for my record as much as anyone's) are as follows:

    Launch mfcmapi
    Session -> Logon
    Select appropriate profile
    Double-click appropriate data store (PST/OST)
    Expand Root
    Expand Top
    Select Inbox
    Double-click PR_CONTAINER_CLASS to edit

    • Marked as answer by PRDIT Friday, January 4, 2013 8:20 PM
    Friday, January 4, 2013 8:20 PM
  • So how do you do this as a "ORDINARY USER!" 

    Have excaktly same issue and this post keeps turning up

    but the ansver is not helpful at all :(

    Thursday, November 14, 2013 3:07 PM
  • Get MFCMAPI - http://mfcmapi.codeplex.com/ - I've had problems with the March 2013 release, January 2013 release seems fine. If you have 64 bit office, you need 64 bit MFCMAPI.

    Here is a video to guide you through PRDIT's steps - http://www.screencast.com/t/GjD6YhWgjHw - you'll change the container class in the Inbox folder from IPF.IMAP to IPF.Note



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    • Proposed as answer by fyrflymiles Friday, April 14, 2017 12:57 AM
    Thursday, November 14, 2013 7:05 PM
  • I had this situation on Outlook 2010 standalone and this fixed the problem. This was in a new POP3  .PST file where it had previously been setup as IMAP.

    any email in the Inbox would have the "DELETE" button on the ribbon, greyed out but the Delete ky on the keyboard worked fine. If I moved the email to any other folder, then the "DELETE" on the ribbon worked fine, but if I moved it back to the Inbox, same problem, so the Problem appeared to be specific to the Inbox folder.

    I had to find the util on Microsoft website, download it and following these explicit instructions, it fixed the problem. I had tried many hours of research on TechNet and many other websites and NOTHING ELSE WORKED.

    Thank You very much!!!

    Rodger Wittmann



    Tuesday, December 10, 2013 12:01 AM
  • That would have taken hours of research.  Excellent answer and it worked with no issues.  Thank you.

    Don Bynum

    Wednesday, April 16, 2014 12:25 PM
  • I don't understand, how do I fix this on my machine?

    Wednesday, September 2, 2015 7:16 PM
  • You need to edit the properties of the folder. I have two macros at http://www.slipstick.com/developer/code-samples/change-outlook-folder-type-export/ or you can use a utility called MFCMAPI and edit the properties yourself.

    The instructions to use MFCMAPI:

    Launch mfcmapi
    Session -> Logon
    Select appropriate profile
    Double-click appropriate data store (PST/OST)
    Expand Root
    Expand Top
    Select Inbox
    Double-click PR_CONTAINER_CLASS to edit
    Change the PR_CONTAINER_CLASS on the Inbox from IPF.IMAP to IPF.Note.



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, September 2, 2015 7:53 PM
  • Worked perfectly! I had a standalone client that I converted from Imap to Pop3 and this took care of the issue. Thank you so much!
    Tuesday, November 10, 2015 4:40 AM
  • This issue has been resolved with the help of Microsoft support.  It was somehow caused by or related to importing from IMAP PSTs.  The solution was to use mfcmapi to change the PR_CONTAINER_CLASS on the Inbox.

    This was set to IPF.IMAP and should have been set to IPF.Note.

    Basic detailed steps (for my record as much as anyone's) are as follows:

    Launch mfcmapi
    Session -> Logon
    Select appropriate profile
    Double-click appropriate data store (PST/OST)
    Expand Root
    Expand Top
    Select Inbox
    Double-click PR_CONTAINER_CLASS to edit

    This example as followed above, fixed Outlook 2010. Thank you!
    Wednesday, November 18, 2015 11:41 PM
  • Problem solved. thank you for the post.

    Monday, July 11, 2016 9:11 PM