Connecting to remote server failed with the following error message : Access is denied.


  • Hello

    I have installed Exchange 2010 RTM onto a new server with a fresh install of Windows Server 2008 R2 and the Exchange setup completed successfully with no errors shown anywhere but I cannot open the Exchange Management Console or the Exchange Management Shell.

    I recieve the following error message when I try to open either:

    Connecting to remote server failed with the following error message : Access is denied. For
    more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
        + FullyQualifiedErrorId : PSSessionOpenFailed

    I originally logged this as a bug in the RC version on MS Connect and was told to wait for the next build to see if it still happens and then re-report it and it was logged as "not reproducible". The next build would appear to be the RTM one which is the one I have now which I downloaded from the Microsoft website.

    I did install the Hyper-V and Remote Desktop Services roles as well in case that has got anything to do with it.
    I'm going to try removing those to see if that makes it work.

    What I did:

    Install Application Server Role
    Install Windows Server 2008 R2 x64
    Install Hyper-V and Remote Desktop Services Roles
    Install the Desktop Experience Feature and some other features
    Install Windows Updates
    Install Drivers from Dell Website
    Install Exchange
    Unable to open the management console or shell

    I used the same domain admin account the whole time

    Has anyone else come across this error in the RTM build? I can see a few posts about the beta version and which talk about enabling remote powershell but as I can't connect to the Exchange version of powershell I can't try running the command.


    Robin Wilson
    Monday, November 16, 2009 10:07 PM

All replies

  • I have now removed the following but it did not help:

    Remote Desktop Services Role
    Desktop Experience, PowerShell and XPS Viewer

    The server now only has the roles required by Exchange yet it still won't work.

    The Server is a Dell Optiplex 760 with 6GB of RAM.

    Robin Wilson
    Monday, November 16, 2009 10:45 PM
  • Just thought I would post an update.


    I removed Exchange from the server and then wiped it and formatted and installed Windows Server again and gave the server another name. I installed exchange and got exactly the same error twice running (I formatted a second time).


    Each time I named the server rws-mail (with a number on the end).


    I then wiped the server again and installed and called it rws-ex2010 and it didn’t give me the error and I was able to get into Exchange Management console so it looks like there may be a bug in the RTM version (and the RC version) if the server has “mail” as part of the server name?


    Each time I formatted I received no errors while exchange was installing.


    I still get a warning when I open Exchange Management Shell but at least it still opens too.

    It seems to be something to do with certificates and remote signing. I did get-executionpolicy and it was set to RemoteSigned which would seem to be correct.

    The error is:

    VERBOSE: Connecting to

    WARNING: Cannot generate Export-Module for the current session, using Import-PSession.

    Import-Module : There were errors in loading the format data file:

    Microsoft.PowerShell, , \\\users\rwsadmin\Application Data\Microsoft\Exchange\RemotePowerShell\rws-ex201\ : File skipped because of the following validation exception

    : File \\\users\rwsadmin\Application Data\Microsoft\Exchange\RemotePowerShell\

    \ cannot be loaded. The file \\\users\rwsadmin\Application Data\

    Microsoft\Exchange\RemotePowerShell\\ is not digitall

    y signed. The script will not execute on the system. Please see "get-help about_signing" for more details...

    At line:3 char:30

    +                 Import-Module <<<<  -Name $name -Alias * -Function * -Prefix $prefix -DisableNameChecking:$disableNam

    eChecking -PassThru -ArgumentList @($session)

        + CategoryInfo          : InvalidOperation: (:) [Import-Module], RuntimeException

        + FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand


    VERBOSE: Connected to


    I’ve tried deleting the file and it just gets recreated next time I open Management Shell with the same warning. None of the built in scripts seem to be working with this warning. MoveAllReplicas gives errors about being unable to run Get-Exchange-Version (I think it was)


    Thanks for any help.

    I’m completely lost now. I’ve confirmed the version number and I have definitely got the RTM edition as it is behaving more like a beta for me.



    Robin Wilson
    Wednesday, November 18, 2009 2:26 AM
  • Ok I've fixed my latest problem now.

    When opening things from the taskbar I was getting warnings as well and after looking at what the execution policy allows when it is set to remote-signed is that local scripts do not need to be signed but remote ones do so this got me thinking that it wasn’t treating \\ as a local intranet folder.

    I then went into Internet Explorer and the security settings for local intranet and added file://* and this fixed the warning in PowerShell which now works correctly as well as removing the annoying message when opening shortcuts on the taskbar.

    So the problem was that I was using folder redirection for the profile and the ps1 file is placed there by EMS which is then treated as a remote location so requires authenticode signing which it doesn’t have so it fails to load it. Adding it to the local intranet forces it to be treated as internal, thus it is allowed to run as only remote scripts require signing.

    I do still believe there may be a bug if the server name contains the word "mail", certainly in my environment anyway.

    Robin Wilson
    Wednesday, November 18, 2009 12:26 PM
  • Hi Robin, check that the clock between your DC and XCH Server is syncronized. Be Careful about clocks syncronizing to the Host Server.

    I hope this will help you.

    • Proposed as answer by dacj Monday, December 19, 2011 6:06 PM
    Monday, November 30, 2009 4:22 PM
  • Hello AleItaly

    Good thinking as the clocks showing different times has stopped things working in the past for me which always took me a while to figure out after trying everything else.
    Unfortunately this was not the case this time.

    The only conclusion I can come to is that it doesn't like it when there is a "mail" in the server name as I tried installing 3 times with the same error until I didn't include "mail" as part of the name and it worked. My feeling is that it has something to do with SPNs but I don't really know enough about them. Maybe this is due to the fact that in the past old exchange 2007 servers had had the same name before???

    Thanks for your input.

    Robin Wilson
    Tuesday, December 01, 2009 6:23 AM
  • By the same reasoning mabey it dosent like numbers at the end of the server name. My Server doesnt include the word "mail" but it ends with "DC1" Same error.

    Though i suspect it is the clocks in my case. Ive been having alot of trouble with them recently.

    Tuesday, April 20, 2010 7:12 PM
  • Good thinking. Issue resolved.



    Monday, December 19, 2011 6:05 PM