locked
Outlook 2003 can't connect to Exchange Server

    Question

  •  

    Hello all,

    The following error is generated when I first open Outlook 2003 on my laptop:

    "Unable to open your default e-mail folders. You must connect to your Microsoft Exchange Server computer
    with the current profile before you can synchronize your folders with your offline folder file."

    Here is my current situation:

    I have installed Windows Server 2003 and Exchange Server 2003 on my desktop for testing.
    So Domain name is created and some network users added in Active Directory.
    On my laptop I login as administrator and join the laptop to Domain (sucessfully), then restart the machine
    and login as a normal user (already created in Active Directory) is also succesfully.

    I did a little change on IIS, so a user able to login to, read/send e-mail through Outlook Web Access.

    Now I'd like a user to be able to use Outlook 2003, so a user open Outlook 2003 for the first time, then
    Outlook 2003 Startup appear then click Next,
    Account Configuration > Yes > Next
    On Server Type select Microsoft Exchange Server > Next
    On Exchange Server Settings, enter "ServerName.XXX.local" in Microsoft Exchange Server text box
    (also checked Use Cached Exchange Mode), then enter "UserName" in User Name text box
    (click Check Name button to verify user and username is underlined) > Next
    Congratulations! message generated > Finish, close the wizard... wait for a while...and the above error is
    generated...

    I've been searching the solutions on the net but none of them solve this issue. Could anyone please show me
    what I've done wrong on Exchange Server setting or Outlook? Any help greatly appreciated.

    Thanks in advance...

    Monday, February 9, 2009 4:35 AM

Answers

  • James-Luo said:

    Troubleshooting:

    1.       If any desktop search engine software is running on the problematic PC, please see KB 905184

    2.       Please try to disable the TCP chimney on the server if it’s enabled before. Then, check the issue

    How’s to know it’s enabled:

    a.       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    b.      If the key EnableTCPChimney is present and its value is 0x1, then the TCP Chimney is installed and enabled

    Disable Steps: http://blogs.technet.com/brad_rutkowski/archive/2007/08/10/how-to-know-if-tcp-offload-is-working.aspx

    3.       Please check if problematic users’ “msexchUserAccountControl” attribute. The value should be “0”, if it’s “Not Set”. The similar symptom will occur

    a.       Launch the ADSIEditor (Start->run-> ADSIEditor.msc)

    b.      Expand “Domain”->”DC=DomainName,DC=com”->”OU=xxx”

    c.       In the right-pane, right-click problematic user object, select “Properties”

    d.      In the “Attribute Editor” tab, check the values of “msexchUserAccountControl” attribute

    4.       Please try to disable firewall on the client for testing

    5.       Please run “Dcdiag” and “Netdiag” on the server, see if there’s any error info

    [dcdiag >dcdiag.txt | netdiag >netdiag.txt]

    6.       Does your windows 2003 server is also the DNS server? Please check the DNS configuration on the server, and also confirm that A record was set properly



    1. Run Exchange Server User Monitor, it nothing to show on the list, so I presume that user could not open the Outlook in the first place. To my knowledge I've never installed Desktop Search Engine on the user machine. 

    2. Had a look at the registry setting, EnableTCPChimney never been altered (is already set to its value 0x0).
        Had a look at the network adapter TCP/IP Offload property is already set to "OFF" by default.

    3. Check "msexchUserAccountControl" attribute value is already "0".

    4. Disabled Firewall on the client machine and tried to run Oulook, the problem persists.

    5. Run DCDiag and Netdiag, ALL Test PASSED. I assumed no problem with the network.

    6. Yes, its role as DNS Server. Only one server on the network. Its role also as Domain Controller, DHCP server etc...
        Check DNS configuration seems OK and has confirmed that A record is set properly.

    Ahh... never mind, I figured it out, that firewall on the server caused the problem. I did registry changes and configure the firewall, problem solved, all clients now can use Outlook 2003 and 2007.
    • Marked as answer by Alan.Gim Monday, March 9, 2009 8:52 AM
    Thursday, February 12, 2009 8:28 AM

All replies

  • Possible cause: The number of MAPI sessions is larger than the permitted limit

    Resolution: Please see if event 9646 is logged on the exchange server KB 842022

     

    Troubleshooting:

    1.       Please check how many sessions are opened by problematic user in the ESM

    <ESM->Mailbox Store->Logons>

    2.       Please try to open the outlook in safe mode <Start->Run->outlook /safe>

    3.       Please check if there’s any error event in the application log on the laptop and server

    <Start->Run->Eventvwr>

    4.       Please see if you can reproduce with another user account

    Tuesday, February 10, 2009 7:48 AM
  • Thanks for your reply James,

    Unfortunately there is NO Event ID 9646 produced on server, so I didn't do any changes to the client machine setting.

    I tried to troubleshoot as you suggested:

    1. Please check how many sessions are opened by problematic user in the ESM <ESM->Mailbox Store->Logons>:
      • All users unable to open Outlook for the first time, but they are able to use Outlook Web Access successfully, so their sessions are listed.
      • There is a user "SMTP (LANGKA-S01-{735887A7-...-...})", I am not sure what kind of user is this. Is this generated when a user attempt to connect to Exchange Server using Outlook??
    2. Please try to open the outlook in safe mode <Start->Run->outlook /safe>:
      • Run Outlook in safe mode the problem persists
    3. Please check if there’s any error event in the application log on the laptop and server <Start->Run->Eventvwr>:
      • The only error on the Server that relate to Exchange is "MSExchangeIS Public Store Event ID: 3043 & 3044"
      • On the laptop, there is no error relate to Outlook.
    4.  Please see if you can reproduce with another user account:
      • Tried to logon with different user account, the problem persists
      • Tried remove user profile from laptop and recreated, the problem persists

    Please note that client machine is able to ping the server. Is there a problem with Windows Server or Echange Server setting or firewall???

    Please help me out, this issue drive me nuts... I will provide more information about the server setting if required...

    Thanks again  

     

    Wednesday, February 11, 2009 3:51 AM
  • Troubleshooting:

    1.       If any desktop search engine software is running on the problematic PC, please see KB 905184

    2.       Please try to disable the TCP chimney on the server if it’s enabled before. Then, check the issue

    How’s to know it’s enabled:

    a.       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    b.      If the key EnableTCPChimney is present and its value is 0x1, then the TCP Chimney is installed and enabled

    Disable Steps: http://blogs.technet.com/brad_rutkowski/archive/2007/08/10/how-to-know-if-tcp-offload-is-working.aspx

    3.       Please check if problematic users’ “msexchUserAccountControl” attribute. The value should be “0”, if it’s “Not Set”. The similar symptom will occur

    a.       Launch the ADSIEditor (Start->run-> ADSIEditor.msc)

    b.      Expand “Domain”->”DC=DomainName,DC=com”->”OU=xxx”

    c.       In the right-pane, right-click problematic user object, select “Properties”

    d.      In the “Attribute Editor” tab, check the values of “msexchUserAccountControl” attribute

    4.       Please try to disable firewall on the client for testing

    5.       Please run “Dcdiag” and “Netdiag” on the server, see if there’s any error info

    [dcdiag >dcdiag.txt | netdiag >netdiag.txt]

    6.       Does your windows 2003 server is also the DNS server? Please check the DNS configuration on the server, and also confirm that A record was set properly

    Wednesday, February 11, 2009 7:56 AM
  • James-Luo said:

    Troubleshooting:

    1.       If any desktop search engine software is running on the problematic PC, please see KB 905184

    2.       Please try to disable the TCP chimney on the server if it’s enabled before. Then, check the issue

    How’s to know it’s enabled:

    a.       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    b.      If the key EnableTCPChimney is present and its value is 0x1, then the TCP Chimney is installed and enabled

    Disable Steps: http://blogs.technet.com/brad_rutkowski/archive/2007/08/10/how-to-know-if-tcp-offload-is-working.aspx

    3.       Please check if problematic users’ “msexchUserAccountControl” attribute. The value should be “0”, if it’s “Not Set”. The similar symptom will occur

    a.       Launch the ADSIEditor (Start->run-> ADSIEditor.msc)

    b.      Expand “Domain”->”DC=DomainName,DC=com”->”OU=xxx”

    c.       In the right-pane, right-click problematic user object, select “Properties”

    d.      In the “Attribute Editor” tab, check the values of “msexchUserAccountControl” attribute

    4.       Please try to disable firewall on the client for testing

    5.       Please run “Dcdiag” and “Netdiag” on the server, see if there’s any error info

    [dcdiag >dcdiag.txt | netdiag >netdiag.txt]

    6.       Does your windows 2003 server is also the DNS server? Please check the DNS configuration on the server, and also confirm that A record was set properly



    1. Run Exchange Server User Monitor, it nothing to show on the list, so I presume that user could not open the Outlook in the first place. To my knowledge I've never installed Desktop Search Engine on the user machine. 

    2. Had a look at the registry setting, EnableTCPChimney never been altered (is already set to its value 0x0).
        Had a look at the network adapter TCP/IP Offload property is already set to "OFF" by default.

    3. Check "msexchUserAccountControl" attribute value is already "0".

    4. Disabled Firewall on the client machine and tried to run Oulook, the problem persists.

    5. Run DCDiag and Netdiag, ALL Test PASSED. I assumed no problem with the network.

    6. Yes, its role as DNS Server. Only one server on the network. Its role also as Domain Controller, DHCP server etc...
        Check DNS configuration seems OK and has confirmed that A record is set properly.

    Ahh... never mind, I figured it out, that firewall on the server caused the problem. I did registry changes and configure the firewall, problem solved, all clients now can use Outlook 2003 and 2007.
    • Marked as answer by Alan.Gim Monday, March 9, 2009 8:52 AM
    Thursday, February 12, 2009 8:28 AM
  • Dear All

    Please help me , I had same problem and I turn off all firewill but outlook still ca not access

    Please help to share with me how did you do with firewal to solve this problem ?

    Thanks so muich

    Friday, June 2, 2017 4:56 AM
  • Please help to share with me your solution with firewall

    My outlook still can not connect with exchange 2007

    Please help me

    Now, our user only access via Outlook Web

    I tried setup outlook client on Exchange server and it work fine

    I did turn off firewall and remove all virus software

    I also did connect server direct to server to make sure network have no problem

    But outlook still can not connect exchnange

    Thanks so much


    Friday, June 2, 2017 6:46 AM