Outbound Email Not Working on Clean Install


  • Ok first, a little background information:

    • This is not my first install and configuration of Exchange 2003, 2007, or 2010
    • This is for my personal use, not business related
    • Single server located in my home running ESXi 5.0
    • Two virtual machines on single ESXi 5.0 host
    • One domain controller - Server 2008 R2 Standard w/ AD services role only - All Windows Updates performed
    • One Exchange server - Server 2008 R2 Standard w/ only Exchange 2010 and necessary services installed - All Windows Updates performed

    Issue: I cannot send outbound SMTP email through exchange


    • Verified that port 25 is open with ISP
    • Tested and confirmed that port 25 is open by successfully sending email through telnet from Exchange server
    • Windows Firewall is OFF completey
    • No Antivirus or 3rd Party Firewall or spam filter installed yet
    • Created send connector with the following values:
    • -General: FQDN:
    • -Address Space: Type:SMTP, Address:*, Cost:1
    • -Network: Use domain name service (DNS) "MX" records to route mail automatically
    • -Network: Use the External DNS Lookup settings on the transport server
    • -Source Server: <internal exchange server name>
    • External DNS Lookup settings are set to use the primary NIC, which points first to the domain controller and then to the router
    • Messages are in the queue with this response: The message has been queued on server 'mail.<domainname>.com' since 6/14/2012 6:19:20 PM (GMT-06:00) Central Time (US & Canada). The last attempt to send the message was at 6/15/2012 10:45:28 AM (GMT-06:00) Central Time (US & Canada) and generated the error '400 4.4.7 Message delayed'.

    So, to sum it up, I appear to have the send connector configured properly, I can send outbound on port 25 through telnet from the same machine, and I don't have any firewalls turned on (or other port blocking programs).

    Any suggestions?

    Friday, June 15, 2012 3:49 PM


All replies

  • Hi

    Did you receive an NDR from one of those messages?

    If you enable SMTP Logging, do the log files say anything?

    Friday, June 15, 2012 6:17 PM
  • Have you tried using a smarthost?
    Friday, June 15, 2012 6:19 PM
  • Follow the wizard and create a send connector, either use a smarthost which your ISP may be able to provide. When you test via the Telnet, where are you connecting to?

    Normally ISP's wont allow this and provide a smarthost for home use.


    Friday, June 15, 2012 6:23 PM
  • I haven't received an NDR yet, the messages are still in the queue. When I use EPC to see the report for the messages, that's where I find the 4.4.x codes.

    How do I enable SMTP logging and where do I find the logs?

    I have not tried using a smarthost and refuse to venture down that path since the most simple path isn't working.

    I have talked with my ISP and paid an extra $50 for them to open this port for my account. 

    I was on the Exchange server when I performed the test with Telnet.

    Friday, June 15, 2012 7:41 PM
  • logging -

    If it's allowed by the ISP, then it must work, just need to figure out the issue.


    Friday, June 15, 2012 8:38 PM
  • I will enable the SMTP logging and provide the details. thank you.
    Friday, June 15, 2012 9:28 PM
  • hi,

    I don't think you will find some useful information in smtp log, because your message is struck in the queue and it should nerver be delivered out of your ORG.

    I suggest that you use the remote conectivity analyzer to test your outbound message.

    Remote Conectivity Analyzer :

    Post the test result here.



    TechNet Community Support

    Monday, June 18, 2012 6:24 AM
  • Hi, thanks for the suggestion. I should have put that in the original description, I've successfully pass the Outbound SMTP test from I can send outbound from the server just fine. Problem is that Exchange can't get the message out. Something wrong with the Exchange configuration.

    Also, I've got to put this whole topic on hold. I applied SP2 and the latest rollup and now my Outlook client can't connect properly. It can find my username when I attempt to add the email address to Outlook, but when i open outlook, it won't expand the folder list and says it can't download or connect to the server anymore. Any suggestions on that one? lol

    Monday, June 18, 2012 5:22 PM
  • All clients or some?

    Check all services are started?

    Check OWA? Does that work?

    All users or some?


    Monday, June 18, 2012 5:41 PM
  • All clients, Outlook only. OWA works fine. Also, the emails to my android devices configured for MS Exchange work fine too. I need to check the services.

    Ok I checked and found the RPC service stopped. I started it and things seemed to be moving now. Still nothing outbound yet. I will check those SMTP logs. Seems like an internal DNS issue.

    Monday, June 18, 2012 10:53 PM
  • hi,

    It seems that your outlook can't connect to your exchange. Since owa and android are work fine. I think your exchange server is ready. You should troubleshoot your outlook.

    Try all these things

    1. Profile Recreation

    2. MAPI Connectivity failures on Mailbox Database

    3. Client Access Server connectivity with user machine

    4. Flush DNS in all machine facing the problem and registerdns in affected computer.

    5. check event viewer on both the cas and mb server for connecivity issue.

    6. Run EXBPA

    You will get more better help from outlook forum:

    hope can help you



    TechNet Community Support

    Tuesday, June 19, 2012 8:20 AM
  • Those are great suggestions!

    1. What are you referring to when you say profile recreation? Are you referring to Outlook profiles?

    2. I ran the Test-Mapiconnectivity and it was successful - no errors

    3. How do i check CAS connectivity with user machine?

    4. DNS flushed and registered successfully

    5. I've run the MS Connectivity tools and passed successfully for Outlook Anywhere (RPC over HTTP), Outlook Autodiscover, Inbound SMTP E-Mail, and Outbound SMTP E-Mail.

    6. I'm not too familiar with EXBPA, what can I do with it to help out right here?

    Tuesday, June 19, 2012 3:27 PM
  • 1: Yes, its Outlook
    3: Press the Ctrl Key and right click on Outlook ICON and click on Connection Status.
    6: Go to Toolbox in Exchange Management Console and in the Middle Pane of the Console you will see option, Exchange Best Practices Analyzer...Run that and post the result

    Did you restart MS Exchange Transport Service?

    Gulab Prasad,
    My Blog | Z-Hire Employee Provisioning App

    Tuesday, June 19, 2012 3:43 PM
  • what did the logs say?


    Tuesday, June 19, 2012 3:50 PM
  • ok heres a snippet from the log:

    Error Code: 10051

    Error Code: 10060

    (over and over and over)

    Remember, I can successfully telnet to these servers from on this exchange machine!

    Any suggestions?

    Wednesday, June 20, 2012 12:10 PM
  • I got Outlook working again, I'm not sure which step did it, but it connects successfully now. Thanks!
    Wednesday, June 20, 2012 12:11 PM