Outlook 2007 & Exchange 2007 -> Out of office assistant not working


  • Hi,

    when using outlook 2007 and the users mailbox is on an Exchange 2007 server the out of office assistant doesn't work. When you start the out of office assistant the following message is displayed:

    'Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.'

    Using Outlook 2003 and connect to the same mailbox, the assistant works fine, however you don't have the additional features new to the Assistant.

    Also, when using outlook 2007 and connect to an Exchange 2003 mailbox the out of office assistant is also functioning fine.

    Using Outlook Web Access on Exchange 2007 to set the out of office assistant works also fine, so the error message is not correct.

    Any idea how to fix this ?


    Wednesday, December 20, 2006 10:40 PM

All replies

  • OOF is dependent on the availability web service. I bet you're not seeing the full Scheduling Assistant on meeting requests.

    For troubleshooting, you might start at

    Friday, December 29, 2006 4:21 PM
  • Your Outlook 2007 needs to be on the computer which is on the domain, and at the time of setting it, your computer needs to be on the domain at that particular time.
    Monday, December 22, 2008 9:59 AM
  • Go into the profiles that you have in outlook and remove them all, make new profiles and adjust according to your settings, the new outlook might be still picking up your old profile from out look 2003. This should work.
    Thursday, June 18, 2009 8:32 PM
  • I have the same issue and it happened only after upgrading to exchange 2010. I am logged into Outlook through my domain account but since I carry a laptop I do not join the domain.
    Thursday, January 27, 2011 10:14 PM
  • Totally Autodiscover issue. Take a look at this:
    Friday, January 28, 2011 1:55 AM
  • Whilst I agree that auto-discover and other comment's could be upheld, I know that even when EWS and auto-discover are setup correctly that this problem will still occur.

    I manage an Exchange 2007 environment with 300 users and and Exchange 2010 environment with 700 user's all using Outlook 2007.  We are in the progress of deploying Outlook 2010 but I know with the new authentication process of the Outlook client with Exchange 2007 or older and Outlook 2007 or older, this problem will still occur.


    I know that their are just a few out of a 1,000 user base that experience this problem, so I don't see how global settings and configurations and settings are the culprit.


    Just like the problem caused by a badly designed update in November or December of last year that meant auto-discover does not auto-configure a new Outlook profile because it would not detect the user's e-mail address but somehow create some random e-mail address with the AD account name before the @ and the FQDN for the domain name, which involved a further release of another update several month's later to fix that.


    Plus the other problem with the daily and frequent prompt's throughout the day for OWA domain login credential's despite being authenticated and Outlook contacting Exchange fine signified by the bottom-right hand corner status stating so.  I press escape and Outlook carries performing as normal for it do the same a few hours later, however I find that after about half a dozen prompt's over several days, it will disconnect the Outlook client saying 'Need Password' in the bottom-right, which despite left and right-mouse clicking does not load a login prompt to re-enter credentials that I should not need to be doing in the first place considering that I am logged in with the correct domain account on my computer and using the destined mailbox for that AD account.


    Exiting Outlook gracefully and re-launching Outlook a few seconds later allowing time for the background application handles and sub-handles amongst probably other things from the previous Outlook session to close (although, I do find every so often this process is hampered every so often by having to end the Outlook.exe process directly through Task Manager before being able to re-attempt launching the Outlook client) and Outlook will just reconnect without the need or receiving a prompt to enter the login details but I will no doubt receive another login prompt that I can likely just press cancel to or the escape button or perhaps, have to follow the above process again.

    Just like releasing SP1 for Exchange 2010 to add more problems that worked without it but fixing those problems that existing in 2010.

    I find that deleting a database result's in a failure error that in fact does successfully remove the database but since SP1, I know have to run a shell command to remove the database in the registry to delete an entry from a 'state' and 'lockstate' folder before I am rid of the Exchange configuration, to then have to suspend all database copies on that server and re-start all of the Exchange services before I can actually delete the edb file.  Just absurd.


    It's all just a backwards and forwards exercise with Microsoft but would love permanent solutions to all of the above.  Please advise on the above because it is a major irritation.

    Thursday, May 19, 2011 1:12 PM
  • Hello everyone,

    I see this kind of issue day in day out with a lot of our customers when trying to do Out of Office and also syncing ip there Offline Address Book.

    The issue we experience is what Jose mentioned with the Autodiscover data not being found. This is usually because your machine is unable to gain a connection when connecting externally of a domain to the autodiscover.xml file huh contains the information you require for these Outlook 2007 / 2010 features. I know how frustrating this is but there is a solution so long as your Autodiscover is configured correctly.

    If you go to your DNS admin panel for your domain you new to add an SRV (Service Record)
    this record will look a little like this;

    _autodiscover._tcp.domainname SRV  0 5 443 exchange.domainname

    You may need it like this:

    Hostname: _autodiscover
    Protocol: _tcp
    Type: SRV
    Priority: 0
    Weight: 5
    Port: 443
    Value: exchange.domain (or whatever your external address is)

    once this then updates it should then appear with an alert within Outlook which says do you trust;
    you will need to accept this.

    Another issue I see is wildcard records in a domain. Outlook take this and looks for autodiscover.domainname and tries to install the certificate off the web server. As guessed this won't work. The best option to get around this is to remove the * wildcard and setup an SRV instead.

    The other way to override this, is to get a copy of the autodiscover.xml file, and add it to your computers registry. This usually goes in;

    HKEY_CURRENT_USER > Software > Microsoft > Office >(number of office version) >  Outlook > AutoDiscover

    V14 = Office 2010
    V12 = Office 2007

    Then if you add a string called; (this will be your domain).

    The value is your location of the autodiscover.xml
    This will then mean you don't have to have an SRV record as some DNS hosts don't allow it.

    Hopefully this will resolve your problems :)

    Friday, May 20, 2011 8:05 AM
  • Check these Directories in IIS

    Autodiscovery, EWS and OAB are the 3 Virtual directories you want.

    Highlight the Directory, say first "Autodiscovery" - then double click on "SSL Settings" and make sure the "Client Certificates" is set to Ignore. if you need to change it then make sure you Apply afterwards.

    Then click on "Autodiscovery" again so it is highlighted. Now go to "HTTP Redirect" double click to open, then make sure the redirect is blank.

    Again click on "Autodiscovery" so its highlighted. Now finally go to "Authentication" double click to open and make sure Basic and Windows Authentication are enabled.


    Now repeat this process for both EWS and OAB folders.

    Then open a command propt and type iisreset hit enter and you should be good to go.


    Monday, August 15, 2011 9:15 AM
  • somewhat the same problem we're having. two users on the same physical network, one OoO works and the other doesn't. same error message

    'Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.'


    Wednesday, August 29, 2012 7:12 PM
  • Thanks you for this short summary. This worked for us after hours of searching forum and KB's.

    In our case Authentication on OAB folders was not correct.

    Everything working perfect again.

    Tuesday, September 30, 2014 7:16 PM