none
Exchange 2010 OOF Simply not working

Answers

  • The final solution to the issue was.

    The service Mailbox Assistant was not running on the mailbox servers.  It would start then stop causing the oof not to work. After speaking to Microsoft, I was advised to set the startup on this service to delayed startup when running on a vitual server that these mailbox servers are.

    Once done and re-started everything works correctly.

    Peter


    Regards Peter
    Wednesday, May 05, 2010 3:08 AM

All replies

  • Thank You For your Post here.

    You mentioned that you have Done all the steps.Does it Includes this one as well

    1)Let's recreate the EWS virtual directory with the following steps:

    ================

    2)1. Test E-mail AutoConfiguration from Outlook client (did this showed any Errors ?)

    3)Step 2: Check the IE Proxy settings on client side

    ==============

    1. Click Start and then Run.

    2. Type inetcpl.cpl and press Enter.

    3. Under Connections tab -> LAN settings, uncheck the "Use a proxy server…" option.  

    4. Restart Outlook to test the result.

     

     

    Waiting for your Reply.

     


    Fazal Muhammad Khan | MCT, MCSE, MCSA, MCTS | Infrastructure Consultant, Technology Services | CDC Pakistan Ltd. | https://fazalmkhan.spaces.live.com | OFFICE: +92 21 111 111 500 Ext: 1402 | +5 GMT
    Monday, April 12, 2010 5:27 AM
  • Hi,

    Did you tried set up OOF thru OWA, if yes what about if you recreate EWS directory as said below forum.


    Anil
    Monday, April 12, 2010 5:38 AM
  • When I try to go to the auto reply section under OWA I get the error

    The Web page isn't loading properly. Please reload the page by refreshing your Web browser.
    Technical Information: 'AutomaticRepliesProperties' is undefined

    I am running a CAS array.

     


    Nothing
    Monday, April 12, 2010 6:14 AM
  • 1. I have re-created the EWS a few times with the same results.

    2. No errors with the test, when I return the EWS/Exchange.asmx I get back loads of XML so that is working

    3. No proxy, but auto proxy is enabled, turned it off, restarted outlook same issue.

    I do run a CAS array, but even with one server only in the array it does not work.

    Peter

     


    Nothing
    Monday, April 12, 2010 6:18 AM
  • One more thing.  Whne i start oof, it says it is running and it all looks ok, but the automatic reply never arrives to the user sending the email to the user. So OOF looks like it is running and gives no errors to the end user at all (except from owa).

    Peter


    Nothing
    Monday, April 12, 2010 6:30 AM
  • Hello, Please answer. Knock Knock!

    I have removed the WES again, but cannot re-create it.

    [PS] C:\Windows\system32>New-WebservicesVirtualDirectory -Path "c:\Program Files\Microsoft\Exchange Server\ClientAccess\
    Exchweb\EWS" -InternalURL " https://wmexchange.wm.org.au/ews/exchange.asmx" -ExternalURL "https://email.wesleymission.or
    g.au/ews/exchange.asmx" -WindowsAuthentication $True -InternalNLBBypassUrl "https://WMEXCASHT1.wm.org.au/ews/exchange.as
    mx"
    Creating a new session for implicit remoting of "New-WebServicesVirtualDirectory" command...
    The Active Directory object for virtual directory 'IIS://WMEXCASHT1.wm.org.au/W3SVC/1/ROOT/EWS' on 'WMEXCASHT1' could n
    ot be created. This might be because the object already exists in Active Directory. Remove the object from Active Direc
    tory, then re-create it.
        + CategoryInfo          : InvalidOperation: (WMEXCASHT1\EWS (Default Web Site):ADObjectId) [New-WebServicesVirtual
       Directory], InvalidOperationException
        + FullyQualifiedErrorId : A5800051,Microsoft.Exchange.Management.SystemConfigurationTasks.NewWebServicesVirtualDir
       ectory

    [PS] C:\Windows\system32>Get-WebServicesVirtualDirectory
    WARNING: IIS://WMEXCASHT1.wm.org.au/W3SVC/1/ROOT/EWS wasn't found. Please make sure you've typed it correctly.

    Name                                    Server                                  InternalUrl
    ----                                    ------                                  -----------
    EWS (Default Web Site)                  WMEXCASHT1                              https://wmexchange.wm.org.au/ews/exc...


    [PS] C:\Windows\system32>Remove-WebServicesVirtualDirectory -Identity "WMEXCASHT1\EWS (Default Web Site)"

    Confirm
    Are you sure you want to perform this action?
    Removing Web Services virtual directory "WMEXCASHT1\EWS (Default Web Site)".
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [?] Help (default is "Y"): y

    I do the above again and again and cannot re-create the EWS

    Peter


    Nothing
    Tuesday, April 13, 2010 4:27 AM
  • Hi,

    Ok I was able to re-create it if I did not use the -path in the command and did it from each CAS server.

    But the same problem as I had still exists.

    The page comes up in outlook 2007 and in OWA to set the information of the Out Of Office information. and it says down the bottom of outlook that it is turned on. But when someone sends an email to the user tith the OOF turned on, they do not get any OOF email telling them that the person is out of the office.

    No matter what I do, delete and re-create, nothing works.  I am pulling my hair out could someone, please help!!

    Peter


    Nothing
    Tuesday, April 13, 2010 4:37 AM
  • I am having the same issue. OOF was working then stopped working. I recreated the EWS Directory and that didn't work. Autodiscover seems to be functioning correctly from the results I get in the Outlook test. Anyone have a clue on fixing this? I really don't want to have to reinstall Exchange 2010.
    Tuesday, April 13, 2010 12:24 PM
  • Single server or CAS Array. if it is an array are you using a physical load balancer or WNLB? have you checked the External URL for EWS? along with permission for EWS. is this happening inside your network or outside the network?
    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003
    Tuesday, April 13, 2010 12:31 PM
  • Hi,

    It is a WNLB. 

    It happends both inside and outside the network from outlook 2007 and owa.

    I have recreated the EWS many times but with the permissions, do you mean Windows Auth and Basic Auth?  Both have been tried in different orders.

     


    Regards Peter
    Tuesday, April 13, 2010 9:52 PM
  • Here is what I did to restore OOF.

     

    Removed the Autodiscover and EWS Virtual Directories.

    Remove-ActiveSyncVirtualDirectory -Identity "Microsoft-Server-ActiveSync (Default Web Site)" -Confirm:$false

    Remove-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -Confirm:$false

    I then recreated those virtual directories.

    New-WebServicesVirtualDirectory -WebsiteName "Default Web Site" -InternalUrl "https://EXTERNAL_FQDN_OF_EXCHANGE/EWS/Exchange.asmx" -basicauthentication 1 -windowsauthentication 1

    New-AutodiscoverVirtualDirectory -WebsiteName "XXXXXXX"  
    -InternalUrl "https://EXTERNAL_FQDN_OF_EXCHANGE/Autodiscover/Autodiscover.xml"  
    -BasicAuthentication 1 -WindowsAuthentication 1

    Wednesday, April 14, 2010 2:30 AM
  • I have done both the above steps many times and it is not working. Could someone please comment if you have seen this issue before?
    Regards Peter
    Wednesday, April 14, 2010 12:21 PM
  • If you have recreated all the virtual directory's like mentioned above then you may want to try checking your I.E settings. try putting the web url in the intranet zone of the security tab. Depending on how lock down the internet Explorer settings  is it may cause a problem. I have seen this is some environments where they apply some pretty tight GPO's


    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003
    Wednesday, April 14, 2010 12:21 PM
  • Yes I have done all that.  Time to log a case with Microsoft.
    Regards Peter
    Thursday, April 15, 2010 2:15 AM
  • The final solution to the issue was.

    The service Mailbox Assistant was not running on the mailbox servers.  It would start then stop causing the oof not to work. After speaking to Microsoft, I was advised to set the startup on this service to delayed startup when running on a vitual server that these mailbox servers are.

    Once done and re-started everything works correctly.

    Peter


    Regards Peter
    Wednesday, May 05, 2010 3:08 AM
  • this is what I get when I run "New-WebServicesVirtualDirectory " command

    [PS] E:\>New-WebServicesVirtualDirectory -WebsiteName "Default Web Site" -InternalUrl "https://private.collinscu.org/EWS
    /Exchange.asmx" -basicauthentication 1 -windowsauthentication 1
    Creating a new session for implicit remoting of "New-WebServicesVirtualDirectory" command...
    An error occurred while creating the IIS virtual directory 'IIS://MAIL.EMUL.COLLINSCU.ORG/W3SVC/1/ROOT/EWS' on 'MAIL'.
        + CategoryInfo          : InvalidOperation: (MAIL\EWS (Default Web Site):ADObjectId) [New-WebServicesVirtualDirect
       ory], InvalidOperationException
        + FullyQualifiedErrorId : 517D170,Microsoft.Exchange.Management.SystemConfigurationTasks.NewWebServicesVirtualDire
       ctory

    Thursday, October 28, 2010 6:58 PM
  • Hi Jeremy,

    I'm getting the EXACT same error.  Let me know if you find anything to get the EWS recreated.  I've checked AD via asdiedit, IIS via Metabase Explorer, and IIS via IIS Administrator and have no evidence of the EWS virtual directory remaining.  Very frusterating...

    Jim

    Wednesday, November 03, 2010 3:25 AM
  • Hi,

    I had same issue  tried all above steps no use ...finally re install CAS role ....now everything working fine only you need to update license  key...Just one hour work J


    Thanks, GJ
    Tuesday, December 14, 2010 4:08 PM
  • This is what I had....the mailboxes that had the OOF not working also had their email being forwarded, but not being delivered to the original email account, thus not triggering the reply email. Placed a check in the deliver to both mailboxes and the replies started working correctly
    Tuesday, November 12, 2013 4:42 PM