Exchange Management Console>Organisation Configuration>You don't have sufficient permissions to view this data


  • I know very little about Exchange, but have been asked to install 2010 RC1 by my boss, on a new windows 2008 server box. Everything was going fine, I created a user to try and test sending an email from the new user to Administrator account through OWA, at some point soon after this, I went back to the EMC, and noticed that it does not give me anything under Organisation Configuration (except Hub Transport which is grayed out). It tells me I dont have sufficient permissions to view this data, However I am logged in with the main administrator account I used to install everything on this server.

    Also I dont see Server Configuration at all. All I can look and configure is Recipient Configuration.

    Any ideas ? Its probably something really simple to do with permissions...
    Tuesday, September 01, 2009 4:31 PM

All replies

  • Try adding administrator account into Organization Management and Server Management roles via EMS...

    Add-RoleGroupMember "Recipient Management" -Member Administrator
    Add-RoleGroupMember "Server Management" -Member Administrator

    If you won't be able to do this then try adding Administrator user into both groups available in AD...

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M |

    • Proposed as answer by Ricsao Monday, June 28, 2010 12:45 PM
    Tuesday, September 01, 2009 4:53 PM
  • I'm having the exact same problem. I'm a member of Organization Management...I'm using the account I installed Exchange 2010 with...but I don't have permissions.
    Friday, September 25, 2009 6:07 PM
  • Yes same here. What is the deal? I mean if I had a nickel for every time I...   :P
    Tuesday, November 24, 2009 4:49 PM
  • You need to go into your root domain > users and computers > View > Advanced Features > Then from the left pain Microsoft Exchange Security Groups and add your Administrator to the Org Management Group. This always fixes the problem in most organizations I work in.
    • Proposed as answer by Tim McCartney Wednesday, August 29, 2012 3:17 PM
    Monday, January 18, 2010 3:50 AM
  • Thanks, Amit! This worked for me.
    Tuesday, April 06, 2010 8:30 AM
  • this helped me as well.
    Tuesday, May 18, 2010 7:34 PM
  • If you have installed and set up an account in Outlook on the machine, delete its credentials from the Credential Manager, see

    To summarise that post:

    "Here's something you can do to test: Open Windows PowerShell (not the Exchange Management Shell). You should get the PowerShell window with the blue background and a prompt. There should be no Exchange scripts running. Then do the following:

    $UserCredential = Get-Credential

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://<Exchange 2010 server name>/PowerShell/ -Authentication Kerberos -Credential $UserCredential

    Import-PSSession $Session

    When entering your credentials, use the domain\username of the administrator account. Specify the full FQDN of your Exchange 2010 server.

    Once you're connected, see if you can run Get-ManagementRoleAssignment. If you can run that cmdlet, then you likely have your permissions. You can run Get-ExCommand again to verify.

    If that works, then you have conflicting credentials stored in your profile. Try removing the conflicting credentials from the credential manager in your Windows Profile and try opening the shell and EMC again. "


    • Proposed as answer by Ricsao Monday, June 28, 2010 12:45 PM
    Monday, May 24, 2010 5:35 AM

  • [PS] C:\Windows\system32>Add-RoleGroupMember "Recipient Management" -Member Administrator
    The term 'Add-RoleGroupMember' is not recognized as the name of a cmdlet, function, script file, or operable program. C
    heck the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:20
    + Add-RoleGroupMember <<<<  "Recipient Management" -Member Administrator
        + CategoryInfo          : ObjectNotFound: (Add-RoleGroupMember:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    [PS] C:\Windows\system32>


    Using AD-UC  The Administrator is a member of the Recipient Management and Organization Management groups but I still get this error and my account is unable to make any changes to the exchange server at all.

    Wednesday, July 21, 2010 7:26 PM
  • I dont understand why this is so complicated to resolve, visited so many sites, forums and nothing worked... 

    this problem was caused by outlook changing EMC configuration, don't know why this happens, and can be solved easly if there was a change login account option on each forest added ( ADD ON NEXT SP PLEASE OR UPDATE!!! )

    .....hence the solution.....

    Re-add the forest on your EMC and problem solved, but you have two forests one with permision and the old one without. Dont know how to delete the old one( another option missing ) in EMC. 

    This does not solve the problem of accessing the old forest dir but give you access to the same forest in another dir in EMC which is very importante. 

    Hope it helps the ones who still cant access EMC.

    • Proposed as answer by erickylaw Wednesday, December 01, 2010 2:07 AM
    Monday, October 18, 2010 2:18 PM
  • I had the same problem this morning and I had even problems with EMS.

    Solution, remove or change the user for the computer in the password vault.

    Control Panel -> Accounts -> Manage User Accounts -> Advanced -> Manage Password

    There should be a post with your Server name here where it has the wrong credential.

    Change it back to the administrator and it should work again.


    Solution found at:,_all_cmdlet_not_recognized/m_1800531527/tm.htm

    Monday, March 07, 2011 2:03 PM
  • Mattias, you rock.

    I don't have much hair left on my head, so you saved the little that's left. It seems that there are a couple different paths to get to the error in EMC.

    My path was as FuriosAngelIPTs. I made a mistake of of installing Outlook2010 on the same Windows2008 server that hosts Exchange2010 and right after configuring the outlook account - BOOM - cannot do any Admin activities on the Exchange, even though the Admin account did not change. This smells like a MSFT bug. I think it's pretty reasonable to set up Outlook with a test account on the Exch Server box itself to run quick connectivity and configuration tests.

    In any case, thanks again, your solution worked just fine.

    Friday, June 03, 2011 6:03 PM
  • Thanks for such a simple solution..I solved my issue..
    Tuesday, June 28, 2011 6:02 PM
  • Mattias, i have done evrything with no success but your answer in PERFECT!!!!!.


    • Proposed as answer by alonmarko007 Tuesday, August 23, 2011 10:27 AM
    Tuesday, August 23, 2011 10:17 AM
  • Mattias, i have done evrything with no success but your answer in PERFECT!!!!!.


    Please mark as answer to close the thread :)
    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 23, 2011 10:24 AM
  • hello,

    Exchange Management Shell does not recognize those commands?

    Sunday, October 23, 2011 2:32 PM

    thank u very much

    the answer is the best

    • Edited by alaater Thursday, May 31, 2012 3:57 PM
    Thursday, May 31, 2012 3:55 PM
  • I have tried a lot of solutions, but this one really solved my problems. Thank you.
    Thursday, June 21, 2012 9:03 AM
  • Mattias!!!!!!!! Thanks man! I'v tried too many solutions, But this little one just did the work. I can smile again :)
    Tuesday, July 17, 2012 9:41 AM
  • Worked like a charm for me. Thanks for the insight. I knew there had to be some kind of exchange admin related sec group, I just couldn't find it :P
    Wednesday, August 29, 2012 3:17 PM
  • Thanks working fine

    Saturday, October 06, 2012 11:33 AM
  • mattias thanks a lot man
    Sunday, October 28, 2012 10:35 PM
  • Thank you.

    It's working fine.

    Friday, November 02, 2012 12:31 AM
  • You are my hero Mattias! None of other suggestions about password change, powershell commands, etc. worked. No offense but you made them look like parrot card reader! You posted the solution over 3 years ago and it is still as good as brand new!

    Thanks Mattias,


    Friday, August 29, 2014 7:11 PM
  • If you have installed and set up an account in Outlook on the machine, delete its credentials from the Credential Manager, see

    Thank you! This was the fix. I had installed Outlook on our Exchange server (temporarily) to work with some PSTs. This fixed the problem. Thank you!
    • Edited by Adam1203 Friday, September 19, 2014 2:01 PM
    Friday, September 19, 2014 2:01 PM
  • thanks a lot!!!!
    Wednesday, November 26, 2014 9:05 AM
  • thanks a lot..! it help me as well..!
    Wednesday, February 11, 2015 6:10 AM
  • Hi Ricsao,

    Thanks for your answer. I went to do some work on my exchange server and I was freaking out because I was no longer able to do it. But did as you suggested. I deleted the credentials of the account I had created and everything is back to normal.



    Thursday, August 13, 2015 5:44 PM