Windows Vista error code 80004002 RRS feed

  • Question

  •  I'm having problems with Windows Vista on my laptop. Whenever I try to do a 'windows update' it just tells me that "Windows could not search for new updates. Error code 80004002." From what I can gather I'm not the only one having this problem, but I'm just wondering if anyone has found a solution yet or can help me in anyway? I'd appreciate any feedback! Thanks for your time! Dani

    Monday, December 10, 2007 1:12 AM


  • This error usually indicates that a Windows Update DLL is not registered correctly. Try this:

    1. Open an Administrator Command Prompt (Start->All Programs-->Accessories-->Command Prompt, but right click and select the Run as Administrator option).
    2. Register the Windows Update DLLs by executing the REGSVR32 command, followed by the name of the DLL to register. Register/re-register all of these:
      • wuapi.dll
      • wuaueng.dll
      • wucltux.dll
      • wups.dll
      • wups2.dll
      • wuwebv.dll
    3. For example, to register wuapi.dll, run REGSVR32 wuapi.dll, and press enter.


    Please let me know if this works for you or not. Cheers,


    -Tony Mann

    Sunday, December 23, 2007 3:46 AM

All replies

  • This error usually indicates that a Windows Update DLL is not registered correctly. Try this:

    1. Open an Administrator Command Prompt (Start->All Programs-->Accessories-->Command Prompt, but right click and select the Run as Administrator option).
    2. Register the Windows Update DLLs by executing the REGSVR32 command, followed by the name of the DLL to register. Register/re-register all of these:
      • wuapi.dll
      • wuaueng.dll
      • wucltux.dll
      • wups.dll
      • wups2.dll
      • wuwebv.dll
    3. For example, to register wuapi.dll, run REGSVR32 wuapi.dll, and press enter.


    Please let me know if this works for you or not. Cheers,


    -Tony Mann

    Sunday, December 23, 2007 3:46 AM
  • This is all the info one gets for your error code here.


    0x80004002 -2147467262 E_Nointerface


    Not very helpful, Im afraid  


    Try re-registering the dll's as suggested above and check TROUBLESHOOTING WINDOWS UPDATE IN VISTA. Should hopefully help you.

    Tuesday, January 1, 2008 7:55 AM
  • Just wanted to let you know that this worked for me...sort of. Now I get a different error...80070490. Off to troubleshoot that one now. Thanks for the little step forward though. At least I THINK this is a step forward. :-)


    Thursday, January 3, 2008 3:08 AM
  • Tony, thank you so much for your time! I really appreciate it! I have no idea what to do when it comes to all this stuff :/

    I gave it a go but it didn't seem to work. Once I registered them all was I suppose to just close it? Unfortunately it still comes up with the same error code when I try to updateSad But thanks again! Dani


    Friday, January 4, 2008 12:33 AM
  • Did you receive any error messages? Can you provide any additional info?


    Wednesday, January 9, 2008 2:37 AM


    I don't mean to hijack a thread, but I'm having the same problem, so I figured I'd put it in the same place.


    For a little background on when I started getting this error:


    I had been running Windows XP, when it started giving me problems, I was afraid I had a virus, so I decided to upgrade to VIsta Home Premium. (I had bought this a year ago, but my computer at that time didn't have enough memory to run in it properly) So I put in the Vista disc, did a fresh install, not the upgrade, and it updated just fine, seemed to have no problems. The thing was, it had the windows.old folder, which was eating most of my hard drive. (only had 1gig free on an 80 gig HDD) I had read online that if you did in fact have a virus, doing things this way wouldn't actually get rid of it, so I found out how to format the HDD, then install Vista. (Boot from CD ROM, booted from vista disk, deleted partition, formatted HDD, then installed fresh)


    DId all that, and it installed, got all the way to selecting time zones, and entered my user name. It got to the windows is examining your computer's performance or something like that, and completely froze. After waiting (probably 3 -4 hours of waiting), I reset my computer, and it went right back to the create user name part, made me create a new one, but went right into windows, seemed to be working fine.


    So I did all that, and tried to update, and it wouldn't do it. At first it gave error 80070002 or something similar. I followed all the instructions there, cleared the temp files, and it still didn't work, just gave another error. (sorry, forgot which one). I thought maybe it was an error on installation, with how it froze up on me. So I decided to start over, reinstall windows one more time. And it did the same exact thing, froze in the same spot! So this time, when I reset and got it running, I just left it. Now it says can't update, with the error 80004002. I look for the fix, no fix found. It never pops up a message for downloading updates, nothing listed in the updates history. But when I go to shut down my computer, it says please wait while windows installs updates. (??!!) So it sits there for roughly an hour,  installing 41 updates, including the drivers for my sound card, which I had been unable to fix yet. I thought maybe this is it, and tried windows update again, but nothing, same error. I give up, and go to bed.


    I got up this morning, and the little "windows has found the following problems, and here's how to fix it" window is there. I click it, and it says it needs to update the sound card. Which it already did last night! So, since that was already working, I just closed it out.


    Today, I come here, find the DLL fix thing I saw on another post, decide to try it, it all seems to go as it should, only I'm still getting the same darn error!


    And that's where I am right now. I'm sorry for the extremely long winded post, but usually, too much detail is better than not enough detail at all, who knows what little screw up is responsible for this whole mess.

    Sunday, February 10, 2008 7:51 PM

    I just want to thank you, I did this and it helped me! I am successfully running my windows update now.

    Thank You!!!!!!




    Sunday, March 2, 2008 4:07 PM
  • I was able to register all of the DLLs successfully (I didn't get any errors when registering) but nothing has changed.  I still get the same error code.

    I also tried turning my Firewall off when checking for updates.  The odd thing is I will occasionaly get updates automatically, but I have never been able to check for updates.

    Are there any other possible solutions?

    Much thanks,

    Josh Jay
    Wednesday, March 19, 2008 8:58 PM
  • Try this....


    Uninstall software update KB929777. Now can you check for updates?


    Wednesday, March 19, 2008 10:25 PM
  • Thanks for the quick response.  I went to view Update History and didn't see that Update number.  There are over a 100 updates listed, but when I go to Installed Updates there is nothing listed there.  I'm not sure if that means anything or not...
    Thursday, March 20, 2008 1:15 AM
  • Wish I could help. I have to confess, I may not remember this exactly right, but......I had this problem and ended up having to do a Vista upgrade in place and then after that I had to make sure I never loaded that patch.


    Thursday, March 20, 2008 1:26 AM
  • I actually have a different error message, and I noticed others had the same one.  It is 80070490.  I have tried searching it, but nothing comes up.  I e-mailed for tech support and they suggest I try renaming the windows software distribution folder.  That didn't help.  I tried the steps you have listed here, but it would only let me register two of them.  What should I do next?  Help!
    Sunday, March 30, 2008 1:32 AM

    I suffered from the 80004002 error, and I done the registering of the files and it worked great, so I would just like to say Thank You to Anthony for his help with this matter.
    Sunday, March 30, 2008 1:05 PM
  • im still geting the same error


    got any other sugestions

    Sunday, April 6, 2008 6:10 PM
  • I have tried downloading & installing  Update for Windows Vista (KB938371) three times!  Please what do I do now?  This vista program has been a thorn in my side.


    Installation date: ‎4/‎9/‎2008 2:41 PM

    Installation status: Failed

    Error details: Code 80070490

    Update type: Important

    Install this update to enable future updates to install successfully on all editions of Windows Vista. This update may be required before selected future updates can be installed.  After you install this item, you may have to restart your computer. Once you have installed this item, it cannot be removed.






    Wednesday, April 9, 2008 9:26 PM

    Hi, I seen that you had a problem with this error code.

    So I browsed around and stumbled across this forum. If you have a read through this and try there recommendations this should hopefully work for you.

    The forum is at the following address:


    In this forum one person was told by Microsoft to perform an in-place Vista Upgrade.
    • Proposed as answer by Cubewano Monday, June 7, 2010 1:27 PM
    Thursday, April 10, 2008 2:44 PM
  • i was having the same error come up on my computer, i registered the dlls and i still received the same error.  Now I don't know if this just happened coincidentally, but when I turned off the User Accounts Control (UAC) found in User Accounts and restarted my computer and then turned the UAC back on, I noticed the next day that my laptop had uploaded many updates and since then mine has worked fine.  Like I said, I don't know if this is just a coincidence, but I figured if it was what fixed it, and it could help others, it would be worth putting it here, because I know how frustrating this problem was to me when I was first faced with it.


    Sunday, April 13, 2008 6:40 AM

    Wednesday, April 16, 2008 10:09 PM
  • I was getting Error: 80004002 after updating to SP3 on XP x86 and re-registering the windows update DLLs did the trick. It couldn't find two of them, but I'm assuming that those two are exclusive to Vista. Thanks for the help!!
    Wednesday, May 14, 2008 5:35 AM
  • This worked for me too, thanks dude.

    Saturday, May 17, 2008 6:12 AM
  • Hi!

    I want to thank you for your share by helping me and probably many others, this was amazing it worked out right away after doing exacly what you have explained. Thanks again and keep turned on.

    Monday, May 26, 2008 11:29 PM
  • Thursday, May 29, 2008 2:31 AM
  • I just install the active x.

    and it worked


    Tuesday, June 3, 2008 9:54 AM
  • After over a year of having Vista I was able to check for updates for the first time last night.  Yesterday I tried installing the Stand Alone SP1 (obviously because Windows Update wasn't working) and wasn't able to install.  So I went to Microsoft's Vista SP1 (Service Pack 1) support page: http://support.microsoft.com/oas/default.aspx?LN=en-us&x=13&y=8&gprid=500921 and did a chat session.  Here is what we did, as best as I can remember:

    • Opened the System Configuration (Hit start button and type in System Configuration in the search box)
      • Under General tab selected Selective Startup and unchecked Load System Services and Load Startup Items
      • Under Services tab selected the "Hide all Microsoft services" then selected the "Disable all" button
      • Selected the OK button
    • Ran a system scan through the CMD prompt (I'm pretty sure this only indicated which files were corrupted)
    • Uninstalled my Anti-Virus software (AVG Internet Security 8.0) then rebooted the computer
    • Tried the Stand Alone SP1 again, which still didn't work
    • Reinstalled Vista (I think it's called In place upgrade?)
    • Below is the directions emailed to me from the Tech Support

    This is [name removed] with Microsoft Windows Vista SP1 Technical Support. 

    I am following up regarding your Windows service request [number removed].  Here is an outline of the steps that we agreed upon during our chat conversation:

    Problem Description   :   

    Unable to Install Sp1 getting an error code 8024200D

    Troubleshooting performed :

    1: Ran Sfc scan

    2: Performed a clean boot

    3: Uninstalled the Anti virus

    Action Plan:

    1: Please insert the Vista DVD and Run the set up.exe file

    2: Click on install now

    4: Then select Do not go online for updates

    5: If you are prompted to type the product key please type it

    6: Please select the upgrade installation

    7: Please ignore the compatibility Report and continue the installation.

    8: Once it competes please go to  Windows update and install all the pending updates

    9: Then Start the Sp1 Installation again


    After performing this I was able to get all the updates, then install the SP1 Stand Alone.  I didn't lose any settings or files and I just reinstalled my Anti Virus and am still able to check for updates.  (P.S. I didn't have to pay for tech support either.) I spent about an hour with tech support, because of diag, reboots, uninstall, etc.  Then it took me a couple of hours to do the updates and installing SP1.


    It may be beneficial to contact Tech Support the way I did, or you can just try the steps above.


    Tuesday, July 29, 2008 4:12 PM
  • I learned why you have to use the administrator's option... (it failed to register under my personal administrator's account).

    However, even though it did register using the "Run as Administrator" option every time that I tried, it still did not resolve the problem. I tried restarting after, not restarting... it didn't matter.  I have tried changing permissions and ownership of all the system files (it seemed that it could be related since it failed to register on my personal admin acct) still to no avail.


    This all started when I had similar unresolved problem with (I believe error code 8000ffff).

    There were no solutions for several months. Since my computer was not secure (unable to update) I performed a system recovery. After re-recovering several times, I was finally ready to update again...


    I had tried all the Windows Updates a few at a time but still had other issues so I recovered again & again... Once I got my ideal settings and programs... Everything was great until I tried to update the 77 updates all at once.

    The computer went into a perpetual configuring updates/restart mode.


    After restoring to my ideal settings... Windows Update provided error code 80004002.

    After following your instructions (and the above actions) I now get error code 800B0100!!!



    Thursday, August 28, 2008 6:51 PM
  • I have tried to install the correct dll files both via the command prompt and a registry.bat file downloaded at the Microsoft help site, but I keep getting this message after the DOS window opens.

    The NTVDM CPU has encountered an illegal instruction.
    CS:00e5 IP:03b0 OP:0f 02 46 70 ff Choose 'Close' to terminate the application

    what can I do.
    Thursday, September 4, 2008 10:13 AM
  • No help but same error in a totally different place. 80004002 pops up when trying to start Microsoft backup. Havn't seen that B4 in this thread.

    Thursday, September 11, 2008 4:43 PM
  • I had the same 80004002 error code with Vista for about 3 months. Contacted Microsoft who gave me 3 different people all trying to help me remotely via emails. All seemed well and they had good instructions, but this error code should have had an easier plug-in type fix. No such luck. all the re-registering .dll files, removing Mcaffee software and reinstalling windows updates and the .dll's again and so many other suggestions from these 3 microsoft people and NOTHING WORKED. I got the dreaded "we have to FORMAT C" email today and reinstall Windows and everything else....and re-register all my additional software.

    Microsoft needs an upgrade for this error code. It is all over the internet and noone seems to know how to fix it.

    My Windows updates areway out of date and the whole experience has left a very bad taste in my mouth.

    Any additional suggestions are greatly appreciated.



    Tuesday, October 21, 2008 3:30 AM
  • Uninstall software update KB929777 - this worked for me after much messing around with other options. it seems very poor indeed that an update should itself stop the updater from working.
    Friday, November 14, 2008 4:02 PM
  • I also have the 80004002 error code.  I tried to do the reg update as described above with no luck.  When I shut down my laptop, it tries to start updating 15 updates, but shuts down without installing anything.  I was going to try to uninstall the KB929777 update to see what happens, but the only windows related program showing is the Microsoft.NET framework SP1. This may be a coincidence, but my Norton AV is not starting, and the list of installed updates does not show up in the Windows Updater.
    Saturday, July 11, 2009 3:53 AM
  • Hello Tony

    Thanks for your advice. I tried re-registering all those .dll files and was told that it was successful. However when I tried to install Service Pack 2 again I got 'Catastrophic error - Error E_UNEXPECTED (0x8000ffff).

    Any further advice please?


    • Edited by TonyK Perth Saturday, August 8, 2009 9:21 AM Wrong error code
    Saturday, August 8, 2009 9:20 AM
  • same problem... WTF!!!
    Saturday, September 5, 2009 9:05 AM
  • GOD I was hopping that a solution would turn up!!! I have the same issue - laptop - (i think that is part of the problem) the issue started after trying to update Vista to service pack 1_

    been in touch with microsoft , went through a long email correspondences with solutions that didnt work (including activating dll files, removing unvirus and you name it!!) i sent very ellaborated screen captures of all the diffrent stages and at the end ---- NOTHING the guy gave up and told me to reinstalll vista and not install the service pack - what can i say i am working with an unupdated mechine , more them a few things dont work ( codec issues - you cant update that either)

    i dont know what to do - Microsoft need to find a solution to the issue- i dont want to re install because as far as i tell it might happen again
    but ill past here some of what i have been told to do maybe it will help somone
    here goes :

    Good day to you! Thank you for your updates and appreciate your effort to collect screenshots. 


    After I reviewed your information, I found out this issue might because the pending.xml file has been corrupted. This pending.xml will control the installation sequence for Windows Update. My suggestion please try to perform Resetting Windows Update components from this attachment (please do not use the previous one) then delete the pending.xml from your computer.


    Step 1 : Resetting Windows Update component


    Please refer it to the attachment


    Step 2 : Delete Pending.xml


    Open this following file  and delete it:



    Since Windows security will not allow you to do this, hereunder the procedure to take ownership of the file:


    1. In the Start menu, find "Command Prompt". Right-click and choose "Run as Administrator".

    2. Type in the following commands, then press Enter to execute them.


    Note: Please notice space between command and parameter.


    takeown /f C:\Windows\winsxs\pending.xml


    Press Enter and perform the next command


    cacls C:\Windows\winsxs\pending.xml /G :F


    Note: Please replace with your logon User name.


    Then delete the file C:\windows\winsxs\pending.xml, and install latest Windows Update Agent via following link:


    Windows Update Agent:



    If any error was encountered, please help me capture a screenshot so that I can get an accurate impression of the issue.


    If you still unable to delete it please perform the deletion from the  Windows safe mode

    1. Shut down your computer.

    2. Turn the computer on, and once the POST (Power On Self Test) has completed, tap the F8 key until you see Windows Advance Options menu.

    3. Highlight Safe Mode and press Enter two times.

    4. Please login normally.



     If you have any questions or concerns on the recent information I've provided you, please don't hesitate to let me know.


    Thank you for your cooperation. Your patience is highly appreciated. 


    Kind Regards,

    Agung Berbudi


    Microsoft  Australia and New Zealand  Online Technical Support


    MY answer to the tech guy :

    Dear Agung,


    Performed all suggested solutions and still unable to update Windows. Tried:


    1)      On a clean boot cleared all start up items, disabled all services (except Microsoft services), went through deletion of SoftwareDistribution folder, was prompted by the system that some items could not be deleted as they were used by another program. Continued to stopping Background Intelligent Transfer Service and Cryptographic Services (which worked fine). Could not stop Automatic Update as that service wasn’t present (couldn’t find it). See attached screen capture. Reactivated the services that were stopped – did not work.

    2)      Created a new user account with administrator privileges and tried to update from that account, even when using the file Windows6.0-KB942288-v2-x86.msu I was still prompted that the update does not apply to your system (see screen shot attached).

    3)      Uninstalled anti-virus, extracted the Auto update file (didn’t need a password – it wasn’t password protected). It did seem that there were a few errors with access denied error 5 (see screen capture attached).

    4)      Reset Internet Explorer – switched off computer. Was prompted install Windows updates and shut down. The screen went to install update 1 out of 7, again a long wait that resulted in no updates being installed “was stuck in process 1 out of 7”.


    Please advise if you have any further solutions

    His next option


    Good day to you. Thank you for your information.


    I still have another workaround for you to try, and I hope this time will remedy this issue.

    Step 1 : Download and install Windows Installer 4.5



    double click to execute the installation.


    Step 2 : Use CheckSUR tools


    1. Please download and run CheckSUR tool from the link below:


    CheckSUR tool for Windows Vista 32-bit



    2. Double-click on the downloaded file to run the CheckSUR tool

    3. Restart computer and try to updates.


    if the issue still remain proceed to the next step


    Step 3 : Rename Windows Update folders from safe mode


    1. Shut down your computer.

    2. Turn the computer on, and once the POST (Power On Self Test) has completed, tap the F8 key until you see Windows Advance Options menu.

    3. Highlight Safe Mode and press Enter two times.

    4. Please login normally.


    Then rename Windows update folder


    1) Click on Start > in the 'start search' box type "services.msc" on the box and press ENTER

    2) Right-click on Background Intelligent Transfer Service, choose Stop

    3) Right-click on Cryptographic Services, choose Stop

    4) Right-click on Windows Update, choose Stop

    5) Close the Services window

    6) Click on Start > in the 'start search' box type %windir% then press ENTER

    7) Locate the SoftwareDistribution folder, right-click on it and choose Rename, then rename the folder to Sdold

    8) Click on Start > in the 'start search' box type c:\windows\system32

    9)Locate the Catroot2 folder, right-click on it and choose Rename, then rename the folder to Catroot21.old

    10) Click on Start > in the 'start search' box  type "services.msc" on the box and press ENTER

    11) Right-click on Background Intelligent Transfer Service, choose Start

    12) Right-click on Cryptographic Services, choose Start

    13) Right-click on Windows Update, choose Start

    14) Close the Services window.

    15) Restart computer into normal mode then try to update.


    If the issue wont go away my advice is try to contact our phone support. I believe it would be more beneficial for you to contact Microsoft Technical Support directly over the phone. This does not mean that we do not want to provide support, it is just to save your time dealing with this issue. Moreover, the speediest resolution is attained by over-the-phone troubleshooting as opposed to email correspondence. They might go through the steps which we did but it might be a little in depth and easier for yourself.


    Please call 13 20 58 (Australia) or 0800 800 004 (New Zealand) and quote the following case service request 1082220761. Please let them know this case number so that they can check the steps which I have suggested to you.


    If you do wish to continue troubleshooting this issue by email, please let me know. I will be glad to help.


    Kind Regards,

    Agung Berbudi


    Microsoft Australia and New Zealand Online Technical Support


    my answer :

    Dear Agung,


    Again I am sorry ( and frustrated) to tell you that the workaround didn’t work.

    Steps 1 and 2 – didn’t work at all as I couldn’t install the Windows installer 4.5 as I was prompted that the file ( although it is my OS) doesn’t match my OS .

    Then I tried anyway to install the checkSUR tool or as it named on the link attached System Update Readiness Tool for Windows Vista I have included a screen shot so you can see the error I got (some updates weren’t installed.jpg).


    Step3:     stoped the services

                    Renamed the folders

                    Attempted to restart the services : was prompted that I can’t restart some of the services under safemode (see attached screens)

    Restarted the computer

    Nothing!!!!!    No Updates


    I still think the problem is that the updates aren’t installed and not about checking for the updates


    If you have any further suggestions I would appreciate it .

    Calling the phone service is a problem as I will have to do it during working hours and unfortunately I run a retail shop and that will make it very difficult for me.

    If you can continue assisting, I would prefer it.


    Thanks in advance,


    on and on it went and at the end - YOK, NOTHING , NADDA, KLUM, GURNICHT,
    nothing worked i am at the same point i was in 2008   any one from microsoft reading ????? anything we can do ?
    p.s i still have all the screen shots i can send if anyone wants them

    Friday, September 11, 2009 4:52 AM
  • I tried about every possible suggestion and nothing worked.  I ended up working the Microsoft with fixes, several emails and suggestions.  BTW, microsoft customer service was very helpful, but the fixes just didn't take.  The problem I was having was on a Lenovo laptop, pretty new, and got some help from their suport folks.  The suggested I use their "One Key Restore" feature, which basically re-installs the computer to factory out of box settings.  Problem is that it's like formating and re-installing Vista.  I had to go back and re-install software and applications.  This was the only thing that worked.  After spending HOURS trying to fix this problem, I then spent a LOT of time updating Vista to bring it current.  It now works very well and the updater is working properly.  I don't know what in the world would cause so much corruption, but what a mess.  It was definitely not a virus, as I had Norton installed too.  Now that Windows 7 is almost out, I guess this will all be moot.  Good Luck to anyone who still has this issue.
    Sunday, October 11, 2009 7:48 AM
  • it dinot seen to work and i did this as admin and all i got error code 80004002 again
    Thursday, November 12, 2009 8:59 PM
  • Tried this but then I get a message "The module wuapi.dll was loaded but the call to dll register server failed.  Error Ox80070005

    Can you help


    R. Cambron
    Wednesday, December 16, 2009 1:10 PM
  • step 1.Okay i had the same issue,here is how i fixed it click "start" then select run and type in "msconfig" hit enter.here u will click on the services tab. and the bottom right u will see "enable all" simply hit that button,then check and make sure all are selected and then hit apply,you will be prompted to restart your computer,do so and all should be fixed .For those that do not wish for all services to start make sure these services are selected--->Windows Update ,Windows Module Installer, & Windows Installer than again hit apply.

    step 2.Now if this still did not fix your problem you can try this,once again navigate to "start" and select "run" type in "services.msc"hit enter and here you need to check a few things firstly make sure "background Intelligent Transfer Service is set to Automatic Startup.If not select and right click this service and select the "properties"option.Now you should have the BITS Menu up and u will see located near the center "startup type"make sure it says "automatic"then hit apply at the bottom of menu.You will do the same for Windows Installer and Windows update.

    i did all of the above and restarted my machine and all was well .. hope it helped :)
    Saturday, January 16, 2010 11:42 PM
  • Tony, thanks for your help.. this worked for me as well.
    Wednesday, February 3, 2010 3:47 AM
  • Thank you Anthony....    It seems to be working for me.  I'm running Vista (hate it) but at least it's checking for updates now.  Thanks you, Christopher

    May 2010

    Sunday, May 23, 2010 4:30 PM