none
Clients unable to download distributed content from DP (404 HTTP error, 1810) RRS feed

  • Question

  • Hello

    we recently upgraded to SCCM 1810 and for the first Moment everything seemed fine. But after I created a new application and tried to install it the download stuck at 0%. So I made some research in the log files and found the following in the data transfer logs:

    UpdateURLWithTransportSettings(): OLD URL - https://server1.mydomain.local/CCMTOKENAUTH_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1	DataTransferService	29.12.2018 10:27:26	9288 (0x2448)
    UpdateURLWithTransportSettings(): NEW URL - https://server1.mydomain.local:443/CCMTOKENAUTH_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1	DataTransferService	29.12.2018 10:27:26	9288 (0x2448)
    DTSJob {1F980A06-C4FC-4A66-B5A3-3E7B2B5411A9} switched to location 'https://server1.mydomain.local:443/CCMTOKENAUTH_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1'.	DataTransferService	29.12.2018 10:27:26	9288 (0x2448)
    DTSJob {1F980A06-C4FC-4A66-B5A3-3E7B2B5411A9} in state 'DownloadingManifest'.	DataTransferService	29.12.2018 10:27:26	12980 (0x32B4)
    [CCMHTTP] ERROR: URL=https://server1.mydomain.local:443/CCMTOKENAUTH_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1, Port=443, Options=63, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    [CCMHTTP] ERROR INFO: StatusCode=404 StatusText=Not Found	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    Raising event:
    instance of CCM_CcmHttp_Status
    {
    	ClientID = "GUID:0fff70e1-ff3f-480c-a760-72a067d26bdc";
    	DateTime = "20181229092727.190000+000";
    	HostName = "server1.mydomain.local";
    	HRESULT = "0x87d0027e";
    	ProcessID = 8484;
    	StatusCode = 404;
    	ThreadID = 12672;
    };
    	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    Successfully queued event on HTTP/HTTPS failure for server 'server1.mydomain.local'.	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    Error sending DAV request. HTTP code 404, status 'Not Found'	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    Download timeout has met. DTS job {1F980A06-C4FC-4A66-B5A3-3E7B2B5411A9} will quit.	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    GetDirectoryList_HTTP('https://server1.mydomain.local:443/CCMTOKENAUTH_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1') failed with code 0x800705b4.	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    Error retrieving manifest (0x800705b4).	DataTransferService	29.12.2018 10:27:27	12672 (0x3180)
    DTSJob {1F980A06-C4FC-4A66-B5A3-3E7B2B5411A9} in state 'Suspended'.	DataTransferService	29.12.2018 10:27:27	15980 (0x3E6C)


    Strangely this only happens to newly created and updated content. Content that was created before upgrading to 1810 is downloading fine. This issue did only affect one Distribution Point. Our branch DP and the Cloud dp are still serving the Content.

    Hope someone can help me out on this.

    Ok I tried accessing the url https://server1.mydomain.local/NOCERT_SMS_DP_SMSPKG$/Content_94464f2a-ee10-42f5-92f6-ac26a23cf986.1 and enter my credentials then I can see the content list but when I try to download the file I am prompted for credentials and they are not getting accepted (401 invalid credentials). 

    This is a behavior that is different from one of the healthy Distribution Points that offer me the file for download.

    Update:
    Ok I realized that the FileLib for the Files of the content do not exist on the problematic DP. The file is OrcaSetup.Msi.INI with the content:

    [File]
    Attributes=00000020
    Size=1910272
    TimeModified=130515597790000000
    Hash=119FC6D2D9A872477A4B12DD43C637E8DD9F7705A26CD9A79A9F0C90C2AA9F45
    
    But there is no folder 119F on the DP while on the other DPs there is the folder. But now the question: Why is it missing?

    Saturday, December 29, 2018 9:49 AM

Answers

  • OK as all bigger issues the root was quiet simple: The DP did not have enough free disk space. I extended the volume a bit and now the folders are getting created. Strangely the sccm did not create any dp failure Messages due to the lack of disk space. But nvm… all good now.
    • Marked as answer by Weatherlights Saturday, December 29, 2018 11:44 AM
    • Edited by Weatherlights Saturday, December 29, 2018 11:44 AM
    Saturday, December 29, 2018 11:44 AM