none
Exchange 2010 mac outlook 2011 external RRS feed

  • Question

  • Hi there,

    We have Exchange 2010 autodiscover working internally/externally on a Windows desktop Outlook 2010.
    However for Outlook 2011 on a mac, this only works internally and not externally.
    On mac with Outlook 2011, i put my email address, select User Name and Password for Method and select configure automatically.
    I then get the prompt for allowing redirectiong to https://webmail/autodiscover/autodiscover.xml , i click allow.
    It fails to configure automatically.
    i then manually enter the server as https://webmail/ews/exchange.asmx but it still doesnt work. Ive even tried putting in our domain controller into the directory settings.
    I've turned logging on outlook 2011 and it seems to connect into our enviornment, i can see our Exchange partition in the logs:

    /o=org/ou=Exchange Administrative Group(FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=clientaccessarray</
    It picks up our domain controller, our public folder server, all the correct EWS URL's eg OOF, OAB, UM.

    But for whatever reason it keeps failing with this error in the log:

    Outlook Exchange Auto Configure: Testing external autodicover settings: BAD

    any help appreciated.

    thanks

    Friday, December 20, 2013 4:22 AM

All replies

  • Hi,

    I recommend you refer to the following article to troubleshoot the issue:

    http://www.officeformachelp.com/outlook/exchange/autodiscover/

    Troubleshooting

    Where Autodiscover services are either partially or incorrectly configured, users may experience the above from their mail client indicating they are being redirected to a different server, which may not exist or may be inaccessible. This can happen when an external DNS entry points to an internal server that is not accessible via the Internet. Administrators can either:

    1. Correct the Autodiscover settings on the network to properly direct mail clients to the correct server (preferable).
    2. Disable Autodiscover for the Exchange account in the mail client itself.

    To disable Autodiscover in Outlook for Mac run the following AppleScript command in AppleScript Editor.app:

    tell application "Microsoft Outlook"
    	set background autodiscover of exchange account 1 to false
    end tell
    Exchange administrators may also need to test their external Autodiscover settings during setup or to troubleshoot connectivity issues. Microsoft has provided the Exchange Server Remote Connectivity Analyzer tool for them. This is a secure Microsoft website that will test a company’s Autodiscover settings and provide feedback about network and Exchange settings.

    Thanks.


    Niko Cheng
    TechNet Community Support

    Friday, December 20, 2013 7:07 AM
    Moderator
  • thanks for the reply but i have seen that article and have already tried disabling autodiscover on the mac client.
    according to this article http://technet.microsoft.com/en-us/library/jj984202(v=office.14).aspx autodiscover for mac 2011 works the same as windows outlook, that is first it goes to https://domain/autodiscover/autodiscover.xml which we dont have.
    next it goes to https://autodiscover.domain/autodiscover/autodiscover.xml which we do have and i can confirm this is working because our external windows outlook 2010 clients can use this to setup outlook externally.
    we also have an SRV record for _autodiscover._tcp.domain.com which points to our external DNS record host autodiscover.domain.com.

    Even though our external outlook 2010 windows clients connect to exchange successfully, when running the autodiscover test on test.exchangeconnectivity.microsoft.com, we get an error when atttempting to retrieve the XML response.

    The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.domain/AutoDiscover/AutoDiscover.xml for user

    A Web exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown.
    Headers received:
    Pragma: no-cache
    Proxy-Connection: Keep-Alive
    Connection: Keep-Alive
    Content-Length: 980
    Cache-Control: no-cache
    Content-Type: text/html; charset=utf-8

    Elapsed Time: 713 ms.

    anybody know what this error means?

    Also when attempting to go to https://webmail.com/ews/exchange.asmx or https://autodiscover.domain/autodiscover/autodiscover.xml
    when prompted for credentials, it never accepts them and keeps prompting for the password and i dont see the xml file compared to how it behaves on an internal network. is this what it should be doing?
    the authentication options for ews and autodiscover are windows authentication and basic. is this correct?

    Sunday, December 22, 2013 9:58 PM