Sysprep - "Failure occurred while executing drmv2clt.dll" - Fix RRS feed

  • General discussion

  • I don't usually have problems running sysprep, but the first time I ran it on a Windows 7 (BETA Ultimate 32bit) PC I received an error that Sysprep could not continue and was halted.  I went to c:\windows\system32\sysprep\panther and opened the setuperr.log file.  (Actually, Windows won't let you open this file (!) so copy it out of this directory, then open it.)  There was not much in the file, just a few lines referencing drmv2clt.dll. 

    2009-04-20 13:37:55, Error      [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'drmv2clt.dll,Sysprep', returned error code -2147024864[gle=0x00000020]
    2009-04-20 13:37:55, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = -2147024864[gle=0x00000020]
    2009-04-20 13:37:55, Error      [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep cleanup providers; hr = 0x80070020[gle=0x00000020]

    I searched the MS KB, and sadly, could find nothing.  Then I Googled some of the above and found a couple of references to this.  They mentioned that drmv2clt.dll is associated with Digital Rights Management and this error in Sysprep could be fixed by disabling Media Sharing in Windows Media Player.  That seemed odd.  This Windows 7 PC was setup just to test Sysprep and imaging.  We didn't even start or configure Windows Media Player.  I also had no idea how to disable Media Sharing in Media Player??  This time I went to Windows Help and searched it, but sadly, it too had no information.  I once again Googled this and found out how to disable Media Sharing in Media Player.  It is a service that is configured to automatically start at boot up.

    Click Start > Run, type Services.msc to open the Services applet.
    Scroll down to Windows Media Player Network Sharing Service, double click it, change the Startup type to Disabled.  Click OK.
    Reboot the PC

    Once I did this, I re-ran Sysprep (sysprep /generalize /oobe /shutdown /unattend:sysprepdomainWin7.xml) and it ran without error.

    Seems like a sysprep bug.  I don't think this is a Win7 thing since the fix for this I read was from a BDD 2007 document.  Oh, and if you want to know how to fix problems in Windows, use Google.
    Tuesday, April 21, 2009 1:47 PM

All replies

  • We have noted the exact same problem and used the same work around as you describe. I have spoken to MS who inform me this is a known bug and will be fixed in the RC.
    Wednesday, April 22, 2009 4:50 PM
  • Just installed the windows 7 RC build 7100 and tried to run Sysprep. The same failure occured and .... has not been fixed in the RC.

    But the "Windows Media Player Network Sharing Service" solution worked just fine.

    A note: The build 7000 did not have this error.
    Monday, May 4, 2009 11:11 AM
  • Issue has been already fixed in Windows 7 RTM and for Windows 7 RC you have to use the workaround

    Thursday, May 7, 2009 3:45 PM

  • Thanks.  Grrr one of those things you can never figure out hidden away, in the dark.

    It worked for me.  Command that might be useful in MDT etc.

    sc stop WMPNetworkSvc
    Tuesday, June 9, 2009 4:05 AM
  • Issue has been already fixed in Windows 7 RTM and for Windows 7 RC you have to use the workaround


    Uh, I got the exact same error on Windows 7 RTM.  I'll try the workaround.
    Saturday, August 22, 2009 3:59 AM
  • ...and of course the workaround fixed the problem on the RTM version, so thanks for the info, Ukon.  I'm wondering why this is still broken.  Lots of people use Sysprep and the Windows Media Player Network Sharing Service is enabled by default.
    Thursday, August 27, 2009 2:21 AM
  • Identical error message, but this workaround didn't work for me...until...also in Services, I disabled Media Center Receiver Service and presto,
    bad, bad error be gone!
    Found it here, Michael's post - http://social.technet.microsoft.com/Forums/en-US/itprovistadeployment/thread/75c5c2bc-65c7-4a3c-ab08-2bbd56c80708?prof=required

    Daniel C.

    Thursday, September 10, 2009 7:57 AM
  • Just ran into same issue on 64 Bit Windows 7 Professional installed via HP provided CD.  The good news is that disabling the Windows Media Player Network Sharing Service worked!
    Wednesday, January 13, 2010 1:16 AM
  • Disabling the Windows Media Player Network Sharing Service in 32 bit Windows 7 worked for me too.   Come on Microsoft, get stuff like this fixed.   Tired of donating my time to problems like this.
    Saturday, March 27, 2010 1:45 AM
  • Hi there,

    @ankito : What makes you so sure the issue "has been already fixed in Windows 7 RTM" (May 07, 2009 : more than a year ago !) ???

    I'm trully curious, since it obviously has NOT been fixed : i just ran into the exact same error, sysprepping an OEM x64 Windows 7 Pro.


    Whatever ; once the Windows Media Player Network Sharing service is stopped, sysprep is not angry anymore and agrees to do its stuff. Clarksville wrote "Tired of donating my time to problems like this." : i second this.

    Friday, June 25, 2010 9:11 AM
  • You sure saved me a lot of work. We are Q4 2010 now and the problem hasn't been fixed. Yes, I ran all the updates... Good job UkonCornelias!
    Saturday, October 30, 2010 7:11 PM
  • One other thing you might want to consider when trying to troubleshoot this issue is whether you have the Zune software installed on this computer or even have connected a Zune to the said computer.  Even though it is not part of the “Windows Media Player/Center” it does still utilize the drmv2clt.dll.  I had that same issue as I don’t use WMP but I do use the Zune software and that escaped my mind as being an issue until I had a brain fart moment, disabled the Zune Media Sharing service and then it worked.  Sorry if this was covered already.

    Monday, January 10, 2011 9:50 PM
  • FYI


    win 7 ho pre x64 SP1

    same problem persists.

    same fix fixed.


    Thursday, March 17, 2011 3:41 PM
  • I had same problem, than I stopped some windows services and Sysprep is running now ok, but I don't known what windows service is the bad guy... the last service that I stopped was "Windows Media Player Network Sharing", but can be other...
    Monday, April 4, 2011 7:26 PM
  • Same here on Windows 7 Professional x64 with SP 1. Funny, we didn't have it in some installations, but now all of a sudden it pops up. I wonder if it has anything to do with volume media vs. retail media.
    Wednesday, April 27, 2011 9:20 PM
  • Hello Hello Microsoft:

    The problem is still here even with SP1.  I am tired of stopping the winmedianetwork serviec and making this sysprep to work.  Please fix it.

    Monday, May 16, 2011 5:57 PM
  • Just having the same issues on Win 7 x64 SP1. Simple install using an autounattend.xml answer file, then when trying to generalise, sysprep fails.

    Just in the process of restoring the reference image again, and will try shutting down the WMP Network serving service to see what happens!



    • Edited by Swinster Saturday, September 3, 2011 2:24 PM
    Saturday, September 3, 2011 2:24 PM
  • Just having the same issues on Win 7 x64 SP1. Simple install using an autounattend.xml answer file, then when trying to generalise, sysprep fails.

    Just in the process of restoring the reference image again, and will try shutting down the WMP Network serving service to see what happens!

    l simply stopped the service and sysprep worked. Of course, doing it this way and not disabling the service will mean that the servie will start if you reboot whilst in audit mode.

    I'm guessing it would be relatively simple to add something to the sysprep command to switch off this service if it is running.

    Saturday, September 3, 2011 4:32 PM
  • I concure that the problem is still exist.   My configuration is with windows 7 Pro 32bits w/SP 1.

    Tuesday, October 18, 2011 3:30 PM
  • This issue still exists in 2012, unreal!!  Setting up a template to clone for VM labs.  Conducted a fresh install of Windows 7 Ultimate w/ SP1 all patched up and sysprep was failing.  I tried every other potential fix I could find without success and then I found this thread.  

    Amazing that disabling the WMP network sharing service worked like a charm.  Rather annoying but just glad I've got it fixed.  Thanks!

    Wednesday, March 21, 2012 2:50 PM
  • Yes, for a company that has a long and challenged history of omnipotence I have come to expect these information black holes as a technician. I have been working with MS and also with Windows since DOS 2.2 and I recall the DOS 4.0 debacle. It was the beginning of the use of "Hi-memory" area. They had created the ability to use hi-memory (introduced by Compaq) but they didn't bother to reserve or map what was in memory. So when DOS went to retrieve information loaded in memory it either was overwritten, or could not be located. Thus, all machines locked! I worked with a couple engineers from UC Irvine who identified and resolved the problem Windows. I recall working at WB and I introduced Windows ADS, well ultimately we had to migrate from one machine to another. There was an information store containing the data of active directories configuration and security called the "DIT" in restoring ADS I ran into a wall. There was no documentation on how to move the DIT, the core of ADS's information. Well I finally got to a high level technician that could work with me to relocate and document the procedure. If you are familiar with UNIX then you understand that the user community documents and tests new code. Just inherent part of computing. So I am not surprised that they have left us to resolve this issue ourselves.

    Of course they are now pushing AZURE and online storage which could be why they aren't assisting us with this issue.

    the only time is now!

    Wednesday, April 4, 2012 4:07 PM
  • I canceled the Windows Media Player Network Sharing Service and everything works great I can not believe how long I break my head with it thank you very much
    Tuesday, October 2, 2012 8:26 AM
  • Cannot believe that this still hasn't been fixed.
    Wednesday, May 8, 2013 5:08 PM
  • This problem first appeared in Vista and also still exists in Windows 7, as you have noticed. You get this error if you choose a Network Location prior to using Sysprep. Any time building an image, if you get the Choose Network Location window, click cancel and you won't have this error.

    I believe, "technically" that it only happens if you choose Home or Work, but not Public. To be safe, I never choose a location at all, and then if I need to specify a location, I will handle it with the answer file.

    Thursday, May 9, 2013 2:23 PM
  • Thank you very much!

    This solved my problem in a matter of minutes.
    Monday, October 21, 2013 11:46 PM
  • Amazing... After four years of this question being posted, the problem still exists. I just ran into it today, and disabling the aforementioned service fixes the issue.
    Friday, November 1, 2013 8:28 PM
  • Issue still occurs. Just received a new Dell Inspiron 3847 with Win7 SP1 x64 and received the error when attempting to sysprep and create an image. Disabling the WMPNetworkSvc resolved the issue. This error did not occur on both an HP Compaq Pro 6300 AiO a Dell Optiplex 780 both running Win7 SP1. Both the Dells also have the issue where after the system reboots from syspreping in loops the error stating "Windows could not finish configuring the system. To attempt resume configuration, restart the computer" I was able to bypass this error by booting the machines into Safe Mode then restarting. You get an error when you boot into Safe Mode however once you reboot back into Normal mode the sysprep completes.

    I haven't yet figured out what causes this as the setup.etl file keeps getting corrupt to I am unable to run a trace log to see what is preventing sysprep from continuing. I believe it has something to do with ESET but ESET is on all 3 PCs yet the issue only happens on the Dell models. 

    Tuesday, February 11, 2014 11:13 PM
  • Yep, after all those years, the fix still works! I have ran into this particular issue while preparing a template for a pooled VDI collection.
    Wednesday, March 5, 2014 8:05 PM
  • Thank you so much for posting this -- you saved me a LOT of time on research!



    Sunday, April 27, 2014 3:41 PM
  • 5 years later, and this is still the thing that ended the ridiculous amount of frustration and time spent trying to get sysprep to work.  For that sir, I thank you... thank you... THANK YOU!
    Wednesday, June 4, 2014 4:48 PM
  • Still the same solution for the same problem in November 2014.

    Great Job. MS :\

    Tuesday, November 25, 2014 3:13 PM
  • Problem still exists in Win7-64 SP1, all updates. Sysprep failed, disabled service and it worked.

    Thank you for the solution!

    Friday, December 12, 2014 4:34 PM
  • Just wanted to provide yet another update in 2015.. 6 years later, the bug is STILL not fixed, and the original 2009 fix from UkonCornelias still works!  Thanks!
    Sunday, March 29, 2015 5:46 AM
  • Win7-x86-SP1, All updates. August 2015. Problem STILL exists.  It must be just a running joke at MS by now.  Stopping this service fixes the issue.
    • Edited by a033197m Saturday, August 1, 2015 8:09 PM
    Saturday, August 1, 2015 8:09 PM
  • I had the cryptic Sysprep "fatal error" happen on Windows 7 Home Premium 32-bit, not even long after I had successfully run it on Vista Home Premium 32-bit. Looking in the error log showed the same drmv2clt.dll file, and it was looking that up which brought me here. Trying your workaround out, it worked! Thank you!

    Gosh, Microsoft, should us users really have to work around your operating system like this? I think that's ridiculous!

    • Edited by Racecar 56 Monday, October 26, 2015 6:47 AM
    Monday, October 26, 2015 6:45 AM
  • I am still trying to get the work around to work on my son's computer so that I can upgrade his system.

    Since there may be a number of programs using drmv2clt.dll, why not change the file name to drmv2clt.dll.tmp, restart the computer, run sysprep, and change the file name back? This could even be done by connecting the drive to another computer externally so the drive will be "clean" at first boot.

    Thursday, December 31, 2015 6:47 AM
  • I did finally get it to work after stopping services for WMP and Windows Media Center and Zune. I would still like to know if temporarily renaming the dll file would work or cause an error. I would have tried that next.

    Wednesday, January 13, 2016 1:35 AM
  • That was NEVER ever fixed. Win 7 is close to its natural death, yet the bug still flourishes!

    Microsoft really should get they act together


    Saturday, January 16, 2016 11:49 AM

  • Hello everybody,

    Same issue in   2016 January !

    Problem with Win 7 X64 Pro SP1 full Update. Never fixed, have to disable Windows Media Player Network Sharing Service as described above.

    Great job MS, Don't change, you're the best ;-)


    Sunday, January 31, 2016 3:04 PM
  • Hi everyone,

    Still the same issue in August 2016.

    Still the same way to resolve it. Great and thank you UkonCornelias !

    Thanks to Microsoft too.

    Friday, August 12, 2016 4:53 PM
  • Aug of 2016 and same issue with same error messages
    Just freshly installed official win7 ultimate x64, spending 72 hours on force update all packages, and sysprep...
    messing with nothing (activation etc... 29 days left...)

    Sunday, August 21, 2016 12:13 PM
  • If you've read this far and are still having this issue, hopefully my solution will help you:

    I encountered this issue while sysprep-ing a Win7 Pro x64 machine for a PCN environment. I set the registry keys described here, reinstalled MSDTC, and disabled the Windows Media Player Network Sharing Service, but the error persisted. I even completely unloaded that service to no avail.

    Here's how we fixed:

    In one of the last lines of the setupact.log file (C:\Windows\system32\sysprep\Panther), we saw this error:

    Info       [0x0f008b] SYSPRP RunRegistryDlls:Found entrypoint in registry at SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\SysPrep\Cleanup\{de7df4f0-0ce9-ca23-6049-1807de6941d3}; will try to launch 'drmv2clt.dll,Sysprep'

    The ID may not match, but the value should look familiar for you.

    Open RegEdit and take ownership of this directory [if needed]:


    Delete the registry key with the value beginning with drmv2clt.dll

    Once we did this, SysPrep completed successfully!

    Wednesday, January 4, 2017 9:11 PM
  • Thanks, Was diving me crazy.  Disabled service and was able to sysprep my PVR Hard drive to install in a new box.  No way i wanted to upgrade to W10.  Love my Media Center configuration.  Will keep W-7 forever if I can.  Now have a clone of the HDD syspreped and saved to an external drive in case of a HDD failure.
    Wednesday, August 12, 2020 12:22 AM