locked
DFS Namespace "Enable Windows Server 2008 mode" option grayed out RRS feed

  • Question

  • Hi,

    This is totally frustrating me today so I come here in the hopes someone has a quick solution!  We used to have a DFS namespace installed on 2 windows server 2003 R2 machines.  The namespace is not very big so instead of migrating anything I just deleted everything off of the old servers and uninstalled DFS through the add/remove windows services in Control Panel.

    Then I go to our new Windows Server 2008R2 server and click "add roles", select file services, and then select Distributed file services and its subitems (Namespace and replication).  Next I choose to create a namespace now and enter a name for the namespace.  On the next screen I select the radio button for domain based namespace, however it will not let me select the "Enable Windows Server 2008 mode" checkbox!!!

    The forest and domain are both raised to the 2008R2 level and DFS has been removed from both servers that had it before.  Both the old and the new servers were restarted afterwards.  Creating it in 2000 mode would work fine, but as long as I am doing this I would like to do it up to snuff.  Is there something stupid I am missing??  I have read the articles with the requirements for 2008 mode and all are met.

    Any ideas for a frustrated admin?  :)

    Thanks

    Tuesday, May 11, 2010 4:27 PM

Answers

  • Hi,

    How many domain controllers are there in the current domain? Please check if DFS is installed on other DC. If needed, you can try to reinstall DFS role service and reboot to see the result.

    Wednesday, May 12, 2010 8:28 AM

All replies

  • Hello,

    Since you may already have pre-2008 DFS-N, it might prevent the switch to 2008 mode.

    Make sure you migrate existing ones using the following method: http://technet.microsoft.com/en-us/library/cc753875.aspx

     


    --- Marc Lognoul [MCSE, MCTS, MVP] Heureux celui qui a pu pénétrer les causes secrètes des choses Happy is the one who could enter the secret causes of things Blog EN: http://www.marc-antho-etc.net/blog/ Blog FR: http://www.marc-antho-etc.net/blogfr/
    Tuesday, May 11, 2010 7:00 PM
  • Hi,

    How many domain controllers are there in the current domain? Please check if DFS is installed on other DC. If needed, you can try to reinstall DFS role service and reboot to see the result.

    Wednesday, May 12, 2010 8:28 AM
  • I've tried this solution to no avail --can you revisit the question please?

    thanks


    --- ian
    Wednesday, March 23, 2011 6:19 PM
  • Solved it by restarting the DFS Namespace Service and the DFS Replication service.

    --- ian
    Wednesday, March 23, 2011 6:25 PM
  • Solved it by restarting the DFS Namespace Service and the DFS Replication service.
    --- ian
    Wednesday, March 23, 2011 6:26 PM
  • Hi

    I have the same problem. I have risen the domain and forest to 2k8R2 mode, but the "Enable Windows 2008 mode" checkbox is not accessible when Im trying to create the DFS Namespace. What do you mean by "check if DFS is installed on other DC"? In our environment we have 3 DCs. On each of them are running services "DFS Namespace" and "DFS Replication", but the role "File services" - "Distributed File System" is not installed. This role is installed on our file servers. I have tried to remove and add the DFS role service from/to our file servers, restart the servers, but the result is the same - check box not accessible.

    Any ideas? thx

    Mike

    Friday, May 25, 2012 6:27 AM
  • Are you using domain root or standalone? If domain, you might need to restart the services on the DCs. 

    --- ian

    • Proposed as answer by mishman Monday, May 28, 2012 8:54 AM
    Friday, May 25, 2012 1:38 PM
  • Thank you Alan!!! That's it! I use domain root and restart services on DCs helped. I would kiss your feet :-D
    Monday, May 28, 2012 8:56 AM
  • See http://www.gavinwill.me.uk/category/active-directory/, restart DFS services mentioned on Infrastructure Master FSMO and the namespace server.
    Friday, July 13, 2012 1:36 PM