none
Exchange 2013 SP1 co-existence Exchange 2010 SP3 Roll up 4 Out Of Office not working for Exchange 2010 mailboxes RRS feed

  • Question

  • Hello,

    We are currently running Exchange 2013 SP1 co-existence with Exchange 2010 SP3 Rollup 4.

    Our Outlook Anywhere and OWA are pointed towards Exchange 2013 CAS servers.  

    User mailboxes are still on Exchange 2010.

    Outlook Anywhere   with Exchange 2010 mailboxes are able to connect via Outlook 2010.

    The only issue is when Outlook Anywhere is being used from Internet or from Internal network and user goes in Outlook 2010 -> File -> Automatic replies get the following error: -

    "Your automatic reply settings cannot be saved.  The server might be unavailable, or your automatic reply message might have exceeded the size limit on the server"

    This only occurs if connection goes via Exchange 2013 SP1 CAS server.  It was working before and it seems it just broke down since we upgraded to Exchange 2013 SP1.  In HTTPProxy EWS logs on Exchange 2013 SP1 CAS server I see this when I re-create the issue on Outlook 2010.

    =================================

    "2014-03-18T12:46:48.135Z,c64653f6-6b52-4657-8b3b-f9f1f5ece965,15,0,847,30,,Ews,messages.domain.com,/EWS/Exchange.asmx,,Negotiate,True,domain.com\id2013,,Sid~S-1-5-21-323741388-3570301916-4168597275-99094,Microsoft Office/14.0 (Windows NT 6.1; Microsoft Outlook 14.0.7113; Pro),10.90.234.35,VPLXCAS01,400,,,POST,Proxy,exch2010casserver.domain.com,14.03.0123.000,IntraForest,WindowsIdentity,,,,5423,,,,2,0,,0,,0,,0,0,0,0,1,0,,,,,,3,0,,2,,4,5,,,CorrelationID=<empty>;BeginRequest=2014-03-18T12:46:48.135Z;ProxyState-Run=None;DownLevelTargetHash=4/4/6;ClientAccessServer=exch2010casserver.atkearney.com;ResolveCasLatency=0;ProxyToDownLevel=True;BeginGetRequestStream=2014-03-18T12:46:48.135Z;OnRequestStreamReady=2014-03-18T12:46:48.135Z;ProxyState-Complete=ProxyRequestData;,StreamProxy=StreamProxy-Request-None;HttpException=Cannot find the appropriate SOAP header or body.;"

    =========================

    I have checked and double checked using https://testconnectivity.microsoft.com/ and there are no issues in "EWS".  

    It works fine if user mailbox is on Exchange 2013 Sp1.

    I was wondering if anyone has co-existence of Exchange 2013 SP1 and Exchange 2010 SP3 could you please test Exchange 2010 mailbox via Outlook Anywhere and see if you could re-create this issue.  After spending a week on this I wonder if it is some sort of bug in Exchange 2013 SP1.

    Thanks,


    Raman


    • Edited by raman03 Tuesday, March 18, 2014 4:37 PM typo
    Tuesday, March 18, 2014 4:35 PM

Answers

  • All,

    Microsoft 3rd level premium support after spending 48hrs asked me to do the following which resolves the issue.  No, one knows why we need to do it or why it was working before.

    On E2k13 CAS serveràIIS manager

    highlight EWS virtual directory and select Configuration Editor

    In the drop down, select System.WebServer/ServerRuntime/

    Then in the middle pane select UploadReadAheadSize and set it to 49152

    Do an IISReset

    Thanks


    Raman

    • Marked as answer by raman03 Tuesday, April 8, 2014 5:38 PM
    Tuesday, April 8, 2014 5:37 PM

All replies

  • They're having trouble connecting to Exchange Web Services on Exchange 2013.  Make sure that Outlook is of the correct version for compatibility with Exchange 2013.

    http://social.technet.microsoft.com/wiki/contents/articles/845.outlook-versions-supported-by-exchange-200720102013online.aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, March 19, 2014 5:06 AM
    Moderator
  • Hi Raman,

    According to the error message, it maybe 2 reasons cause this issue.

    1. The server might be unavailable.

    2. The automatic reply message might have exceeded the size limit on the server.

     

    Please follow following steps to narrow down this issue:

    1. Can we set OOF in OWA? If yes, it seems the mailbox in Exchange 2010 is fine. Please run "Test E-mai AutoConfiguration" in Outlook to verify whether there is anything abnomal.

    2. Did we have many Outlook rules? There is a rule limit in Exchange 2010 server. Please run following command to re-set the rule limit.

    Set-Mailbox <username> -RulesQuota:256KB

    Information on the RulesQuota Paramenter:

    The RulesQuota parameter specifies the limit for the size of rules for this mailbox. When you enter a value, qualify the value with one of the following:

    • B (bytes)

    • KB (kilobytes)

    Unqualified values are treated as bytes.

    The default value for this parameter is 64 KB. The maximum value is 256 KB.

    Then please run Outlook with the /cleanrules switch.  That will require the user to re-set his OOF.

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    Wednesday, March 19, 2014 5:45 AM
    Moderator
  • Hello Ed,

    I have tried from Outlook 2010, Outlook 2013 and Outlook 2013 SP1.

    It works for if mailbox is on Exchange 2013.  But if mailbox is on Exchange 2010 then it does not work and I see "HttpException=Cannot find the appropriate SOAP header or body.;" in HTTPProxy logs on Exchange 2013 CAS server.

    If I use Outlook 2010 via LAN and force Exchange 2010 mailbox to go through Outlook Anywhere so connection goes to Exchange 2013 CAS server and then it proxy it to Exchange 2010 CAS server it works fine.

    Refer this link although it is not exactly the same.

    http://social.technet.microsoft.com/Forums/en-US/b52fafb5-4db9-4f83-906a-a19d9d6ef54b/exchange-2007-exchange-2010-your-automatic-reply-settings-cannot-be-displayed-because-the-server?forum=exchange2010

    Please let me know your thoughts.

    Hello Mavis,

    Thanks for your response but it is not related with Rules quota.  This issue with all the users.


    Raman

    Wednesday, March 19, 2014 2:57 PM
  • It appears that you're having a problem with Exchange 2013 proxying for Exchange 2010.  I don't have intimate enough knowledge of the internals of Exchange to tell you what's wrong here.  It's a problem I've never seen before, sorry.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, March 19, 2014 6:36 PM
    Moderator
  • Hi, ranman

    From the logs, it seems to be related to these two registry keys MaxFieldLength and the MaxRequestBytes.

    Refer to this KB:

    http://support.microsoft.com/kb/2020943

    Friday, March 21, 2014 8:07 AM
    Moderator
  • Hi Richard,

    This article says if domain user is member of 120 groups then you may see issues.

    I have bee trying it with a test user which is only part of Domain Users group but same issue.

    I was wondering if you or someone else in their production environment where large number of connections are coming to Exchange 2013 SP1 CAS and then it is being Proxy to Exchange 2010 SP3 CAS and see if you are able to set "Out of Office" using Outlook connected from Internet only via Outlook Anywhere.

    In our environment using the above scenario it does not work or even if you force Outlook to use Outlook Anywhere when you are on VPN client does not work either you cannot set Out Of office.

    But if you keep clicking on "Your automatic reply settings cannot be saved.  The server might be unavailable, or your automatic reply message might have exceeded the size limit on the server" and then try to set Out of Office once again it works sometimes in 3 times, sometimes it takes 12 tries and some time it does not work at all.

    Following are the HTTPProxy logs from Exchange 2013 SP1 CAS server when it works and when it fails.

    Failure log lines

    2014-03-20T19:55:33.772Z,eff51a57-1fb0-4894-8972-6702a82b06d3,15,0,847,30,,Ews,outlookanywhere.domain.com,/EWS/Exchange.asmx,,Negotiate,True,domain.com\testid01,,Sid~S-1-5-21-323741388-3570301916-4168597275-10077,Microsoft Office/14.0 (Windows NT 6.1; Microsoft Outlook 14.0.7113; Pro),10.90.105.232,Exch2013CASserver01,400,,,POST,Proxy,Exchange2010casserver,14.03.0123.000,IntraForest,WindowsIdentity,,,,5026,,,,6,0,,0,,0,,0,0,0,0,0,0,,,,,,2,1,,3,,9,9,,,CorrelationID=<empty>;BeginRequest=2014-03-20T19:55:33.772Z;ProxyState-Run=None;DownLevelTargetHash=4/4/6;ClientAccessServer=Exchange2010casserver;ResolveCasLatency=0;ProxyToDownLevel=True;BeginGetRequestStream=2014-03-20T19:55:33.772Z;OnRequestStreamReady=2014-03-20T19:55:33.772Z;ProxyState-Complete=ProxyRequestData;,StreamProxy=StreamProxy-Request-None;HttpException=Cannot find the appropriate SOAP header or body.;



    Success log lines

    2014-03-20T19:55:33.865Z,c7e9d027-a4a2-473b-973f-860af6ade80d,15,0,847,30,,Ews,outlookanywhere.domain.com,/EWS/Exchange.asmx,,Negotiate,True,domain.com\testid01,,Sid~S-1-5-21-323741388-3570301916-4168597275-10077,Microsoft Office/14.0 (Windows NT 6.1; Microsoft Outlook 14.0.7113; Pro),10.90.105.232,Exch2013CASserver01,200,200,,POST,Proxy,Exchange2010casserver,14.03.0123.000,IntraForest,WindowsIdentity,,,,5026,807,1,,2,0,,0,,0,,0,0,62.3956,0,0,0,0,42,0,1,0,46,0,43,3,3,5,48,,,CorrelationID=<empty>;BeginRequest=2014-03-20T19:55:33.803Z;ProxyState-Run=None;DownLevelTargetHash=4/4/6;ClientAccessServer=Exchange2010casserver;ResolveCasLatency=0;ProxyToDownLevel=True;BeginGetRequestStream=2014-03-20T19:55:33.819Z;OnRequestStreamReady=2014-03-20T19:55:33.819Z;BeginGetResponse=2014-03-20T19:55:33.819Z;OnResponseReady=2014-03-20T19:55:33.850Z;EndGetResponse=2014-03-20T19:55:33.850Z;ProxyState-Complete=ProxyResponseData;S:ServiceCommonMetadata.Cookie=ce9899198c244e7389d2e007855d48aa,

    Thanks


    Raman

    Friday, March 21, 2014 3:22 PM
  • Do we have TMG or other similar feature for the CAS? How about we pointing the url to one of the CAS directly?
    Saturday, March 29, 2014 7:09 AM
    Moderator
  • All,

    Microsoft 3rd level premium support after spending 48hrs asked me to do the following which resolves the issue.  No, one knows why we need to do it or why it was working before.

    On E2k13 CAS serveràIIS manager

    highlight EWS virtual directory and select Configuration Editor

    In the drop down, select System.WebServer/ServerRuntime/

    Then in the middle pane select UploadReadAheadSize and set it to 49152

    Do an IISReset

    Thanks


    Raman

    • Marked as answer by raman03 Tuesday, April 8, 2014 5:38 PM
    Tuesday, April 8, 2014 5:37 PM
  • I don't know who you are. But thank you for publishing this and likely saving me a ton of work. 
    Monday, April 14, 2014 2:47 PM
  • Hi,

    Would you please let me know if you are seeing this exact issue in your production environment.  If you are please provide me details, I may send it to MS support because from the start it looks like a bug.

    Thanks,


    Raman

    Monday, April 14, 2014 3:00 PM
  • yes we had this problem and thank you so much for posting this, you rock and support should NOT count those hours against your contract.

    Thursday, June 5, 2014 1:53 PM
  • Hi,

    Thanks for the response.  Fortunately they agreed to mark it as bug and did not charge 48hrs to our Premium Support account, so that was a relief. :)

    Thanks,


    Raman

    Thursday, June 5, 2014 3:32 PM