"Windows Update" Has Become Unusable Gradually During the Period January - August 2016, in Microsoft Windows Vista Home Premium... RRS feed

  • General discussion

  • My computer that had been running the Microsoft Windows Vista Home Premium since early 2009 had become an appliance:  It worked every time it was turned on and it handled every network transaction that came through my DSL line.  I had set the "Windows Update" program to check for updates periodically, every month or so, and then to inform me when ever any update was available.  I could tell when the "Windows Update" program had been checking for updates, as the CPU usage went up to 100 percent with the used memory amount "sawtoothed" up and down for about 15 to 20 minutes.   The "Windows Update" then would tell me about the available updates and it would ask whether it should load any of those. 

    This  worked until about January 2016.  At that time, the "Windows Update" CPU usage would stay at 100 percent for more than an hour.  After that, it gradually got worse:  Around June 2016, it held the CPU at 100 percent usage for about 14 hours.  In August 2016, the CPU is held at 100 percent usage by the "Windows Update" for more than 45 hours with no end in sight.  It did find some updates to load, but it would not load them as the CPU had no time to do that. 

    "Windows Update" is currently holding the CPU at 100 percent load  this every time the machine is booted up until all of the updates are loaded and it can not do this as the CPU load prevents the updates from loading in and from installing.  It is in an essentially "infinite loop" doing probably utterly nothing other than holding the CPU up at 100 percent usage.  I have noted that it starts to hold the CPU up in about 12 to 15 minutes after a reboot.

    The only "quick" solution to the problem at this time is to tell the "Windows Update" never to check for updates and reboot the machine.   That freed the CPU from the burden.  I am looking into the cause of this, as time permits, and I will post what I have found out.

    -- Yekta

    Wednesday, August 10, 2016 3:11 PM

All replies

  • It has been one year and four months since I have had looked at the Windows Update problem mentioned above.  I did not have time to work on this.  In the meantime, Microsoft stopped supporting Microsoft Windows Vista, which probably meant that they would not supply any more updates to this very fine and robust operating system, except may be one, which would fix the Windows Update problem.  Since the Windows Update is broken, there is no way to update it using itself.  Any fix, should it exist,  has to be located, downloaded  and manually installed.  I am not aware of any such fix, so the Windows Update is still set to "never" check for any updates.  Microsoft also stopped supporting the Microsoft Security Essentials, which is a virus protection program.  I uninstalled it.  The Windows Defender, however, was working well with regular updates.

    A few days ago, the Windows Defender came back with an unlisted error message that it could not check for updates anymore.  I clicked on the "Help" link that was supplied and ended up on the Microsoft Support Web page "https://support.microsoft.com/en-us/help/918355/how-to-troubleshoot-definition-update-issues-for-windows-defender".  Following the instructions given there, I was able to download the "updated definitions installer" file "mpas-fe.exe" which was released on 12/05/2017.  I ran the program, and it did talk to the network for while and then it exited with no message at all.  The Windows Defender was not updated.  I ran it a couple of times more with various permissions, and that did not help.  While I was tracing other issues that required a few reboots, the Windows Defender came back somehow "updated".  It no longer asks for updates and promises to get them automatically.  There is no manual "Check for updates" button anymore.   This was fine as it did not seem to bother anything else.  While tracing this somewhat surprising behavior, I ended up locating "Microsoft Security Essentials" for Microsoft Windows Vista in the Microsoft Support web pages as well.  I downloaded this and installed with two somewhat odd results:  It turned the broken Windows Update on and that tried to lock the machine up by holding the CPU at 100% load.  I shut the Windows Update down again.  In the meantime, the Microsoft Security Essentials finished installation successfully, and immediately declared itself useless proceeding to shut itself down.  I uninstalled it again.

    At this point, I noticed something somewhat odd about my network connection as well.  However, to explain this, I need to describe my network connection:  

    I do have a dedicated DSL line which has only data service on it.  This line is connected to a 2009 model Motorola Modem that has a wall transformer as its power supply and it is directly connected to the network card of the computer through the standard Cat 5 network cable which is very short in length.  The wall transformer of the modem is plugged into an in-line switch which lets me disconnect the AC power line from the transformer, shutting the modem down.  The network cable does not carry any power to the modem, so the computer is hard-disconnected from the "Network", that is to say not by a "software switch",  when the power switch is off.  This looks somewhat old-fashioned, but it is not any different from any other network architecture in terms of connections.  What I will describe below can happen through any network connection.

    The picture below shows the lower right side of my computer display when the power to the modem is off.

    Note the red "X" over the Network connection icon (two display terminals one behind another) which means that there is no connection to the network.  When the modem power is turned on and the modem is initialized, this icon changes, as shown below:

    The filled blue circle indicates that there is a connection to the network.  Clicking on this icon results in another pop-up window just above the task bar which is shown in the picture below:

    Note that the access to the internet is indicated.  Clicking on the line "Netwrk and Sharing Center", brings up another window:

    All connections are normal as indicated, and everything works well.  However, lately when the modem is turned on, the network icon has started to show something else more and more often:

    Note that there is neither a "blue-filled circle" or "red X" over the network connections icon.  Clicking on the icon now brings up:

    Note that the "Access" is "Local Only", but the computer is actually "connected" to something like the "network" as it will reach the web pages one looks for using "Mozilla", somewhat erratically.  Clicking on the "Network and Sharing Center" line now brings up:

    As one clearly sees, the computer is "connected" to the "Network", but the "Network" "is not" connected to the "Internet", in the usual sense.  It actually is connected in an "odd" way.  Clicking on the red-X in this connection diagram now brings the following window up:

    The computer indicates that "Connections to webpages are currently being redirected to another webpage." Now, this is worse than just being "odd", as I am paying for the dedicated DSL line, and for the Internet service provider.  Redirecting to another webpage is actually like "espionage".  Should one click on the line "-> Click to open the web page", one of two things happen: It either runs a module on one's default web browser (Mozilla Firefox in my case) in the background, but it does not bring a display up, or it goes to the web page which is always:

    This the somewhat unbelievable situation as my internet service provider is AT and T, not Microsoft, and logging into the Microsoft web page does not change anything, as well expected. 

    Should one click-close this web page and exit the Mozilla Firefox, the display disappears, but the Firefox module keeps running in the background with no indication.  My next reply message shows this as there can be only 9 pictures in one message in this forum...

    -- Yekta

    Saturday, December 9, 2017 1:07 AM
  • The "Task Manager" display shown below indicates that the "Firefox" plug-in is still running after Mozilla Firefox display exits.  This is also the case when clicking on the line "-> Click to open the webpage" in my previous message above leads to no display, but a running Firefox plug-in  module in the background:

    What is happening here is not "technology dependent", that is to say it has nothing to do with my old, but perfectly working modem or perfectly functional DSL line.  The computer is always connected to a "Network" (Fiber Optics, Dish, Cable modem, Wi-Fi, DSL, Network Router, even Bluetooth or Radio Amateur transmitter-receiver) and that always connects to the "Internet".  This means that the "redirection" can happen anytime without the user's knowledge and this is almost always detrimental to the network performance and security.  Mozilla Firefox somewhat tracks this, but not entirely, and it does not say anything about it.  I am not sure whether Microsoft Edge does anything about it.

    It is worthwhile to note that the computer lately almost always connects to the network correctly after a reboot, but it loses the connection subsequently, oscillating back and forth these two states of "connection" even during large file transfers, causing immense delays.

    Needless to say, I am looking into this deeply...

    -- Yekta

    Saturday, December 9, 2017 1:34 AM
  • I continued using the network to access some Linux distributions.  These are large files (nominally around 4.5 GB each), and they are very good ones to test the network speed and connections, as well as supplying me what I have needed at the time.  The network annunciator located the at the lower right side of the screen was still indicating "Local only" network connection, despite the fact that the machine was transferring very large files across the network. 

    It transferred three files , and the total transfer size was about 12.5 GB.  At this point, I decided to move these large files to a back up disk to free up some storage space.  One of the files was moved at normal transfer speeds (about 32 MB per second in this machine).  The next file which was 4.5 GB long  was moved at 67 MB per second for the entire length of the file.  This machine has only 1.5 GB of memory, only about 1 GB of which can be used as system "Cache",  and the transferred files are not really any similar, so this was a little mysteriously too high a transfer speed.  The transfer terminated very abruptly (nearly with a sound) , but normally, then the machine became unstable.  The third file was being transferred at speeds of 3 to 4 MB per second, when I stopped the transfer.

    I rebooted the machine from the power down state, and it would not reboot reliably.  After several attempts with different options, the "Safe Mode" booted up, but it would not shutdown normally.  After a few more tries, the machine came up reasonably reliably and I decided to back it up just in case.  The back up program aborted twice, complaining about bad sectors.  After two disk checks using the Windows disk checking program, the disk checker located "bad" clusters in a file located in "...\Windows\System32\WDI\{ ... }\krundown.etl"-  which is system performance checker log file - and fixed it.  The system came up perfectly this time, with a "This Windows is not genuine" message, which was normal as disk checker had changed the system.  After few more shutdowns and reboots, system came back up completely normally with no indication of any problems.

    I turned the modem on and the network connected with the correct annunciation this time ("Local and Internet"), with the filled blue circle displayed over the "two display terminals".  The annunciation stayed on for the next 4.4 GB file transfer, and it has still been in that state.  

    I will look into this further and post the results...

    -- Yekta

    Sunday, December 17, 2017 7:06 PM
  • The network connection remained erratic for the next few days.  Sometimes, - mostly after a reboot, but not always - , the computer would make normal network connection with "Local and Internet" displayed when the modem has had been turned on, and other times it would not, with "Local only" displayed despite existing "Internet" connection.  I made sure that everything on my computer remained unchanged so that all of the apparent changes were due to the hardware and software it was connecting to in the Internet Service Provider's facility.  I decided to track the connection in real time to determine what was causing this erratic behavior.

    The Motorola DSL modem has five, multi-color indicator lights ("annunciators").  From left to right, these are: 1) POWER: It glows in steady green light when the modem power supply operating within its specifications. It is off when the modem power is off, and it turns red when the modem is going through its "Reset" procedure. 2) ETHERNET: It indicates whether the connection from the Ethernet card in the computer to the modem is properly made.  It glows in steady green light when the connection is made, and it blinks in green light when the computer is making an Ethernet request ("data sent").  It glows in steady red light should there be no connection.  3) DSL: It indicates the status of the DSL line connection from the modem to the Internet Service Provider.  It is glows in steady red light when there is no connection, and it blinks in green light as the connection is being attempted.  It glows in steady green light when the DSL line is properly initialized. 4) INTERNET: This one monitors the status of the Internet Protocol ("IP") address assignment either through Point-to-Point Protocol over Ethernet ("PPPoE") or Dynamic Host Configuration Protocol ("DHCP").  It blinks in green light as the IP address assignment is in progress, and it glows in steady green light when the IP address assignment is successful.  It glows in steady red light when the IP address assignment fails or when the assigned address disconnects. 5) ACTIVITY: It shows the status of the received data packets from the Internet.  It blinks in green light as the data packets are received, and it remains off should there be no incoming data packets.

    The time sequence of the modem indicator lights as the modem is manually turned on after the computer completely reboots from the "shut down" state for a normal Internet connection is: POWER: It briefly glows red, then it glows in steady green light.  ETHERNET: It starts dark, then it blinks in green light until the initialization is complete.  It then glows in green light, occasionally blinking in green light as Ethernet requests are made by my computer. DSL: It starts glowing red, then blinks in green light as the DSL line initializes.  The light becomes steady green when the DSL line initialization is complete. INTERNET: It blinks in green light as the IP address assignment is in progress. It glows in steady green light when the IP address assignment is complete. ACTIVITY: It blinks in green light as the data packets are received.  The network annunciator in the lower right corner of the computer screen shows the filled in "blue circle" over the "two display terminals" with "Local and Internet" connection correctly  indicated.

    The time sequence of the modem indicator lights as the modem is manually turned off then turned on after the computer completely reboots from the "shut down" state for an abnormal Internet connection is: POWER: It briefly glows red, then it glows in steady green light.  ETHERNET: It starts dark, then it blinks in green light until the initialization is complete.  It then glows in green light, occasionally blinking in green light as Ethernet requests are made by my computer. DSL: It starts glowing red, then blinks in green light as the DSL line initializes.  The light becomes steady green when the DSL line initialization is complete. INTERNET: It blinks in green light as the IP address assignment is in progress. It then glows in red light for a while. It glows in steady green light after a while as if the IP address assignment is complete. ACTIVITY: It blinks in green light as the data packets are received.  The network annunciator in the lower right corner of the computer screen shows nothing over the "two display terminals" with a "Local only"  connection indicated, but the Internet is somehow connected.

    I looked into the "abnormal" network connection through the sequence "Control Panel => Network and Internet => View network status and tasks => Manage Network Connections".  The connections were made through the "Teredo (Shipworm) Tunneling Pseudo Network Interface", "6TO4 Pseudo Network Interface" and "ISATAP Pseudo Network Interface" for Internet Protocol version 6 ("IPv6") network packets tunneling through an Internet Protocol version 4 ("IPv4") network.  There is support in Microsoft Windows Vista Home Premium for these tunneling procedures with IPv6 support listed as "Limited", but I have a DSL, dedicated line IPv4 network connection system and there is no reason why there should be a "Teredo" server at the other end of the line, nor there is any reason to contact a remote one to achieve the tunneling.

    This situation lasted for a short while, then the system started making abnormal connections without the IPv6 support.  This time it was through the IPv4, but it was not any obvious matter how that was accomplished.  I was about to use the Microsoft Network Monitor 3.4 software to see what really was happening, then things got a little bit better especially after I had a telephone conversation with one of the AT&T network support personnel about another matter.  She asked me why I was still using DSL when everyone else had switched to "better" connection systems.  The reason why is that there is nothing better available in the area I live.  AT&T Fiber Optic Network is not available in this area.

    First, the INTERNET light on the modem stopped showing "red".  The modem INTERNET connection now initialized by first blinking in green light then directly going to steady green light.  The kind of connections that were made now depended on whether the modem was turned on right after a reboot after a complete shut down or whether the modem was turned off after a normal connection and then turned back on without shutting down and rebooting the computer.  The connection was now always normal in the first case, and it was always abnormal in the latter case.  This indicated that somehow a network identification process was being skipped over.  Nothing had changed in my computer as far as I knew, but I decided to test this.

    When the connection was abnormal, the sequence "Control Panel => Network and Internet => View network status and tasks => Manage Network Connections" shows:

    A right click on the "Local Area Connection 3" and then selecting the displayed "Diagnose" option results in:

    Note that Windows Vista does not think there is a problem, but that is not the case.  It still shows the "red X" on the connection from the modem to the Internet in the "Network and Sharing Center" diagram.   I do not know yet how it is "fooled" into thinking that.  Now , clicking on the "Reset the network adapter "Local Area Connection 3" " yields:

    which then displays:

    And, now the sequence "Control Panel => Network and Internet => View network status and tasks => Manage Network Connections" shows:

    And, the problem is fixed.  In fact, I was confident enough that this would work very well,  I shut the modem down in the middle of typing this message, and I went through the procedure.  The network reconnected with the annunciator showing the filled blue circle over the two display terminals, and I continued typing the message in with no loss.  I did send the information to Microsoft.

    I still do not know why the network identification is somehow skipped over when the modem is turned back on.  I will look into it as I have time.  For now, everything works again somewhat painlessly...

    [P.S.  I also encountered another problem during all of this.  It is not directly related to computer hardware or software, but I do cook my own food and I do my own dishes by hand while I use and debug computers all the time, so I have thought I should put it here, as there may be some interest in it. 

    I always do my dishes by hand and without wearing dishwashing gloves.  I do use "mild" detergents for this purpose, like "Palmolive", "Dawn", "Ajax"... Recently, the dishwashing detergent manufacturers stopped listing the ingredients of the detergents on the bottle labels ("Palmolive", "Ajax").  Instead, there is a warning label advising the user not to mix the detergent with Chlorine bleach to avoid "fumes".  The manufacturers also have changed the composition of the detergents:  For example, "Palmolive Original",  I think,  has only the original scent.  The manufacturers also have added Sodium Hydroxide ("NaOH", or "Lye") as an ingredient into the detergents ("Dawn", "HDX"? which does not list the ingredients).  The "Dawn Antibacterial" which clearly lists the ingredients on the detergent bottle, shows this.

    I have always used sufficiently diluted Chlorine bleach to clean the sink and the dishes and to prevent any molds from developing anywhere.   This method had caused no harm to my hands for many years.  On the other hand, Sodium Hydroxide, although a very powerful "grease cutter", will cumulatively remove skin layers from one's hands thus thinning the skin continuously.  Finally, the over-thinned skin will develop cracks that do not heal readily.  An act of simply going to any toilet can cause infections that can be very, very dangerous.  

    I do now use tight fitting, Latex gloves while I do the dishes and while I handle these detergents, especially the industrial ones.  Those ones may contain even higher concentrations of "Lye"...  Note also that, the dishes must be rinsed under running water to remove all of the detergent residue as any remnant left on the dishes does get into the food and subsequently, it does get into the digestive system eventually ruining the sensitive lining of the stomach and the intestines.  I have never rinsed the detergents and soap out by dipping the dishes into a sink full of water.  That method never removes all of the detergent and it may even deposit more...]

    -- Yekta

    • Edited by Yekta_Gursel Wednesday, December 27, 2017 10:14 PM I had forgotten to mention the rinsing method.
    Wednesday, December 27, 2017 9:49 PM
  • After the fixes I mentioned above, the computer became normal, more or less...  I noticed that I had some Category 5 network cables mixed with Category 6 network cables in the system, and I decided to convert  everything uniformly to Category 6 cabling. 

    The ethernet Category 5 cabling in the most commonly used TIA/EIA -568B connection standard consists of 4 loosely twisted, stranded wire pairs in an unshielded, plastic outer casing with 8 pin RJ-45 connectors (8P8C, 8 positions, 8 contacts, equally spaced,  parallel, contact  pins in the connector) at the ends of the cable.  The twisted wire pairs are colored as follows: Pair 1: White striped blue wire twisted with Blue wire , Pair 2: White striped orange wire twisted with orange wire , Pair 3: White striped green wire twisted with green wire, and Pair 4: White striped brown wire twisted with brown wire.

    The ethernet Category 6 cabling consists of 4 very tightly twisted, stranded wire pairs (100 Ohm impedance, balanced each pair) together with a non-conducting, strengthening strand in an unshielded,  plastic outer casing with the same  RJ-45 8P8C connectors at the ends of the cable.  The pair numbering and the wire coloring are the same as those in Category 5 network cabling.  The category 6 ethernet cable is rated for 250 MHz operation with maximum length of 55 meters.

    The two  pictures below show the signal definitions and wiring diagrams for Category 5 and Category 6 cables.  The source for each of these pictures is indicated at the top of each picture:

    As one can clearly see, the third twisted wire pair in TIA/EIA-568B wiring (white-striped green wire twisted with green wire) is separated in the connector only, that is to say, the two halves of the pair are not next to each other in the connectors only, causing an impedance change in the twisted wire pair at the connectors for about an inch (two mated connectors).  This causes reflections from the joint to propagate backward down the cable, increasing the cable systematic noise, as well as causing additional attenuation.

    I checked the "Wikipedia" entry for these cables, and they say: 

    "Ethernet compatible pin-outs "split" the third pair of RJ25 across two separate cable pairs, rendering that pair unusable by an analog phone. This was necessary to preserve the electrical properties of those pairs for Ethernet, which operates at much higher frequencies than analog telephony." 

    I found it very hard to believe that splitting a tightly twisted pair at the connector would make the cable work better in higher frequencies,  as those pairs are driven with differential signals.  There is a new ethernet cable standard (Category 6A) which will work at 500 MHz for a length of 100 meters and not surprisingly, it requires new connectors and new wiring schemes at the connectors to achieve this.

    I now use all Category 6 cables, and I am looking into this oddly induced impedance change situation deeply as well, even though this last line is getting a bit repetitious...

    -- Yekta

    Tuesday, February 13, 2018 5:24 PM
  • Yesterday, I came home from work in the late afternoon, and I turned my computer (the one mentioned above) on to look at the e-mail accumulated during the day.  It came up to the Microsoft Windows Vista Home Premium login screen, then it froze up as I moved the mouse over to type my password in. 

    This was odd.  It had shut down normally early in the morning as I left for work and the power was cut off with two switches: The internal power supply switch in the back of the case of the computer and the multiple outlet power switch its line cord is plugged into.  In addition, the CPU reset line was held at reset with yet another switch, even at power up.  The switches are sequenced so that the power supply, the cooling fans and the heater for the colder days are normally operating when the CPU is told to reboot. 

    I tried to bring it up again, and it would not.  It was getting stuck with the disk light on at various stages of the boot process.  I decided to back the boot disk up sector by sector with the Acronis True Image software without bringing the whole system up, using the Acronis True Image boot CD I had made sometime ago (on December 26, 2012.  You can tell how I spent the holidays at that time...).  This method worked, and the software backed up the entire 280 GB of software and data onto an external USB disk, while locating some sectors on the boot disk which caused a direct read failure. 

    I detached the backup disk from the computer, and I managed to reboot the computer into the "Safe Mode" of the operating system and scheduled disk checks.  The disk checks ran until about 2 AM or so while I was sleeping.  It found a few damaged files and repaired it.  I woke up around 4 AM, and started another backup, this time after logging into the Microsoft Windows Vista Home Premium.  The second backup with output compression completed in several hours without any sector read errors, and the computer became normal.

    While the second backup was running, I booted my other computer (a newer, faster one with a dual-core processor and larger memory which also runs Microsoft Windows Vista Ultimate I have had purchased from a person who has had not used it) and I plugged it into the network to look at  the accumulated e-mail.  I looked at the e-mail, and then I noticed that the Mozilla Web Browser on it was somewhat outdated (version 37 as opposed to version 51), and I decided to update that one.

    The computer started going through the multi-stage update, loading the versions leading to the most current one, one by one.  As I was watching the update process early in the morning around 8 AM, a vehicle with very powerful sub-woofers and sub-woofer amplifiers passed by on Baldwin Avenue, in Temple City, California about 150 feet away from the computer, shaking everything and causing large amplitude resonances in the cases of the computers. 

    I had seen many of these vehicles on the roads as I motorcycle and bicycle a lot (almost every day).  They tend to approach from behind, and the forward directed sound field from these vehicles are hazardous to one's ears and head at a distance of nearly 30 to 40 feet away from the vehicle.  At those times, I had moved immediately away.  I do not know why there is not a law against these vehicles with outward directed sub-woofers (mostly the "bazooka" typed, but there are other types as well), as they are causing damage to people and their property (especially to ill or elderly people).

    The sound field from the vehicle on the street resonated the parts in the case of  the computer that was loading the Mozilla update and the computer froze.  The computer did not boot back up successfully.  It got stuck at the initialization stage with one of the SATA drives (hard disks or the DVD/CD drives) not responding to the initialization request.  I had to open the case of the computer and then I had to check the connectors on everything step by step.  It was one of the CD/DVD drives with the SATA data connector displaced slightly.  After re-plugging the connector in, the computer came up.

    I then knew what had happened to my computer on the previous day while I was not at home.  It was caused by one or more of those vehicles passing by, with earth-shaking (literally) sub-woofers with sound fields directed outward.  Note that it is somewhat difficult to direct very low frequency sounds without the installation performed by experts.

    -- Yekta

    • Edited by Yekta_Gursel Friday, February 23, 2018 7:58 PM Typographical error fixed.
    Friday, February 23, 2018 7:53 PM
  • Vehicles similar to the SUVs with sub-woofers passed by my house two more times within 24 hours after the events I had mentioned above:  This time one pass on the north side of the house on the adjacent street and one pass on the south side of the house in the adjacent alley.  The previous passes I had mentioned above had been on the west side of the house on the adjacent street.  There is no way to pass by on the east side as there are no streets or alleys there.

    This time, however, I was at the keyboard of the computer that ran the Microsoft Windows Vista Home Premium and I was able to notice the computer going unstable and I stopped it.  After a few more disk checks, and reboots the computer became completely stable, and it ran fine for several days.  Note that this computer is sixteen years old, and it has been on the network for nine years.  You can find its detailed hardware description in other messages I have posted in this forum under my name.  The vehicles with sub-woofers stopped  passing after these events.

    Few days later, I decided to charge my old, deactivated cellular phone (a Pantech P6010) on the computer, which was sitting around with its battery completely discharged.  It has a nice display,  a keyboard and it has few useful applications, like camera, music player, USB stick, calculator, unit converter, timer, stop watch, etc...  I do not use its original charger as it is a very fast, and crude one, and it ruins the battery.  I had used it once when I had bought the cellular and I had noticed how hot the cellular phone had become after charging on it.  I had decided to charge it on the USB port of the computer.  This takes longer, but the phone still has its original battery after several years of use.   The phone memory also optionally connects to the computer file system through a special software interface and and there has never been a problem caused by the phone in the computer for several years.

    But, not this time...  The computer went unstable after a daily shutdown, and it itself went into boot disk consistency check to be able to boot up after long, long delays.  I knew that whatever caused this problem this time around was not the network as it was disconnected and I could monitor the network port with Microsoft Network Monitor Version 3.4.  It was not the USB TV receiver I used every day, as its output could also be recorded.  That left only the phone as the "culprit", as there was no other way into the computer that was being used at the time.  The phone hardware and software was working well.  However, the phone is a RF receiver and transmitter (one can still make emergency calls to 911 even if it is deactivated) and it can receive something (no telling what can be sent to it and by who, in general) that can cause the problem through its special USB interface.

    I separated the phone from the computer.  The charging the phone was not a problem as I had designed and made a charger for it several years ago that would not ruin its battery and this charger can operate on the house AC line, on my motorcycle's battery charging system with magnetos, on my motorcycle's battery, on my Jeep's battery charging system, on my Jeep's battery, or any other battery and charger system with some reasonable voltage output.  That worked (and had been working) as designed, and the phone now is fine.

    The computer is also fine.  It has been working flawlessly at maximum load for about two weeks with no hardware or software changes...

    -- Yekta

    Tuesday, March 6, 2018 7:15 PM
  • I decided to check on the other computers I had, as these were not turned on for sometime. Two of these were old computers, modernized using spare and other less-costly parts.  The remaining one of the three was a relatively new computer built in late 2009.  They were all shut down normally with everything working on them.

    I plugged in and I turned the relatively new one on.  The power light on the power button came on, and as far as I could tell, disks and other peripherals are initialized.  Then, the computer halted with no display whatsoever (no BIOS banner, no self-test, no memory test, etc...) emitting one long and two shorter beeps from the buzzer attached to the motherboard.

    I thought the 3 Volt, button battery which kept the CMOS BIOS parameter RAM contents intact had run out of charge.  I took the battery out, and I measured its output voltage.  It was 2.7 Volts (a new one has about 3.3 Volts).  This was somewhat low, but not low enough to cause a memory failure.  I put a new button battery in, and powered the computer back up.  Not surprisingly, it halted with no display at all, emitting the same beeps.

    The manuals that came with the MSI motherboard had everything in them, except a description of the BIOS beep codes.  I checked the MSI web page to get the most recent version of the manuals, but those did not have the descriptions of the BIOS beep codes either.  I posted a message to their forum about these codes, but no one replied in a day or two.  In the mean time, I determined that the motherboard is running a version of AMIBIOS8.

    I located the document AMIBIOS8_Checkpoint_and_Beep_Codes.pdf at www.ami.com/ami_downloads , which describes everything about the BIOS check points, but it has very little information about the beep codes.  I also got the documents  AMIBIOS8_Error_Messages.pdf , AMIBIOS8_Keystrokes.pdf and AMIBIOS8_EZ-Port_Users_Guide.pdf from the same web page and these did not have any information about the beep codes either.  I looked around the web and located the documents The complete BIOS beep guide - TechSpot Forums at the URL www.techspot.com/community/topics/the-complete-bios-beep-guide.95391 and Computer POST and beep codes at the URL www.computerhope.com/beep.htm . 

    After reading all of the documents above, I concluded that somehow the PCI-E Display card in the computer was not initializing anymore.  There was nothing wrong with this card, and its software had not been changed.  The only reasonable assumption was that the connections to this, clamped-and-bolted-down display card were somehow jarred by those SUV's sub-woofers and some of the pins of the card were not contacting the corresponding pins in the motherboard socket for it.  This is a very tight socket.

    I took the card out and treated the card-edge connector pins with a contact enhancer (DEOXIT D100L).  I made sure the contact enhancer was only on these pins by gently wiping the excess fluid by a soft piece of tissue.  I plugged the card back in, and I clamped it and bolted it down.  I plugged the computer back in, and turned it on.  It came back up with a working display.  It had forgotten about everything in the CMOS RAM, but that was easy to fix.  After the CMOS RAM content fixes, Microsoft Windows 7 Professional came up normally.

    In one of the other two older computers, the SATA connector to a DVD-RW drive was jarred and broken due to the vibrations induced by the SUV's sub-woofers, and last one had its CMOS RAM battery depleted for some reason.  I will fix these as well...

    [To have a feeling of what low-frequency-sound-induced vibrations can do, you might want to watch the movie "Dune", inspired by the well-known series of science-fiction novels by Frank Herbert.  In one particular scene, the hero in the movie is introduced to a secret weapon by his trainer.  The trainer points to a 8 ft.-or-so-high spire made out of the hardest known material in that planet and asks him to curse at it, to kick it and to shoot at it.  As somewhat expected, nothing happens to the spire.  He then gives him a small, hand-held sound weapon, and asks him to try that one.  The hero  uses the weapon and the top half of the spire is instantly pulverized.  To call this scene something out of a science-fiction plot is somewhat foolhardy, these days...]

    -- Yekta

    • Edited by Yekta_Gursel Tuesday, March 13, 2018 3:10 PM Added more material
    Tuesday, March 13, 2018 2:07 PM
  • I fixed the problems  with the remaining two computers.  One of them had both power and SATA cables partially jarred out of their sockets on both of its DVD drives which were located at the top part of the case of the computer .  All of these cables were tied together with cable ties to form a harness, and it was very hard to move these connectors normally, unless, of course, there were large, sustained, low-frequency vibrations.  I removed one of the DVD drives for ease of access, re-arranged and re-tied the cables, re-inserted the connectors and installed the drive back into the case of the computer.  The computer returned to normal operation.

    The other computer had its CMOS memory reset while it was off.  The battery voltage was just above 2 Volts.  The battery-backed-up, CMOS, non-volatile RAM loses its contents when the voltage drops below 1.8 V (about 50 percent of its output voltage when the battery is new), so this battery was also jarred in its seat long enough for the non-volatile RAM to reset to empty.  I put a new battery in with 3.3 Volts of output voltage, the computer came back up, stating that the CMOS RAM contents were lost.  I typed in the needed parameters into the CMOS RAM and the computer became fully operational.

    -- Yekta

    Wednesday, March 14, 2018 2:04 AM
  • The computer I was using in my message of March 06, 2018 worked very well until March 28, 2018.  That morning, it came up with a very unusual symptom: 

    I had "Windows Sidebar" in the Microsoft Windows Vista Home Premium operating system added to the "start-up" menu so that it made itself an icon on the right side of the "Windows Taskbar" which was displayed at the bottom of the screen.  I usually right-click the mouse on Windows Sidebar icon to get a menu so that I can close it by choosing the "Exit" option.  I do not use Windows Sidebar often.  However, I find it nice to use occasionally.

    I did right click the mouse on the Windows Sidebar icon, and the machine did nothing.  Windows Sidebar was working fine, on the other hand.  The only way to close it was to use the Task Manager to stop the process.  In addition, the operating system background activity was very low (1-2 percent), about half of what it was before (4 percent).  Obviously, the checks for the Windows Sidebar "right-click" menu was not being performed.

    This indicated that the operating system was somehow changed in the areas I did not use any often.  I started two disk checks with scanning for marginal sectors.  After some hours, the machine located 8 bad clusters among the 48 million clusters normally occupied by the operating system and the user files,  in two widely separated areas in the "../System-1/.." cabinets and it proceeded to fix them.  The machine rebooted shortly after the fix, and everything returned to normal.

    I do not know what has caused this problem at this time.  The machine was used normally while monitoring e-mail and running a USB TV receiver when I was at home. 

    -- Yekta

    Friday, March 30, 2018 11:49 PM
  • On April 22, 2018, the computer started acting erratically again for no apparent reason.  It had shut down normally on the previous day.  I shut the computer down with scheduled disk checks and rebooted it back up.  The disk checks went through, but the computer was still acting erratically.  It halted with a message that the Microsoft Windows Registry was corrupt, and it would not boot back up.  I booted the computer using the Microsoft Windows Vista Home Premium DVD from the DVD reader, and selected the repair option "Startup repair".  The program worked for a long while on the disk with the disk access light flashing all along.  It then halted with a message stating that it could not fix the startup problem automatically, while offering no manual fix options.  It could not restore the operating system to an earlier point in time, pointing out that the small debugging program did not have the sources to do so.  It also had altered the "Master Boot Record" (MBR), so that the computer could not boot from the disk, even though it said nothing about this last part.

    I decided the save the digital image of the disk in an attempt to preserve what was on it, the operating system and all, on an external USB disk drive.  I booted the computer from one of the  CD/DVD ROM drives using the bootable CD-ROM I had made for the Acronis True Image program I had downloaded from the web page of Western Digital, which was the manufacturer of the disk drive.  Acronis True Image software was able to make a sector-by-sector image of the disk (Western Digital WD5000AAKB-00H8A0, 500 GB PATA drive, 27 NOV 2010) on the external USB disk, while complaining about a few bad sectors.

    I then decided to erase the disk using the Acronis Drive Cleanser program on the same CD-ROM in an attempt to restore the disk to a usable state.  This did not work.  The program halted with messages indicating that it was not possible to read from or to write to  certain sectors.  Re-formatting the disk did not work either, for similar reasons. 

    I then located a similar disk in the web pages of  amazon.com for a reasonable price and ordered one of them.  It would take a few days for the new disk drive to arrive.   In the mean time, I connected the USB disk drive with the sector-by-sector backup image to another computer I had constructed running Microsoft Windows Vista Ultimate.  I restored the two partitions of the original disk onto two partitions of the disks of computer running the Vista Ultimate.  Disk checks indicated that all of the operating system and the user files were intact in the restored partitions.  However, the "originally bootable" partition was no longer bootable, due to the altered "Master Boot Record". 

    I had another regular backup made on March 30, 2018 of the same file system.  I restored those onto  two other partitions of the system running the Windows Vista Ultimate, and I verified that the "system disk" image thus formed was bootable.   I had to load this earlier system disk image onto the new disk first, then I had to restore the newer files on the non-bootable system image onto the bootable, older system image.  Due to frequent backups, only the user directory on the system disk had to be incrementally loaded, together with a picture directory on the other partition.

    The disk drive arrived a few days later.  I opened the computer up, and cleaned up the dust, as I did every six to eight months or so.  I then installed the new drive and I turned the computer on.  It would not boot up even to the boot screen.  It stopped the boot process emitting a single beep.   I suspected that somehow the memory modules were jarred during the installation and they were not contacting the connector pins well.  I pulled the memory modules out, completely cleaned the edge connectors with DeoxIT D100 L, an excellent contact cleaner and restorer.  I treated the connectors on the motherboard as well.  I installed the modules back onto the motherboard and rebooted the computer.  No change.  It got stuck again with a single beep.

    This time, I removed every installed card in the computer, and cleaned all of their edge connector and motherboard connector contacts with the same contact cleaner.  I installed everything back into the computer.  I also removed, cleaned and re-installed every disk and USB connector.  Still, no change.  Stuck with a single beep.

    I removed and measured the voltage on the non-volatile BIOS RAM (NVRAM).  It was a TOSHIBA battery, labeled with 3V of output.  The battery voltage read exactly  3.00 V.  I cleaned the battery and its holder with the contact cleaner and installed it back.  No change, stuck with a single beep. 

    I then remembered that it had been sometime since I had replaced this battery and this motherboard (it will be 16 years old on September 11, 2018) required higher NVRAM battery voltages, like 3.2 to 3.3 Volts, even though the batteries were labeled with 3 V.  I removed the TOSHIBA battery and installed a brand new ENERGIZER battery, with an output voltage of more than 3.2 V.  I rebooted the computer and the boot screen came up with the passing memory test and I pressed the "DEL" (Delete) key to enter the NVRAM parameter settings portion of the BIOS ROM.  It came up and I set the parameters correctly.  I also set it to boot from the CD ROM so that I could run the Acronis True Image Program to load the operating system and the user files back.

    I put the Acronis True Image CD-ROM in the CD/DVD-ROM drive and rebooted the computer.  It would not boot from the CD-ROM.  I checked everything again.  All connectors were in and all voltages were correctly supplied.  The computer still would not boot from the CD-ROM.

    At this point, to test the hardware and everything else, I decided to install a new Microsoft Windows Vista Home Premium into the computer from the original DVD.  This went well indicating that the hardware was now working very well.  I then tested the Acronis True Image boot CD on my other computer running the Vista Ultimate, and it booted from the CD with no problems.  I then checked the same CD on this computer running the Vista Home Premium and the CD worked very well on the same CD/DVD ROM drive under the Vista Home Premium.

    It was possible that CD was not seating in the drive well, or there was some kind of accumulated dirt on the CD surface that somehow came off, as the next attempt on booting from the CD succeeded.  Acronis True Image program came up and I loaded the system partition of the bootable backup disk image I had made on March 30, 2018.  This took several hours (170 GB).  I then rebooted the system from this partition.  It worked, and it was May 1, 2018, about 8 days after the original disk drive had stopped working for some reason.

    It took another day or two to copy the backup images of two partitions I had made on April 22, 2018 on the external USB disk drive, onto two partitions on the computer so that I could directly restore files from internal fast disk partitions, instead of the external and slower USB drive.  That worked as well, and the computer was up and running completely as if nothing had happened on May 3, 2018.  Only a few, cross partition installed  software programs (four of them in all) had to be repaired using their original installation CD-ROMs, due to the operating system relabeling the partitions in a different fashion.  No user or system file was ever lost, during all of this.

    I typed this message in, using the computer with its new disk drive.  Everything nicely feels the same...

    -- Yekta

    [P.S.:  A note about dust:  Should you live in an area with neighbors burning sooty materials like wood, coal, etc... for keeping warm or for cooking, you might want to clean the dust in your computer more often.  The very-small carbon particles in the smoke are sucked into the computer by the computer cooling fans and they are deposited on the traces and solder joints of the circuit boards (interface cards, motherboard, etc...) in the computer.  With the moisture (and traces of oil due to home cooking) always present in the air in the households, these very-finely-deposited carbon-rich layers turn into resistors changing the operating parameters of the circuits in the circuit boards, causing the computer to act erratically, sometimes with disasterous results.   This is the reason why I clean the dust in my computers every six-to-eight months.  I do not burn any sooty materials to produce heat, but my neighbors do that quite often...]

    • Edited by Yekta_Gursel Monday, May 7, 2018 1:20 AM A note about household dust addded at the end.
    Sunday, May 6, 2018 9:42 PM
  • The computer and its software has been working well with no indication of any problems since May 3, 2018.  In the meantime, I have made a needed cable for my audio priority-multiplexer which lets me listen two sources of audio at the same time.  One channel has priority, but its audio source has a lot of quiet passages.  During these quiet passages, the multiplexer plays the second audio channel which is very much like continuous background music.  The switching is accomplished flawlessly, with no annoying "clicks" or "pops". 

    The cable worked fine for a while.  Then, the audio-multiplexer "low battery" light started to flicker.  This was somewhat unexpected as the battery was relatively new, and I had not been using the multiplexer much.  I opened up the battery compartment of the multiplexer, and found its Thunderbolt Magnum 9 V, Alkaline battery in a condition I had never seen before.  The battery seemed to be blown apart without any fluid leaks or corrosion.  Its voltage was 7.98 Volts.  The multiplexer was kept in a very cool place, away from any heat sources, and its current consumption was normal.  Its "on/off" switch was taped down in the "off" position during storage and nothing was connected to the multiplexer.  See the picture of the battery below:

    I do not know what caused this, and it happened sometime during April-mid May 2018, as far as I can tell.  I am looking into it...

    -- Yekta

    Tuesday, May 15, 2018 4:28 AM