Delete Profiles Older than Specified Number of Days - Not Working RRS feed

  • Question

  • Hoping to get some help here.  We have a 2008 R2 RDS Server, and we use the group policy setting to delete profiles older than a specified number of days upon reboot.  This worked well in 2008, and even our Vista workstations.  Now with 2008 R2, as well as our Windows 7 clients, this is not working anymore.

    A search of the internet I could find only one person with this problem, however, he stated simply disabling Windows Defender did the trick as it was scanning at night and modifying the NTUSER.dat files for every profile.  I followed his advice, and disabled Windows defender on the RDS server, as well as some Windows 7 machines, and the NTuser.dat files for every profile are getting modifed once a day wether the the profile was used that day or not. 

    I have disabled backup agents, and even Antivirus on the machines I am testing with, and yet still they are getting modified.  If you look under the User Profile section under Advanced System Settings, it shows every profile as been last modified the same time.  Since these are getting shown as modified each day, when the system reboots, the profiles do not get cleared.

    I knows 2008 R2 and Windows 7 has TONS of built in tasks scheduled to run automatically by the OS upon install.  Could one of this be trigging these user profile modifications?  There are NTUser.dat.log files with the same timestamp as the NTuser.dat files that are getting changed, however they aren't readiable by us.

    Is there anyone out there with the same issue, that can point me to what might be causing this?  I have tried to look through tons of the built in system tasks, but I can't find one that coordinates with the exact time the profiles are getting changed.  On the RDS server alone, the Disk Defrag service is the closest (45 min before the profiles get modified) but according to the system logs, it was finished well before the time on the NTuser.dat files are getting changed.

    Wednesday, April 7, 2010 12:52 PM

All replies

  • Really could use some help here people...still having the issue.

    Sunday, April 18, 2010 5:58 PM
  • I am having the exact same issue, but have yet to find an answer.  Windows Defender is already disabled for me.  We have SEP installed which could be doing it.
    Friday, May 28, 2010 12:12 AM
  • hi LE2Strat, can you actually fully uninstall all antivirus and antispyware applications and see if it still does it?
    Saturday, May 29, 2010 1:47 AM
  • James,

    Yes I have even gone that far and it hasn't changed anything.  It even happens on machines with clean installs with nothing else added to it.  I believe this is a bug and related to this fix for Vista/Server 2008:


    Looking at the date release for this fix, I think it was to late to make it into the RTM version of Windows 7/Server 2008 R2.  Hopefully this will get included in the fixes for SP1.  Maybe they will even do a public hot fix for the issue before SP1 is out.

    Thursday, June 3, 2010 5:48 PM
  • Same problem here - I would hope there is a fix coming soon for this.
    Thursday, June 10, 2010 3:48 PM
  • The fix is here, finally!


    • Proposed as answer by Harry Hi Thursday, June 24, 2010 8:53 PM
    Tuesday, June 22, 2010 1:35 PM
  • Hello LE2Strat,

    > "The fix is here, finally! <

    Thanks for this helpful information.

    Best regards,

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, June 22, 2010 3:06 PM
  • sweet
    Wednesday, June 23, 2010 1:04 AM