none
Autodiscover Authentication

    Question

  • Did an installation of Exchange 2010. enabled outlook anywhere and configured rules on ISA 2006 for autodiscover and outlook anywhere to work.

    did a test on www.testexchangeconnectivity.com and got the following results:

    Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
      Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
     
    Test Steps
     
    ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.fnpf.com.fj/AutoDiscover/AutoDiscover.xml for user ashneelb@fnpf.com.fj.
      ExRCA failed to obtain an Autodiscover XML response.
     
    Additional Details
      An HTTP 401 Unauthorized response was received from the remote Unknown server. This is usually the result of an incorrect username or password. If you are attempting to log onto an Office 365 service, ensure you are using your full User Principal Name (UPN).

    it seems that some sort of authentication is causing errors. tried removing RPC directory and recreating it through exchange powershell. not sure what i am missing. anyone out there with any ideas?

    Thursday, August 18, 2011 2:25 AM

All replies

  • Hi
    Please check the authentication settings on the /AutoDiscover virtual directory as below, incorrect settings will cause the symptom:

    ·Anonymous Authentication: Enable

    ·ASP .NET Impersonation: Disabled

    ·Basic Authentication: Enabled

    ·Digest Authentication: Disabled

    ·Forms Authentication: Disabled

    ·Windows Authentication: Enabled

    2. Set the User Principal Name (Logon Name plus suffix in ADUC) to match the SMTP address and you can.


    • Proposed as answer by rschulz Monday, February 17, 2014 4:19 PM
    • Unproposed as answer by rschulz Monday, February 17, 2014 4:21 PM
    Friday, August 19, 2011 2:41 AM
    Moderator
  • Quote "Did an installation of Exchange 2010. enabled outlook anywhere and configured rules on ISA 2006 for autodiscover and outlook anywhere to work."

    You have to configure it manually, RCA output shows that your autodiscover service is not configured correctly.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Friday, August 19, 2011 3:18 AM
  •  

    Hi
    Please check the authentication settings on the /AutoDiscover virtual directory as below, incorrect settings will cause the symptom: 

     

    ·Anonymous Authentication: Enable

     

    ·ASP .NET Impersonation: Disabled

     

    ·Basic Authentication: Enabled

     

    ·Digest Authentication: Disabled

     

    ·Forms Authentication: Disabled

    ·Windows Authentication: Enabled

    2. Set the User Principal Name (Logon Name plus suffix in ADUC) to match the SMTP address and you can.


     



    Thanks  Terence for your reply. the authentication methods are correct as you have indicated above. however, not sure what you meant by 2. above. if you could clarify on that, then i will be able to post back my results.

     

    cheers

    Sunday, August 21, 2011 10:11 PM
  • Hi
      I am sorry. I just copy Andy's advice and not modify it.It is about activesync problem.
      http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/7ec71e7d-9270-4eec-adcc-6de172c8e5ec
    Monday, August 22, 2011 2:46 AM
    Moderator
  • Quote "Did an installation of Exchange 2010. enabled outlook anywhere and configured rules on ISA 2006 for autodiscover and outlook anywhere to work."

    You have to configure it manually, RCA output shows that your autodiscover service is not configured correctly.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com


    Hi Anil,

    what/how do i configure RCA service?

     

    Monday, August 22, 2011 10:07 PM
  • Hi, I'm having the same problem but with the Exchange 2007 on Windows 2008 R2 STD in testexchange shows this error. I've made the change to the Anomine do it all the more when http://local/autodiscover does not work. The funny thing is that when I test the autodiscover works in 2k3 more Win7 not work in installing the same certificate.
    Thank you!

    Atenciosamente, Rafael Carvalho

    Friday, August 26, 2011 1:45 PM