locked
Part of LegacyExchangeDN in Outlook 2003 autocomplete list

    Question

  • Hello, I have Exchange 2010SP1 Server with Outlook 2010 and Outlook 2003 (SP3 + updates) clients. On Outlook 2010 autocomplete list is normal - i see display name and mailnickname but for all outlook 2003 clients I see Display Name and part of LegacyExchangeDN.

    with power shell cmdlet

    Get-Mailbox -Identity User1 | FL 

    i see that is part of LegacyExchangeDN.

    LegacyExchangeDN        : /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=User 1777         

    On Outlook 2010 it looks like: User Display Name <mailnickname>

    How to resolve this issue?

    I think that algoritm for autocomplete list is different for outlook 2003 and outlook 2007/10. Anybody know how it works?

    Found out article about LegacyExcahngeDN

    http://www.simple-talk.com/sysadmin/exchange/exchange-e-mail-addresses-and-the-outlook-address-cache/


    Truly, Valery Tyurin






    • Edited by Valery Tyurin Monday, February 20, 2012 8:07 AM Correct information
    Saturday, February 18, 2012 5:29 PM

Answers

  •  

    Hi ,

    It has been confirmed as by design that random 3 Character Hex Appended behind Mailnickname . It is the new feature which would be added after rollup 6 and later update.

    You can refer to the following link.

    Random 3 Character Hex Appended in LegacyExchangeDN Attribute After Enabling User Mailbox:<//span>

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8b4181c3-2fa2-4311-a245-3e81e9659f4b

    We general don’t recommend change Legacyexchangedn attribute. You can try to change its DisplayName and test if it have changed.


    Wendy

    • Marked as answer by Valery Tyurin Thursday, March 01, 2012 9:23 AM
    Wednesday, February 29, 2012 8:15 AM
    Moderator

All replies

  •  

    Hi ,

    It is a typical migration issue, Outlook automatically cache the account addresses of Sent Items. It is LegacyExchangeDN attributes. In migration process, in fact only the SMTP user migration and mail address content, LegacyExchangeDN is not been moved! In order to solve this problem, need to the X500 address to solve the problem.

    If it was in the same exchange organizations migrate account, use the migration or move-mailbox guide command will automatically add a x500 address.

    Please try to restart Outlook Client and test again.

    And hope the following related links can help you resolve it.

    Understanding the LegacyExchangeDN:

    http://www.msexchange.org/tutorials/Understanding-LegacyExchangeDN.html

    Global Address list shows the legacyExchangeDN instead of the email address (Dgoldman’s blog):

    http://blogs.msdn.com/b/dgoldman/archive/2009/07/01/gal-showing-legacy-dn-instead-of-email-address.aspx

    Introduction to ADModify.net:

    http://technet.microsoft.com/en-us/library/aa996216(v=exchg.65).aspx

    Migration issue Exchange 2010 (similar issue): <//span>

    http://social.technet.microsoft.com/Forums/ar/exchange2010/thread/2ac1b90f-f7fe-478e-9973-4a5c705b28f0


    Wendy

    Tuesday, February 21, 2012 7:15 AM
    Moderator
  •        Hello, Wendy!

    Thank you for your help and links.

    I do not migrate user from Exchange 2003 to Exchange 2010. I create new user or contact on exchange 2010. After create user i check attribute LegacyExchangeDN. It's look like

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=userd1fa9fab

    I found article

    http://technet.microsoft.com/ru-ru/library/bb123558(v=EXCHG.65).aspx 

    cn must equal mailNickname (alias), but instead i see user<random number>.

    This not affect mail flow but users outlook 2003 annoy.

    Try to create powershell script for modifying legacyExchangeDN attribute.


    Truly, Valery Tyurin




    Wednesday, February 22, 2012 9:59 AM
  •  

    Hi ,

    Outlook 2003 and Outlook 2007/2010 use different Email address type.

    The detail you can refer to the following Dgoldman’s blog:

    Global Address list shows the legacyExchangeDN instead of the email address:

    http://blogs.msdn.com/b/dgoldman/archive/2009/07/01/gal-showing-legacy-dn-instead-of-email-address.aspx

    How to correct Email address in SMTP format instead of EX in GAL:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrmigration/thread/9911853d-67c9-48ec-af8a-7fd72832d778/


    Wendy


    Thursday, February 23, 2012 6:29 AM
    Moderator
  • Some additional information:

    I think that Exchange 2010 have such logic.

    I created two user:

    First Mailbox User with Russian Name, Surname, Display Name. After looked at legacyExchangeDN and see that is equal

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user2dddad54

    Second Mailbox User with English Name, Surname, Display Name. After looked at legacyExchangeDN and see that is equal

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=<Display Name>1d6

    I tested this is behavior on two identical configurations.

    How to change AD DS behavior that  legacyExchangeDN looks like

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=<mailNickname>

    and if you change legacyExchangeDN for existing users you must update outlook profile.


    Truly, Valery Tyurin



    Friday, February 24, 2012 10:32 AM
  • Create simple script for replace legacyExchangeDN for mailboxes.

    # Step 1. Get list all mailboxes from OU 
    $Mailbox = Get-Mailbox -OrganizationalUnit "OU=Test,DC=contoso,DC=com" -ResultSize Unlimited
    # Step 2. For each mailbox get Alias and replace attribute legacyExchangeDN
    foreach ($Record in $Mailbox)
    {
    $UserDN = $Record.DistinguishedName
    $mailNickname = $Record.Alias
    $NewLegacyExchangeDN = "/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=$mailNickName"
    Set-ADUser -Identity $UserDN  -Replace @{'legacyExchangeDN'=$NewLegacyExchangeDN}
    Get-Mailbox -Identity $UserDN | FT Alias,legacyExchangeDN -AutoSize
    }


    Truly, Valery Tyurin


    Saturday, February 25, 2012 8:50 PM
  • And script for replace legacyExchangeDN on mail-enabled contacts.

    # Step 1. Get list mail-enabled contacts for all organization 
    $MailContact = Get-MailContact -ResultSize Unlimited
    # Step 2. For each mail-enabled contact replace attribute legacyExchangeDN
    foreach ($Record in $MailContact) 
    {
    $ContactDN = $Record.DistinguishedName
    $mailNickname = $Record.Alias 
    $NewLegacyExchangeDN = "/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=$mailNickName"
    Set-ADObject -Identity $ContactDN  -Replace @{'legacyExchangeDN'=$NewLegacyExchangeDN}
    Get-MailContact -Identity $ContactDN | FT Alias,legacyExchangeDN -AutoSize
    }
    Do not forget import module powershell for Active Directory

    Truly, Valery Tyurin


    Saturday, February 25, 2012 8:56 PM
  • When you test are you creating new objects that you know never used the same cn? The random legacyExchangeDN are generated if it detects a duplicate cn even if it exists in the tombstone. You see this with migrations because during migrations a mail enabled object is provisioned in the target domain, then later gets provisioned as a mailbox object which detects the duplicate cn already existing. When testing again try to use a very unique test account ie. jdoe7465 and se if it appends anything afterwards. If you're intending on fixing all the legacyExchangeDN's make sure that they exists as x500 addresses on the contacts or expect to start getting NDRs.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com


    Sunday, February 26, 2012 4:41 PM
  • Hello, James!

    I  don't have migration from exchange 2003 to exchange 2010. I have clean installation AD DS 2008 R2 and exchange 2010 SP1. But all my clients is outlook 2003.

    I have tested on new uniqe mail-enabled contact (Sherlok Holmes) in my exchange organization and see legacyExchangeDN look like

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Sherlok Holmescf9

    Do not know how to get exchange to set cn=mailNickname.

    It's nightmare for me.


    Truly, Valery Tyurin

    Sunday, February 26, 2012 6:38 PM
  • Hmm is the native language english? If not it's possible that it's appending the random number because it thinks it has invalid characters.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Sunday, February 26, 2012 9:14 PM
  • Hmm is the native language english? If not it's possible that it's appending the random number because it thinks it has invalid characters.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

         Do you mean about OS language? I have tested on two configuration:

    First, on Russian version operating system.

    Second, on English version operating system.

    Result is the same.


    Truly, Valery Tyurin

    Monday, February 27, 2012 6:46 AM
  • James, can you check on your exchange 2010 organization? Create new uniqe user and view at legacyExchangeDN?

    Truly, Valery Tyurin

    Monday, February 27, 2012 7:49 AM
  •  

    Hi ,

    LegacyExchangeDN Guid displaying with the Autocomplete feature in Outlook is by design. There is no workaround.

    There is a solution to the problem - If you upgrade the users to Outlook 2007/2010, Autocomplete in Outlook 2007 uses the SMTP address.

    If you upgraded to Outlook 2007/2010, you would need to refresh or delete existing .NK2 files.


    Wendy

    Tuesday, February 28, 2012 11:57 AM
    Moderator
  • Hi, Wendy!

    I do not ask about why Oulook 2003 use legacyExchangeDN, I ask about why behavior AD DS not as

    http://technet.microsoft.com/ru-ru/library/bb123558(v=exchg.65).aspx and legacyExchangeDN not equal mailNickname

    Some additional information:

    We are on the way migrate from postfix (smtp/pop3 system) to exchange 2010.

    Our Scenario:

    1. User on postfix. Create in Exchange organization mail-enabled contact with legacyExchangeDN = bla-bla-bla/cn=mailNickname

    2. User migrate to Exchange. Delete mail-enabled contact and create user with the same legacyExchangeDN = bla-bla-bla/cn=mailNickname

    As Outlook 2003 use legacyExchangeDN we do not need to clear autocomplete list. Wow!!! My scritps help me. :S But I do not know does AD DS in consistensy state.


    Truly, Valery Tyurin

    Tuesday, February 28, 2012 1:37 PM
  • And we do not have budget to buy new version outlook. :(

    Truly, Valery Tyurin

    Tuesday, February 28, 2012 1:38 PM
  •  

    Hi ,

    It has been confirmed as by design that random 3 Character Hex Appended behind Mailnickname . It is the new feature which would be added after rollup 6 and later update.

    You can refer to the following link.

    Random 3 Character Hex Appended in LegacyExchangeDN Attribute After Enabling User Mailbox:<//span>

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8b4181c3-2fa2-4311-a245-3e81e9659f4b

    We general don’t recommend change Legacyexchangedn attribute. You can try to change its DisplayName and test if it have changed.


    Wendy

    • Marked as answer by Valery Tyurin Thursday, March 01, 2012 9:23 AM
    Wednesday, February 29, 2012 8:15 AM
    Moderator
  • Hi, Wendy!

    Can not find it in release notes for RU6

    http://support.microsoft.com/kb/2608646/en-us

    Why?


    Truly, Valery Tyurin


    Wednesday, February 29, 2012 9:40 AM
  •  

    Hi Valery,

    Thank you for your response.

    It is have confirmed with Microsoft Engineer about this point.

    And it produces a new feature to prevent repeat of Legacyexchagnedn since Exchange 2010 SP1 RU6.


    Wendy

    Thursday, March 01, 2012 6:53 AM
    Moderator