none
OWA and activesync not working

    Question

  • hi

    2 issues which i facing using exhange 2010SP1,

    1. i am unable to delete my emails from owa inbox unless open that email and delete it.

    2. my active-sync isn't connecting (our firewall bock HTTPS traffic so i configure owa and active-sync without ssl )

    Saturday, January 08, 2011 3:29 PM

Answers

  • issue resolved. old admin modify the webhost.config file which create these issues. he tries to run owa and activesync services with HTTP. after reseting these files and removing modified entries issue resolved. i am now asking my client to purchase ssl certificate.
    Wednesday, January 19, 2011 4:54 AM

All replies

  • Hello,

    For OWA, did you tried from different machines ? for ActiveSync, did you try to work with SSL , by default Exchange 2010, all traffic are not encrypted and secured.

    For mor info, you can consult Exchange 2010 network port reference:

    http://technet.microsoft.com/en-us/library/bb331973.aspx

    Saturday, January 08, 2011 4:22 PM
  • CORRECTION, by default Exchange 2010, all traffic are encrypted and secured.
    Saturday, January 08, 2011 4:23 PM
  • yes i tried it with SSL and on different machines. no success.

    Saturday, January 08, 2011 4:51 PM
  • Do you experience this deletion behavior for all OWA users or just single user account?

    Please use Exchange Remote Connectivity Analyzer at https://www.testexchangeconnectivity.com/ and post the error you get here.

    Ramy


    Ramy W. Messiha MCSA/MCSE: Messaging Specialization MCTS/MCITP: Exchane Server 2007/2010 ITIL Foundation
    Saturday, January 08, 2011 5:08 PM
  • owa deletion error occurs on all users and also with ssl

     

    active sync test results are post below. is there any possibility to test active sync with HTTP only

    .....................................

    ExRCA is testing Exchange ActiveSync.
         The Exchange ActiveSync test failed.
        
        Test Steps
        
        Attempting to resolve the host name mailhost.cuba.k12.nm.us in DNS.
         The host name resolved successfully.
        
        Additional Details
         IP addresses returned: 151.213.142.245
        Testing TCP port 443 on host mailhost.cuba.k12.nm.us to ensure it's listening and open.
         The specified port is either blocked, not listening, or not producing the expected response.
          Tell me more about this issue and how to resolve it
        
        Additional Details
         A network error occurred while communicating with the remote host.
    Exception details:
    Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 151.213.142.245:443
    Type: System.Net.Sockets.SocketException
    Stack trace:
    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
    at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()

    Saturday, January 08, 2011 5:46 PM
  • Exchange 2010 is designed to work in an encrypted manner.  It is not recommeded to try and circumvent this.  Any reason you aren't trying to work with SSL through your firewall?  It will be much more secure...and supported.


    Tim Harrington | MVP: Exchange | MCITP: EMA 2007/2010, MCITP: Server 2008, MCTS: OCS | Blog: http://HowDoUC.blogspot.com | Twitter: @twharrington
    Saturday, January 08, 2011 5:50 PM
  • it means active sync cant work without ssl. 2nd thing is that i am not able to delete directly from OWA inbox. it only possible when i open that email in seperate window and delete. whats reason behind it.
    Saturday, January 08, 2011 6:27 PM
  • You did not answer my question, are you facing this OWA problem with all users ?, did you try to move the mailbox to another server for example?

    You must configure ActiveSync to work with SSL 443. Please note that self-signed certificates will NOT work with Exchange ActiveSync (EAS) nor Outlook Anywhere.


    Ramy W. Messiha | MCSA/MCSE Messaging Specialization | MCTS/MCITP Exchange Server 2007/2010 | ITIL Foundation
    Saturday, January 08, 2011 6:53 PM
  • Setup a internal PKI solution or even better go with 3rd part certificates

    digicert and godaddy have cheap ones..

     


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | Blog: http://www.testlabs.se/blog | Follow me on twitter: jonand82
    Tuesday, January 11, 2011 7:53 AM
  • Quote: “owa deletion error occurs on all users and also with ssl”

    Please provide the deletion error, and also check the related traces in the IIS log on the CAS after reproduced the issue

    Please check if there’s any error event in the application log on the exchange server after reproduced the issue

    Please try to browse the ActiveSync virtual directory externally/internally, see if you can get the expected error response “501/505” on the webpage

    http://FQDN/Microsoft-Server-Activesync/

    Please check if the issue can be reproduced with windows mobile emulator

    Windows Mobile 6 Localized Emulator Images

    Please run ExBPA against the exchange servers for health and permission check


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, January 14, 2011 8:37 AM
    Moderator
  • How's the issue currently? Any further information?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, January 17, 2011 5:53 AM
    Moderator
  • issue resolved. old admin modify the webhost.config file which create these issues. he tries to run owa and activesync services with HTTP. after reseting these files and removing modified entries issue resolved. i am now asking my client to purchase ssl certificate.
    Wednesday, January 19, 2011 4:54 AM