Windows XP 'First time only' connection error with Server 2008 R2 RDS RRS feed

  • Question

  • Hello,

    The problem I am experiencing can be summarised as so:

    When connecting to Remote Desktop Services through the Gateway from a Windows XP machine running with the latest available update to the Remote Desktop Client, the first time a connection is made from the client it fails to connect with the following error: "Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to. Contact your network administrator for assistance. ".

    To clarify, when I open the Remote Desktop client, configure it to connect to the Remote Desktop farm name, and configure the Remote Desktop Gateway settings, then click connect it will fail. If I then click connect again it will connect successfully. If I were to then close the Remote Desktop client, open it up again, then try to connect it would fail, and so on.

    Some further assertations regarding this problem are as follows:
    • This happens both when on the same local network as the gateway and session host, and when connected remotely.
    • This problem does not occur on Windows 7 operating systems (or Server 2008 R2).
    • Similar symptoms exist for connecting through the local Remote Desktop client, or using the Remote Desktop Web Access portal.
    • The problem does not occur when connecting directly to the session host, that is, when not connecting through the gateway.

    I have had a look at the logs for the session host and gateway roles and have discovered the following.

    When the client connects, regardless of whether it fails or connects successfully, the gateway logs the following events:


    Information 7/05/2010 1:14:31 PM TerminalServices-Gateway  200 (2)
    The user "DOMAIN\user", on client computer "", met connection authorization policy requirements and was therefore authorized to access the RD Gateway server. The following authentication method was used: "NTLM".

    Information 7/05/2010 1:14:31 PM TerminalServices-Gateway 300 (5)
    The user "DOMAIN\user", on client computer "", met resource authorization policy requirements and was therefore authorized to connect to resource "farm-name.domain.com".

    Information 7/05/2010 1:14:31 PM TerminalServices-Gateway 302 (3)
    The user "DOMAIN\user", on client computer "", connected to resource "farm-name.domain.com".


    After these events are logged for the Gateway, the following events are logged under 'Remote Connection Manager' for a successful connection :


    Information 7/05/2010 2:14:36 PM TerminalServices-RemoteConnectionManager 261 None
    Listener RDP-Tcp received a connection

    Information 7/05/2010 2:14:36 PM TerminalServices-RemoteConnectionManager 1149 None
    Remote Desktop Services: User authentication succeeded:
    User: user
    Domain: DOMAIN
    Source Network Address:


    However, when the client fails to connect, the second of these two items (1149) does not occur . Unfortunately, there is no error logged in it's place. I find this unusual because it seems to not be authenticating with the connection manager, yet according to this (http://technet.microsoft.com/en-us/library/ff404145%28WS.10%29.aspx ) list of role events, I would expect an error to be logged, such as 1148.

    If anyone could provide any assistance or guidance on this confusing issue I would be greatly appreciative.

    Kind Regards,




    Thursday, May 13, 2010 1:05 AM

All replies

  • Hi Nick. We're having very similar problem, possibly the same (cannot tell as those are remote clients connecting and we don't know whether they repeatedly press the connect button or close/reopen rdc).

    Have you solved the issue or at least found the culprit?

    Wednesday, May 26, 2010 3:23 PM
  • We are experiencing the exact same issue.  We tried creating a sandbox enviroment inside our network and we didn't have any problems (might be because it was not an xp machine internally).  Did you ever find a solution here?
    Tuesday, June 1, 2010 9:49 PM
  • Hi Nick,

               As per your question regarding RD connection failure issue while connecting, so check the

    firewall setting on both the pc, and check ip address,gatway, time zone should exact on both the

    sides, If your using router chechk the router gatway setting,



    Wednesday, June 2, 2010 10:19 AM
  • Hi, my problem might have been slightly different - described at http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2rds/thread/2fe2fa8f-a74e-4c64-87c9-e6f33a9f3fcb, but it seems to have been resolved by enabling CredSSP on the XP machines.

    I say "seems to", because I wasn't directly involved and have bit incomplete info from my colleagues.

    Wednesday, June 2, 2010 11:11 AM
  • My apologies for the very delayed response. This problem is indeed still occuring.

    Regarding the firewall setting: I don't understand how it could be a firewall issue if it's connceting the second time. However, to test I disabled the firewall on all machines and the problem still occured.

    The timezone is indeed the same on both sides, both are synchronising their time from a DC.

    I will try MarkosP's suggesting and report back.




    Wednesday, June 23, 2010 5:59 AM