locked
Distribution Group Manager Cannot Manage Distribution Group RRS feed

  • Question

  • Having checked a lot of related threads I havent seen this issue actually answered in any instance so I'm launching a new thread.

    Some background.

    Running an exchange 2010 server on 2008 R2 standard with SP1.

    Currently in co-existance with exchange 2003.

    Single domain without replication issues.

    User marked as the manager of distribution group,

    Manager can update membership list checked off,

    User has all security permissions on group object,

    user has write membership permission explicitly allowed.

    error received in outlook reads:

    "Changes to the public group membership cannot be saved. You do not have sufficient permission to perform this operation on this object."

    Are there any suggestions?

    Monday, September 9, 2013 3:42 PM

All replies

  • Hi,

    Have you seen my post in below thread ?

    Go with every steps 

    http://social.technet.microsoft.com/Forums/exchange/en-US/04dd6062-fcee-4c7c-a0c7-15f39544034c/distribution-lists-multiple-owners


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer. ---------- MCITP - Exchange 2010 | MCITP - Windows Server 2008 R2


    • Edited by Tarique Noorain Monday, September 9, 2013 6:01 PM s
    • Proposed as answer by Amy.WangModerator Tuesday, September 10, 2013 7:43 AM
    • Unproposed as answer by SysAdminMan Monday, September 16, 2013 3:09 PM
    • Marked as answer by SysAdminMan Tuesday, September 17, 2013 11:09 AM
    • Unmarked as answer by SysAdminMan Wednesday, September 18, 2013 2:41 PM
    Monday, September 9, 2013 4:44 PM
  • Hi,

    I agree with Tarique's suggestion. From the problem description, the default setting for Role Based Access Control (RBAC) needs to be changed for group managers to make changes to distribution group. Please change the 'My Distribution Groups' from Not Assigned to Assigned at first.

    Besides, here is a helpful thread for your reference.
     
    "changes to the distribution list membership cannot be saved. you do not have sufficient permission to perform this operation on this object"

    http://social.technet.microsoft.com/Forums/exchange/en-US/9c5a6f84-dbdb-46e8-8095-75ac51f3075a/changes-to-the-distribution-list-membership-cannot-be-saved-you-do-not-have-sufficient-permission

    Hope it helps. If you need further assistance, please feel free to let me know.

    Best regards,
    Amy

    • Marked as answer by SysAdminMan Tuesday, September 17, 2013 11:09 AM
    • Unmarked as answer by SysAdminMan Wednesday, September 18, 2013 2:41 PM
    Tuesday, September 10, 2013 3:17 PM
    Moderator
  • thankyou for replies folks. I will update the thread when i get a chance to put these to use.
    Wednesday, September 11, 2013 11:25 AM
  • Hi,

    Have you seen my post in below thread ?

    Go with every steps 

    http://social.technet.microsoft.com/Forums/exchange/en-US/04dd6062-fcee-4c7c-a0c7-15f39544034c/distribution-lists-multiple-owners


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer. ---------- MCITP - Exchange 2010 | MCITP - Windows Server 2008 R2


    OK I've added those settings in but I still have the same error message.

    I've got a policy applied to my mailbox that allows me to change "my" groups but still no joy. I'll try this with an entirely new group and see what I get.

    Monday, September 16, 2013 3:13 PM
  • Hi

    FYI,

    http://social.technet.microsoft.com/Forums/exchange/en-US/837fdfb4-880a-47bd-9e5f-1ed6cf94f31b/exchange-2013-distribution-group-owner-to-addremove-members

    This is one more similar thread and it resolved by my post.


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer. ---------- MCITP - Exchange 2010 | MCITP - Windows Server 2008 R2

    Monday, September 16, 2013 3:41 PM
  • EDIT: I take it all back, this inexplicably works in some cases but not others.

    This is bugged plain and simple.

    Right I shall restate this with the new changes included.

    Running an exchange 2010 server on 2008 R2 standard with SP1.

    Currently in co-existance with exchange 2003.

    Single domain without replication issues.

    User marked as the manager of distribution group,

    Manager can update membership list checked off,

    User has all security permissions on group object,

    user has write membership permission explicitly allowed.

    Distribution group created within the EMC and manager for group selected there. The EMC doesnt allow you to tick off manager can update so this was done in ADU&C. Group is of Universal type.

    RBAC administrative role covering distribution groups was created and members including the test user added to the role.

    RBAC default role assignment policy was altered to include my distribution groups and my distribution group members. This default policy is confirmed to be in effect on the test user.

    error received in outlook reads:

    "Changes to the public group membership cannot be saved. You do not have sufficient permission to perform this operation on this object."

    Most bizarre of all is that these settings have worked for some groups and not for others seemingly completely at random. Even worse is that the settings have worked and then ceased to work in one instance in spite of there being no change whatsoever to configuration.

    Unless someone can point out a missing piece of config then there's something wrong.

    With reference to the 2003 - 2010 side of things I've noticed that objects report needing to be converted into 2010 versions of themselves.

    With all of these changes sometimes clients arent recognising the new permissions but freshly downloaded mailboxes ARE allowing managers to manage distro groups. If the outlook clients need some kind of update I'm not sure why some are getting it and others arent.

    • Edited by SysAdminMan Friday, September 20, 2013 9:29 AM
    Wednesday, September 18, 2013 4:10 PM