locked
Not able to add the DAG Member in to DAG RRS feed

  • Question

  • Hi

    While adding one of the member server in DAG. I am getting the below error.

    Not able to remove the member server from dag also.

    Cluster service is stopped and disabled. Not able to start the service.

    Please suggest, How to remove this server from DAG and re-add again.

    This is very urgent.

    [PS] C:\Windows\system32>Add-DatabaseAvailabilityGroupServer -Identity DAG01 -MailboxServer server name
    WARNING: The operation wasn't successful because an error was encountered. You may find more details in log file
    "C:\ExchangeSetupLogs\DagTasks\dagtask_2012-12-02_09-53-22.524_add-databaseavailabiltygroupserver.log".
    Unable to contact the Cluster service on other 7 members (xxxxxxx, xxxxx.xxxx.xxxx.xxxx.xxxx.xxxx) of the database availability group.
        + CategoryInfo          : InvalidArgument: (:) [Add-DatabaseAvailabilityGroupServer], DagTaskServerCa...lusterExce
       ption
        + FullyQualifiedErrorId : 1933DDD4,Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityG
       roupServer

    [PS] C:\Windows\system32>
    [PS] C:\Windows\system32>Remove-DatabaseAvailabilityGroupServer -Identity DAG01 -MailboxServer servername
    Creating a new session for implicit remoting of "Remove-DatabaseAvailabilityGroupServer" command...
    WARNING: The operation wasn't successful because an error was encountered. You may find more details in log file
    "C:\ExchangeSetupLogs\DagTasks\dagtask_2012-12-02_16-06-15.038_remove-databaseavailabiltygroupserver.log".
    Unable to connect to the cluster service running on the machines in the database availability group 'DAG01'. Ensure tha
    t the machines have quorum, or use the -ConfigurationOnly option.
        + CategoryInfo          : InvalidArgument: (:) [Remove-DatabaseAvailabilityGroupServer], DagTaskRemoveDa...QuorumE
       xception
        + FullyQualifiedErrorId : 8AE81A0B,Microsoft.Exchange.Management.SystemConfigurationTasks.RemoveDatabaseAvailabili
       tyGroupServer

    [PS] C:\Windows\system32>

    Sunday, December 2, 2012 5:37 PM

Answers

  • Resolved Issue.

    Some one has added the Fake IP for the production servers in hosts file.

    Uninstalled Failover Clustering and tried again to add the server in to cluster.

    It worked fine

    Regards

    M

    • Marked as answer by Sean_Xiao Friday, December 7, 2012 10:27 AM
    Friday, December 7, 2012 10:13 AM

All replies

  • To remove the server from DAG you can use -configurationonly switch with the command:

    Remove-DatabaseAvailabilityGroupServer -Identity DAG01 -MailboxServer servername -ConfigurationOnly

    After the server is removed from dag with the command above, uninstall the failover cluster administrator and let the Add-DatabaseAvailabilityGroupServer install the Feature for us

    It appears like an issue with the communication. Basic Steps:

    1. Make sure that Remote Registry service is started.

    2. Make sure to have the MAPI Network on the top on the NIC Binding Order.

    3. Disable/uninstall Antivirus and check if that helps!


    M.P.K ~ ( Exchange | 2003/2007/2010/E15(2013)) ~~ Please remember to click “Vote As Helpful" if it really helps and "Mark as Answer” if it answers your question, “Unmark as Answer” if a marked post does not actually answer your question. ~~ This Information is provided is "AS IS" and confers NO Rights!!

    Monday, December 3, 2012 2:34 AM
  • Hi

    On both your servers is the cluster service disabled? They should be started if the DAG is running.

    Have you tried setting the service to manual and then starting it? Was your DAG working correctly before?

    Monday, December 3, 2012 4:59 AM
  • Hi,

    Please make sure all cluster services are started correctly in all members of the DAG then check the issue again.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sean Xiao
    TechNet Community Support

    Monday, December 3, 2012 8:13 AM
  • Resolved Issue.

    Some one has added the Fake IP for the production servers in hosts file.

    Uninstalled Failover Clustering and tried again to add the server in to cluster.

    It worked fine

    Regards

    M

    • Marked as answer by Sean_Xiao Friday, December 7, 2012 10:27 AM
    Friday, December 7, 2012 10:13 AM