none
Exchange 2007: Resource delegate never receives forwarded meeting requests for approval

    Question

  •  

    Hi guys

     

    I have a room resource which have the following settings:

    AutomateProcessing: AutoUpdate

    AllBookInPolicy: False

    AllRequestInPolicy: True

    AllRequestOutOfPolicy:False

    ForwardRequestsToDelegates: True

    ResourceDelegates: User1 (not the real name, but you get the point)

     

    In addition the delegate has been give full mailbox access by running the cmdlet:

    Set-MailboxCalendarPermission Resource1 -User:User1 -AccessRights:FullAccess

     If I open the room resource mailbox using User1's account he is listen on the delegates tab.

     

    Now, the problem is that User1 never receives any forwarded meeting requests for this resource. I have never been able to get any resource to forward its requests to any delegates. What am I doing wrong? Anyone know how to solve this?

     

    Thanks

    Morgan

    Friday, September 28, 2007 10:21 AM

All replies

  • Were you ever able to figure this out? I'm having the same difficulty.

     

    Chris

    Tuesday, March 25, 2008 5:58 PM
  • We do these, but the delegate still does not get the requests in their Inbox.  They have to look at the room's mailbox to answer requests.

    AllRequestOutOfPolicy:True
    AllRequestInPolicy:False

    AutomateProcessing: AutoUpdate

    ResourceDelegates: User1

     

    In addition the delegate has been give full mailbox access by running the cmdlet:

    Set-MailboxCalendarPermission Resource1 -User:User1 -AccessRights:FullAccess


    We don't do this one, is it required?
    ForwardRequestsToDelegates: True
    Tuesday, April 08, 2008 7:44 PM
  • I think it would be there but just confirm.

     

    In delegates tab of outlook where user1 is listed.

    select that user1 and click on permission.

    Verify if checkbox is selected for "Delegate receives copies of meeting-related messages sent to me".

    Wednesday, April 09, 2008 1:39 AM
  • I granted my account fullaccess permissions to the mailbox in order to view the delegates in the GUI. 

    When I select either delegate and choose Permissions, the checkbox for "Delegate receives copies of meeting-related messages sent to me" is grayed out and not checked.

    I then ran the command

    set-mailboxcalendarsettings Resource1 -forwardrequeststodelegatesEmbarrassedtrue

    but it is sitll not checked and still grayed out even after re-opening Outlook.  Any ideas?
    Wednesday, April 09, 2008 4:03 PM
  • Create a new resource mailbox and configure everything newly if something messed up with current resource mailbox.

    Wednesday, April 09, 2008 5:17 PM
  • Easier said than done since it's a well used meeting room.  And we have hundreds that were setup incorrectly.

    I'll just try that on the next one that gets created and see if it works as expected - then I can go back and recreate as time permits.

    So basically you're saying that the fact that it's grayed out is because something is corrupt?
    Wednesday, April 09, 2008 5:25 PM
  • Something like, permission are conflicting or which is not clicking in our mind.

     

    I will also check in my environment if time permits and let you know the outcome...

    Wednesday, April 09, 2008 5:44 PM
  • Make sure AutomateProcessing is set to autoaccept or else it will not process through to the delegate.  I had this problem and it worked out for me.
     
    Get-Mailbox -RecipientTypeDetails RoomMailbox | Set-MailboxCalendarSettings -AutomateProcessing AutoAccept

    -Jerry

    Friday, April 25, 2008 10:03 PM
  • Make sure AutomateProcessing is set to autoaccept or else it will not process through to the delegate.  I had this problem and it worked out for me.
     
    Get-Mailbox -RecipientTypeDetails RoomMailbox | Set-MailboxCalendarSettings -AutomateProcessing AutoAccept

    -Jerry


    I thought the whole point of forwarding to the delegate is when you don't want the room to automatically accept the meeting request.
    Monday, July 20, 2009 5:45 PM
  • I tried having auto accept off, and on and it still doesn't forward the request to delegates.  I have exchange 2010..
    Thursday, April 22, 2010 7:46 PM
  • I see this thread is pretty old, but thought I'd chime in after spending 2 days trying to get this to work.  I have Exchange 2010 with SP1, and all clients are using Outlook 2010.

    I created the resource mailboxes per Microsoft's instructions... configured a delegate in the resource mailbox settings, and the delegate would not receive any emails.  The emails would only show up in the inbox of the resource.  I have autoaccept turned off, since my thinking is that defeats the purpose of having a delegate in the first place.

    I have everything working as it should now.  What I had to do to get the delegate to receive the emails, is create an Outlook profile for the resource mailbox, open the mailbox, click file-account-settings, delegate access; Then go to permissions tab, and check the box 'delegate receives copies of meeting-related messages sent to me' (under calendar)

    After doing that, the delegate now receives the emails in their own inbox. 

    geez, what a pain!  Would be nice if this just worked when you setup the resource mailbox and configure the delegate.

    Hope this helps someone...

    • Proposed as answer by Tom Warda Tuesday, July 10, 2012 10:39 AM
    Thursday, March 08, 2012 4:53 PM
  • Whats the point of the having the below option in Get-Mailboxcalendarsettings, if it has to be done manually on Outlook. I have the same issue......looks like a bug! Would have been greate to get it working without modifying manually.

    ForwardRequestsToDelegates : True

    Tuesday, August 07, 2012 3:46 AM
  • This discussion is several months old (actually years...) but this combination worked for me and without having to mess with anything on the client side:

    ---------------------------

    [PS] C:\>Get-MailboxCalendarSettings "Conference Room X" | fl *auto*,*policy*


    AutomateProcessing    : AutoAccept
    RequestOutOfPolicy    :
    AllRequestOutOfPolicy : False
    BookInPolicy          :
    AllBookInPolicy       : False
    RequestInPolicy       :
    AllRequestInPolicy    : True

    #####################################

    In the Outlook meeting "Tracking" feature we see, for the room response:

    Tentative

    #####################################

    The delegate does indeed receive a message in his inbox and must approve for the room to be booked (despite the "autoaccept" setting).


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Friday, November 30, 2012 2:49 AM