none
Outlook 2007 and search in additional mailboxes

    Question

  • Hi guys!

    I have a question regarding search in MS outlook 2007 and Exchange 2007. We have around 30 mailboxes. 18 mailboxes for services (mails from customers, support suits etc...) and 12 for employees...

    Our Outlook setup is like this: Look at the picture - Click to see image

    So we have our own mailbox and then we added Sales, Marketing, Tehnical support etc... mailboxes to outlook. So each user has around 6-7 mailboxes opened.

    Now the search part...


    Case 1:
    Outlook in ONLINE MODE
    Search in your own mailbox (primary) --> Goes very smooth and very fast
    Search in any other mailbox than your own, lets say "Sales" mailbox --> Search take about 1-2 minutes to complete

    Case 2:
    Outlook in ONLINE MODE
    I created new profile and added "Sales" mailbox as my primary and only mailbox in Outlook --> Search is super fast

    Case 3:

    Outlook in CACHED MODE
    Again, search in my primary mailbox is super fast, in additional mailboxes is super SLOW, even slower than if Outlook is in ONLINE MODE

    Case 4:

    I use OWA and test search in random 10 mailboxes --> Search is again fast as ____, no problem here


    Enviroment:
     
    - Exchange 2007 SP1 Update rollup 9
    - Exchange has 4 storage groups for mailboxes and 1 storage group for public folders
    - Exchange and databases have Indexing enabled and databases have their full crawl completed
    - Mailbox databases (4 of them) sizes: 1st one: 3GB, 2nd and 3rd one: 4GB and 4th: 11GB
    - There is no error in eventlog
    - Exchange is running on VmWare ESX 3.5 server -> Dual Quad core Xenon proccessors assigned and 5GB of RAM and 70GB of storage (RAID 1+0) on 10k SAS disks
    - We use Windows XP SP3 and Vista SP2 -> and all patcheas applied
    - We use Outlook 2007 SP2 -> And all patches applied
    - All client PCs have at least 2 GB of memory and Core 2 Duo proccessors
    - Firewall is disabled on server and on clients
    - On Exchange I tested every mailbox with "Test-ExchangeSearch" command and all vere successful


    Can someone please help us out? I tried this on 3 different servers in 3 different firms, all have the same issue... Exchange search works fine, OWA is the proof. In OWA and mailbox with 160.000 mails it finds one mail in 2 seconds...

    We only have problem with additional (shared) mailboxes in Outlook 2007. And same story on Outlook 2003 (we have only 1 in our firm left :))

    Thanks for looking into it...

    **EDIT**
    One more thing I noticed...
    When I perform search in online mode on primary mailbox, store.exe on exchange does nothing unusual... But when I perform search in additional / shared mailbox, store.exe takes almost 100% CPU until search complete... This is weird...
    • Edited by Grega_SLO Wednesday, July 29, 2009 6:41 PM
    Wednesday, July 29, 2009 4:44 PM

All replies

  • HI,

    have you install below hotfix on Outlook 2007?

    Update for Outlook 2007 (KB933493)


    Regards


    Chinthaka
    Wednesday, July 29, 2009 6:50 PM
  • Hi!

    Thanks for quick reply!

    Yes this update is installed on all PCs with Office 2007 on them...

    Any other idea :) ?
    Wednesday, July 29, 2009 6:55 PM
  • HI,

    Per my knowledge only primary mailbox can be index. So your primary mailbox searches are very speed. The feature to index additional mailboxes and non-cached mailboxes has been introduced since Windows Desktop Search 4.0.Install WDS 4.0 on that PCs and additional configuration can be configure via GPO.

    Resource

    Windows Desktop Search

    How do I enable Windows Desktop Search to index Microsoft Outlook mail attachments?

    Regards


    Chinthaka
    Wednesday, July 29, 2009 7:05 PM
  • Yes I know that... But Outlook is in ONLINE mode, so it should use Exchange search which has index for all mailboxes on the server... We are mainly using Vista, which has desktop search already implemented in it...
    Thursday, July 30, 2009 6:21 AM
  • HI,

    that
    feature supports only with WDS 4.0 and it has comes with Vista Sp2.Your WDS version may not compatible with outlook indexing, so please reinstall WDS 4.0 and reproduce the issues have below mentioned download links.


    Quote-
    SP2 includes Windows Search 4.0, which builds on Microsoft’s search technology with improved indexing and search relevance. It also helps find and preview documents, e-mail (including signed e-mail messages), music files, photos, and other items on the computer. The search engine in Windows Search 4.0 is a Microsoft Windows® service that is also used by programs such as Microsoft Office Outlook® 2007 and Microsoft Office OneNote® 2007. Autotuning Diagnostics in SP2 now interprets current network conditions when implementing Windows scaling. This feature includes full netsh support.”

     

    Resources

    Notable Changes in Windows Server 2008 SP2 and Windows Vista SP2

    Windows Search 4.0 for Windows Vista SP1 (KB940157) 32bit

    Windows Search 4.0 for Windows Vista x64 Edition (KB940157)


    Regards

    Thursday, July 30, 2009 8:03 AM
  • Hmmm... But we have Windows Vista SP2 already installed about 1-2 months ago... If I rry to install this it says that is not compatible with my system... Because SP2 is already on all Vista machines...

    Its funny and I don`t understand it -> OWA searches fast and with no problems, Outlook 2007 whic is powerfull mail client searches slow...
    Thursday, July 30, 2009 9:56 AM
  • I fixed this search issue... Now in online mode flies like ____ :)
    Monday, August 10, 2009 8:24 AM
  • Mind sharingm how you fixed it?
    Tuesday, August 25, 2009 3:21 PM
  • Hi,

    Would you please share the information that how did you fix the issue.  I am facing the same issue as you were facing before as per your first message.

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/d2d1b01c-c85a-41ef-ba4e-394e8425266f?prof=required

    Thanks,

    Regards
    Raman
    Raman
    Wednesday, September 30, 2009 9:11 PM
  • Wow!!! May U pleeeease share Your solution with us? Seems like it's quite many of us suffering under slow search/browse under shared mailboxes!

    Once again: Pleeeease!
    Tuesday, October 13, 2009 12:46 PM
  • Hello Aseim,

    We have done the following on one of the remote users machine: -

    ·         Click Start

    ·         Click Run

    ·         Type gpedit.msc and press OK

    ·         Expand Computer Configuration

    ·         Expand Admin templates

    ·         Expand Windows Components

    ·         Click on Search

    ·         Double Click on “Enable indexing of online delegate mailboxes” option

    ·         Select “Enabled”

    ·         Click OK

    ·         Close Local Group Policy Editor

    ·         Click Start

    ·         Click Run

    ·         Type “gpupdate /force” and press ok

    ·         Restart Microsoft Outlook

    Please let us know if it works for you.


    Raman
    Wednesday, October 14, 2009 3:01 PM
  • We opened a supportcase with Microsoft in July 2009 and it looks like a fix is finaly on it's way :



    ==========

    After several discussions back and forth with our Outlook development team, I'm able to provide you with some additional insight on what is going on and why Quick Find works differently with Microsoft Office 2007 Service Pack 2 applied compared to Service Pack 1.

    After Service Pack 1 was released, we found an issue that was corrected. There has been few additional updates too, but one in particular that had an impact on your scenario.

    One of these updates we cannot remove as if we would, we you will eventually be unable to open items from that view.

    In detail, the issue in this particular case is that Outlook's view code attempts to associate the search results (from the search folder) with the containing folder the view uses with short term entry IDs which are unreliable for when we are online. Some additional information about Short Term Entry IDs

    http://msdn.microsoft.com/en-us/library/cc842254.aspx

     

    As a result of this, we would need to use Advanced Find to search for items in another user's store.

     

    The current status is that the issue with Advanced Find is scheduled to be corrected in our February Cumulative Update Release.
    ==========

    Thursday, February 11, 2010 10:58 PM
  • Hello!

    OK, this is a very old topic, but still....

    Now we moved all our clients to Office 2010 and of course Outlook 2010.

    Now these Outlook clients are in ONLINE mode. And whenever I search in different mailbox than mine I wait 5 minutes to get my search results.

    If I use ADVANCED find search completes in 2 seconds in mailbox with 30.000 mails in it...

    How can I use simple search with advanced search speed?

    Is this even possible?

     

    Thanks!

    Tuesday, March 01, 2011 1:50 PM
  • Grega_SLO, Do you mind sharing the solution that you had back in August 10, 2009?

    For the past few years, I got by by making sure SP2 for Office 2007 and KB980376 (and some other KBs I think) are not installed. Then our search was fast. Now we are moving to Office 2010 and the problem comes back. Microsoft never addressed the problem otherwise this slow search on non-primary mailboxes should not still exist.

    Friday, March 18, 2011 10:22 PM
  • That was the solution...

    Not install SP2 and wait...

    Same story on Exchange 2010 SP1 Update rollup 3 and Outlook 2010....

    Slow and super slow search...

    Wednesday, March 23, 2011 1:33 PM
  • Microsoft stuff is getting out of hand. Every problem I try to resolve open up a dozen others. I was a MCSE a decade ago. I miss the good old days. Nowadays so much time is spent trying to keep these Microsoft products running correctly (barely).
    Tuesday, March 29, 2011 7:25 AM
  • ·         Double Click on “Enable indexing of online delegate mailboxes” option

    This works fine for XP, what about Windows 7?

    Tuesday, May 03, 2011 3:20 PM
  • "Enable indexing of online delegate mailboxes" might work to create a local index on your PC. That works if the mailbox is small. But when it is in gigabytes, Your local HD will be very busy for a long while (when it is first creating the index and when it is finding something in the index). The issue is when the Exchange server is holding and running the indexes for each mailbox in memory ALREADY and ready to serve, why doesn't Outlook just get the result from it?

    Ok, tried Windows 7 64 bit and Office 2010 with all the updates available (as of today), STILL NO LUCK! Microsoft, ARE YOU THERE?


    Tuesday, May 10, 2011 4:24 PM
  • We have the same problem with SLOW searches, only started after migrating from Exchange 2007 to Exchange 2010. 

    Vista or Win 7 makes no difference.  All using Office 2007.  When using OWA searches are fast, but when using Outlook in online mode, searches report "searching" and take forever to run, something is seriously wrong.

    Wednesday, May 18, 2011 5:20 AM
  • http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/3fab8dbd-f998-455a-955c-777d5dcff2e7?prof=required

     

    Can we merge theese two topisc as they both talk about same issue?

     

    Thanks!

    Thursday, June 23, 2011 10:00 AM
  • Hello again :)

    We switched to Server 2008 R2 and Exchange 2010 SP1 latest UR applied. On clients is Win7 and Outlook 2010.

    We are still experiencing VERY slow search in mailbox with 40.000 items (mail only). If mailbox is primary, search works super fast. In WebApp search is super fast. If mailbox is shared in Outlook 2010 on totally free server and we initiate search it takes forever to return results...

    Is MS aware of this?

    I added screenshot of what I mean with shared mailbox...

     

    Regards,
    Greg

    Thursday, November 10, 2011 10:01 AM
  • Greg,

    You and I, along with many others, have been haunted by this slow secondary mailbox search issue for a few years already. Microsoft is ignoring us. I guess we are the 5% that they decide to ignore or they are so out of hand to correct this problem which might be impossible to fix by now. The Exchange server is maintaining the search indexes for all the databases yet few years back they provided us some local desktop search for those cache mode Outlook users and now screwed us all the online mode users. They are not fixing this mess. Give it up.

    Too bad you upgraded to Outlook 2010 because out of the box the problem is already there. I tried and I went back to Office 2007 and made sure Windows Update doesn't download any updates for it.

    Yes, we should merge this topic with this:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/3fab8dbd-f998-455a-955c-777d5dcff2e7?prof=required 


    Derek Chung
    Thursday, November 10, 2011 5:14 PM
  • Huh, that`s shame... I thought it will move forward, maybe I hoped for too much...

     

     

    Friday, November 11, 2011 9:12 AM
  • Wednesday, September 05, 2012 10:45 AM
  • You can always add another mailbox to outlook 2007
    You mean another mailbox to Outlook 2010. This make no difference. If you add second mailbox to Outlook 2010 o if you add secondary mailbox to Outlook 2007/2010 enabling "indexing online delegate mailboxes" GP you enable local Windows Search. The problem is local indexing is wasting resources and Outlook can not use server-side indexing for searches.

    -- P J

    Wednesday, September 05, 2012 12:14 PM