Can't Restore Exchange 2010 Mailbox DB from HP Data Protector backup


  • I'm trying to implement Exchange 2010, but I won't feel comfortable moving many users to it until I've successfully restored a mail database from tape backup.  So far, this hasn't worked out so well.  I'm using HP Data Protector for my backup solution.

    Here's what I've done:
    1.  In DP's "Restore" GUI, navigated down to the MS Volume Shadow Copy Writers entry, then selected both "Files" and "Logs" from the DB's entry under Microsoft Information Store.  I'm not restoring any of the other Writers.  So that I don't have to take down Exchange, I'm restoring them to a temporary restore location.
    2. After the restore completes, I go to the temporary restore location on the server and run eseutil /mh on the database, which returns a "Dirty Shutdown" db status.
    3.  Since I have the log files, I attempt to repair using eseutil /r E01 in the log files' path.  This generates "Operation terminated with error -1216 (JET_errAttachedDatabaseMismatch, An outstanding database attachment has been detected at the start or end of recovery, but database is missing or does not match attachment info) after 10.608 seconds."

    Can anyone suggest what I'm doing wrong with this recovery?  If my steps are incorrect I'd love to know, as HP's documentation for restoring Exchange 2010 is very young and not terribly useful.  My ultimate goal is to be able to restore a database from DP's tapes and bring it back online on the Exchange 2010 server.


    Wednesday, March 17, 2010 8:05 PM

All replies

  • Hi,

    Did you try repair restored DB using eseutil /P .

    Sunday, March 21, 2010 7:14 AM
  • Hi,

    Did you try repair restored DB using eseutil /P .

    Sunday, March 21, 2010 7:14 AM
  • Does the same thing happen if you try a backup using Windows Backup? What's your backend storage? Are these databases in a Dag? If so, how many copies?
    Sunday, March 21, 2010 4:15 PM
  • Anil: running a DB repair with /p should always be the last option (remember my old days in PSS)

    So when u run the /mh, how many log files it says that is missing. look for those log files, put them in the correct location and then try to mount the DB again.

    Let us know the result.

    Monday, March 22, 2010 5:17 AM
  • I suggest you to use any other Exchange Database Repair tool if eseutil is not working. There are many such tool van be found over search engines. One of those tools is available at http://www.exchangedatabaserepair.com/

    Tuesday, August 03, 2010 11:07 AM
  • ApprissIT,

    Have you found the solution? I've got the same problem with DP 6.11 and Exchange 2010 - eseutil /r not working. Please help :)


    Best regards,





    Friday, October 01, 2010 8:30 PM
  • it appears to me that the issue you are experiencing is a flaw with HP Data Protector.  I say this because we have been working on and testing the heck out of our recently released "Exchange Protection Managerhttp://www.lucid8.com/product/epm.asp product for the last few years and during that time we encountered this same issue and it drove us nuts.  It took us awhile to figure out what was going on but we resolved it. 

    BTW here is a datasheet on EPM in case you are interested http://www.lucid8.com/product/EPMDatasheet.pdf and if after reading it you wonder how we are able to do a SinglePass VSS database only backups, yet provide granular recovery at any level form any backup its because we included the core of our DigiScope product http://www.lucid8.com/product/digiscope.asp  

    That aside I suppose you could contact HP and see if they have some magical fix but I doubt it since whenever this happened to us the db was hooped, i.e. had to do a repair or pull another backup.  I know this of course doesn't help you much right now and not what you wanted to hear but there it is. Also Rajnish is right /P is a last ditch effort but I think the only way to resolve this is to do a ESEUTIL /P against that offline EDB to make it consistent. 


    Troy Werelius


    Friday, October 01, 2010 9:03 PM
  • Hi ALL,

    Eseutil /P is not the only one solution! After a busy night I've solved it!

    For me there are two bugs (if it can be named like this):

    1. DataProtector 6.11 restores databases and logs with one small difference. After you restore the files into alternate location notice that mail log file (named EXX.LOG) is named EXXtmp.LOG !!! Just rename that file.

    2. Eseutil /r works correctly on restored database from nr 1. IF the files are on the same drive and the same directory as the backuped database! It may be on different server but the drive letter and directory MUST be the same!

    I've tried this several times - everytime I was able to attach database without errors and with all the data from database and log files !!!

    If someone needs more details on procedure let me know - I will prepare something :)

    Best regards,


    Sunday, October 03, 2010 8:17 AM
  • OK - one more update :) nr 2 is not en error :) just run "ESEUTIL /R EXX /D" and you can fix your database in any folder and any drive you like. Best regards, Aleksander
    Sunday, October 03, 2010 9:53 AM
  • Hi Aleksander,

    We are trying to do the same as you did with Data Protector 6.11. No matter which way we run the eseutil /r command, we end up with a dirty shutdown database, not a clean one. When we renamed the exxtmp.log we get the following error when running eseutil:

    Operation terminated with error -501 (JET_errLogFileCorrupt, Log file is corrupt
    ) after 0.31 seconds.

    Putting the file back to e00tmp.log allows the eseutil command to do the soft recovery successfully but does not alter the database, and as before, the database is still in the dirty shutdown state.

    We contacted HP's support for Data Protector and the support tech claimed restoration of Exchange 2010 databases to a recovery database is not supported in 6.11.

    Maybe you found a way?


    Saturday, February 26, 2011 12:37 AM
  • Hi Ben,

    It's look like you have something wrong with your backup of log files. Could you please describe your procedure and settings in DataProtecor - it will help me understand your configuration.

    HP support is wrong :) DP6.11 supports backup/restoring Ex2010 databases but only in shadow copy mode. The API method (ie: single item recovery - mailbox/e-mail) is not supported in DP6.11+Ex2010 as it was in Ex2007. That's means that you always have to restore full database (in my situation whole 360GB) and then extract single item(mailbox/e-mail) with powershell...

    Best Regards,


    Sunday, February 27, 2011 6:45 PM
  • Hi Aleksander,

    Thanks for your reply. When you do your DP backup are you backing up a primary or database replica (Microsoft Exchange Writer or MS Exchange Replica Writer)? We are backing up and trying to restore a database replica. Would this be the issue?


    Friday, March 04, 2011 1:17 AM
  • Hi Ben,

    We backup our primary database (Ex Writer) and always with full backup (DB+LOGS). When we restore we restore to alternate location, then manualy copy db file and everything from restored log directory to one folder (for example: d:\restore_DB1). At this stage DB is in dirty shutdown state. Then we run (in folder where we copied db file and log files) 


    Eseutil.exe /R E00 /D

    it takes a couple of seconds (160GB file) and the db is in clean shutdown state. Then we do:

    New-MailboxDatabase -Name “Restored DB” -Server MBOX1 -EDBFilePath “D:\Restore_DB1\DB1.edb” -Logfolderpath “D:\Restore_DB1” -Recovery


    Mount-Database “Restored DB”

    now we can restore single mailbox or even single item from mailbox with:

    1: whole mailbox with overite the destination


    Restore-Mailbox –Identity “USERNAME” –RecoveryDatabase “Restored DB”


    2. whole mailbox to alternate location (new folder in another mailbox)



    Restore-Mailbox –Identity “EXISTING MAILBOX TO RESOTRE TO” –RecoveryDatabase “Restored DB” –RecoveryMailbox “MAILBOX DO BE RESTORED FROM BACKUP” –TargetFolder “NEW FOLDER IN EXISTING MAILBOX”

    3. the same as 2 but single item with MEETING in email subject

    Restore-Mailbox –Identity “EXISTING MAILBOX TO RESOTRE TO” –RecoveryDatabase “Restored DB” –RecoveryMailbox “MAILBOX DO BE RESTORED FROM BACKUP” -SubjectKeywords "MEETING" –TargetFolder “NEW FOLDER IN EXISTING MAILBOX”

    Best Regards,


    Friday, March 04, 2011 7:41 AM
  • Hello Alex,

    your solution description was very helpful. The "/D" Option for eseutil was the key for us.

    Thanks and regards

    Ralf  & Sven

    Thursday, September 01, 2011 7:51 AM
  • Exchange Recovery is a result-driven tool that can recover all e-mails, attachments, tasks, journals, contacts, calendars, as well as permanently deleted email items. Don't let corruption hamper your organization's productivity, simply download our Exchange Recovery tool and restore it back to healthy state Free download and more information visit http://exchangedatabase-recovery.blogspot.com
    • Edited by stays1 Sunday, May 25, 2014 5:02 PM
    Sunday, May 25, 2014 5:01 PM