none
why Exchange attachments would be corrupted by an IMAP client via Exchange 2010 RRS feed

  • Question

  • I hate even asking but I have several clients that "have" to use Thunderbird or Seamonkey to retrieve mail via IMAP. As such they are receiving corrupted email attachments. In Exchange 2003 the fix for this was to un-check fast mail retrieval but that setting does not exists in Exchange 2010. I have been looking at the Message Retrieval settings on the CAS servers under IMAP properties and am wondering if changing one of these settings could be the answer. The problem is I can't find any docs explaining anything about these various settings. Of course some are self-explanatory but I would like some detailed info so I can make a informed decision without just changing these settings and hoping it fixes the issue. TechNet docs are very sparse on the topic and I will need specifics to go back to the client with. Any help will be greatly appreciated.
    MRR
    Tuesday, April 5, 2011 4:36 PM

Answers

All replies

  • No IMAP experts at MS?
    MRR
    • Marked as answer by MRR045 Tuesday, April 19, 2011 2:59 PM
    Wednesday, April 6, 2011 6:31 PM
  • Hi,

     

     

    Exchange 2010 no longer has the setting.

    Exchange 2003 IMAP4 client use the streaming store (.stm file) for reading and writing mailbox data that is stored as MIME content.

    If you use the Move Mailbox functionality in Exchange System Manager or Active Directory Users and Computers to move a mailbox that is accessed by an IMAP4 client, the data in the moved mailbox is promoted into the Extensible Storage Engine store (.edb file), and the content is converted from MIME content to MAPI content.

    When the IMAP4 client logs on, exact message sizes are calculated, and MAPI-to-MIME conversion of the mailbox data occurs in memory and on the disk of the server.

    Fast message retrieval improves performance of the MAPI-to-MIME conversion.

     

    Exchange 2010 no longer use .stm file.

     

    More information

    Enable Fast Message Retrieval for IMAP4

    http://technet.microsoft.com/en-us/library/cc164353(EXCHG.80).aspx

     

    Understanding the Exchange 2010 Store

    http://technet.microsoft.com/en-us/library/bb331958.aspx

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Jerome XiongModerator Thursday, April 7, 2011 6:12 AM
    • Unproposed as answer by MRR045 Friday, February 24, 2012 11:27 PM
    Thursday, April 7, 2011 6:12 AM
    Moderator
  • I don't know if it is appropriate to answer in such an old topic but since it shows up in searches for this problem I'll take my chances:

    This is usually not (for once) Exchange not following published standards, but Thunderbird relying on an optional request in section 3.4.5 of RFC 2683. The RFC2683.SIZE setting seems to be something Thunderbird (and possibly other Mozilla mail clients) erroniously rely on. Exchange does not provide this apparently, I guess for speed reasons.

    If you go to Tools>Options>Advanced in Thunderbird and click on 'Config Settings' Then find 'mail.server.fetch_by_chunks' and set this to false it may solve your problems. You may also find something along the lines of 'mail.imap.fetch_by_chunks' or similar (I can't remember.. Sorry), this should also be set to 'False'. YMMV!

    I know this is not an Exchange problem and it may belong in another thread, if so I am sorry.

    -TS.

    PS: Why cant I get linebreaks?

    • Edited by TStorjord Friday, February 24, 2012 1:04 PM
    Friday, February 24, 2012 11:30 AM
  • Your right this has been awhile and from what I can remember it had something to do with the TLS setting.

    Thanks for your imput!

    Mike


    MRR

    Friday, February 24, 2012 11:28 PM