none
Autodiscover not working RRS feed

  • Question

  • We have a single Exchange 2010 server which holds the CAS, mailbox and HUB role. We use split DNS and the appropriate internal records are created.
    For some reason autodiscover (and thus OOF) isn't working. When I run the test-outlookwebservices command, no errors are shown. Also testexchangeconnectivity shows no errors when testen autodiscover, RPC-HTTP or OOF. Only when I rightclick the Outlook tray icon, holding CRTL and then test email autoconfiguration I receive an error (autodiscover settings weren't obtained).

    Any ideas?

    Monday, August 29, 2011 7:57 AM

Answers

  • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
    "PreferLocalXML"=dword:1
    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:1
    "ExcludeHttpsRootDomain"=dword:1
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:1
    "ExcludeSrvRecord"=dword:1


    ...these values are the reason Autodiscover is not working for you (unless you have created your own Autodiscover.xml file and copied it to the client computers)
    Remove them or change the value to "0"


    Martina Miskovic
    • Marked as answer by SPLS Monday, August 29, 2011 10:46 AM
    Monday, August 29, 2011 10:32 AM

All replies

  • http://technet.microsoft.com/en-us/library/bb124251.aspx
    Monday, August 29, 2011 8:04 AM
  • What do you get when you issues this command?

    Get-ClientAccessServer | List Name, AutoDiscoverServiceInternalUri

    Have you set all the internal URLs? (For the procedures see especially Part 2 of the article series.)

    Exchange Autodiscover (Part 1)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

    Exchange Autodiscover (Part 2)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover-part2.html


    MCTS: Messaging | MCSE: S+M
    Monday, August 29, 2011 8:21 AM
  • What do you get when you issues this command?

    Get-ClientAccessServer | List Name, AutoDiscoverServiceInternalUri



    This is the response to Get-ClientAccessServer | List Name, AutoDiscoverServiceInternalUri:

    AutoDiscoverServiceInternalUri : https://internalfqdn/Autodiscover/Autodiscover.xml

    Monday, August 29, 2011 9:01 AM
  • Since you are using a split DNS, see if it helps to set the internal URI for Autodiscover to the external FQDN/Autodiscover/Autodiscover.xml
    (I always do this.)

    Get-ClientAccessServer | Set-ClientAccessServer -AutoDiscoverServiceInternalUri: https://externalfqd/Autodiscover/Autodiscover.xml

    You can easily change it back again by using the same command. You might need to restart IIS.


    MCTS: Messaging | MCSE: S+M
    Monday, August 29, 2011 9:16 AM
  • Since you are using a split DNS, see if it helps to set the internal URI for Autodiscover to the external FQDN/Autodiscover/Autodiscover.xml
    (I always do this.)

    Get-ClientAccessServer | Set-ClientAccessServer -AutoDiscoverServiceInternalUri: https://externalfqd/Autodiscover/Autodiscover.xml

    You can easily change it back again by using the same command. You might need to restart IIS.



    Tried it, but no difference...
    Monday, August 29, 2011 9:42 AM
  • Hi,

    Can you check if you have any of the below registry keys set?
     
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
    "PreferLocalXML"=dword:1
    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:1
    "ExcludeHttpsRootDomain"=dword:1
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:1
    "ExcludeSrvRecord"=dword:1


    These keys are not in the registry by default. 


    Martina Miskovic
    Monday, August 29, 2011 9:57 AM
  • While of course Martina can be right ... you can use the Test-OutlookWebServices cmdlet to verify the Autodiscover service settings for Microsoft Outlook. The output might help troubleshooting this issue further.

    Test-OutlookWebServices -Identity:jas@contoso.com

    Test-OutlookWebServices
    http://technet.microsoft.com/en-us/library/bb124509.aspx


    MCTS: Messaging | MCSE: S+M
    Monday, August 29, 2011 10:01 AM
  • Hi,

    Can you check if you have any of the below registry keys set?
     
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
    "PreferLocalXML"=dword:1
    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:1
    "ExcludeHttpsRootDomain"=dword:1
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:1
    "ExcludeSrvRecord"=dword:1


    These keys are not in the registry by default. 


    Martina Miskovic

    Yes, they are all present and with the correct values.
    Monday, August 29, 2011 10:19 AM
  • ..and what are the correct values in your environment?
    The above settings is usually used during migration and if you have for example ExcludeScpLookup"=dword:1 the client will not read the SCP Value for Autodiscover.
    I would remove them.



    Martina Miskovic
    Monday, August 29, 2011 10:22 AM
  • While of course Martina can be right ... you can use the Test-OutlookWebServices cmdlet to verify the Autodiscover service settings for Microsoft Outlook. The output might help troubleshooting this issue further.

    Test-OutlookWebServices -Identity:jas@contoso.com

    Test-OutlookWebServices
    http://technet.microsoft.com/en-us/library/bb124509.aspx


    MCTS: Messaging | MCSE: S+M


    Seems OK to me:

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1019

    Type       : Information

    Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1006

    Type       : Information

    Message    : Contacted the Autodiscover service at https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1016

    Type       : Information

    Message    : [EXCH] The AS is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1015

    Type       : Information

    Message    : [EXCH] The OAB is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1014

    Type       : Information

    Message    : [EXCH] The UM is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1016

    Type       : Information

    Message    : [EXPR] The AS is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1015

    Type       : Information

    Message    : [EXPR] The OAB is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1014

    Type       : Information

    Message    : [EXPR] The UM is configured for this user in the Autodiscover response received from https://externalFQDN/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1022

    Type       : Success

    Message    : Autodiscover was tested successfully.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1106

    Type       : Information

    Message    : Contacted the Autodiscover service at https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1116

    Type       : Information

    Message    : [EXCH] The AS is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1115

    Type       : Information

    Message    : [EXCH] The OAB is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1114

    Type       : Information

    Message    : [EXCH] The UM is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1116

    Type       : Information

    Message    : [EXPR] The AS is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1115

    Type       : Information

    Message    : [EXPR] The OAB is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1114

    Type       : Information

    Message    : [EXPR] The UM is configured for this user in the Autodiscover response received from https://InternalFQDN:443/Autodiscover/Autodiscover.xml.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1122

    Type       : Success

    Message    : Autodiscover was tested successfully.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1024

    Type       : Success

    Message    : [EXCH] Successfully contacted the AS service at https://internalFQDN/EWS/Exchange.asmx. The elapsed time was 796 milliseconds.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1026

    Type       : Success

    Message    : [EXCH] Successfully contacted the UM service at https://internalFQDN/EWS/Exchange.asmx. The elapsed time was 546 milliseconds.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1024

    Type       : Success

    Message    : [EXPR] Successfully contacted the AS service at https://externalFQDN/ews/exchange.asmx. The elapsed time was 140 milliseconds.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1026

    Type       : Success

    Message    : [EXPR] Successfully contacted the UM service at https://externalFQDN/ews/exchange.asmx. Theelapsed time was 296 milliseconds.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1124

    Type       : Success

    Message    : [Server] Successfully contacted the AS service at https://internalFQDN/ews/exchange.asmx.

                 The elapsed time was 124 milliseconds.

     

    RunspaceId : ac43fcbd-b7f7-483d-aa12-3b4e2e59e2f7

    Id         : 1126

    Type       : Success

    Message    : [Server] Successfully contacted the UM service at https://internalFQDN/ews/exchange.asmx.

                 The elapsed time was 187 milliseconds.

    Monday, August 29, 2011 10:27 AM
  • ..and what are the correct values in your environment?
    The above settings is usually used during migration and if you have for example ExcludeScpLookup"=dword:1 the client will not read the SCP Value for Autodiscover.
    I would remove them.



    Martina Miskovic

    The same values you mentioned (I presumed they were the right ones). So you would like me to remove al the mentioned values?
    • Edited by SPLS Monday, August 29, 2011 10:34 AM
    Monday, August 29, 2011 10:30 AM
  • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
    "PreferLocalXML"=dword:1
    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:1
    "ExcludeHttpsRootDomain"=dword:1
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:1
    "ExcludeSrvRecord"=dword:1


    ...these values are the reason Autodiscover is not working for you (unless you have created your own Autodiscover.xml file and copied it to the client computers)
    Remove them or change the value to "0"


    Martina Miskovic
    • Marked as answer by SPLS Monday, August 29, 2011 10:46 AM
    Monday, August 29, 2011 10:32 AM
  • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover
    "PreferLocalXML"=dword:1
    "ExcludeHttpRedirect"=dword:0
    "ExcludeHttpsAutodiscoverDomain"=dword:1
    "ExcludeHttpsRootDomain"=dword:1
    "ExcludeScpLookup"=dword:1
    "ExcludeSrvLookup"=dword:1
    "ExcludeSrvRecord"=dword:1


    ...these values are the reason Autodiscover is not working for you (unless you have created your own Autodiscover.xml file and copied it to the client computers)
    Remove them or change the value to "0"


    Martina Miskovic


    I removed the values and also the ones at HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover\RedirectServers


    Rightclicking the Outlook tray icon, holding CRTL and then test email autoconfiguration still doesn't work, but when adding the mail account using only the e-mailaddress and the password it suddenly works!! Also OOF works now!

     

    Thank you very much Martina!


    • Edited by SPLS Monday, August 29, 2011 10:47 AM
    Monday, August 29, 2011 10:40 AM