locked
the data area passed to a system call is too small RRS feed

  • Question

  • i have recently publish OWA 2003 using ISA 2006, everthing is working file except OMA from mobiles devices, OMA from PC internet explrer is working fine but when we try to access it from mobile device we receive this error after we accept the certificate

    error code: 500 internal server error. The data area passed to a system call is too small

    OWA AND EAS is working fine, we are using FBA on ISA 2006 with SSL and RSA SecureId, any help will be highly appreciated...
    Tuesday, August 28, 2007 4:08 PM

Answers

  • hi

     

    you still using FBA , it is working internally because your accessing the OMA directly not thru  ISA

    Internally you will go directly to exchange with basic Auth , and from the mobile you will go thru isa with FBA

     

    This problem occurs if the following conditions are true:

    You are using the forms-based authentication filter in ISA Server 2006.

    You have installed a third-party add-in program for Microsoft Exchange

     

    Wednesday, August 29, 2007 8:35 AM

All replies

  • hi

    I had same issue and I think it is becuase you are using FBA

    FBA requires the ‘Basic Authentication’ method for Web access to the OWA folder /Exchange.  The OMA and EAS they require it to have ‘Integrated authentication’ without any SSL.

    check  this link in how to resolve this issue

    http://www.msexchange.org/tutorials/Configuring-Exchange2003-HTTP-Remote-Access.html

     

    Tuesday, August 28, 2007 7:23 PM
  • thanks for your reply Ehad

    we are not using FBA on IIS but on ISA 2006 and ISA 2006 is doing the authentiction (basic) with IIS on client behalf, now everying is woking fine including OWA, EAS and OMA. If i test OMA from PC browser over the internet using my.domain.com/oma its works fine but when i try the same using my PPC browser i get the above error. if OMA is working from a desktop PC thats means authenticatin is not a problem but something else...


    Wednesday, August 29, 2007 6:14 AM
  • hi

     

    you still using FBA , it is working internally because your accessing the OMA directly not thru  ISA

    Internally you will go directly to exchange with basic Auth , and from the mobile you will go thru isa with FBA

     

    This problem occurs if the following conditions are true:

    You are using the forms-based authentication filter in ISA Server 2006.

    You have installed a third-party add-in program for Microsoft Exchange

     

    Wednesday, August 29, 2007 8:35 AM