locked
Cannot get OWA back RRS feed

  • Question

  • I deleted the OWA virtual directory by mistake.  I uninstalled the CAS server role and reinstalled it.  I ran get-owavirtualdirectory and OWA does not come up.  Yet everytime I try to reinstall the CAS directory I get this:

    Code Snippet

    Exchange Server component Client Access Role failed.  Error:Error:

    An error occurred while creating the IIS virtual directory

    'IIS://sacspc.com/W3SVC/1/ROOT/owa' on 'XCHANGE'.

     

    Cannot create a file when that file already exists.  (Exception from HRESULT: 0x800700B7)

    Thursday, June 18, 2009 7:35 PM

Answers

  • Check info:

    1.      Do it mean that we can’t see /OWA virtual directory after run the cmdlet below?

    Get-OwaVirtualDirectory -Identity "CASServerName\owa (default web site)"

    2.      Based on the error info, it seems that the /OWA virtual directory already exists. Please open the IIS console on the CAS server and confirm the existence of the /OWA virtual directory

    3.      Even we can’t see /OWA virtual directory by using steps above, still doesn’t mean it not exists, please go to check the IIS 7.0 Metabase

    a.      Find adsutil.vbs script on the CAS server, usually it’s in SystemDriver\Inetpub\AdminScripts

    b.      Then, please open cmd window, and “cd” to the path above

    c.       Use the command below to check the metabase, see if there’s any remained trace about  /OWA virtual directory

    Cscript adsutil.vbs enum w3svc/1/root

    Possible cause: last uninstallation of CAS server didn’t remove the trace of /OWA virtual directory completely, so remained bad cache in Metabase was preventing the recreation of /OWA virtual directory

    Resolution 1: The IIS configuration files are located in ApplicationHost.config. This file is located in %windir%\system32\inetsrv\config. Found the below entry even with no owa vdir in IIS manager, remove the entries below and reinstall the CAS server role

    <application path="/owa/8.1.263.0" applicationPool="MSExchangeOWAAppPool">

    <virtualDirectory path="/" physicalPath="C:\Program

    Files\Microsoft\Exchange Server\ClientAccess\owa\8.1.263.0" />

    </application>

    Resolution 2: If the resolution 1 fails or if deleting the entries is not practical (there are too many) another option is to use the following steps:

    a.      Remove CAS and Hub roles (if present)

    b.      Remove IIS from the server

    c.       Restart the server

    Notes: If the ApplicationHost.config is still present, it can be deleted

    d.      Reinstall IIS, and CAS and Hub roles (if present)

    Friday, June 19, 2009 4:00 AM

All replies

  • Check info:

    1.      Do it mean that we can’t see /OWA virtual directory after run the cmdlet below?

    Get-OwaVirtualDirectory -Identity "CASServerName\owa (default web site)"

    2.      Based on the error info, it seems that the /OWA virtual directory already exists. Please open the IIS console on the CAS server and confirm the existence of the /OWA virtual directory

    3.      Even we can’t see /OWA virtual directory by using steps above, still doesn’t mean it not exists, please go to check the IIS 7.0 Metabase

    a.      Find adsutil.vbs script on the CAS server, usually it’s in SystemDriver\Inetpub\AdminScripts

    b.      Then, please open cmd window, and “cd” to the path above

    c.       Use the command below to check the metabase, see if there’s any remained trace about  /OWA virtual directory

    Cscript adsutil.vbs enum w3svc/1/root

    Possible cause: last uninstallation of CAS server didn’t remove the trace of /OWA virtual directory completely, so remained bad cache in Metabase was preventing the recreation of /OWA virtual directory

    Resolution 1: The IIS configuration files are located in ApplicationHost.config. This file is located in %windir%\system32\inetsrv\config. Found the below entry even with no owa vdir in IIS manager, remove the entries below and reinstall the CAS server role

    <application path="/owa/8.1.263.0" applicationPool="MSExchangeOWAAppPool">

    <virtualDirectory path="/" physicalPath="C:\Program

    Files\Microsoft\Exchange Server\ClientAccess\owa\8.1.263.0" />

    </application>

    Resolution 2: If the resolution 1 fails or if deleting the entries is not practical (there are too many) another option is to use the following steps:

    a.      Remove CAS and Hub roles (if present)

    b.      Remove IIS from the server

    c.       Restart the server

    Notes: If the ApplicationHost.config is still present, it can be deleted

    d.      Reinstall IIS, and CAS and Hub roles (if present)

    Friday, June 19, 2009 4:00 AM

  • Resolution 1 : The IIS configuration files are located in ApplicationHost.config. This file is located in %windir%\system32\inetsrv\config. Found the below entry even with no owa vdir in IIS manager, remove the entries below and reinstall the CAS server role

    <application path="/owa/8.1.263.0" applicationPool="MSExchangeOWAAppPool">

    <virtualDirectory path="/" physicalPath="C:\Program

    Files\Microsoft\Exchange Server\ClientAccess\owa\8.1.263.0" />

    </application>

    That was the fix!  Thanks for your help!

    I did go through that file and saw those entries, but figured it best not remove the ExchangeAppPool.  I know better now!
    Friday, June 19, 2009 12:22 PM
  • J Glad to help

    Monday, June 22, 2009 1:16 AM
  • Hi,

    Resolution 1 works.

    James, you da man!

    -KOT
    Thursday, July 9, 2009 6:51 PM
  • Glad this resolution can benefit so many people J

    Friday, July 10, 2009 12:47 AM
  • Hello

    The above solution works! thanks! 

    But.. I'm using SBS 2008. After installing the cas hub, it puts the virtual directories in "Default web site". Shouldn't it be in "SBS Web Applications" directory?

    I can see a potential conflict as "BPService, Exadmin, Public, Remote, RPC, RpcWithCert, and Webhelp" is placed in there. Conflicts such as SSL:443 binding as you can only have one.

    EDIT: I logged into another SBS 2008 server and it has everything in SBS Web Applications directory. But the Exchange 2007 repair placed them in Default Web Site directory. How do I move them back into SBS Web Applications directory?

    Saturday, March 6, 2010 4:53 PM
  • 
    You'd want to ask that in an SBS forum.
    --
    Ed Crowley MVP
    "There are seldom good technological solutions to behavioral problems."
    .
    "LexNLexN" wrote in message news:92816e5a-db9d-49f9-b182-c67847fa0733...
    Hello

    The above solution works! thanks! 

    But.. I'm using SBS 2008. After installing the cas hub, it puts the virtual directories in "Default web site". Shouldn't it be in "SBS Web Applications" directory?

    I can see a potential conflict as "BPService, Exadmin, Public, Remote, RPC, RpcWithCert, and Webhelp" is placed in there. Conflicts such as SSL:443 binding as you can only have one.

    EDIT: I logged into another SBS 2008 server and it has everything in SBS Web Applications directory. But the Exchange 2007 repair placed them in Default Web Site directory. How do I move them back into SBS Web Applications directory?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Proposed as answer by noliver Friday, January 21, 2011 5:15 PM
    Monday, March 8, 2010 4:20 AM
  • You can skip the CAS reinstall by shortcutting it, I just did the same thing and it works perfectly.  Do as James-Luo suggests and  locate that file and delete the owa lines, but then just run the new owavirtual command on the proper iis site and poof, it's back.  I did in on an SBS 2008 server.

    Delete the following lines-
                <application path="/owa/8.1.340.0" applicationPool="MSExchangeOWAAppPool">
                        <virtualDirectory path="/" physicalPath="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\8.1.340.0" />
                    </application>
    from the file ApplicationHost.config located in the %windir%\system32\inetsrv\config (back it up first).

    Then run the following command in the Exchange Management Shell:

    New-OWAVirtualDirectory -Name "OWA" -Website "SBS Web Applications"

    Friday, January 21, 2011 5:17 PM
  • Thanks Alan, worked a charm!
    Monday, June 2, 2014 7:24 PM
  • There is an easier way to remove the [/w3svc/1/root/owa] entry.

    It will stay there because in the IIS manager under  Sites > Default Website > Click on "view applications" in the action pane, you will see two applications pointing at the owa virtual directory.

    Click the application and then Click "remove" in the action pane.

    When you now run "Cscript adsutil.vbs enum w3svc/1/root" the entry [/w3svc/1/root/owa] will be gone.


    Raymond Rothengatter - RayFlexCom


    • Edited by Raymond-R Tuesday, September 9, 2014 1:02 AM
    Tuesday, September 9, 2014 1:01 AM