locked
Calendar Sharing not available error message RRS feed

  • Question

  • Trying to share my calendar with staff at the office here. I get the error:

     

    Calendar sharing is not available with the following entries because of permission settings on your network.

     

    I am using Offiice 2007 SP1, Exchange Server 2007 SP1

     

    I can however go to the other workstation and use the "open a shared calendar" option to access my shared calendar.

     

    It does work on some accounts, but not the majority of accounts.

     

    Where do I start trouble shooting this issue? How do I check the "permission settings on my network"

     

    Sorry if this is an easy one, I'm a new user to exchange. This is not a full production setup yet, still testing before I let folks know what it can do.

     

    Thanks

    Kevin Maracle

    First Nations Technical Institute

     

     

    Thursday, November 20, 2008 3:53 PM

Answers

All replies

  • We had the same problem and found out that if we used the GAL to choose the ones we wanted to share our calenda with then it worked. If we typed in the mail address it didnt. My 5 cent, hope it helps.
    • Proposed as answer by TX DJ Tuesday, May 17, 2011 7:37 PM
    Saturday, November 22, 2008 8:15 PM
  • Issue description: You can’t share calendar to other people

    Calendar sharing is not available with the following entries because of permission settings on your network

    Collect info:

    1.       Do the users you want to share belong to other forests?

    2.       Is the issue only happened on your account?

    3.       Is there any error info in the application log on the server or client if you reproduce the issue?

    Troubleshooting:

    1.       How did you grant the permission to other users, from the “Properties” of the calendar or share it in the invitation? Please check which permissions stay in the “Properties” of calendar by default

    2.       Check if DACL status is “GOOD” on your calendar by using PFDavAdmin

    a.       Launch tool on client [Install NET Framework 1.1 at first]

    b.      “File” menu->”connect”->select “mailbox” to connect->OK

    c.       Right-click your mailbox->”Folder permissions”

    d.      Check the “DACL state” on the right-up corner

    3.       Check if “automatically update e-mail addresses based on e-mail address policy” option is checked

    a.       EMC->Recipient Configuration->Mailbox, go to the “Properties” of your mailbox

    b.      “E-Mail Address” tab, check the option

    4.       Please recreate your mail profile on another test PC, see if you can reproduce the issue. in this way, we can isolate the issue to server or client side

     

    Monday, November 24, 2008 9:21 AM
  • Thanks for the suggestions I will try them out today.

     

    1. This is a single domain, though in the future I want to allow another domain (connected via wiress VPN) to connect to this server as well.

     

    2. It happens to multiple accounts - there are 41 accounts.

     

    3. I couldn't find any errors on the server. I have logging enabled on my outlook 2007 client. It doesn't record calendar interactions - only mail, I didnt see anywhere for calendar logging options in outlook but I will so some more searching,

     

    ----

     

    1. Calendar permissions look fine to me. I can tell another account to open my calendar via the "Open a shared calendar" link in outlook, that works. But if I click the "share my calendar" link, I get the network error message.

     

    Will download and install PFDavAdmin.

     

    Kevin

    Monday, November 24, 2008 1:45 PM
  •  

    2.       Check if DACL status is “GOOD” on your calendar by using PFDavAdmin

    a.       Launch tool on client [Install NET Framework 1.1 at first]

    b.      “File” menu->”connect”->select “mailbox” to connect->OK

    c.       Right-click your mailbox->”Folder permissions”

    d.      Check the “DACL state” on the right-up corner

     

    It does say Good

     

    3.       Check if “automatically update e-mail addresses based on e-mail address policy” option is checked

    a.       EMC->Recipient Configuration->Mailbox, go to the “Properties” of your mailbox

    b.      “E-Mail Address” tab, check the option

     

    It is set to automatically update email addresses......

     

    4.       Please recreate your mail profile on another test PC, see if you can reproduce the issue. in this way, we can isolate the issue to server or client side

     

    AHA - I recreated a new outlook exchange account on a brand new pc I had ready. It worked fine. I have deleted and recreated my exhange account on my regular machine and it didnt make any difference.

     

     

    Monday, November 24, 2008 9:36 PM
  • Based on your testing, it seems that we can isolate the issue to the problematic client PC. Please try to recreate your login account’s windows profile on the problematic client PC, then create mail profile to test

    If the issue still persists, please recreate the office on the problematic client PC

    References:

    How to uninstall the 2007 Office system if you cannot uninstall it by using the "Add or Remove Programs" feature

     

    Tuesday, November 25, 2008 2:00 AM
  • I'm having the same problem. I followed all of the steps and checked everything line by line basing it on the solution provided here. I'm running 1 Exchange Server 2003 Enterprise SP2 on Windows Server Enterprise 2003 SP2

    I built a new PC with a fresh install of Windows XP Professional SP3 and Office 2007 Enterprise SP1.
    I logged in as the user, created a new Windows and Outlook profile and I get the same problem.

    My question is, if the problem is not isolated to the workstation, where else can I look to solve the problem. What on the server or Active Directory side should I look for?

    I want to re-iterate that I followed all of the steps including running the PFDAVAdmin tool and confirming the DACL state of the user is good.

    Thank you,

    Fabian Leiva
    Friday, March 20, 2009 5:19 PM
  • I ran into this problem today.  The solution turned out to be an email address formatting problem.
    If I select the user 's email address that I want to share with from my local contacts list, a list that I created before moving to exchange, then I receive this error message.  If I select the user's email address from the Exchange Global list, then I have no problem.  Also, entering the address in manually seems to work.

    Outlook was autocompleting the addresses for me and using my local contact list.  That was causing a problem.

    Let me know if you find this information useful.

    Sonny
    • Proposed as answer by snooplup Tuesday, February 23, 2010 2:03 PM
    Monday, April 6, 2009 7:22 PM
  • Rabid Turkey:

    Your advice nailed it for me.

    Mac
    • Proposed as answer by Purtech Monday, April 9, 2012 1:45 PM
    Wednesday, April 8, 2009 4:38 PM
  • Thanks, Rabid Turkey!  That was exactly it.  I previously did everything mentioned, but none of it worked.  When I tried, however, to put in the address from the global list - rather than my contacts - it took immediately.
    Thursday, October 22, 2009 6:34 PM
  • This saved me a lot of time!  I have had this problem for a few weeks, and I didn't even think about this!  That was it!  

     

    Thanks so much!

    • Proposed as answer by PaTryptik Thursday, July 8, 2010 6:36 PM
    Wednesday, June 9, 2010 7:04 PM
  • What fixed the issue for me was to start outlook with the /cleanprofile command line option.
    Thursday, July 8, 2010 6:37 PM
  • I had the same problem with Outlook 2010 and Exchange 2010.

    I had specified manually the specific permissions in Calendar Permissions for the user, using the checkboxes. Instead of doing that, I selected the predetermined Reviewer role, and when sending the envite selected the user from the GAL as was previously stated.

    Thanks

    Tuesday, August 3, 2010 3:36 PM
  • Jup, perfect! You helped me too!
    Perfect example of Microsoft's logic.

    Thanks!

    Thursday, August 19, 2010 7:58 AM
  • Had this problem aswell with one or two clients, and racerrommanos suggestion was a suitable workaround seeing you dont do this too often and setting up the users local profile all over can be quite time consuming.
    Lidahl
    Friday, December 10, 2010 10:42 AM
  • I Was having the same problem this was the only solution for me. Thank You.  I suggest everyone try this.
    Friday, December 31, 2010 3:54 AM
  • I had the same problem, it turned out the user had a shared mailbox instead of an user mailbox.

    I converted the shared mailbox to an user mailbox using the following command: set-mailbox -identity <alias> -type regular, after this the error message went away.

    Tuesday, March 15, 2011 9:11 AM
  • @Rabid Turkey : This was the solution for me as well! perfect.

     

    Is there any way to automate this, or make all the clients look in the Exchange global list by default?

    Thursday, April 21, 2011 12:14 PM
  • Points to Rabid Turkey.  This solved our issue as well.
    Tuesday, June 28, 2011 2:51 PM
  • I ran into this problem today.  The solution turned out to be an email address formatting problem.
    If I select the user 's email address that I want to share with from my local contacts list, a list that I created before moving to exchange, then I receive this error message.  If I select the user's email address from the Exchange Global list, then I have no problem.  Also, entering the address in manually seems to work.

    Outlook was autocompleting the addresses for me and using my local contact list.  That was causing a problem.

    Let me know if you find this information useful.

    Sonny


    clear the email address out of the Outlook.NK2 file worked for me. I take it, it is the same as going to the GAL and not the local cache

    Thanks for the help

    John R


    John R
    • Proposed as answer by Sandra Bursey Wednesday, January 21, 2015 1:02 AM
    • Unproposed as answer by Sandra Bursey Wednesday, January 21, 2015 1:03 AM
    Friday, July 15, 2011 4:57 PM
  • You've just made my day smoother.  Thanks.  This worked!!!!!!
    Tuesday, August 23, 2011 1:51 PM
  • What about the instance of this error message still appearing randonly even when the Contacts are all listed in the Global Address List?

    This is the issue we're getting: some users are allowed to view Shared Calendars, some are not....but they're all in the GAL.

    Wednesday, December 14, 2011 10:42 AM
  • Sonny,

    Thanks!!!!

    I just upgraded from exchange 2003 to exchange 2010 and the cached addresses from 2003 have been giving me (and my users) a bunch of trouble.

    Your post was just the bit of info I needed to confirm my suspicions.

    Thanks again!

    Matt M.

     

    Wednesday, January 18, 2012 4:21 PM
  • Thank you so much THIS IS THE ONE AND ONLY SOLUTION!
    • Proposed as answer by RaymondLMCD Tuesday, April 17, 2012 4:28 PM
    Tuesday, April 17, 2012 4:27 PM
  • Thank you Rabid Turkey!  One of my users was having this problem, and your post was the solution.
    Thursday, May 3, 2012 1:19 PM
  • Thanks Rabid Turkey! This worked great! Thats the best advice I ever recieved from a Turkey with Rabies.

    Monday, June 11, 2012 2:14 PM
  • Thanks Rabid Turkey,

    Such a simple answer and worked perfectly.

    Everyone vote as helpfull, Do all the MSFT moderators on this forum propose the wrong answers?
    I think James-Lou should return to the call center as thats an answer i'd expect from an ameture.

    Kudo's Rabid Turkey

    Friday, June 22, 2012 2:01 AM
  • I have seen this problem several times and the solution has always been to simply use the GAL rather than typing in the email address.  See http://www.urtech.ca/wp-admin/post.php?post=2913&action=edit&message=6

    I hope this helps!


    Ian Matthews www.urtech.ca www.commodore.ca

    Wednesday, July 11, 2012 2:23 AM
  • I am not trying to be mean here, but that is the worst answer and many people like me are tired of this.

    How is the product ever going to be fixed if the response is reinstall (overwrite everything). I believe this is why more and more and more glitches are not being repaired within Microsoft products.

    Whomever heads support at Microsoft: this should be a fire-able offense. The right answer would be changing permissions for an actual file, or fixing a registry entry, or discovering whatever is the true, real problem.

    Instead, there is some glitch that caused this problem, which will happen over and over, and it never gets identified and fixed within the actual Office product itself. Surprise, when another problem occurs and it gets left over as a problem in the product too, and then another.

    Not good here. I have now had problems cross versions (I.e. 2007-2010 Office) where profiles get corrupted and Excel won't open .xlsx files by double-clicking.) Yep, I have to create a new profile and migrate everything (a pain). It happens over and over.

    Why?

    This kind of horrid support.


    Wednesday, September 5, 2012 11:22 PM
  • This worked for me thanks!

    • Proposed as answer by ButlerTech Tuesday, September 25, 2012 7:21 PM
    Tuesday, September 25, 2012 2:05 PM
  •  Delete the offline address books from the user profile.  It worked for me.  The new users appeared in the GAL and I was able to share the calendar.

    Tuesday, September 25, 2012 7:26 PM
  • Thanks worked like a champ!

    Outlook 2007-Sharing sub contacts

    Tuesday, October 30, 2012 6:06 PM
  • Whilst your "work-around" may yield a short-term answer for many, it does not solve, nor does it escalate the issue with Microsoft.

    Kudos on the help, but Exchange/Outlook really is becoming crap. The simplest of tasks require hours of troubleshooting and console commands.

    A user really should be able to share there calendar.

    I am experiencing the very same errors with Outlook/exchange 2010 sharing a calendar with users on the network who already have permissions assigned. I have tried the suggestions regarding the GAL but it's not working for me.

    All i wanna do is share a calendar for ONE of my 900 users.

    Tuesday, May 21, 2013 8:43 AM
  • Hi, this worked for me. Thanks!
    Thursday, July 4, 2013 12:48 PM
  • Agreed! Its ridiculous to have to troubleshoot problems for hours on the simplest of tasks.

    Tuesday, August 27, 2013 2:25 PM
  • Sonny,

    Your answer was only correct one for my issue! Thank you!

    Thursday, August 29, 2013 7:08 PM
  • Just faced this issue, and thanks for the advise!

    chanwingkai

    Monday, September 23, 2013 9:41 AM
  • Your 5cents Works.. Thanks for sharing!!
    Tuesday, October 22, 2013 2:20 PM
  • This works quite nicely!  Helped immensely.  Thanks, TX DJ!
    Friday, February 7, 2014 6:13 PM
  • PERFECT, THX A LOT!!!
    Friday, March 7, 2014 8:50 AM
  • Thanks for this solution, it worked for me.
    Thursday, September 18, 2014 3:12 PM
  • This was exactly right and fixed my issue with a user today!  Thank you for these posts.

    Bob

    Thursday, December 4, 2014 11:55 PM
  • Thanks for the post Sonny, tried this while comparing two user accounts and immediately spotted the issue.

    -El Gaupo


    • Edited by El Guap0 Friday, December 5, 2014 8:16 PM
    Friday, December 5, 2014 8:16 PM
  • This worked!
    Thursday, March 12, 2015 1:46 PM
  • Sonny the Rabid Turkey, I have been wondering for months why I could not do this simple calendar share, and here is your simple and perfect answer from 6 years ago.  Thank you!!!  Why is it not marked as the best answer???
    Thursday, July 23, 2015 7:03 PM
  • Rabid Turkey - You are a freakin genius.  All the other stuff was way over my head and I didn't want to try it but this is so simple I did it and it worked!!!! Thank you for a simple solution!
    • Edited by bpierce55 Thursday, June 16, 2016 7:33 PM
    Thursday, June 16, 2016 7:31 PM