none
Error code 600 and 500 on autodiscover in Exchange 2010

    Question

  • Hi,

    I have a problem on Exchange 2010 Autodiscover, the error code 600 and 500, Please see below message and please help to fix this error.

    <?xml version="1.0" encoding="utf-8" ?>  

    - <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

    - <Response>

    - <Error Time="09:28:57.8739220" Id="2715916636">

      <ErrorCode>600</ErrorCode>

      <Message>Invalid Request</Message>

      <DebugData />

      </Error>

      </Response>

      </Autodiscover>

     

    Thanks,

    ShutMo

     

     

    Monday, August 15, 2011 8:35 AM

Answers

  • Hello

     

    Http 600 means autodiscover service works and can be accessed properly.

     

    You can use test email configuration to further confirm if the autodiscover can be accessed successfully.

     

    [Check AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    Do not worry about the error 600 code.

     

    Thanks,

    Simon

    Wednesday, August 17, 2011 7:22 AM
    Moderator
  • Thanks Simon for your help.

    The problem was solved. There was a miss configuration on the firewall.

     

    Regards,

    Robel

     

     

     

    Monday, August 22, 2011 6:25 AM
  • Thanks Simon for your help.

    The problem was solved. There was a miss configuration on the firewall.

     

    Regards,

    Robel

     

     

     

    Please mark as answer so that it will be closed
    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by ShutMo Tuesday, August 23, 2011 4:30 AM
    Monday, August 22, 2011 8:03 AM

All replies

  • Error 600 means there was something wrong with the Autodiscover request - for instance you'll usually see this when testing it in a browser. (Since you're doing HTTP GET and not POSTing any xml.) This does however indicate that the server itself is responding.

    Have you tested http://testexchangeconnectivity.com to see what it returns on the Autodiscover tests?

    Monday, August 15, 2011 9:09 AM
  • HI,

    Did you enable certificate for autodiscover URL. Can you go into outlook email test setting and fire a query for autodiscover, It will give you a clear error message. Is it have issue in internal and external both.

    For Error <ErrorCode>600</ErrorCode> ::

    http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/f2e62d15-7eb5-440e-b2a8-253ec63ac652/

    How to troubleshoot auto discover::

    http://msexchangeguru.com/2010/10/05/autodiscover/

    http://uc-technology.blogspot.com/2011/03/troubleshooting-for-autodiscover-in.html


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Monday, August 15, 2011 9:14 AM
  • Hi Gents,

     

    Thanks for the reply, will try the above and will update you later.

     

    Regards,

    ShutMo

    Monday, August 15, 2011 11:56 AM
  • Hello

     

    Http 600 means autodiscover service works and can be accessed properly.

     

    You can use test email configuration to further confirm if the autodiscover can be accessed successfully.

     

    [Check AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    Do not worry about the error 600 code.

     

    Thanks,

    Simon

    Wednesday, August 17, 2011 7:22 AM
    Moderator
  • Hi Gents,

     

    Thanks for the reply, will try the above and will update you later.

     

    Regards,

    ShutMo

    update please
    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 17, 2011 7:24 AM
  • Hi,

     

    The website https://host.abdomain.local/autodiscover/autodiscover.xml

    Shows the following error:

    <?xml version="1.0" encoding="utf-8" ?>

    <Autodiscover xmlns= "http://schemas.micosoft.com/exchange/autodiscover/responseschema/2006">

    <Response>

    <Error Time="09:28:57.8739220" Id="2715916636">

    <Errorcode>600</Errorcode>

    <Message>Invalid Request</Message>

    <DebugData/>

    </Error>

    </Response>

    </Autodiscover>

     

    Test Email Autoconfiguration

      

     

            

     <

    I have do "Test Email Autoconfiguration" and have the following log:

    Guessmart POP: server pop3.aadomain.com, port = 110, initializing

    Guessmart POP: server aadomain.com, port = 995, initializing

    Guessmart POP: server pop3.aadomain.com, port = 110, ssl=Yes, tls=No, spa=No, starting

    Guessmart POP: server aadomain.com, port = 110, initializing

    Guessmart POP: server aadomain.com, port = 995, ssl=Yes, tls=No, spa=No, starting

    Guessmart POP: server aadomain.com, port = 110, ssl=Yes, tls=No, spa=No, starting

    Attempting URL https://host.abdomain.local/Autodiscover/Autodiscover.xml found through SCP

    Autodiscover to https://host.abdomain.local/Autodiscover/Autodiscover.xml starting

    GetLastError=0; httpStatus=500

    Autodiscover request completed with http status code 500

    Autodiscover to https://host.abdomain.local/Autodiscover/Autodiscover.xml failed (0x80004005)

    Autodiscover to https://host.abdomain.local/Autodiscover/Autodiscover.xml starting

    Guessmart IMAP: server mail.aadomain.com, port=143, ssl=Yes, tls=No, spa=No, failed (0x800CC4005)

    Guessmart IMAP: server mail.aadomain.com, port=143, ssl=Yes, tls=No, spa=No, starting

    Guessmart POP: server pop.aadomain.com, port = 110, ssl=Yes, tls=No, spa=No, failed (0x800CCC1A)

    Guessmart IMAP: server imap.aadomain.com, port 143, ssl=Yes, tls=No, spa=No, failed (0x800CCC1A)

    Guessmart IMAP: server imap.aadomain.com, port 143, ssl=Yes, tls=No, spa=No, starting

    Guessmart POP: server pop.aadomain.com, port 110, ssl=Yes, tls=No, spa=Yes, starting

    then I received another failed.

     

    Please advise.

     

    Thanks,

     

    Shutmo

     

     

     

     

    Thursday, August 18, 2011 6:41 AM
  • Hi Shutmo,

    Now, the issue is that the IE can access autodisocver sucessfully and the issue is related to the Outlook client.

    Does this issue occur ot all the Outlook client?

    Please help to confirm, when you do the test email configuration, whehter the user name is the smtp email address or user priciple name. if it uses the user priciple name, you must update the Outlook client to fix this issue.

    Also check if there any proxy settings on the problematic client.

    Thanks,
    Simon

     

    Sunday, August 21, 2011 2:07 AM
    Moderator
  • Thanks Simon for your help.

    The problem was solved. There was a miss configuration on the firewall.

     

    Regards,

    Robel

     

     

     

    Monday, August 22, 2011 6:25 AM
  • Thanks Simon for your help.

    The problem was solved. There was a miss configuration on the firewall.

     

    Regards,

    Robel

     

     

     

    Please mark as answer so that it will be closed
    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by ShutMo Tuesday, August 23, 2011 4:30 AM
    Monday, August 22, 2011 8:03 AM
  • Hi Robel,

    I know this is a old thread, I would like to know how you solved this issue. I face the same issue. Thanks for your time to reply.

    Best regards

    Wednesday, February 04, 2015 7:03 AM
  • Hi..

    Check out the blog that i found while searching on internet

    http://www.blog.edbtopst.org/quick-way-to-fix-autodiscover-error-code-600-in-exchange.html

    Hope it will work for you

    Thanks

    Joe

    Tuesday, April 07, 2015 6:58 AM
  • AutoDiscoverError code 600 occurs if you have not configured the Autodicvoer property. This link may help you in resolving the issue: http://www.what-is.in/howto/fix-autodiscover-error-code-600-in-exchange.html

    Saturday, March 19, 2016 5:34 AM