locked
Exchange 2007 Installation Error please help! RRS feed

  • Question

  • I am setting up a 2007 exchange server on a 2003 std sp1 server. server is GC and domain controller.

    I've copied the entire dvd to my d: partition.

    I want to do a "default" installation but I get the following error

    Summary: 5 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:36


    Organization Preparation
    Failed

    Error:
    There was an error when executing 'ldifde.exe' to import schema file 'D:\Setup\ServerRoles\Common\Setup\Data\PostWindows2003_schema0.ldf'. Error code: 8206. More details can be found in the error file 'C:\Documents and Settings\Administrator.%domainname%\Local Settings\Temp\1\ldif.err'

    Elapsed Time: 00:00:36


    in the error file I have the following text:

    The server side error is "The FSMO role ownership could not be verified because its directory partition has not replicated successfully with atleast one replication partner."

    An error has occurred in the program

    Friday, February 16, 2007 10:05 AM

All replies

  • Please read the following Microsoft article. http://support.microsoft.com/kb/285172/EN-US/ 

    Schema Updates Require Write Access to Schema in Active Directory

    Wednesday, March 28, 2007 9:29 AM
  • The article found at http://support.microsoft.com/kb/285172/EN-US/  is for Windows 2000 Server, however my problem is with Windows Server 2003, and there is no "Schema may be modified on this Domain Controller"-check box.
    Thursday, June 28, 2007 5:12 PM
  • Hi,

     

    I had exactly the same error & it was solved by following this article:

    http://support.microsoft.com/kb/326262

     

    Have fun Smile

    • Proposed as answer by Tamouh Saturday, November 14, 2009 5:03 PM
    Saturday, June 30, 2007 6:04 PM
  • I doubt, that you had *exactly* the same error:

    This is the error that is really causing the problems:

    The server side error is "The FSMO role ownership could not be verified because its directory partition has not replicated successfully with atleast one replication partner."

    And that is exactly the problem: Previous Domain Controllers that were not gracefully demoted but simply deleted in "Active directory Users and Computers" still cause replication errors which I found out doing dcdiag.

    To completely get rid of those domain controller(s) that don't exist any more, go to "Active Directory Sites and Services" and delete them there under "Sites - <yoursitename> - Servers"

    After that (maybe i did a restart, i don't remember) dcdiag found no more replication errors and the Exchange 2007 preparation and installation worked without any further errors!

    • Proposed as answer by fbsamson Thursday, July 22, 2010 12:55 AM
    Thursday, July 5, 2007 9:54 PM
  • I get the same error when installing Exchange 2007. What is the solution please?

    Friday, February 15, 2008 4:05 AM
  • habnix, thaks for the great info. this worked for me.

    Sunday, February 24, 2008 10:36 PM
  • Hi all,,

    i came across the same problem..

    here what i have done..

    Windows 2003 R2 enviroment (32 bit)

    i had 2 domain controller one FSMO and another ADC with Exchange 2003 (SP2)

    then i introduced Windows 2008 Std x64 in the network ..(yes i did prepare the Active directory with ADPREP avaialable on 2008 media, (i ran it on FSMO (win 2003 R2 32 bit, without a fuss))

    My domain was already windows 200 native so no problem in that area too..

    then i transfer the FSMO role (all , schema, PDC, RID, Infrastructure, operation master)

    Then i manually deleted the OLD FSMO server from Site and services(on windows 2008)

    forced replication from Exchange box (using windows support tool> replmon)

    (cudn't figured out what is available in windows 2008-- any ideas??? )

     

    Then i tried to prepare the exchange box for Exchange 2007 SP1

    and i got those errors..

    now this what i did..

    went in to Exchange > AD Users & Computers >View > Advance Features

    Browse in the left container for System > File replication Service

    if you see the demoted server in the right container just right click and Delete the object.

    Apply above on every domain controller you got in place.

    Next is cleaning the DNS records..

    Open the DNS mmc..

    and Expand every entry in forward zone

    delete the entry corresponding to the OLD FSMO server.

    again repeat this on all Domain controller in place..

     

    Climax

    Just a restart of MS ADDS (windows 2008)

    run

    setup.com /prepareSchema (from Exchange2007SP1)

    runns smoothely.. no problems...

     

    PS: im migrating the windows domain controller from 2003 R2 (32bit) to 2008 std (64bit)

    And also migrating 2003 Exchange(32bit) to Exchange 2007 SP1 (64 bit)

    looks like im half way there..

     

    Hope this help....

     

     

    Monday, November 17, 2008 5:48 AM
  • you need install support tools ....
    Saturday, December 5, 2009 3:15 AM
  • great job habinx!
    Thursday, July 22, 2010 12:55 AM
  • Hi,

     

    well, you really sovled my problem.

    I didnt demote the second Dc and that was the issue i was not able to install exchange 2007.

    after deleting the way you told me from sites and services, not its working fine.

     

    thanks habnix . THANKS A MILLION :)

     

    Tuesday, December 28, 2010 4:51 PM
  • First of all you need to update your schema when updating to Exchange 2007. See http://technet.microsoft.com/en-us/library/aa995902%28EXCHG.80%29.aspx.

     

    Thursday, January 27, 2011 5:52 PM
  • I had the same problem,The FSMO role ownership could not be verified because its directory partition has not replicated successfully with atleast one replication partner." Network discovery was disabled, which prevented it from replicating and importing the schema.
    Tuesday, February 15, 2011 11:22 AM
  • Habnix

    Thanks for the solution, it worked for me too.


    Saturday, November 26, 2011 10:38 PM
  • to replicate manually go to command prompt and type repadmin /sycall

    Wednesday, February 19, 2014 1:54 AM