none
Event id 1310 source ASP.NET 4.0.30319.0

    Question

  • Hi I'm not sure what this error is or how to correct it:

    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 1/25/2013 11:56:33 AM
    Event time (UTC): 1/25/2013 5:56:33 PM
    Event ID: 62fce806f72c424d85b3548473ddc0f5
    Event sequence: 54
    Event occurrence: 11
    Event detail code: 0

    Application information:
        Application domain: /LM/W3SVC/1/ROOT-1-130034534090133488
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\
        Machine name: SERVER08

    Process information:
        Process ID: 4216
        Process name: w3wp.exe
        Account name: IIS APPPOOL\DefaultAppPool

    Exception information:
        Exception type: ConfigurationErrorsException
        Exception message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS. (C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\web.config line 37)
       at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName)
       at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)
       at System.Web.Configuration.RuntimeConfig.get_Identity()
       at System.Web.HttpContext.SetImpersonationEnabled()
       at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)



    Request information:
        Request URL: https://webmail.abcd.org:443/exchange/user/Inbox/?Cmd=contents&View=Messages&Page=1
        Request path: /exchange/user/Inbox/
        User host address: 50.77.35.41
        User:  
        Is authenticated: False
        Authentication Type:  
        Thread account name: IIS APPPOOL\DefaultAppPool

    Thread information:
        Thread ID: 2143
        Thread account name: IIS APPPOOL\DefaultAppPool
        Is impersonating: False
        Stack trace:    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName)
       at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)
       at System.Web.Configuration.RuntimeConfig.get_Identity()
       at System.Web.HttpContext.SetImpersonationEnabled()
       at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)


    Custom event details:

            
    Friday, January 25, 2013 7:04 PM

Answers

  • Hi

    This error indicates that the Exchange virtual directory in IIS is not an Application.  To correct this issue you should open the IIS Manager and expand the sites and the Default Web Site so that you can see the Exchange virtual directory.  Right click on it and select Convert to Application.

    Cheers


    Zi Feng
    TechNet Community Support

    Monday, January 28, 2013 8:25 AM
    Moderator
  • Hi,
    Is there any special reason why .Net Framework4 has been installed on your Server?

    Exchange 2010 does not use it so please make sure that it hasn't changed the .Net Framework version assigned on the application pools. If it has, then pls change it back to v2.0 as shown in the picture below.



    Martina Miskovic

    Monday, January 28, 2013 2:43 PM

All replies

  • "This error can be caused by a virtual directory not being configured as an application in IIS. (C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\web.config line 37)"

    Did something change in the OWA virtual directory or was an edit made to the web.config recently?  I pulled the above out of the log as a place to start looking.


    Jason Apt, Microsoft Certified Master | Exchange 2010 My Blog

    Friday, January 25, 2013 7:19 PM
  • I'm not sure.  We had a messy migration and there were changes made.  Most have been done through suggestions on this site.  As far as line 37, I opened the file and tabbed down to the 37th line and this is what I see:

           <authentication mode="Windows" />

    I'm assuming that's what's meant by line 37?

    Friday, January 25, 2013 7:34 PM
  • Hi

    This error indicates that the Exchange virtual directory in IIS is not an Application.  To correct this issue you should open the IIS Manager and expand the sites and the Default Web Site so that you can see the Exchange virtual directory.  Right click on it and select Convert to Application.

    Cheers


    Zi Feng
    TechNet Community Support

    Monday, January 28, 2013 8:25 AM
    Moderator
  • Hi,
    Is there any special reason why .Net Framework4 has been installed on your Server?

    Exchange 2010 does not use it so please make sure that it hasn't changed the .Net Framework version assigned on the application pools. If it has, then pls change it back to v2.0 as shown in the picture below.



    Martina Miskovic

    Monday, January 28, 2013 2:43 PM
  • Martina,

    I have been struggling with several other issues with Exchange server for a whole week.  I've read hundreds of posts, change multiple settings in IIS and Exchange and your .NET version assignment comment fixed almost all of my problems.  For some reason the Exchange Application Pools were set to v4.0.   I switched them back to v2.0 and I'm back into EMC and Out of Office Assistant works again.  Thank you for your post!


    Curtis

    Thursday, August 1, 2013 8:25 PM