none
Exchange 2010 Mailbox move is extremely slow

    Question

  • Hello,

    We are using Exchange 2010 with DAG in our organization.

    Now we are in the process of moving the database from Local drives to Storage and we have noticed that the mailbox movements are extremely slow. Both the source and target databases are part of DAG. Is it because of this? We have disabled forefront protection also, but no didn't help.

    Please tell me, is this the default behavior or can we do anything to improve the performance.

    Thanks and Regards,
    Sarath Kumar M

    Monday, May 03, 2010 2:45 AM

All replies

  • My personal experience is that mailbox moves are very quick, faster than any previous version.

     

     

    Monday, May 03, 2010 2:59 AM
    Moderator
  • Hello Andy,

    Can you please tell why i am facing this problem. The mailbox movement became a long taks for me. I guess it may take one week for me to move 700 users.

    Whether i need to change any configurations ?  Please helpe Me..

    Thnaks and Regards,

    Sarath Kumar

    Monday, May 03, 2010 3:04 AM
  • I just moved couple of thousands mailboxes last week, the average speed was 4 GB per hour, I have to say the old servers weer pretty old and I was moving from 2003, do you move slower than that?
    Regards, Mahmoud Magdy http://busbar.blogspot.com http://ingazat.wordpress.com
    Monday, May 03, 2010 5:01 AM
  • Hello,

    If it move at a speed of 4 Gb per hour i will be happy but for me it is taking more than one and half hour per GB . In worst cases it went upto 7:30 hours. Is there anything wrong with what i am doing?

    Regards,

    Sarath Kumar

    Monday, May 03, 2010 5:24 AM
  • for sure there are something wrong, did you try to isinteg on the database to make sure that it is healthy, also run perfmon and try to see if disks IOs are encountring errors and if they are performing correctly.

    also make sure the execlude the DB files and paths from file level AV


    Regards, Mahmoud Magdy http://busbar.blogspot.com http://ingazat.wordpress.com
    Monday, May 03, 2010 5:32 AM
  • Make these changes on all of your Windows 2008 servers - worked like a charm for us...we had a 3 Gig mailbox take 10 hours and 49 minutes to move, set these setting and we can move the same sized mailbox in under an hour now:

     

    netsh interface tcp show global      (check settings)

     

    netsh interface tcp set global autotuninglevel=disabled

    netsh int tcp set global chimney=disabled

    netsh int tcp set global rss=disabled

     

    reboot server and then check settings again

     

    should show disabled

     

    Tuesday, May 17, 2011 8:12 PM
  • netsh interface tcp show global      (check settings)

     

    netsh interface tcp set global autotuninglevel=disabled

    netsh int tcp set global chimney=disabled

    netsh int tcp set global rss=disabled

     

    reboot server and then check settings again

     

    should show disabled

     


    Hi Thor what are you actually doing by running these commands. I know it changes the configuration of the NIC. Which server will I run these commands on? The MBX server or the Client Access server? Also if the are two NIC's on the server (Client Access has both internal and external facing NIC) how do you make sure you are configuring the right one?

    But if you could let me know what exactly these commands do that would be great. Currently taking over 13hrs to move a 4GB mailbox in my Exchange org...


    Grove08
    Wednesday, July 27, 2011 7:10 AM