Name Autoresolution issue in Outlook 2003/2010


  • Hi,

    Environment details:
    Exchange 2003 3 node cluster on Win 2K3 servers.  AD Domain at 2003 functional level currently migrating to 2008 R2 functional level.

    Clients are Windows XP/Win 7 with Outlook 2003/2010.

    All clients have the same issue:
    When entering a name in the TO: field, autoresolution does not resolve the display name of some users.  When typing the display name and hitting CTRL+K or Check Names, a lot of users can't be found, even though the name is correct.  If I then hit 'Show more names' the users show up in the GAL ok.  Typing the first three characters ONLY resolves the name ok.  Typing the alias name works ok.  Problem is with resolving by display name.  Especially evident when adding a mailbox to Outlook, where you can't click 'Show more names.'  You have to type just the first three characters to get the full list of matching users.

    I am talking about resolving names from the GAL through AD, not using autocomplete in Contacts (remembered names).

    I created six new users at the same time across different mailbox stores and three of them resolve ok, but the other three don't.  I can't find any differing information within the first 15 characters of the display name and security is the same for both.  As above, entering only the first three characters of the display name resolves them, even with special characters and spaces.

    Tested in cached and non-cached mode, ensured the 'allow name resolution' (or whatever it is) is ticked in options, tried from multiple computers with new profiles.  All have the same result for the same users.

    I've searched everywhere and the only thing I found similar was this: http://www.pcreview.co.uk/forums/autocompletion-works-but-not-autoresolution-outlook-2002-a-t842773.html

    but no solution there.  The difference is that I can resolve most names in the GAL by hitting CTRL+K, just a seemingly random selection don't resolve.

    Friday, March 04, 2011 5:41 AM

All replies

  • Hi
       I also search the problem in our database. But I can’t find any reference article. You can’t tell the regulation of display name which can’t be solved.
       So the only possible reason is that the format of display name doesn’t match display name of AD account. Can you check the version of outlook or other reference of your client computer? Can you delete display name account and add the same account? Maybe it can solve your problem.

    • Proposed as answer by Terence YuModerator Thursday, March 10, 2011 8:43 AM
    • Marked as answer by Gavin-Zhang Friday, March 11, 2011 10:05 AM
    • Unmarked as answer by Blanna79 Thursday, March 24, 2011 1:36 AM
    • Unproposed as answer by Blanna79 Wednesday, March 30, 2011 5:20 AM
    Monday, March 07, 2011 3:05 AM
  • Hi
       Do you have anything to update your issue ?
    Wednesday, March 09, 2011 8:56 AM
  • Hi again,

    Sorry I've been working on other things and haven't checked here for a while.

    We still haven't resolved this.

    Strange thing is this works for over half of the mailboxes, but not all. If I type the first three characters of the display name it resolves the whole name fine in the resulting list, but type any more than three characters and it won't resolve, even in the list displayed.

    I created 6 mailboxes at the same time, all with a common name with different ending - i.e. ! Test mailbox one, ! Test mailbox two etc. - and three of the mailboxes resolve ok, but the other three only resolve if the first three characters are typed.

    Not sure if it's relevant, but all of these mailboxes are resource mailboxes which start with "! ", as above. So typing '! T' will resolve, but '! Te' will not.

    Thanks for your help

    Thursday, March 24, 2011 1:36 AM
  • Anyone?  Seems to be getting worse.  Is it possible the address book is corrupted and needs a rebuild?  And does this impact Exchange if it's run?
    Wednesday, March 30, 2011 5:21 AM
  • Has anyone experienced this?  It seems to be getting worse now and a lot of users are complaining of the problem.  Sometimes I can't even access a mailbox because the first three characters produce a list too long.
    Wednesday, April 06, 2011 12:24 AM
  • From the Home tab: Look for the Find group, click on the Address Book button.

    In the Address Book window: Click Tools, Options You can take it from there.

    Wednesday, April 06, 2011 7:45 PM
  • That's not where the problem is though.  It resolves the name fine in the address book.  It's when typing it into the To: field or in the Advanced settings -> Add mailbox section that it won't resolve.  Which in the latter, unfortunately you don't have the 'Show more names' option. 

    Actually had one the other day that couldn't resolve at all, and the only way it could be added to the mailbox in the end was to go to the GAL, open it from the list and click the Add to: Contacts option, then go back into the add mailbox section and it resolved fine from the contacts.
    Wednesday, April 13, 2011 1:25 AM
  • i am seeing this on one user. address book is fine, but CTRL+K in the to: field is only displaying users. so if i have a user named STS DBA and distribution list named STS Department and STS Infrastructure, and i type STS into the to: field, only sts dba shows up when i click ctrl+k. but (so far) this is only happening to one user, although i don't know how many of my users use or even know about ctrl+k.

    everything works fine for me.

    update: i just noticed that on the problem machine, when i click the "Show More Names," on the CTRL+K window, it opens a "Recipients" contact list instead of the Global Address List. every setting i can find in outlook is configured to use the GAL first, so i don't know how this is happening.

    Tuesday, February 05, 2013 4:21 PM