none
Mail routing with Partner Connector RRS feed

  • Question

  • I have a Hybrid setup with all mail using the on-prem gateway.

    I have added a connector in Exchange Online to send Journal emails to external partner organisation. This connector is set to be used for journal.domain.com

    The standard outbound connector is set for * domain

    I am receiving the following undeliverable reports:

    Your message:

       From:    mx12@datacom.co.nz

       Subject: Undeliverable Mail: "Todd"

    Could not be delivered because the domain name was unresolvable:

    Unable to resolve route journal.domain.com (MX) - *

    To me, this means it is using the normal route for * domain, as the undeliverable message came from out normal Smart Host and not the Smart Host on Journal Connector.

    I notice the normal outbound connector has a setting RouteAllMessagesViaOnPremises : True. Could this be the issue? I would think it should only affect the connector it is on?

    Friday, October 18, 2019 3:46 AM

Answers

  • If RouteAllMessagesViaOnPremises is set to true, you need to set up your connectors to journal.domain.com onprem, not in the cloud. With that set to true, all mail will go through the cloud to onprem connector regardless of whether other connectors have been set.

    The way I have it set is like this:

    Journal reports go to journal@mydomain.com. There is then a contact object onprem with an email address of journal@mydomain.com. This contact forwards email to journal@journal.domain.com. My onprem exchange environment points journal.domain.com to a smart-host owned by the journalling provider.

    • Marked as answer by techophil Wednesday, October 23, 2019 4:53 AM
    Monday, October 21, 2019 9:58 PM

All replies

  • I have a Hybrid setup with all mail using the on-prem gateway.

    I have added a connector in Exchange Online to send Journal emails to external partner organisation. This connector is set to be used for journal.domain.com

    The standard outbound connector is set for * domain

    I am receiving the following undeliverable reports:

    Your message:

       From:    mx12@datacom.co.nz

       Subject: Undeliverable Mail: "Todd"

    Could not be delivered because the domain name was unresolvable:

    Unable to resolve route journal.domain.com (MX) - *

    To me, this means it is using the normal route for * domain, as the undeliverable message came from out normal Smart Host and not the Smart Host on Journal Connector.

    I notice the normal outbound connector has a setting RouteAllMessagesViaOnPremises : True. Could this be the issue? I would think it should only affect the connector it is on?

    WHy is that domain unresolvable?
    Friday, October 18, 2019 10:37 AM
    Moderator
  • Hi

    That subdomain is not in DNS. That is why I know those messages are trying to go via the normal connector as it is our normal smart host (datacom.co.nz) rejecting it.

    You see all our external mail goes through the smart host (Datacom).

    Another connector has been made for all mail going to journal.domain.com via journal.smarthost.com smart host. This means that sub domain does not have to be resolvable.

    For some reason Exchange Online has not figured out it should use the second smart host for these messages. The Microsoft documentation says it will use the more specific route. When setting up and/or testing the connector, test messages go successfully, so the actual connector does work.

    I might try changing the setting RouteAllMessagesViaOnPremises : True, to False and test

    Friday, October 18, 2019 10:57 PM
  • Update:

    I tried changing the setting RouteAllMessagesViaOnPremises  from True, to False, but it appears I cannot do this as I got this error message: Connector validation failed: Recipient Domain cannot be set to * on an outbound connector of type OnPremises unless RouteAllMessagesViaOnPremises is set to true.  There must be something else forcing only the normal to be used.

    Saturday, October 19, 2019 9:03 PM
  • Update:

    I tried changing the setting RouteAllMessagesViaOnPremises  from True, to False, but it appears I cannot do this as I got this error message: Connector validation failed: Recipient Domain cannot be set to * on an outbound connector of type OnPremises unless RouteAllMessagesViaOnPremises is set to true.  There must be something else forcing only the normal to be used.

    Please also set the -ConnectorType to "Partner".

    Ensure that the connector services domains that are external to your organization.

    Get-OutboundConnector | fl Identity, ConnectorType

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, October 21, 2019 10:18 AM
    Moderator
  • Hi Manu

    It is already set as Partner connector. Here are the settings:

    RunspaceId                    : 2e2xxx-xxxx-xxxx

    Enabled                       : True

    UseMXRecord                   : False

    Comment                       :

    ConnectorType                 : Partner

    ConnectorSource               : AdminUI

    RecipientDomains              : {journal.domain.com}

    SmartHosts                    : {smtp-journal-1.domain.com}

    TlsDomain                     :

    TlsSettings                   : CertificateValidation

    IsTransportRuleScoped         : False

    RouteAllMessagesViaOnPremises : False

    CloudServicesMailEnabled      : False

    AllAcceptedDomains            : False

    TestMode                      : False

    LinkForModifiedConnector      : 00000000-0000-0000-0000-000000000000

    ValidationRecipients          : {journaling@journal.domain.com}

    IsValidated                   : True

    Monday, October 21, 2019 8:43 PM
  • Hi Manu

    It is already set as Partner connector. Here are the settings:

    RunspaceId                    : 2e2xxx-xxxx-xxxx

    Enabled                       : True

    UseMXRecord                   : False

    Comment                       :

    ConnectorType                 : Partner

    ConnectorSource               : AdminUI

    RecipientDomains              : {journal.domain.com}

    SmartHosts                    : {smtp-journal-1.domain.com}

    TlsDomain                     :

    TlsSettings                   : CertificateValidation

    IsTransportRuleScoped         : False

    RouteAllMessagesViaOnPremises : False

    CloudServicesMailEnabled      : False

    AllAcceptedDomains            : False

    TestMode                      : False

    LinkForModifiedConnector      : 00000000-0000-0000-0000-000000000000

    ValidationRecipients          : {journaling@journal.domain.com}

    IsValidated                   : True

    I'd open a ticket with 365 support
    Monday, October 21, 2019 9:28 PM
    Moderator
  • If RouteAllMessagesViaOnPremises is set to true, you need to set up your connectors to journal.domain.com onprem, not in the cloud. With that set to true, all mail will go through the cloud to onprem connector regardless of whether other connectors have been set.

    The way I have it set is like this:

    Journal reports go to journal@mydomain.com. There is then a contact object onprem with an email address of journal@mydomain.com. This contact forwards email to journal@journal.domain.com. My onprem exchange environment points journal.domain.com to a smart-host owned by the journalling provider.

    • Marked as answer by techophil Wednesday, October 23, 2019 4:53 AM
    Monday, October 21, 2019 9:58 PM
  • Ok, I will try that.

    It is confusing though, because you need a connector for {*} and when using * RouteAllMessagesViaOnPremises has to be True. Plus documentation says the more specific connector will be used.

    Monday, October 21, 2019 10:28 PM
  • I just went to create an opprem connector and chose Partner type, bit I cannot add smart host, it is greyed out. Is there another setting I have to do first?
    Monday, October 21, 2019 11:55 PM
  • Update:

    I found this MS article that explains the connectors on Exchange 2019 https://docs.microsoft.com/en-us/exchange/mail-flow/connectors/send-connectors?view=exchserver-2019

    It says to create the connector, then go back and change to use Smart Host

    Partner 35 MB When you create a Send connector of this usage type in the EAC, you can't select Route mail through smart hosts or a smart host authentication mechanism. After you create the connector, you can go to the Delivery tab in the properties of the Send connector and select Route mail through smart hosts and the smart host authentication mechanism

    I still don't have it getting to the Smart Host, but at least now the Journal messages are trying to use that connector. There is not a 'validate' link for the Partner Smart Host, or option to use TLS.

    Tuesday, October 22, 2019 4:43 AM
  • Update:

    I found this MS article that explains the connectors on Exchange 2019 https://docs.microsoft.com/en-us/exchange/mail-flow/connectors/send-connectors?view=exchserver-2019

    It says to create the connector, then go back and change to use Smart Host

    Partner 35 MB When you create a Send connector of this usage type in the EAC, you can't select Route mail through smart hosts or a smart host authentication mechanism. After you create the connector, you can go to the Delivery tab in the properties of the Send connector and select Route mail through smart hosts and the smart host authentication mechanism

    I still don't have it getting to the Smart Host, but at least now the Journal messages are trying to use that connector. There is not a 'validate' link for the Partner Smart Host, or option to use TLS.

    You could refer to the following link: 

    Create a Send connector to route outbound mail through a smart host

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, October 22, 2019 9:30 AM
    Moderator
  • Thanks. I have it working now by creating the Partner connector on-prem.

    The RouteAllMessagesViaOnPremises $True setting, means then that you can only ever have one working SendConnector in O365. It would be nice if you could add a partner connector. I wonder if that is a bug, oversight, or by design?

    It is working now anyway, albeit back through Hybrid.

    Thank you

    • Marked as answer by techophil Wednesday, October 23, 2019 4:52 AM
    • Unmarked as answer by techophil Wednesday, October 23, 2019 4:53 AM
    Wednesday, October 23, 2019 4:52 AM
  • There's actually a hidden, built in * send connector in Office 365. You need to have a * connector on-prem, but not in O365. If you don't have a * connector in O365, all internet bound mail will flow through MS's datacenter IPs to the Internet. If you do have one, you have to go through your onprem system to reach the Internet.
    Wednesday, October 23, 2019 10:25 PM
  • Ah, that makes sense and helps explain.

    Is this stuff documented anywhere? I have been searching for days...

    Thursday, October 24, 2019 8:18 AM
  • Ah, that makes sense and helps explain.

    Is this stuff documented anywhere? I have been searching for days...

    Alot of that is mentioned in different ways.

    Example:

    https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/use-connectors-to-configure-mail-flow/use-connectors-to-configure-mail-flow

    Look under the section:

    How connectors work with my on-premises email servers

    and there is a diagram of mail flow.

    In this example it states:

    When email is sent between Bob and Sun, no connector is needed.

    I'm sure there are more examples out there.

    Sunday, October 27, 2019 11:55 AM
    Moderator
  • Hi,

    Thanks, that is helpful.

    When asking about documentation, I was really more trying to find information about the 'hidden' O365 connector, and the RouteAllMessagesViaOnPremises $True setting effect when using Hybrid and setting up a Partner connector.

    I mean, I have worked it out now with your help, but in hindsight, what should I have been reading up first to find out this before trying to implement?

    Monday, October 28, 2019 8:19 PM