none
Cannot open your default e-mail folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost).

    Question

  • I've installed Exchange 2010 on Windows Server 2008 R2 and have the following result:

    1. Web Access Client working great.
    2. Attaching with a mobile device - works great.
    3. Trying to attach with outlook 2010 gives the following error:

    Cannot open your default e-mail folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost).

    I've tried numerous things with no change at all to the symptoms including:

    1. Deleted the ost file and all profiles and created a new profile.
    2. Made sure outlook always prompted for login. (*note - the login worked without error prior to the error above coming up.)

    It is important to note that when setting up the eMail account the "Check Name" function worked just fine.

    Please help!!!

    Friday, January 13, 2012 11:11 AM

Answers

  • go to DNS server  then...

    Match with the IP  and exchange server name.  my problem resolved :)

    ( I try 2 month ....)

    Saturday, February 04, 2012 1:11 AM

All replies

  • Have you tried setting up Outlook with Caching disabled.
    Regards Herbert Zimbizi
    Friday, January 13, 2012 11:28 AM
  • of course :)
    Friday, January 13, 2012 1:00 PM
  • Monday, January 16, 2012 6:09 AM
    Moderator
  • go to DNS server  then...

    Match with the IP  and exchange server name.  my problem resolved :)

    ( I try 2 month ....)

    Saturday, February 04, 2012 1:11 AM
  • since m using a test environment, I used /etc/hosts to configure route to the exchange server and it worked (thanks to Revolution Technolog's advice)
    Thursday, June 07, 2012 11:35 AM
  • Client: Windows 7 Outlook 2010
    Server: 2003, Outlook 2003 

    I've just spent over an hour diagnosing/troubleshooting this issue on one of my machines; what I finally found and resolved the issue was the following: http://support.microsoft.com/kb/842022

    Turns out a lot of people view this users calendar; he himself had undocked/redocked his laptop several times this morning and had "Download shared folders" checked in his outlook profile.  All of this culminated in him reaching/exceeding the maximum mapi connections to his mailbox.

    I actually came across the error in the system event log only because I was moving his mailbox to another store as part of another suggested fix I had found, I have now increased the mapi session registry value as described in kb 842022.  Although upon completion of the move the mailbox reconnected immediately, so I haven't restarted the mailbox store service yet.  So moving the mailbox 'fixes' the symptom but not the original cause.

    The combination of the above factors gave the error message you have listed above on a client machine, and the Event ID 9646 on the relevant server log.


    Although I don't think this is a fix for your issue, many people who search for the above error will find this page (as I did) and hopefully this will help them.

    Thursday, December 06, 2012 1:35 PM
  • This worked for me thank you!
    Monday, August 19, 2013 6:57 PM