none
RBS with SharePoint 2013 and SQL 2012 Almost Working RRS feed

  • Question

  • I am deploying a new Windows Server 2012 box with SharePoint Foundation 2013 and SQL Server 2012 Express.  I would like to get RBS working.  I have succesfully done this in the past with SPS 2010 and SQL 2008 but the 2013 / 2012 mix is giving me a bit of trouble.  Here is what has been done so far, all of these steps have worked.

    - Ran SQL queryies to provision the filestream

    - Installed the rbs.msi via the command prompt with correct instance name and database name

    - Used power shell to enable RBS for my content database

    This is a single server, single database setup.  When I execute the PowerShell command $rbss I do not get any errors, output says that rbs is enabled and the provder name is my new filtestream.  I can still upload documents to SharePoint.  However, none of the documents actually go to my d:\blobstore folder location that was provisioned in my sql queries.  I have not adjusted the default file size for rbs.  The instructions I followed were from here: http://technet.microsoft.com/en-us/library/ee748631.aspx

    Please let me know where I can start to look to resolve this issue, any input is helpful.  Thank you.



    Sunday, January 20, 2013 4:48 AM

All replies

  • Are you sure you ran the SQL commands on the content database you are uploading documents to?

    Monday, January 21, 2013 5:24 PM
  • Yes, and I confirmed the mssqlrbs tables are in the database.  Thx, let me know if you have any other ideas. 
    Monday, January 21, 2013 5:29 PM
  • The tables are created in the database when you run the RBS client library (RBS.msi). I am talking about the SQL queries to setup FILESTREAM on your content database. You need to run each query individually.

    Have you ensured FILESTREAM is enabled on the database server? You need to ensure that the FILESTREAM access level is set to 2 as well. To do this, open up a new query window and type in the following:

    EXEC sp_configure filestream_access_level, 2
    RECONFIGURE

    Run each statement individually.

    • Edited by hhancock Monday, January 21, 2013 5:51 PM
    Monday, January 21, 2013 5:41 PM
  • FILESTREAM is enabled (SQL Server Config Manager -> SQL Server Services -> SharePoint -> Properties ->FILESTREAM -> Enabled for Transact and I/O

    I ran three SQL queries in Management Studio, prior to installing RBS.msi, all completed successfully:

    use [WSS_Content]
    if not exists 
    (select * from sys.symmetric_keys 
    where name = N'##MS_DatabaseMasterKey##')
    create master key encryption by password = N'Admin Key Password !2#4'
    use [WSS_Content]
    if not exists 
    (select groupname from sysfilegroups 
    where groupname=N'RBSFilestreamProvider')
    alter database [WSS_Content]
    add filegroup RBSFilestreamProvider contains filestream
    use [WSS_Content] 
    alter database [WSS_Content]
     add file (name = RBSFilestreamFile, filename = 
    'D:\SPS_RBS') 
    to filegroup RBSFilestreamProvider

    I have also double checked that my content database is actually WSS_Content.

    Thank you for your help, please let me know what else I shoudl be checking.  Thx.

    Monday, January 21, 2013 5:52 PM
  • Did you run the command for setting the FILESTREAM access level?
    Monday, January 21, 2013 5:55 PM
  • Hmmmm..... probably not, since I don't know what that command would be... care to share?
    Monday, January 21, 2013 5:57 PM
  • You need to run this in a new SQL query window. You don't have to run this on a specific database. Run this command at the root level.

    EXEC sp_configure filestream_access_level, 2
    RECONFIGURE

    Monday, January 21, 2013 6:00 PM
  • Done, but actually I think I did already to that.  This was my output:

    Configuration option 'filestream access level' changed from 2 to 2. Run the RECONFIGURE statement to install.


    Monday, January 21, 2013 6:02 PM
  • You need to run RECONIFGURE again to reconfigure for FILESTREAM.
    Monday, January 21, 2013 6:07 PM
  • Done.  Uploaded a 2 MB PDF, no change to my SPS_RBS folder.
    Monday, January 21, 2013 6:14 PM
  • Sounds to me like the content database isn't configured for RBS properly. Are you scripting out the configuration of your web application and site collection? Ensure that the web application and/or your site collection is using the WSS_Content content database.


    • Edited by hhancock Monday, January 21, 2013 8:32 PM
    Monday, January 21, 2013 8:32 PM
  • I've checked to ensure my web app and site collection is using the WSS_Content database (actually, I only have one content database).  I'm using SharePoint's PowerShell to enable RBS on the Content Database with these commands:

    $cdb = Get-SPContentDatabase WSS_Content
    $rbss = $cdb.RemoteBlobStorageSettings
    $rbss.Installed()
    $rbss.Enable()
    $rbss.SetActiveProviderName($rbss.GetProviderNames()[0])
    $rbss

    $rbss.Installed() returns true.  $rbss returns Enalbed = True, Active Provder = My FileStream, Minimum Blob Storage = 0, and Upgraded Properties = {}

    Let me know if you have any other ideas.  Thank you again for your help.

    Monday, January 21, 2013 8:38 PM
  • Try setting up RBS/FILESTREAM on a new content database and see if you are experiencing the same issue.
    Wednesday, January 23, 2013 5:24 PM
  • I thought about doing that, but didn't want to break things further.  The first time I did the instsall the rbs.msi install command had database specific arguments in it.  I assume I can run the install command again with the new arguments and all will be well?  Or is there another preferred way of configuring rbs.msi for another content database?  Just wanted to double check.  Thx.
    Wednesday, January 23, 2013 5:29 PM
  • Have you checked the RBS.msi log file to ensure that the RBS client library was installed successfully? I assume so because you said that the RBS tables appeared in your content database.

    As for adding additional content database, you will need to run the new command. It's very similar to the first one. Refer to the guide for specifics.

    Wednesday, January 23, 2013 5:32 PM
  • Thank you.  Yes, the first msi installed correctly, log file was good, over 1 MB which I believe is a good indication of it being successfuly, couldn't find any errors or failures in it.  I'll give the additional content database a try and let you know.  Thanks again.
    Wednesday, January 23, 2013 5:35 PM
  • Not sure how applicable this will be to your situation, but check out:

    http://support.microsoft.com/kb/2767183


    SharePoint - Nauplius Applications
    Microsoft SharePoint Server MVP
    MCITP: SharePoint Administrator 2010

    -----------------------
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, January 25, 2013 6:09 AM
    Moderator
  • Hi Kenyon,

    Have you tried to migrate the content to see if there are any errors? In the Application, Security, or System Event logs?

    $rbs=(Get-SPContentDatabase WSS_Content).RemoteBlobStorageSettings
    
    $rbs.Migrate()
    

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.

    Friday, January 25, 2013 8:13 AM
  • Hi Kenyon, 

    Please let me know if you still need assistance or close this ticket if your questions were answered as it stays open in my profile...

     

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.

    Friday, February 1, 2013 11:00 AM
  • Hi Kenyon, 

    Please let me know if you still need assistance or lets close the discussion if your questions were answered, if you need further assistance please let us know...

     

    -Ivan


    Ivan Sanders My LinkedIn , My Blog, @iasanders, BI in SP2013, SP2013 Content Packs.

    Friday, February 8, 2013 7:12 AM
  • I haven't had any success and think I'm just giving up on it.  The migrate command did not help.  The second content database behaved the same way.  Hotfix didn't help.  Everything looks like it should work, but it doesn't.  I'll probably wait six months and rebuild the server then.  Go ahead and close the discussion, but know the issue hasn't been resolved.  Thanks for all the input.
    Friday, February 8, 2013 3:43 PM
  • Hi, I have exactly the same problem completely. The same installation procedure, everything is OK. but still no folder BLOB data. :-(

    still no idea?

    Thanks Jan

    Wednesday, September 11, 2013 2:50 PM
  • Hi Jan, I gave up, never could get it to work.  I ended up splitting their content into multiple content databases / sharepoint sites to get around things.  Not my ideal solution, but better than the bruises from banging my head against the wall.  Good luck, and if you ever figure something out please post it back so I can try it out too.  Thx.
    Wednesday, September 11, 2013 3:52 PM
  • Hi Ivan,

    I have the same issue. I don't think you should close this just because Kenyon gave up.

    Maybe somebody finally will help us.

    Thanks

    Tuesday, May 20, 2014 3:01 AM
  • Yes, we still need assistance.

    Thanks

    Tuesday, May 20, 2014 3:03 AM
  • More diagnostic information from your end would help, e.g. RBS MSI install log with verbose logging enabled.

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, May 20, 2014 3:04 AM
    Moderator
  • Hey Trevor,

    whats up?

    Your right, the issue is its easy to setup and configure. Most of the issues I have seen is FileStream has not been configured via sql iso prior to installing the SharePoint configuration. Most people for some reason think this is all you need to do.

    To be more specific please provide the SQL Installation log from when FileStream Support was added, and we can go there if you have SQL FileStream Installed

    clip_image001 clip_image002 clip_image003 clip_image004 clip_image006 clip_image008


    -Ivan

    Tuesday, May 20, 2014 3:31 AM
  • If I follow this guide to the letter it works every time for me:

    http://www.adventuresinsharepoint.co.uk/index.php/2013/10/05/enable-filestream-and-provision-a-remote-blob-store/

    Get SQL setup first, then run the RBS.MSI on the SharePoint server, ensuring the parameters specified match those configured in SQL.

    If you experience permissions issues, this may help:

    http://www.adventuresinsharepoint.co.uk/index.php/2014/05/03/sorry-something-went-wrong-error-after-enabling-rbs-remote-blob-storage/

    • Edited by Dai Webb Tuesday, May 20, 2014 6:58 AM
    Tuesday, May 20, 2014 6:53 AM
  • Hi,Myself I've installed and configure RBS (correctly) in Sharepoint 2013 but doesn't work.
    It didn't put any file in File System (BLOB Storage). The rights seems to be ok.
    Any idea why?
    Other people seems to have the same issue:
    http://social.technet.microsoft.com/Forums/exchange/en-US/e279451f-fe02-4e9f-8e97-30290bdbdc35/rbs-with-sharepoint-2013-and-sql-2012-almost-working?prof=required
    Thanks
    Grig
    Tuesday, May 20, 2014 3:35 PM
  • Have you checked your Shredded storage 'shred size'? By default all items larger than 64kb are shredded down to that size. That means that if RBS has been set to 1MB then it'll never see a file large enough to externalise.
    Tuesday, May 20, 2014 3:40 PM
  • Hi,

    Thank you for your message.

    The size is 1048576 = 1M

    I've put all kind of size until 1.5G.

    The WebApplication identity has rights to write also in the content DB also in this BLOB folder. 

    $rbss = $cdb.RemoteBlobStorageSettings

    $rbss

    Enabled ActiveProviderName  MinimumBlobStorageS UpgradedPersistedPr

                                                ize operties

    ------- ------------------  ------------------- -------------------

       True FilestreamProvid...             1048576 {}

    So everything seems to be ok but is not putting the file in BLOB folder ( store).

    Thanks

    Grig

    Tuesday, May 20, 2014 10:05 PM
  • In my evaluation environment at home is working.

    At work it doesn't!

    The only differences are: at work I have Office Web apps  for SharePoint installed and configured and I didn't do it for the main content DB (wss_content), it is a different content DB.

    Anybody succeed to installed and configured the RBS in similar situation?

    Thanks

    Grig

    Wednesday, May 21, 2014 3:37 AM
  • How large are the BLOBs in your home environment and what SQL version are you using in both environments?

    Edit: Also what do you want RBS to do and what do you think it does? In 2013 it's mostly a waste of effort.

    • Edited by Alex Brassington Wednesday, May 21, 2014 10:22 PM
    • Proposed as answer by grigb Thursday, May 22, 2014 2:47 AM
    Wednesday, May 21, 2014 10:21 PM
  • Hi,

    It doesn't matter the size. I'm just testing and using all kind of size above the threshold set it for RBS and is working.

    I'm doing the same at work and it doesn't. The only différences are: at work I'm using OWA and is not for the main wws_content.

    Do you think it could be related?

    Thanks

    Thursday, May 22, 2014 2:54 AM
  • Nope, that's why i ignored those aspects and asked questions about areas that might be relevant.

    If it works in one environment and not the other the most likely reason is that you made a mistake in one environment but not the other or there's a deeper underlying difference.

    Are you using the same version of SQL at home and how large are the externalised BLOBs at home? Are the entire files making it through unshredded?

    Thursday, May 22, 2014 8:17 AM
  • Often overlooked is that SQL Server Enterprise Edition is a pre-requisite and SQL Server Standard Edition often used as a default SharePoint install.

    Gavin

    Tuesday, October 28, 2014 12:58 AM
  • Same thing happened to me. After a lot of headache, all i did was to give the account running my application pool (in my case, sp_service) a dbowner permission in the database and it started working. Dropping in the right folder.
    Thursday, April 23, 2015 8:36 AM
  • I spend 3 days on fixing this issue as well:

    * Do not EVER use $rbss.Disable() on your content database, this will make your ContentDatabase unusable when deinstalling/installing the RBS feature. This causes your DB to become unusable for further RBS-implementations

    Glad I tried this in Test-environment first. 

    Other things I also came through:

    * Run RBS.msi as admin and in CommandLine

    * Assign DBO-permission to the Application Pool account

    * Assign the following database role membership to the Content Database for the Pool account: 

    db_rbs_admin (this will also apply the db_rbs_filestream_maintainer_1/Reader_1/writer_1 roles)

    => This is not documented ANYWHERE on the web. 

    Tuesday, January 12, 2016 10:12 AM
  • Hello guys,

    We have configured the RSB following the TechNet guide but unfortunately we don't know how to resolve this issue.

    When a file is uploaded into a library, it is not stored in the blob location, only a subfolder is created in the blob folder but without the file, the size doesn't get increased.

    We have tried all the suggestions found in this thread and in other communities but...nothing.

    Is anybody able to help us with the resolution of this issue?

    Thanks a lot

    Regards,

    Walter

    Wednesday, March 2, 2016 1:35 PM
  • Before you go any further; why are you using RBS?
    Wednesday, March 2, 2016 2:10 PM
  • Any updates in this thread?

    I am facing the same issue.

    To Alex: I want to use BLOB to speed up the performance with large objects!

    Monday, October 10, 2016 11:53 AM