none
[WinServer2012]Failed to add a task: The requested operation was made in the context of a transaction that is no longer active. RRS feed

  • Question

  • Hi,

    I got an error when adding a task.

    ---------------------------------------------------------------------------------------------------------------

      C:\Users\Administrator>SCHTASKS /create /sc HOURLY /TN "TaskA" /TR "C:\TaskA.exe" /ST 11:40

      The requested operation was made in the context of a transaction that is no longer active.
    ---------------------------------------------------------------------------------------------------------------

    I checked the event viewer and found this.

    ---------------------------------------------------------------------------------------------------------------

    Log Name:         System

    Source:           Microsoft-Windows-Kernel-Tm

    Date:            2019/11/21 11:24:18

    Event ID:       1

    Task Category:      None

    Level:           Warning

    Keywords:         

    User:          SYSTEM

    Computer:       

    Description:

    The Transaction (UOW={e8aa4f0d-0bfd-11ea-80ed-f4e63afc5e6e}, Description='RegisterTask{F4E33CD7-BA2E-4A4D-9A31-E772CF09F1A1}') was unable to be committed, and instead rolled back; this was due to an error message returned by CLFS while attempting to write a Prepare or Commit record for the Transaction.  The CLFS error returned was: 0xC0000061.

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-Kernel-Tm" Guid="{4CEC9C95-A65F-4591-B5C4-30100E51D870}" />

        <EventID>1</EventID>

        <Version>0</Version>

        <Level>3</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x8000000000000000</Keywords>

        <TimeCreated SystemTime="2019-11-21T02:24:18.311543200Z" />

        <EventRecordID>328488</EventRecordID>

        <Correlation />

        <Execution ProcessID="836" ThreadID="352" />

        <Channel>System</Channel>

        <Computer>tokyo-ecs-spc</Computer>

        <Security UserID="S-1-5-18" />

      </System>

      <EventData>

        <Data Name="TxUow">{E8AA4F0D-0BFD-11EA-80ED-F4E63AFC5E6E}</Data>

        <Data Name="TxDescriptionLength">50</Data>

        <Data Name="TxDescription">RegisterTask{F4E33CD7-BA2E-4A4D-9A31-E772CF09F1A1}</Data>

        <Data Name="ClfsStatus">0xc0000061</Data>

      </EventData>

    </Event>

    ---------------------------------------------------------------------------------------------------------------

    Tried [sfc /scannow] and [restart] ,but nothing changed.

    Kindly help!

    <audio controls="controls" style="display:none;"></audio>
    Thursday, November 21, 2019 2:43 AM

All replies

  • Hi, 

    Did you run other batch file through task scheduler at the same time? 

    Please see the official article about same error code with yours.

    Task Scheduler task fails if running at the same time as the DiskPart command

    Please check if the issue persists when add task scheduler through GUI.

    Go to Settings\Update&Security\Windows update to download and install the latest package and check the issue again.

    Bests,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 22, 2019 8:38 AM