none
Outlook time out setting

    Question

  • I'm having an issue with my netscaler and RPC connections. One of the issues is that when i click TO: on new emails to pul up GAL i would get exchange not available. if i close it and open it again it works fine. i don't get disconected as far as the entire outlook client goes

     Long story short after some t-shooting i changed my hosts entry to go straight to one of CAS servers (bypassing VIP). I didn't have that issue in 4 days that i was testing. We created a test VIP and were playing with timeout settings. If i would increase time out on Netscaler to 2 hours i would get that issue every time i click TO:. We decreased it to 20 min and i also went ahead and put in  a registry setting on my workstation for KeepAliveTime for TCP/IP to 5 min. while leaving Netscaler time out to 20 min. Been testing for 2 days. I had this issue occur to me twice yesterday and once today. To me it seems like i need to match time outs properly between outlook and netscaler to make it work.

    So my question is Are there any other time outs that can be modified? It works perfectly fine when Outlook speaks directly to CAS's servers. So i'm just trying to match those times on netscaler at this point

    Wednesday, June 20, 2012 4:55 PM

All replies

  • Nothing specific, contact the vendor and ask them, I'm sure they have seen this. I saw similar issues on with Cisco, and we had ours set to 15 mins.

    Sukh

    Wednesday, June 20, 2012 5:13 PM
  • i talked to them before and they couldn't give anything concrete.

    I did set time out to 15 min and will try my luck with citrix on monday

    Saturday, June 23, 2012 3:25 AM
  • Any new on this issue? We are having the same problem.

    Are you changing the persistence time out or the client and server timeout on the service group?

    • Edited by EmilHa Thursday, June 28, 2012 1:24 PM
    Thursday, June 28, 2012 1:22 PM
  • not yet.

    According to Netscaler that setting has to be set to 150 min.

    It didn't work for us.It was pretty bad at 2 hour time outs.

    Like i said no issues when Netscaler is not involved.

    So we created a test VIP and i modified my host file so my outlook uses that VIP.

    and we just adjusting settings to see if we can tweak it

    Thursday, June 28, 2012 1:26 PM
  • So have you set static ports for RPC. and are you doing Cached Mode vs Online mode for you outlook client? I am assuming online mode based on the behaviour you are describing. And do you have individual rules for RPC or did they have you setup a wild card for RPC.

    Mitch Roberson MCM Exchange 2010|MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003

    Thursday, June 28, 2012 3:43 PM
  • I didn't limit RPC ports. Our 2 netscalers don't have anything else configured, so i figured for a HNLB it won't be a lot of stress.

    I have a mix of Online and cached. However it happens to both.

    We have a wildcard as far as ports go setup on a netscaler for RPC VIP. We separated our RPC vip from our OWA, EWS VIP. That one is only limited to port 80 and 443

    Thursday, June 28, 2012 3:52 PM
  • So cached clients should be polling the GAL from a local copy of the OAB. Since you say this is experienced on both cached and non-cached machines I am lead to believe that there is a problem on 443 with ews and OAB virtual directory setups on the LB. Could be wrong but this seems to lead that way. does the client receive the OAB. and have you check to see if out of office works as well and free busy?

    Mitch Roberson MCM Exchange 2010|MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003

    Thursday, June 28, 2012 4:24 PM
  • OAB is working, in fact i just put a few people in exchange and they already on my GAL (i'm in cached mode)

    Free/Busy is working although it seems sometimes it takes a little longer to download. Mostly for our shared calendars. I had an issue today that when i opened shared calendars it took over a minute to display information. I was opening about 5 at the same time

    OOF is woking fine

    Thursday, June 28, 2012 4:41 PM
  • I have used 2 hours for most if not all of my LB configs and have not had a problem nor have i had to set anything in the client. what is your affinity set to for RPC and are you using outlook anywhere for these clients?

    Mitch Roberson MCM Exchange 2010|MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003

    Thursday, June 28, 2012 4:48 PM
  • right now we have

    Server Persistence: 20 Minutes.

    Client Idle Timeout:  900 Seconds

    We did try 2 hours however we noticed that the issue was more prevalent.

    With these settings above i'm getting the issue twice a day. We switched to 15 min time out on our test VIP, however i haven't notice a lot of difference between 20 and 15 min time outs.

    We do have outlook anywhere enabled. All of this is happening on the internal network, so i assume that outlook will try to connect through RPC FQDN that is pointing to vip and if that is not resolved it points to our webmail.domain.com for outlook anywhere


    • Edited by Halo-NEXT Thursday, June 28, 2012 4:58 PM
    Thursday, June 28, 2012 4:57 PM
  • Any news?
    Friday, June 29, 2012 12:13 PM
  • We seem to have the exact same problem. Followed the Citrix guide on how to configure the netscaler, but still have the same issues as TS describes. Is there any news on this issue?
    Thursday, February 14, 2013 5:46 PM
  • Did anyone get anywhere with this?  We have 2x MBX and 2x combined CAS/HUB servers sitting behind Netscalers and we experience the exact same problem with GAL and free/busy - everything else works fine.  Whether the client is Cached or Online (Citrix) it randomly pops up that the connection to exchange is unavailable.  Come out and click TO again and it works.  Happens at random.  I also notice the same symptoms with Free/Busy information sometimes and when you go back into Outlook it works again.

    I have raised a call with MS and they have asked me to put in the TCP/IP KeepAliveTime of 4 minutes on each CAS server and reboot them as a first step.  I am not confident this will fix the problem but is a first step requested by Microsoft.


    • Edited by Douggly Wednesday, July 17, 2013 1:47 AM Updated
    Wednesday, July 17, 2013 1:29 AM
  • We seem to have the exact same problem. Followed the Citrix guide on how to configure the netscaler, but still have the same issues as described. Is there any news on this issue?
    Tuesday, November 05, 2013 2:18 PM
  • We had Citrix fix this issue for us in the end. I believe they 'solved' it by disabling ssl offloading and configuring the lb vserver as SSL_BRIDGE. 

    You might want to try this. Let me know if it works for you as well.

    Tuesday, November 05, 2013 4:38 PM
  • I've had similar issues but our Netscaler only balances the web traffic. RPC connections for Directory (address book) were getting reset. I did add the KeepAliveTime entries to the CAS servers which solved the issue. The "Directory" connection for Address Book is done through 2010 by proxy to the DC. In 2007, the client connects direct to the DC but not in 2010. In our case the 2010 CAS connection to the DC was getting reset. Try putting the KeepAlives on the CAS servers.
    • Edited by Geezberry Tuesday, November 05, 2013 4:59 PM
    Tuesday, November 05, 2013 4:57 PM