none
Sorting by categories in Outlook makes items in a folder disappear

    Question

  • When running Outlook in online mode, if I click on the Categories column heading to sort by Categories and then click it again to sort it in the ascending order, the items in the folder disappear and Outlook states "There are no items to show in this view."

    This only happens in online mode, no problems when using cached mode, and it only happens with mailboxes that are on Exchange 2010. If I connect the same client to a mailbox hosted on Exchange 2007 I don't have the problem.

    The servers are running Exchange 2010 RU4 and I can reproduce this with Outlook 2010 and 2007 (haven't tried 2003).

    Tuesday, July 27, 2010 5:19 PM

Answers

  • Update (5/11/2014):
    A KB article was published on this issue, it is:

    Folder views are not updated when you arrange by categories in Outlook after you apply Exchange Server 2010 Service Pack 3 Update Rollup 3 or Update Rollup 4
    http://support.microsoft.com/kb/2925273

    Please contact Microsoft Support (1-800-Microsoft) to obtain fixes (Interim Update or IU) for E2010 SP3 RU4 and RU5. There will be no fix for E2010 SP3 RU#, those customers will have to upgrade to later builds.

    --------------------------------------------------- 

    This is a known issue at this moment and Microsoft is working to investigate it. Currently there is no ETA on fix. I will update the post when we have more details. You can always contact Microsoft Support (1-800-Microsoft) to report this issue or get more details.

    Users of any version of Outlook may experience this issue while connecting to Exchange 2010. Usually its experienced working with Public Folders, but you can also see this while working with your own mailbox in 'Online Mode' or working with someone else's shared mailbox in your Outlook while working in 'Cached Mode' in Outlook.

    The workaround is to reverse the sorting order, may be one or a few times and all messages will re-appear in that folder.


    Sr. Program Manager, Product Quality, Exchange Client Access Server
    Monday, January 31, 2011 11:54 PM
    Moderator

All replies

  • Hi Abhi Jalan

     

    Please check the setting whether the outlook has open the filter option in view setting.

     

    Outlook 2010>View> View settings>Advanced View Settings: Messages>Sort None>Filter Off>

     

    Thanks


    Your expertise never fails to impress!
    Wednesday, July 28, 2010 6:10 AM
  • I checked and the filter is set to off. Can anyone else using Exchange 2010 reproduce this?
    Wednesday, July 28, 2010 12:40 PM
  • Please share with us

    • Is this problem happen to different pc, different user as well
    • did you try re-create a new profile to test (you do not need to delete existing profile or change setting, because new profile do not have previous cache)

    MT | MCITP ----- Please vote helpful or mark as answer if it's answered your question, this help us follow up the question status.
    Thursday, July 29, 2010 5:51 AM
  • So far it happens on at least 5 different PCs, each running under a different user account. Basically any machine I test on, I can reproduce the problem. If I create a new profile, it still happens as long as I uncheck cached mode when creating the profile. 
    Thursday, July 29, 2010 1:00 PM
  • We have the same problem.Running Outlook 2010, 2007 and exchange 2010 . Happens to TS sessions and non TS sessions.  Like Abhi, this happens when I click on the Categories column heading to sort by Categories and then click it again to sort it in the ascending order, the items in the folder disappear and Outlook states "There are no items to show in this view."No other columns show this behavior. 

     

    Found a solution: In outlook, slect View>Grouping>"standard settings for show/hide", select "expand all". Then select this view for all folders.

    • Proposed as answer by Pyromanen Wednesday, December 15, 2010 8:24 AM
    Wednesday, December 15, 2010 8:13 AM
  • Update (5/11/2014):
    A KB article was published on this issue, it is:

    Folder views are not updated when you arrange by categories in Outlook after you apply Exchange Server 2010 Service Pack 3 Update Rollup 3 or Update Rollup 4
    http://support.microsoft.com/kb/2925273

    Please contact Microsoft Support (1-800-Microsoft) to obtain fixes (Interim Update or IU) for E2010 SP3 RU4 and RU5. There will be no fix for E2010 SP3 RU#, those customers will have to upgrade to later builds.

    --------------------------------------------------- 

    This is a known issue at this moment and Microsoft is working to investigate it. Currently there is no ETA on fix. I will update the post when we have more details. You can always contact Microsoft Support (1-800-Microsoft) to report this issue or get more details.

    Users of any version of Outlook may experience this issue while connecting to Exchange 2010. Usually its experienced working with Public Folders, but you can also see this while working with your own mailbox in 'Online Mode' or working with someone else's shared mailbox in your Outlook while working in 'Cached Mode' in Outlook.

    The workaround is to reverse the sorting order, may be one or a few times and all messages will re-appear in that folder.


    Sr. Program Manager, Product Quality, Exchange Client Access Server
    Monday, January 31, 2011 11:54 PM
    Moderator
  • Has anything been released to fix this issue other than this workaround? It's starting to become annoying to explain to the users that they need to keep resorting in order to see their email.

    Tuesday, March 1, 2011 2:38 PM
  • I'm having this same issue, well very similar. I've seen it with 3 different users now. They look at a subfolder within their inbox and its empty, when there is indeed emails. If right click and hit sort, then by received. They all reappear. It seems like an issue if the folder is set to organize by "From".

    Running outlook 2007-2010 and exchange 2010. Both outlook versions have the issue and are in online mode.

    Thursday, March 3, 2011 10:15 PM
  • Hello

    does the rollup 3 can resolve this issue ?

    thanks

     

    Monday, March 14, 2011 3:49 PM
  • No I don't believe so.  We have seen this issue.  I logged a call with MS who have provided us with an interim fix, this is avaialbe if you are on SP1 RU2 or RU3.  The fix is due in SP1 RU4 which is scheduled for a May release

    Hope this helps.

    Thursday, March 17, 2011 11:14 PM
  • I have a client who has the same issue if the folder is set to organise by "From" as well.  Using Outlook 2010 on Server 2008 R2 for a XenApp 6 environment.  It doesn't seem to happen every time though - it seems random.
    Wednesday, April 13, 2011 2:36 AM
  • Hey Matt.  We had the same IM but it did not fix the problem.  We still get the issue.  We have been told that it may be a while before it is fixed.
    Monday, May 23, 2011 2:59 AM
  • Hi Nash,

    We still have not installed the interim fix because we have had no further reports of the issue.  I'm not surprised though, as we've only just expanded our Pilot group for Exchange 2010.  So I cannot confirm that this fix resolves the issue.

    Sorry

    It's May now, so maybe RU4 isn't far away?

    Monday, May 23, 2011 3:41 AM
  • Well this was serendipitous. Having this exact problem and was just about to post about it. Now I know I need to wait.

    Neill

    Monday, May 23, 2011 8:07 AM
  • Any updates to this yet? It's been almost a year since the innitial report of the problem.
    Wednesday, July 6, 2011 3:12 PM
  • Hi

    same problem here. RU4 changed nothing.

    Exchange 2010 SP1 RU4 (migrate from 5.5 => 2000 => 2007 => 2010). 1 server with all roles including UM.

    Office 2007 (with all update) online mode (terminal server 2003).

     

    No problem when cached mode is used (office 2007 or 2010).

     

    Thanks

    Wednesday, July 6, 2011 3:19 PM
  • Old problem, but I got this issue today (and on all my computer)

    I run outlook 2007 and exchange 2010 (SBS 2011)

    Is this problem have a fix ?

    Thks for your help

    Friday, March 29, 2013 1:57 PM
  • When will this be fixed? 
    Monday, May 12, 2014 2:36 AM