locked
Send-MailMessage returns The server response was: 4.3.2 Service not available

    Question

  • Dear Microsoft Support;

    We have implemented a MS Exchange 2010 server on windows 2008 R2. Every thing is fine so far so good.

    Now it's time to set the welcome message to the newly created mailbox user. I couldn't get it to work due to the fact I have an error when using the command Send-MailMessage.

    Logged as Domain Admin

    Command launched from MS Exchange server:

    Send-MailMessage -From "user@local.domain" -To "user@local.domain" -SmtpSer
    ver "exchange_server.local.domain" -Body "Test sending email via Powershell" -Subject "Test Send Email from Powershell"

    Full Error Message:
    Send-MailMessage : Service not available, closing transmission channel. The server response was: 4.3.2 Service not available
    At line:1 char:17
    + Send-MailMessage <<<<  -From "user@local.domain" -To "user@local.domain" -SmtpServer "exchange_server.pasteur-kh.org
    " -Body "Test sending email via Powershell" -Subject "Test Send Email from Powershell"
        + CategoryInfo          : InvalidOperation: (System.Net.Mail.SmtpClient:SmtpClient) [Send-MailMessage], SmtpExcept
       ion
        + FullyQualifiedErrorId : SmtpException,Microsoft.PowerShell.Commands.SendMailMessage

    2 Receive Connectors: Client and Default. Default is exchange server name with allow anonymous access.

    Steps already done:

    Disable internal Firwall: no help
    test with -credentail and username domain admin : NOK
    Services looks OK:
    email sent from gmail to MS Exchange : OK
    replied : OK
    tested with our Postfix mail relay but it should work locally. I use the command on the server.
    Changed to localhost: server not happy wants a FQDN
    Tested IP Address: same error message
    Same message with telnet send from my desk computer.

    Any idea? Which information do you need more?

    Thanks in advance

    Monday, November 5, 2012 4:08 AM

Answers

  • Solved: Added my server IP Address to the field "Receive mail from remote server that have this IP Address"
    • Marked as answer by gametorus Monday, November 5, 2012 5:17 AM
    Monday, November 5, 2012 5:17 AM

All replies

  • Solved: Added my server IP Address to the field "Receive mail from remote server that have this IP Address"
    • Marked as answer by gametorus Monday, November 5, 2012 5:17 AM
    Monday, November 5, 2012 5:17 AM
  • In Exchange 2010, do the following:

    1. Open Exchange Management Console.
    2. Expand Server Configuration.
    3. Click Hub Transport.
    4. In the Receive Connectors pane, add a New Receive Connector for your server.
    Tuesday, February 18, 2014 5:14 PM
  • It works for me, buy any idea why start to happen this if it was working before?

    Thanks

    Tuesday, March 14, 2017 9:29 PM