none
Creating a DAG

    Question

  • Hello,

    I am trying to create a DAG, and popularte it with two mailbox servers.
    When I run New-DatabaseAvailabilityGroup -Name DAG -FileshareWitnessShare '\\HUB\DAG' -FileShasreWitneddDirectory 'C:\DAG', new DAG is being created.
    However, the whitness share is not being created, and I cannot add memeber servers to the DAG.

    Help?
    Thursday, April 16, 2009 5:35 PM

Answers

  • Use the Local PowerShell icon and then rerun the command. There is a known issue in the beta build with remote PowerShell and executing that command.
    Microsoft Exchange MVP | http://exchangeexchange.com
    • Proposed as answer by Erik Szewczyk Thursday, April 16, 2009 5:43 PM
    • Marked as answer by Anatoly Ivanov Thursday, April 16, 2009 5:50 PM
    Thursday, April 16, 2009 5:37 PM
  • To expound on Henrik's reply:
    We'll delete the File Share Witness resource when you go to an odd number of machines (1,3,5, etc.), and add it back when going to an an even number.
    We do not delete the File Share itself (\\hub\dag) when going to the odd number. Only the cluster resource. You can look in cluadmin if you're curious, but there should be no need to open cluadmin anymore.

    -martin
    Legal Stuff: This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 16, 2009 8:05 PM

All replies

  • Use the Local PowerShell icon and then rerun the command. There is a known issue in the beta build with remote PowerShell and executing that command.
    Microsoft Exchange MVP | http://exchangeexchange.com
    • Proposed as answer by Erik Szewczyk Thursday, April 16, 2009 5:43 PM
    • Marked as answer by Anatoly Ivanov Thursday, April 16, 2009 5:50 PM
    Thursday, April 16, 2009 5:37 PM
  • Thanks, it worked (not the New-Dag part, but Add-DagServer)
    And FS whitenss is only created when you add the second node to the DAG.

    You rule!
    Thursday, April 16, 2009 5:49 PM
  • The FSW won't be created before you reach an even number of MBX servers in the DAG, so what you see in regards to the FSW share is also expected behaviour.


    Henrik Walther Exchange MVP | MCM: E2K7 | MCITP: EMA/EA | MCSE: M+S - MSExchange.org
    Thursday, April 16, 2009 7:15 PM
  • To expound on Henrik's reply:
    We'll delete the File Share Witness resource when you go to an odd number of machines (1,3,5, etc.), and add it back when going to an an even number.
    We do not delete the File Share itself (\\hub\dag) when going to the odd number. Only the cluster resource. You can look in cluadmin if you're curious, but there should be no need to open cluadmin anymore.

    -martin
    Legal Stuff: This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 16, 2009 8:05 PM
  • Hello Guys,

    just a question,

    is there is a relation between this behaviour and the cluster no. of node is this means that when using the odd No. the Exchange is using node majority in the background and then when using even no. it's changing the quruom type to file share witness.

    or what is the theory behind the deletion and recreation of this file share witness.

    regarding your main descussion my case was like that :

    i had 2 servers in my lab each one of them have Mailbox,cas and hub.

    when i tryied to create a DAG it gave me this error message

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:02
    
    EXCHANGE
    Failed
    
    Error:
    Insufficient permissions to view the network shares on machine 'dc'. Error code 5.
    
    Warning:
    The operation wasn't successful because an error was encountered. More details may be found in log file "C:\Windows\TEMP\dagtask_2009-04-17_18-49-24_add-databaseavailabiltygroupserver.log".
    
    
    Exchange Management Shell command attempted:
    Add-DatabaseAvailabilityGroupServer -Identity 'Test-DAG' -MailboxServer 'EXCHANGE'
    
    Elapsed Time: 00:00:02
    when i used same shell comand EMC was tried to execute in the local shell it's wonderfully goes ok and added the servers to the dag.

    Thanks
    Alaa Elmahdy
    Friday, April 17, 2009 7:28 PM
  • >>>is there is a relation between this behaviour and the cluster no. of node is this means that when using the odd No. the Exchange is using node majority in the background and then when using even no. it's changing the quruom type to file share witness.

    Yes, that's correct.

    In the Beta build, you can not use the GUI or remote powershell for adding and removing servers from a DAG. You must use Local Powershell. You'll get errors like ACCESS_DENIED (which is what '5' means, it may also show up as 0x80070005 or -2147024891). Sorry for the inconvenience.

    -martin


    Legal Stuff: This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, April 17, 2009 7:34 PM
  • Thanks Martin ,

    the concept is clear now .
    Friday, April 17, 2009 7:36 PM
  • just as a clarification if some one read this descussion,this will proof the concept of the file share more and more.

    http://technet.microsoft.com/en-us/library/dd298065(EXCHG.140).aspx

    Friday, April 17, 2009 8:33 PM
  • Well, I am facing same issue. And i am not able to add second node.

    Error is "AddClusterNode Failed with 1460".

    What can be issue?

    -Vikram
    Thursday, April 23, 2009 12:44 AM
  • Hi Vikram,

    you will need to add the second server from the local power shell

    you can follow this article http://technet.microsoft.com/en-us/library/dd298049(EXCHG.140).aspx

    which descripe how to add a server to the availability Group.

    Thursday, April 23, 2009 4:49 AM
  • I am using local power shell for creating DAG and adding DAG too.

    Still not successful in doing so.

    Error is "Cluster common transient Exception. Add Cluster node failed at 1460."

    I though it might be related to fire wall issue but thats not the case.

    Anyone has faced this issue before.?

    -Vikram
    Thursday, April 23, 2009 5:36 PM
  • So you get this error when you add the first MBX to the DAG?

    Did you install the WFC component prior to adding the MBX server to the DAG? If not you might want to try this.


    Henrik Walther Exchange MVP | MCM: E2K7 | MCITP: EMA/EA | MCSE: M+S - MSExchange.org
    Thursday, April 23, 2009 5:55 PM
  • Henrik, 

    I am able to add first MBX but not second MBX.

    Well, Sorry I am not aware what is WFC component. Is it Win Foundation Class..??? Where can i get WFC component?

    Thanks.
    -Vikram
    Thursday, April 23, 2009 6:20 PM
  • He was referring to the Windows Failover Clustering feature. Computer people have way too many overlapping acronyms!


    Joel Stidley | Microsoft Exchange MVP | http://exchangeexchange.com
    Thursday, April 23, 2009 6:22 PM
  • Yes sorry the Windows Failover Cluster component.

    Also try to add the second MBX to the DAG from the console of the second MBX server, if this isn't already the case.


    Henrik Walther Exchange MVP | MCM: E2K7 | MCITP: EMA/EA | MCSE: M+S - MSExchange.org
    Thursday, April 23, 2009 6:26 PM
  • I have installed Windows Failover Cluster component before.

    Also, i tried adding second MBX through local powershell....but that doesnt seem to work some how.

    Not able to exactly find out where I went wrong in previous steps. Well these are commands I fired.



    New-DatabaseAvailabilityGroup -Name DAG3 -FileShareWitnessShare \\MIT2\DAG3FSW -FileShareWitnessDirectory C:\DAG3DIR (Success)

    Add-DatabaseAvailabilityGroupServer -Identity DAG3 -MailboxServer MIT3 (Success)

    Add-DatabaseAvailabilityGroupServer -Identity DAG3 -MailboxServer MIT4 (Failed)



    Also,I am able to ping DAG from all server.

    Thanks,
    -Vikram

    Thursday, April 23, 2009 6:32 PM
  • 1460 is ERROR_TIMEOUT.

    Easy things to try. Run the following command (in local powershell) on MIT4, and if that fails, try it again on MIT3:
    Add-DatabaseAvailabilityGroupServer -Identity DAG3 -MailboxServer MIT4

    If that still fails, then remove Failover-Clustering (using servermanagercmd.exe or servermanager.msc), and reinstall it. You'll probably have to reboot in between.
    That has worked for a few people. (There was a problem with the configuration of the netft driver that Failover Clustering uses.)

    It may also help if the addition fails with 1062 (ERROR_SERVICE_NOT_ACTIVE).

    Other people reading this thread -- don't go around removing and adding failover-clustering on a whim. It rarely solves the problem. I'm only aware of it it helping for the two specific error codes listed here, and even then I'm not sure it always helps.

    -martin
    Legal Stuff: This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 23, 2009 7:34 PM
  • Hi All,

    I don't belive that reinstalling the failover cluster will solve the proplem because actually what time out means miss communication.

    I think you need to diagonos your network or your antiviruse software and disable the firewall and try again.

    It happened before with some one and the cause was in his case that his symantec end point client is blocking the connection.

    If you are using crossover cables and only one network card in each server check the cable 

    If you are using crossover cable and two network cards check both of them you don't know which one may be defected.

    wish that helps.

    thanks
    Alaa Elmahdy
    Thursday, April 23, 2009 9:11 PM
  • I have disabled firewall and all antivirus software. Also, Re-installing Failover cluster didnt worked for me.

    I guess, I need to check Network card and would let you know status.

    Guys, I really appreciate all your suggestions.

    Thanks.




    Thursday, April 23, 2009 9:53 PM
  • the thanks is for you for the share.

    will wait to know your feed back.
    Thursday, April 23, 2009 9:55 PM
  • Did you deploy the Exchange 2010 MBX servers in a Hyper-V based test environment?


    Henrik Walther | MVP: Exchange | MCM: Exchange 2007 | MSExchange.org
    Friday, April 24, 2009 6:22 AM
  • Yes Henrik, I did deployed in hyper-v based enviornment. 

    I was not sure what was issue with that system.

    I restore snapshots of VM from last 3 days and started again.

    Good thing that it worked without any issue and bad part was I couldnt find out what was an issue before.

    -Vikram
    Friday, April 24, 2009 5:12 PM
  • Congratulation Vikram.

    Henrik please let us know if there is any issue on testing the Exchange 2010 MBX servers in a Hyper-V based test environment.

    i know that it's not recommended to do it in Exchange 2007 but i thought this limitation removed with the enhancements of the ESE and i/o

    also for me it worked like a sharm.

    wish to know from you Henrik.
    Friday, April 24, 2009 5:22 PM
  • Running the E2K10 MBX roles as well as the other roles (except UM) on Hyper-V is fully supported. The reason why I asked Vikram about this question was because of a rare bug revolving around WFC when adding MBX servers to the DAG.


    Henrik Walther | MVP: Exchange | MCM: Exchange 2007 | MSExchange.org
    Friday, April 24, 2009 7:23 PM
  • I have 1 server 2K8DC (Hub, CAS,DC) , 2 mailbox server role EX1, EX2. EX1 and EX2 was installed Failover clustering feature by manually. All of them were installed in VMWARE 6.5 (windows 2008 Enterprise SP2)

    I used Local Poweshell at EX1 to run command

    New-DatabaseAvailabilityGroup -Name DAG1 -FileShareWitnessShare \\2K8DC\DAG1 -FileShareWitnessDirectory C:\DAG1 (success but there is no folder DAG1 in DC)

    Add-DatabaseAvailabilityGroupServer -Identity DAG1 -MailboxServer EX1 -DatabaseAvailabilityGroupIpAddresses 192.168.1.50 (success)
    Add-DatabaseAvailabilityGroupServer -Identity DAG1 -MailboxServer EX2 (failed)


    WARNING: The operation wasn't successful because an error was encountered. More
     details may be found in log file
    "C:\Users\Administrator\AppData\Local\Temp\dagtask_2009-06-17_08-53-25_add-data
    baseavailabiltygroupserver.log".
    Add-DatabaseAvailabilityGroupServer : Cluster common transient exception: AddCl
    usterNode failed with -2147024891, MaxPercentage=12.
    At line:1 char:36
    + Add-DatabaseAvailabilityGroupServer <<<<  -Identity DAG1 -MailboxServer EX2
        + CategoryInfo          : InvalidArgument: (:) [Add-DatabaseAvailabilityGr
       oupServer], ClusCommonTransientException
        + FullyQualifiedErrorId : 85A07DFE,Microsoft.Exchange.Management.SystemCon
       figurationTasks.AddDatabaseAvailabilityGroupServer

    I checked the log file

    WriteError! Exception = Microsoft.Exchange.Cluster.Replay.ClusCommonTransientException: Cluster common transient exception: AddClusterNode failed with -2147024891, MaxPercentage=12. ---> System.ComponentModel.Win32Exception: AddClusterNode failed.
       --- End of inner exception stack trace ---

    I re-installed  Failover clustering feature on EX2, it's not work
    Wednesday, June 17, 2009 9:01 AM
  • If the node was added to the Dag in the AD (check Get-DatabaseAvailabilityGroup) but not added to the cluster you can add it to the windows failover cluster yourself. Of course if you do that you miss out on the FSW being configured, so run Add-DagMember again and see if it adds the FSW to the cluster.
    Wednesday, June 17, 2009 4:36 PM
  • [PS] C:\Windows\System32>Get-DatabaseAvailabilityGroup

    Name             Member Servers                  Operational Servers
    ----             --------------                  -------------------
    DAG1             {EX1}

    Then by manually, I used Windows Failover Cluster at EX1 to add the node at EX2. I got the report

    Validate Cluster Network Configuration  Failed
    Validate Network Communication Canceled
    List All Disks Failed
    List Potential Cluster Disks Canceled
    Validate Disk Access Latency Canceled
    Validate Disk Arbitration Canceled
    Validate Disk Failover Canceled
    Validate File System Canceled
    Validate Microsoft MPIO-based disks Canceled
    Validate Multiple Arbitration Canceled
    Validate SCSI device Vital Product Data (VPD) Canceled
    Validate SCSI-3 Persistent Reservation Canceled
    Validate Simultaneous Failover Canceled

    and anything else were success
    The server 'EX2.abc.local' could not be added to the cluster. An error occurred while adding node 'EX2.abc.local' to cluster 'DAG1'. Access is denied.

    Thursday, June 18, 2009 4:25 PM
  • Hi there,

    I am also experiencing issues creating a DAG.  Have two mailbox servers, one hub all running under HyperV.  The New-DatabaseAvailibiltyGroup works ok, but second command from EMC or Local Powershell I get this:

    [PS] C:\Windows\System32>Set-DatabaseAvailabilityGroup -Identity "DAG2" -Network
    Encryption "InterSubnetOnly" -NetworkCompression "InterSubnetOnly"
    WARNING: The command completed successfully but no settings of 'DAG2' have been
     modified.

    When trying to add mailbox server:

    [PS] C:\Windows\System32>Add-DatabaseAvailabilityGroupServer -Identity DAG2 -Mai
    lboxServer vw2k8ex10-1
    WARNING: An unexpected error has occurred and a Watson dump is being generated:
     Object reference not set to an instance of an object.
    Add-DatabaseAvailabilityGroupServer : Object reference not set to an instance o
    f an object.
    At line:1 char:36
    + Add-DatabaseAvailabilityGroupServer <<<<  -Identity DAG2 -MailboxServer vw2k8
    ex10-1
        + CategoryInfo          : NotSpecified: (:) [Add-DatabaseAvailabilityGroup
       Server], NullReferenceException
        + FullyQualifiedErrorId : System.NullReferenceException,Microsoft.Exchange
       .Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer

    Have installed Failover Cluster feature.  Switched off Firewall on all servers.  No A/V running on them.

    Couldn't start Failover Cluster service.  So re-installed it.  Any thoughts?  I am using Admin account with Enterprise Admin permissions.  Many thanks in advance.
    • Proposed as answer by suthuc Tuesday, June 30, 2009 2:19 AM
    Saturday, June 27, 2009 12:59 PM
  • I tried to do that on the virtual machine with VMWARE. It's also not work. Maybe in Exchange 2010 beta ,this feature cannot use on the virtual machine. I think so
    Tuesday, June 30, 2009 2:21 AM
  • Hello Suthuc,

    Thanks for the info - it would be a shame if we cannot test DAG in a virtual environment?  
    Did you manage to get this working on physical servers?

    I also found some info about disabling IPv6 and disabling "Admin Audit Agent", here:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8112d707-c11f-4a2f-a880-f6b04f7dcf82

    I tried these and still the same problem.

    The logs show this:

    add-databaseavailabiltygroupserver started on machine VW2K8EX10-2.
    [2009-06-30T09:48:13] add-dagserver started
    [2009-06-30T09:48:13] commandline:         $scriptCmd = {& $wrappedCmd @PSBoundParameters }

    [2009-06-30T09:48:13] Option 'Identity' = 'DAG1'.
    [2009-06-30T09:48:13] Option 'MailboxServer' = 'VW2K8EX10-2'.
    [2009-06-30T09:48:13] Option 'DatabaseAvailabilityGroupIpAddresses' = ''.
    [2009-06-30T09:48:13] Option 'WhatIf' = ''.
    [2009-06-30T09:48:13] Updated Progress 'Working' 2%.
    [2009-06-30T09:48:13] Validating the parameters.
    [2009-06-30T09:48:13] LogClussvcState: clussvc is Stopped on VW2K8EX10-2. Exception (if any) = none
    [2009-06-30T09:48:13] Looking up IP addresses for DAG1.
    [2009-06-30T09:48:16] Failure while trying to resolve DAG1: threw a SocketException: System.Net.Sockets.SocketException: No such host is known
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostEntry(String hostNameOrAddress)
       at Microsoft.Exchange.Cluster.Replay.DagTaskHelper.LogMachineIpAddresses(HaTaskOutputHelper output, String machineName).
    [2009-06-30T09:48:16] Looking up IP addresses for VW2K8EX10-2.
    [2009-06-30T09:48:16]   VW2K8EX10-2 = [ 10.21.2.120, ::1 ].
    [2009-06-30T09:48:16] DAG DAG1 has 0 servers:
    [2009-06-30T09:48:16] Updated Progress 'Working' 4%.
    [2009-06-30T09:48:16] Checking if Mailbox server 'VW2K8EX10-2' is in a database availability group.
    [2009-06-30T09:48:16] GetRemoteCluster() for the mailbox server failed possibly with error 194187999, ex = Microsoft.Exchange.Cluster.Replay.ClusCommonNonRetryableTransientException: Cluster common transient exception: Unable to communicate with the Cluster service or the RPC service. Error: There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9) ---> System.Runtime.InteropServices.COMException (0x800706D9): There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
       at Interop.MSClusterLib.ClusterClass.Open(String bstrClusterName)
       at Microsoft.Exchange.Common.Cluster.Cluster.OpenInternal(String[] OrderedListOfNetworkNames)
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Common.Cluster.ExceptionHelper.HandleRetryExceptions(Exception e, Int32& count, Boolean dbAccess, Cluster cluster, Nullable`1 sleepIntervalMilliSecs)
       at Microsoft.Exchange.Common.Cluster.Cluster.OpenInternal(String[] OrderedListOfNetworkNames)
       at Microsoft.Exchange.Common.Cluster.Cluster.GetRemoteCluster(String[] OrderedListOfNetworkNames)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.FindClusterForDag(). This is OK.
    [2009-06-30T09:48:16] The new server (VW2K8EX10-2) is not a member of a cluster, nor are the other servers (if there are any other servers).
    [2009-06-30T09:48:16] The computer account DAG1 does not exist.
    [2009-06-30T09:48:16] According to GetNodeClusterState(), the server VW2K8EX10-2 is ClusterStateNotRunning.

    Should I be doing something to configure Failover Clustering first?  The feature is installed on both boxes.  Many thanks.

    Tuesday, June 30, 2009 9:55 AM
  • Hutton,

    I'm not sure why you were getting the NullReferenceException before.

    In regards to the log, everything you highlighted is expected when there are no servers yet in the DAG. Once the DAG is formed, then there will be a cluster named 'dag1' and it will have an IP address and a computer account. What does the rest of the log say?

    -martin
    Legal Stuff: This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, July 3, 2009 11:01 PM
  • Hi Martin,

    Thanks for your reply, we've deciced to rebuild our test environment as we can see some strange behaviour with EX03.  Will post back once we have competed this work. 

    Hutton.
    Tuesday, July 7, 2009 1:45 PM
  • Hi there,

    Stripped out Exchange from test environment and reinstalled EX03/EX10.  Tried creating DAG and got the same results.

    Before resorting to wiping whole test domain did a bit more diging around.  We have 2003 and 2008 DC in the domain, so decided to try switching off 2008 DC (out of desperation!) and hey presto it works.  After we saw there were replication issues between the DCs so that may be the cause.  Thanks for your help.  Hutton.
    • Proposed as answer by suthuc Thursday, July 16, 2009 6:06 PM
    Wednesday, July 8, 2009 12:38 PM
  • I can use DAG in Hyper-V environment. But when I remove DAG and try again, it's not working. ......"watson dump"..... That's is Exchange 2010 beta. It does not work smoothly
    Thursday, July 16, 2009 6:11 PM
  • Hi Hutton,

    Might be I will be very late to reply your problem's answer but It will be help you create a new DAG on your Exchange Server 2010. What error you have received, same error I also received today when I was creating the DAG.

    I didn't do too much change, but you have to make sure you switch off the Firewall and failover cluster should be installed.

    When I received this error, I thought It will failover cluster problem. I had already installed the failover cluster while installing my mailbox server. I checked the failover cluster services (services.msc) and I do noticed that failover cluster service was disabled on my both mailbox server. I enabled it as startup type "automatic" and try to start this services, but unfortunately I couldn't start. But failover cluster service was on startup Type ="Automatic start" mode.

    I again try to install the DAG member servers through Local Power Shell Command and I received the error and I couldn't add the member servers in DAG.

    Then I think again, what I had major changed in my server. Then I noticed that I had tried to start the Failover Cluster Service on server but I was not able. But have change the settings of startup type of service was "Automatic". So I have again "Disable" the Failover Cluster Startup Type to "Disable".

    Now again I tried to add the member server in the DAG, and it was successfully created. After that I add the Database Copy of all my Database though Exchange Management Console and Power Shell, I am successfully created.

    I hope it will help you.

    Thanks
    Shambhu Sharma

    Tuesday, July 21, 2009 7:02 AM
  • Hi Hutton,

    Might be I will be very late to reply your problem's answer but It will be help you create a new DAG on your Exchange Server 2010. What error you have received, same error I also received today when I was creating the DAG.

    I didn't do too much change, but you have to make sure you switch off the Firewall and failover cluster should be installed.

    When I received this error, I thought It will failover cluster problem. I had already installed the failover cluster while installing my mailbox server. I checked the failover cluster services (services.msc) and I do noticed that failover cluster service was disabled on my both mailbox server. I enabled it as startup type "automatic" and try to start this services, but unfortunately I couldn't start. But failover cluster service was on startup Type ="Automatic start" mode.

    I again try to install the DAG member servers through Local Power Shell Command and I received the error and I couldn't add the member servers in DAG.

    Then I think again, what I had major changed in my server. Then I noticed that I had tried to start the Failover Cluster Service on server but I was not able. But have change the settings of startup type of service was "Automatic". So I have again "Disable" the Failover Cluster Startup Type to "Disable".

    Now again I tried to add the member server in the DAG, and it was successfully created. After that I add the Database Copy of all my Database though Exchange Management Console and Power Shell, I am successfully created.

    I hope it will help you.

    Thanks
    Shambhu Sharma

    Tuesday, July 21, 2009 7:02 AM

  • Hello , I know this problem ,

    but all u need to working clear ,, remove shared folder and local folder   "FileshareWitnessShare '\\HUB\DAG' -FileShasreWitneddDirectory 'C:\DAG "

    remove the old "DAG" ,

    restarting your server

    recreate the new "DAG" and use Local Power sheel

    add-DatabaseAvailabilityGroupServer –Identity “Database Availability Groups name” –Mailboxserver “serverNode”

    it will working fine



    loves,

    Mory

    Tuesday, July 28, 2009 2:52 PM
  • This is my lab step by step  "DAG in Exchange server 2010 beta" http://thuc.nhatnghe.vn/ex2010-dag/
    I want to share to everyone
    Wednesday, July 29, 2009 1:30 AM
  • Dear Friends,

    Please help me to fix the below problem:

    Environment:
    Exchange version on all Exchange boxes: Exchange Server 2010 - Enterprise Edition
    DC - Windows Server 2008 R2
    2 Servers - HUB / CAS + NLB + CAS ARRAY
    2 Servers - Mailbox (DAG MEMBERS)

    Today when I looked at my DAG "NAME RESOURCE" in Failover Cluster Manager, so I found that the FCM was giving red notificatino for error, that CLUSTER NAME RESOURCE (MISDAG.ABC.COM) is not coming online, becuase the "IP ADDRESS RESOURCE" is missing from the FCM.

    Kindly tell me how can I recreate the IP ADDRESS RESOURCE in FAILOVER CLUSTER MANAGER of WINDOWS SERVER 2008 R2 - EXCHANGE 2010 MAILBOX DAG SERVERS.

    My Exchange Enviornment is working fine, but I have to bring the DAG NAME RESOURCE ONLINE, becuase my BACKUPEXEC 2010 needs this IP+NAME Resource online to start taking DAG DATABASES backup.

    Looking forward for your prompt response.

    Zahir Hussain Shah
    zahirjajee@hotmail.com


    Zahir Hussain Shah MCP, MCSE, MCTIP Enterprise Admini, CCNA, ITIL Senior Infrastructure Consultant zhshah@live.com United Arab Emirates
    Tuesday, May 4, 2010 4:24 PM