locked
MSExchangeFBPublish Event ID 8197

    Question

  • Hi,

     

    I currently have a coëxistant exchange 2003 / 2007 situtation. The 2007 ogranisation consists out of two CAS, two HT and two stand-alone enterprise mailbox servers. On the first mailbox server I've created a Public folder Store (by hand) and I've set-up replication between the 2003 organisation and 2007 (free-busy info).

     

    Al seems well exept for the following error i keep getting every 25 minutes on my second mailbox server:

     

    Event Type: Error
    Event Source: MSExchangeFBPublish
    Event Category: General
    Event ID: 8197
    Date:  15-9-2008
    Time:  15:21:50
    User:  N/A
    Computer: MBX02
    Description:
    Error initializing session for virtual machine ANMAILMBX02. The error number is 0x80040111. Make sure Microsoft Exchange Store is running. Also, make sure that there is a valid public folder database on the Exchange server.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    I've looked at the information micoroft provides on this subject and find the following information:

     

    This Error event indicates that the Microsoft® Exchange Server that logged this event could not initialize a MAPI session to a public folder store.

     

    I have no idea what to do with that information.

     

    The follwing did not help: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3336195&SiteID=17 as i do not have a cluster.

     

    The following: http://msexchangeteam.com/archive/2005/07/29/408394.aspx applies only to exchange 2000/ 2003 and does not work for 2007 (can't even find the mentioned registry keys)

     

    Same goed for http://support.microsoft.com/kb/918006 (the lan manger authentication settings are set on 2. according to the document it should be set to 1 if u have windows NT 4.0 machines in your domain which is really not the case.

     

    I'm thinking the problem might be over when i setup a second public folder on the second mailbox server and replicate the free/busy info there as wel but this should not be neccesary.

     

    Any thoughts?

    Monday, September 15, 2008 2:47 PM

Answers

  • Well... i just created another public folder store on the server that was giving met trouble. All seems to be ok now.

     

    Only thing i need to figure out now is how to deal with OAB, address lists and recipient policies (they seem to be legacy and are giving me trouble). But i'll start a new post on that one.

     

    Friday, September 19, 2008 3:27 PM

All replies

  • Hi Matthijs,

     

    Run Exchange Best Practice Analyzer and see if it indicates any issue...

     

    http://exbpa.com/

     

    Also check if there is any other error in event log...

    Monday, September 15, 2008 3:17 PM
  • I ran it today and it didn't show anything important (the page file isn't big enough according to BPA). Next to this error I do find the following error when i reboot the machines or restart the SA:

     

    Event Type: Error
    Event Source: MSExchangeSA
    Event Category: General
    Event ID: 9317
    Date:  15-9-2008
    Time:  17:11:37
    User:  N/A
    Computer: MBX02
    Description:
    Failed to register Service Principal Name for exchangeMDB; error code was 800401e4.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Which according to Microsoft http://support.microsoft.com/kb/935676 is only happening on clustered mailbox servers... which mine ar not. Or can this be because i installed exchange 2007 enterprise and not standard on the stand alone mailbox servers?

     

    Other then this the eventlog is clean and SCOM can't find anything either (he does find the MSExchange SA entries) including the 8197 error (doesn't show in SCOM).

    Monday, September 15, 2008 3:25 PM
  • You may try by adding that...

     

    add-ADPermission -Identity "cn=exchangeserver,cn=computers,dc=mydomain,dc=com" -User "exchangeserver$" -AccessRights WriteProperty -Properties "Validated-SPN"

    Monday, September 15, 2008 3:56 PM
  • Clarify: MBX server always receive 8198 error, the server don’t have public store on it, right?

    Troubleshooting:

    1.       Use ADSIEditor to check “Folder Hierarchy”, see what we get there

    “Configuration”->”CN= Configuration,DC=DomainName,DC=Com”->”CN=Services”->”CN=Microsoft Exchange”->”CN=OrgName”->”CN=Exchange Administrative Group (xxx)”->”CN=Folder Hierarchies”

    Notes: Also see the value of “msExchOwningPFTreeBL” in the “Properties” of “CN=Folder Hierarchies”

    2.       Still use ADSIEditor, check if we get “CN=Public folder” in the right-pane of the “CN=Microsoft Exchange”

    3.       Can you create public folder with no error currently?

    Notes: New-PublicFolder –Name Test –Path \xx\yy –Server ServerName

     

    Tuesday, September 16, 2008 10:45 AM
  • @ amit tank. I tried that (giving the machine acount right to it own computer object but this did not solve te problem:

     

     

    @ James

     

    1. I don't seem to have a a CN=Folder Hierarchies under my exchange 2007 administrative group. I do have one however under my exchange 2003 administrative group. The value msExchOwningPFTreeBL has 3 values which correspond with my 3 public folder stores (two on exch 2003) and one one exch2007

     

    2. Don't seem to have that either. If i go to CN=Microsoft exchange and look at the value pane, there is no value concerning public folders. Also when i expand CN=Microsoft exchange i do not get a CN=Public Folder (just a CN=Activedirectory Directory Connections and CN=myOrgName

     

    3. Also a no go but i think i'm doing it wrong cause it keeps telling me that i've entered a non valid public folder ID:

     

    there is no existing public folder that matches the following identity: "what ever i put under path" Please make sure that you have specified the correct PublicFolder Identity and that you have the correct permissions to view public folder.

     

    Her is an out put of get-publicfolder:

     

    Name                                    Parent Path
    ----                                    -----------
    IPM_SUBTREE

     

     

    Hope you have any suggestions.

    Tuesday, September 16, 2008 1:59 PM
  • That’s right we shouldn’t have “CN=Microsoft Exchange” under “CN=Microsoft Exchange”, it would be issue if you got things there

    We can run “Get-PublicFolder -recurse” to get detailed public folder structure

    Make sure that the account you log on has proper permission to create public folder

    Troubleshooting:

    1.       Run a DACL check on all public folder by using PFDAVAdmin

    a.       Launch PFDAVAdmin->”File” menu->select “Connect”

    b.      Select properly server and logon user, click “OK”

    c.       Right-click “Public Folders”->select “Check DACL state”

    d.      See if all results is “OK”

    2.       Increase public folder event level and reproduce issue, check if we get any error in the application log

    a.       EMS->Set-EventLogLevel -Identity "xxx\xx" -Level High

    ·         MSExchangeIS\9001 Public\General

    ·         MSExchangeIS\9001 Public\Transport General

    ·         MSExchangeIS\9001 Public\Replication General

    b.      Reproduce issue, and check application log for error info

    c.       Set event log level back

    3.       See if you can view public folder in the “Public Folder Management Tool”, it locates in the EMC->Toolbox. Test if you can create public folder there without error

     

    Wednesday, September 17, 2008 3:16 AM
  • Alright i tried a vew things u said:

     

    The output of the get-publicfolder -recurse:

     

    Name                                                                            Parent Path
    ----                                                                            -----------
    IPM_SUBTREE
    Internet Newsgroups                                                             \

     

    Shouldn't there be a Free/busy folder as well? since i'm replicating that to the exchange 2007 machine?

     

    I downloaded the PFDAVAdmin tool and fired it up on one of the exchange servers. I can connect but get the following èxpand when i try to expand public or system folders in the navigation pane:

     

    could not expand http://anmailmbx01.asp.local/ExAdmin/Admin/ASP.LOCAL/public%20folders/: Name cannot begin with the '0' character, hexadecimal value 0x30. Line 1 Position 406.

     

    If i click that item in the navigation pane and click through the tabs i get the following error:

     

    Exeption getting folder contents: Object reference not set to an instance of an object.

     

     

    This last error makes sense as i'm clicking on an object that cannot be retriefed. I got no clue about the first error to be honest. The name of my publicfolder store as it turns up in ESM starts with: PublicFolder so...

     

    pff what a hassle... thanks for your feedback btw i really appriciate it!

     

     

    Wednesday, September 17, 2008 2:11 PM
  • After reviewed the event 9317, I’d like to check the registered SPNs on MBX02

    a.       Start->Run->cmd

    b.      Run “setspn –l MBX02”

    c.       Check if there’s “exchangeMDB/MBX02” and “exchangeMDB/MBX02.domain.com” existed

    d.      Also please help me to check other computer’s spn list by use “setspn” command

    e.      Please output of “exchangeMDB” part from different computers for analyzing

    I saw you had viewed KB 828764, you have already checked the connectivity to GC, right?

    Also, this event is something to do with NIC, so please check the following

    1.       How many NICs do we have on MBX02?

    2.       Check the binding order, see if NIC is at the top of the binding order

    a.       Go to “Network Connections” window

    b.      ”Advanced” menu->”Advanced Settings”

    c.       In the “Connections” column, ensure NIC is at the top

    3.       Does “NWLink” installed on your NIC?

    a.       Right-click NIC->”Properties”

    b.      “General” tab, ensure “NWLink” is not installed there

    Does MBX02 connect to a CISCO switch? CISCO has added a "feature" called "SmartPorts" to some of their switches. If you look at the in HTTP, you can see the ports. Have the customer determine which port the Exchange server is plugged into. Check to see if port is enabled for "Server". SmartPorts allow you to choose what types of devices are plugged into (server, desktop, router, etc). Further details

    Finally, I want to know if there’s an event 1005 logged on the application log of MBX02

    Event ID : 1005

    Category : General

    Source : MSExchangeSA

    Type : Error

    Thursday, September 18, 2008 10:59 AM
  • 1. Result from the setspn for all the exchange 2007 servers. Looks ok to me.

     

    C:\--------------------------------------->setspn -L mbx01
    Registered ServicePrincipalNames for XXXX:
        SMTP/mbx01
        SMTP/mbx01.asp.local
        SMTPSVC/mbx01
        SMTPSVC/mbx01.asp.local
        exchangeRFR/mbx01.asp.local
        exchangeRFR/mbx01
        exchangeMDB/mbx01
        exchangeMDB/mbx01.asp.local
        HOST/mbx01
        HOST/mbx01.asp.local

    C:\--------------------------------------->setspn -L mbx02
    Registered ServicePrincipalNames for XXXX:
        SMTP/mbx02
        SMTP/mbx02.asp.local
        SMTPSVC/mbx02
        SMTPSVC/mbx02.asp.local
        exchangeMDB/mbx02.asp.local
        exchangeMDB/mbx02
        exchangeRFR/mbx02.asp.local
        exchangeRFR/mbx02
        HOST/mbx02
        HOST/mbx02.asp.local

    C:\--------------------------------------->setspn -L ht02
    Registered ServicePrincipalNames for XXXX

        SmtpSvc/ht02
        SmtpSvc/ht02.asp.local
        SMTP/ht02.asp.local
        SMTP/ht02
        HOST/ht02
        HOST/ht02.asp.local

    C:\--------------------------------------->setspn -L anmailht02
    Registered ServicePrincipalNames for XXXX

        SMTP/ANMAILHT02
        SMTP/anmailht02.asp.local
        SmtpSvc/ANMAILHT02
        SmtpSvc/anmailht02.asp.local
        HOST/ANMAILHT02
        HOST/anmailht02.asp.local

    C:\--------------------------------------->setspn -L ca01
    Registered ServicePrincipalNames for XXXX
        POP3/ca01
        POP3/ca01.asp.local
        IMAP/ca01
        IMAP/ca01.asp.local
        IMAP4/ca01
        IMAP4/ca01.asp.local
        HOST/ca01
        HOST/ca01.asp.local

    C:\--------------------------------------->setspn -L ca02
    Registered ServicePrincipalNames for XXXX
        IMAP/ca02
        IMAP/ca02.asp.local
        IMAP4/ca02
        IMAP4/ca02.asp.local
        POP3/ca02.asp.local
        POP3/ca02
        HOST/ca02
        HOST/ca02.asp.local

    C:\--------------------------------------->

     

    2. I checked the connection with the GC's. All seems to be well.

    3. There are two NIC's on the mailbox server. One in the backbone network, one in the 'client' network. Where the backbone network is used for internal server traffic and the client network for communication to other subnets.

    4. I checked the binding of the NIC's the client network one is higest on the list  followed by a disabled adapter and then the backbone network one for both exchange servers.

    5. nwlink is not installed

    6. that event has never been logged.

    Thursday, September 18, 2008 4:05 PM
  • What looks like in the binding order of MBX01, same as MBX02? Compare the NICs' configuration between two servers

    Per my knowledge, the issue may relate to network connectivity. Please try to consult with the engineer on your network team

     

    Friday, September 19, 2008 3:16 AM
  • Well... i just created another public folder store on the server that was giving met trouble. All seems to be ok now.

     

    Only thing i need to figure out now is how to deal with OAB, address lists and recipient policies (they seem to be legacy and are giving me trouble). But i'll start a new post on that one.

     

    Friday, September 19, 2008 3:27 PM