Exchange 2007 Database Recovery Management Tool RRS feed

  • Question

  • We have Exchange 2007 SP2 (CCR) and DPM 2007 SP1 to backup exchange server. I was able to recover the mailboxes successfully using DPM and Database Recovery Management Toolbox. I used Copy to a network folder option in DPM.

    I recovered the database using DPM Recovery option then tried to mount the recovery database using Database Recovery Management tool as well as Powershell but got the following error message.

    Error encountered while trying to mount the database. Error Code: MapiExceptionCallFailed (hr=0x80004005, ec=.1032)

    I have to run eseutil /p switch to repair the database after that it mounts the database. Running the eseutil /p takes additional time for the recovery process. I tried couple of times but each time I got the error message while mounting the database and had to run eseutil  switch.

    Is there any way I can mount the recovery database without running the eseutil switch that will shorten the recovery process time??

    Thanks and Regards,




    Friday, September 3, 2010 5:46 PM

All replies

    1. hopefully you have a backup of the original database pre /P
    2. if not make one now
    3. Then if as you say you already ran the /P against it, be sure to run a /D and see if that helps your situation.
    4. NOTE:  if it still fails you may also want to consider cleaning out all unnecessary files from the RSG path, i.e. ensure you don't have old or unnecessary files from a previous recovery in that path

    Alternatively you could also check out Lucid8's DigiScope http://www.lucid8.com/product/digiscope.asp since it can open raw Exchange 2010, 2007, 2003 2000 or 5,5 EDB files without the need of an RSG and then you can Browse, Search, Export PST, MSG & XML or Recover data directly from the EDB to a live Production Exchange Server. 

    Troy Werelius


    • Proposed as answer by Troy Werelius Friday, September 3, 2010 6:53 PM
    Friday, September 3, 2010 5:59 PM
  • Hi Troy,

    Thanks for the reply. Yes, I have the backup of the original database.

    Actually I am trying to shorten the recovery process so trying to recover the mailboxes without using the eseutil switch.

    I will definately try the alternate option.

    Thanks and Regards,


    Friday, September 3, 2010 6:39 PM
  • Is there any error event in the application log right after you failed to mount the database?

    For code 1032 in the error information, please refer the suggestions in this article to troubleshoot

    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, September 6, 2010 2:42 AM