locked
Export/Import Suggested Contacts - autocomplete cache

    Question

  • As a followup to another thread I created, I have found that exporting the Suggested Contacts from one account and importing it into another on Outlook 2010 does not cause the addresses to appear in the autocomplete cache.  Is there another step involved or is there any point as the address has to be keyed in into the To: space in a real EMail message before it will appear as an autocomplete cache entry? 

    This autocomplete business is really driving us nuts.  Lots of problems that have to be addressed as users have become very dependent on it!

    Marty

     


    Martin J. Franek
    Monday, April 4, 2011 8:56 PM

Answers

  • Hi,

    So if you copy (export/import) the contacts from one machine to the other than will the autocomplete-cache not migrated.

    In Outlook 2010 there is no nk2 file. Please try to copy the "Stream_Autocomplete_*.dat" and give a look if it works.

    With above named tool you can modifiy your current autocomplete list and delete a wrong entry.

    andy

    • Marked as answer by MartyFranek Thursday, April 7, 2011 1:58 PM
    Tuesday, April 5, 2011 6:22 AM

All replies

  • Hi Marty

    You can give a try to copy the autocomplete cache from an user to another one. the cache-file is located at "C:\Users\user\AppData\Local\Microsoft\Outlook\RoamCache". I've never testing this solution.

    However if the above solution doesn't work than take a look to the software named nk2edit from NirSoft.

     

    Best Regards Andy


    • Proposed as answer by Jamestechman Monday, April 4, 2011 11:13 PM
    • Unproposed as answer by Jerome Xiong Wednesday, April 6, 2011 8:43 AM
    Monday, April 4, 2011 10:16 PM
  • Thanks Andy; 

    Since both machines run Outlook 2010, there is no .nk2 file but I have not yet tried to replace the autocomplete cache file.  The thing is, when exporting the Suggested Contacts to another computer running Outlook 2010, since it apparently failed to update the autocomplete cache on one, I tried it on another - with the same result.  Is it possible that the Roamcache file is bad on two computers? 


    Martin J. Franek
    Tuesday, April 5, 2011 12:37 AM
  • Hi,

    So if you copy (export/import) the contacts from one machine to the other than will the autocomplete-cache not migrated.

    In Outlook 2010 there is no nk2 file. Please try to copy the "Stream_Autocomplete_*.dat" and give a look if it works.

    With above named tool you can modifiy your current autocomplete list and delete a wrong entry.

    andy

    • Marked as answer by MartyFranek Thursday, April 7, 2011 1:58 PM
    Tuesday, April 5, 2011 6:22 AM
  • Hi MartyFranek,

     

    At first, please make sure you can see the contacts in the suggest contacts.

     

    Then you need to enable suggest contact.

    Expand to FileàOptionsàContactsàSuggest Contacts

    Ticket the “Automatically create Outlook contacts for recipients that do not belong to an Outlook Address Book”.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Calibre IT Tuesday, August 12, 2014 1:14 PM
    Wednesday, April 6, 2011 8:42 AM
  • Thanks Jerome;

    Yes, I can see the Suggest Contacts as well as the Contacts.  As it turned out, the nk2edit freeware program from Nirsoft that Andy_Ch recommended has been tried out and seems to do exactly what we need to do - which was migrate backwards the information for Autocomplete from and Outlook 2010 account to an Outlook 2003 account.  On the Outlook 2010 computer, I was able to export the Suggested Contacts to a csv file (Windows format) and then use that file as input when I run the n2kedit program on the Outlook 2003.  NK2edit imported the csv data into the .nk2 file for the user and then would appear on the autocomplete seletion list.  What a great product.  (Well, it was exactly what we needed anyway).

    I have to admit I was little surprised that it worked so seemlessly as it seems that software in general is never designed well for 'backwards compatability'.  But in the real world, scenarios do arise when you have to go back in time technologically.  Sometimes that's just what the end user wants.

    Thanks again. -Marty

     


    Martin J. Franek
    Thursday, April 7, 2011 1:52 PM
  • This works, but you need to be more specific.  If you are moving Outlook 2007/2010 from one machine to another, you will need to move the "Stream_Autocomplete_*.dat" file.  It is located in:

    Win Vista and Win 7: "C:\Users\username\AppData\Local\Microsoft\Outlook\RoamCache"
    Windows XP: C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Outlook\RoamCache

    1. Start with you new install of Outlook on a new computer and send an email to someone by manually typing in the email address and clicking send. 

    2. Now close Outlook and go to to the above folder.  You should see your "Stream_Autocomplete_*.dat" with a bunch of numbers before the ".dat" 

    3. Now find the newest (largest) corresponding file on your OLD system and copy it to the RoamCache folder on your NEW computer.

    4. Lastly, rename the file from #3 to the same name as the file in #2 (rename the #2 file first).

    5. Close Outlook and re-open. That should fix your issue. 

    Monday, March 5, 2012 4:35 PM
  • Hi All,

    If you are moving from Outlook 2007 -> Outlook 2010, you can use the nk2 file and import it into Outlook 2010. The nk2 file should be copied to the location "C:\Users\%username%\AppData\Roaming\Microsoft\Outlook" and should have the same name as the profile (e.g. Outlook.nk2 or Outlook Profile.nk2).

    The command for this action can be entered via Start - Run (or in W7 in Search programs and files after clicking on the Start button) by entering:

    Outlook.exe /importnk2

    The nk2 file will be imported in Outlook 2010, and when Outlook will be closed, the file will be renamed to Outlook.nk2.old (this means a successfull import). You can also check Outlook by creating a new mail message and enter a character in the To field to see the cache appear.

    Hope this can help.

    Kind regards,

    Philip

    Monday, June 25, 2012 9:32 AM
  • I just signed up to say that it worked and you are the BEST!!!!!!!!!!

    Sunday, September 30, 2012 7:26 AM
  • I just signed in to vote that it worked for me and the solution is the best.
    Thursday, March 31, 2016 12:44 PM