locked
Could not open OWA locally?! Syntax error, Code: 0

    Question

  • Hi,

     

    Could not open OWA locally!

     

    https://email/owa

     

    Error:

     

    ! Internet Explorer

    Problem with this Web page might prevent it from being displayed properly of functioning properly. In the future, you can display this message be double-clicking the warning icon displayed in the status bar.

     

    Line: 7

    Char: 1

    Error: Syntax error

    Code: 0

    URL: https://email/owa/auth/logon.aspzx?url-https://email/owa&reason=0

     

    ======

    And we I tried to browse it through IIS Manager -> owa -> Browse

     

    The page must be viewed over a secure channel

    The page you are trying to access is secured with Secure Sockets Layer (SSL).


    Please try the following:

    • Type https:// at the beginning of the address you are attempting to reach and press ENTER.

    HTTP Error 403.4 - Forbidden: SSL is required to view this resource.
    Internet Information Services (IIS)


    Technical Information (for support personnel)

    • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 403.
    • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled About Security, Secure Sockets Layer (SSL), and About Custom Error Messag

     


     Your assistance is apprciated.

     

    Thanks

    Sunday, August 5, 2007 8:46 AM

Answers

  • Here it is the solution providede by "Tig Stone" on other post.

     

    Code Snippet

    I too hit this problem.  I inspected the MetaBase.xml and found three attributes labeled IpSecurity, with blank values:

    IpSecurity=""


    Stopping IIS, deleting these entries, saving the modified MetaBase.xml and restarting seems to have resolved the issue.

     

     

    Here is the link of the post: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3576366&SiteID=17&mode=1

     

     

    Saturday, July 5, 2008 5:00 AM

All replies

  • I'm having the same error and have found it posted in several places online. Only one post mentioned they were able to resolve the problem: Remove the Exchange organization from A.D. and then reinstall Exchange 2007. Not an acceptable answer in my book. If you find a real solution to this OWA problem please post on here. I will do the same. Thanks.

    Sunday, August 12, 2007 12:55 AM
  • Similiar issue.. no luck.

     

    This is my config. It was working until two days ago when the external website stopped serving OWA. The internal still works fine. There are no errors in the application log. These are brand new Dell PowerEdge 2950s quads bought solely for Exchange.

     

          Exchange server 2007(Mailboxes) we will refer to as EX-A, it has mailbox, client access, hub transport roles installed.

     

          Exchange server 2007 also we will refer to as EX-B, it has only the client access role installed, primarily for OWA.

     

          Both have the Exchange servers have the Rollup 4 patch installed.

     

          I have configured EX-B (DMZ) to use certificates from our domain’s CA, I have also installed certs on EX-A so that it can also provide SSL OWA.

     

          I have configured EX-A and EX-B with the following command:

     

    Enable-ExchangeCertificate -Thumbprint THUMBRINTFROMCERTGOESHERE -Services "IIS"

     

    I used the correct FQDNs for both server’s certs which were successfully enabled.

     

    I have two nics in EX-B, one is configured for internal network, the other for the internet. The Internet facing Nic does NOT register with DNS and is the sole gateway for the box. It has a persistent route manually added to route internally through the private network across routers.

     

    It has two websites installed, one for the External nic and the other for the internal nic. They are both mapped to their proper IP’s (internal / External). They both redirect to HTTPS://INTERNAL_EXCHANGESERVER_FQDN/OWA and HTTPS://mail.publicdomain.com/OWA. It does NOT register with DNS, the FQDN for the private is svrname.privdomain.local and does correctly register with DNS.

     

    Both websites have FQDN certs installed based on priv/pub nics/ips. These certs have been enabled for exchange server by using the commandlet Enable-ExchangeCertificate and the certs exist in the computer account’s personal store.

     

    My problem is when you pull up http://mail.publicdomain.com it acts as if it were loading, but then stops and states it is done, with errors. This is the URL and the error msg. Keep in mind that both internal and external websites have their own virtual directories which map to the same physical directories. Since the internal works and the external does not, it is safe to assume that the physical files are working correctly. The second website was created by saving config to file, then new website from file. I have switched the certs and IPs for the internal/external websites, and the internal always works. Also keep in mind this was working until two days ago.

     

    https://mail.pubdomain.com/owa/auth/logon.aspx?url=https://mail.pubdomain.com/owa/&reason=0

     

    any suggestions, recommendations, or ideas would be greatly appeciated.

    Tuesday, August 28, 2007 12:13 AM
  • This same thing happened to me immediatly after applying rollup 4 for Exchange 2007.  The update also set all my Exchange and IIS services to disabled, I had to go in and change them all back to Automatic to get Exchange to work again.

    I am running a single server for all roles.

     

    Uninstalling rollup 4 got OWA working again

     

    • Proposed as answer by tmezz Wednesday, January 21, 2009 1:00 AM
    Tuesday, August 28, 2007 10:34 AM
  • I had the exact same thing as cjhugen. Monday all of the services were disabled. I modified all of the service startups and exchange was backup and running. The only problem now is that OWA does not work. I do not have the un-install option available in the control panel.

     

    HELP!

     

    Tuesday, August 28, 2007 7:22 PM
  • Same thing here.  I tried to install exchange server 2007 rollup 4 and instead it creates issues with outlook web access along with disabling all the services.  I have uninstalled it and things are working now.  Michael, you might not be using an administrator account if the uninstall option is not available.  Also, make sure that show updates is checked.  This update will be postponed until I see concrete solutions.  This is the 3rd time that I deal with a Microsoft update that makes me pull my hair instead of solving issues.

    John
    Tuesday, August 28, 2007 9:16 PM
  • Hey guys, just thought I'd send this along. I had the same problem after Rollup 4, but the resolution in this KB worked for me...

     

    http://support.microsoft.com/kb/935490

     

    Andy

    Wednesday, August 29, 2007 1:16 AM
  •  

    Update.

     

    Okay, so in the end, I have found that Exchange 07 is really picky about directories for OWA and AUTODISCOVER which is an Outlook 07 auto config feature. I was lucky for having my CAS role installed a different server then my mailbox server. I uninstalled the CAS role, and IIS, then reinstalled them and it is back to normal.

     

    Note: Do not attempt to create an Exchange configured directory by backing up the website to file, then new website from file. There are "Service Connection Points" that must be configured via the Ex command shell for the exchange directories. And in doing this, it completely hosed IIS and Exchange from working with anything. I beleive it some how corrupted the metabase, but having said that, I did also restore the metabase from a manual base backup which

    I made right after the Exchange install. The reason I beleive the metabase was corrupted was due to it impacting other websites running on that server but restoring the metabase did not resolve the issue so I am not sure where the breakage was.

     

    -T

     

    more info ...

     

    http://www.exchangeninjas.com/CasCertMethod1

     

    http://www.exchangeninjas.com/CasCertMethod2

     

    http://www.exchangeninjas.com/cascertificateconfig 

     

    also ... thanks to Henrik of www.exchange-faq.dk for assitance in finding a resolution.

     

    Wednesday, August 29, 2007 7:25 PM
  • Hi I have a similar problem... After rollup 4 on Exchange 2007 (which fixed a couple of things) OWA would not work from clients using IE versions 6 and 7. I have not tested other IE versions... But Firefox works fine!!!.... seeing as we are Microsoft partners I am reluctent to put this forth as a solution.... Is there anyone out there with a solution that uses IE that works..

    The exact details of the IE error are as follows:

    Line: 7
    Char: 1
    Error: Syntax error
    Code: 0
    URL: https://<server url>/owa/auth/logon.aspx?
    url=https://<server url>/owa/&reason=0


    Any hints or solutions that allow the use of IE with Exchange 2007 rollup 4 would be greatly appreciated

    Thanks
    Tuesday, September 25, 2007 8:18 AM
  • Rolling back the update rollup 4 for Exchange will fix the issue. And will also resolve the problem which sets all the exchange and IIS services to disabled.

    This might not have something to do with the ExchangeSetupLogs folder since this was still in place on our server.

    Regards!
    Thursday, October 11, 2007 8:54 AM
  • I jhad the same problem after installing Exchange Server 2007 sp1 rollup2 on a 64-bit server. The ExchangeSetupLog folder was in place on the system drive, so the fix in http://support.microsoft.com/kb/935490 didn't seem to apply. But since I didn't want to roll back the update, I decided to modify the suggestion in the kb article -- I renamed the ExchangeSetupLog folder to yada-old, created a new empty ExchangeSetupLog folder, and reinstalled the rollup AFTER A COMPLETE BACKUP. It worked -- OWA is back on line.
    Friday, July 4, 2008 6:07 PM
  • Here it is the solution providede by "Tig Stone" on other post.

     

    Code Snippet

    I too hit this problem.  I inspected the MetaBase.xml and found three attributes labeled IpSecurity, with blank values:

    IpSecurity=""


    Stopping IIS, deleting these entries, saving the modified MetaBase.xml and restarting seems to have resolved the issue.

     

     

    Here is the link of the post: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3576366&SiteID=17&mode=1

     

     

    Saturday, July 5, 2008 5:00 AM
  • before installing the rollup 4, just before backup your logon.aspx and then delete it.

    if you ever installed the rollup 4, delete or rename logon.aspx and reinstall rollup4.

    it work fine
    Thursday, October 23, 2008 10:51 AM