Exchange server was renamed


  • Installing first 2010 server in a 2007 environment.

    Installed with a the wrong server name.  Renamed the server only to find out that doesn't work.  Renamed it back to original name and removed Exchange 2010.  Had to remove the arbitration mailboxes first - used:
    Get-Mailbox -Arbitration | Disable-Mailbox - Arbitration
    Get-Mailbox -Arbitration | Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed
    to remove arbitration mailboxes.

    Waited 24 hours for any replication to occur.

    Renamed server to the desired name (Exchange2010).

    Thought everything was going to be ok until I opened EMC to find out that I received a kerboros auth error using the OLD server name.

    I have since renamed server to old name and can open EMC, but it shows the database as belonging to the Exchange2010 server.

    Don't want to mess around too much more without some input.

    It appears the removal of the original Exchange 2010 server did not remove everything necessary from AD.

    Installing additional servers temporarily is not a problem if necessary.

    Exchange 2007 system is working fine (as far as I know).

    Rick Scaiefe

    2012年6月8日 14:58


  • Check adsiedit.msc if you have entry of old(wrong) server name.

    Gulab Prasad,
    My Blog | Z-Hire Employee Provisioning App

    2012年6月8日 15:05
  • In Configuration/services/microsoft exchange/administrative groups/exchange administrative group (FYD...)/servers, I have 2 servers listed:

    1) The new Exchange 2010 server and

    2) The current Exchange 2007 server

    I can not find any reference to the improper name, unless I'm not looking in the correct place.

    Rick Scaiefe

    2012年6月8日 15:14
  • Hello,

    It’s not recommended and support to rename the FQDN of the Exchange Server by Microsoft.



    2012年6月11日 9:08
  • I realize that! That is why I named it back, removed exchange (per my original post), then reinstalled with the new name in place.  Any other ideas?

    Rick Scaiefe

    2012年6月11日 12:15
  • Post the error you are getting in EMC.
    @Simon_Wu, Sorry to say, but MS Recommendation term (your response) is not going to fix the issue.

    Gulab Prasad,
    My Blog | Z-Hire Employee Provisioning App

    2012年6月11日 12:35
  • Here is the message I get when trying to open EMC.  (EMS opens fine).  win-n6irfo7... is the old, original server name when Exchange was originally installed.  Exchange was removed, the server renamed and Exchange reinstalled.

    Here is a partial screen clip of the EMS opening screen.

    Rick Scaiefe

    2012年6月11日 13:29
  • Here is the result of Get-ExchangeServer

    [PS] C:\Windows\system32>get-exchangeserver
    Creating a new session for implicit remoting of "Get-ExchangeServer" command...

    Name                Site                 ServerRole  Edition     AdminDisplayVersion
    ----                ----                 ----------  -------     -------------------
    VEXCHANGESVR        scu.local/Configu... Mailbox,... Standard    Version 8.3 (Bui...
    EXCHANGE2010        scu.local/Configu... Mailbox,... Standard... Version 14.1 (Bu...

    I am checking the links you provided.

    Rick Scaiefe

    2012年6月11日 13:46
  • I have since logged in as a different user (after granting proper Exchange Roles) and the EMC works.  If I log back in as the original user (administrator login), it still doesn't (with the error mentioned above).

    Rick Scaiefe

    2012年6月11日 18:42
  • Hi,
    Have you tried to delete the MMC Cached Files?
    File | Options --> Delete Files

    Martina Miskovic

    2012年6月11日 18:53
  • Yes, I had tried that earlier this morning.

    Rick Scaiefe

    2012年6月11日 18:54
  • Ok, then I suggest that you log on as the different user and remove the profile of the account that you have problems with.

    Martina Miskovic

    2012年6月11日 18:56
  • Kind of tried that.  I logged in as user #2 and renamed the profile for the original user (Administrator).  When I logged on as the first user, I got a temporary profile.

    Rick Scaiefe

    2012年6月11日 18:59
  • Delete the profile from the System Properties | Advanced Tab

    Martina Miskovic

    2012年6月11日 19:01
  • I agree with Martina, since you are able to open EMC with a different user account why dont you remove the user account that is not working  then add it again. How does your event viewer looks? 
    2012年6月11日 19:07
  • Yep, that was my next action, but, I like to try to figure out why things happen.  I think if you remove Exchange from the control panel, it should be completely removed.  

    I want to completely remove exchange 2010 and start over.  And, removing the install account removes a critical part of the process that got me to this point.  I may not be able to return.

    Rick Scaiefe

    2012年6月11日 19:09
  • Application log only has errors / warnings concerning User Profile Service (1511) about not finding the local profile.  Goes back to when I had renamed the user profile.

    System log has typical errors concerning printer drivers (I'm working via Remote connection manager and the server doesn't have any of the printer drivers for the printers on my PC).

    Rick Scaiefe

    2012年6月11日 19:13
  • Can you post some of the errors from your event viewer if it is not too large. On the screen shot above it looks like WinRm is having a problem are you  using windows remote management to connect t the EMC.
    2012年6月11日 19:24
  • Skeefer, take a look at this site ""
    2012年6月11日 19:27
  • Application log filtered for warnings and errors.  Changed name of server back to the name used during install around 9:50AM which stopped a number of errors.

    System log shows no errors other than previously mentioned printer errors.

    Rick Scaiefe

    2012年6月11日 19:44
  • Thanks for the info, I downloaded and ran the utility as the administrator and got:

    The EMC still shows the same Initialization failed message.

    Rick Scaiefe

    2012年6月11日 19:48
  • Can you access the EMC with a different account and then remove the user you are having the problem with. after you remove the user  form the Exchange administrator try to add it again and see what happens.
    2012年6月12日 0:01
  • You might want to try to clear the cache credentials
    rundll32.exe keymgr.dll, KRShowKeyMgr

    Delete the admin credential if you get..
    Log off and login again and try.. Post the udpate

    Gulab Prasad,
    My Blog | Z-Hire Employee Provisioning App

    2012年6月12日 9:11
  • Doesn't show anything.  Sorry, I was unable to return to this last week.

    Rick Scaiefe

    2012年6月18日 13:16
  • Hi Rick,

    What is the status of Windows Management Instrumentation service? Is it set to Logon As "Local System" or "Network Services"?

    If it's System Services than change it to Local System and check the issue.
    Post the update.

    Gulab Prasad,
    My Blog | Z-Hire Employee Provisioning App

    2012年6月18日 14:12
  • Already set to Local System.

    We may be getting off track for what I need to get accomplished.  I can log in as another user and open EMC and EMS.  I run BPA as receive multiple Certificate SAN mismatch - the certificate refers back to the original name of the server.  I can't open EMC logged in as the original user (see previous posts).  My attempt to resolve this is just for my understanding of where / how EX2010 remembers the original server name.

    I think I now want to completely remove Exchange 2010 and start over.  I still have two arbitration mailboxes "floating" around preventing me from removing the database (I think I should have 3 arbitration mailboxes).  My plan now is to temporarily install EX2010 on another server, move any and all arbitration mailboxes to that server.  Then remove and reinstall EX2010 on the planned production server and move the mailboxes back.

    I appreciate the time and advice you have given me so far.

    Rick Scaiefe

    2012年6月18日 14:24
  • That works.  I still wonder where the information concerning the old server was located - obviously somewhere in the user profile.

    Rick Scaiefe

    2012年6月19日 13:14